On 3/29/21 3:45 AM, Huang Guobin wrote:
> From: Guobin Huang
>
> There is a error message within devm_ioremap_resource
> already, so remove the dev_err call to avoid redundant
> error message.
>
> Reported-by: Hulk Robot
> Signed-off-by: Guobin Huang
> ---
> drivers/net/ethernet/xilinx/xil
Use already prepared dev_err_probe() introduced by commit a787e5400a1c
("driver core: add device probe log helper").
It simplifies EPROBE_DEFER handling.
Also unify message format for similar error cases.
Signed-off-by: Michal Simek
---
drivers/net/can/xilinx_can.c | 10
tristate "Xilinx 10/100 Ethernet Lite support"
> - depends on PPC32 || MICROBLAZE || ARCH_ZYNQ || MIPS
> + depends on PPC32 || MICROBLAZE || ARCH_ZYNQ || MIPS || COMPILE_TEST
> select PHYLIB
> help
> This driver supports the 10/100 Ethernet Lite from Xilinx.
>
Acked-by: Michal Simek
Thanks,
Michal
On 31. 10. 20 18:47, Andrew Lunn wrote:
> drivers/net/ethernet//xilinx/xilinx_emaclite.c:341:35: warning: cast from
> pointer to integer of different size [-Wpointer-to-int-cast]
> 341 | addr = (void __iomem __force *)((u32 __force)addr ^
>
> Use long instead of u32 to avoid problems on 64
out occurs for Emaclite device.
> */
>
Fixes: 0290bd291cc0 ("netdev: pass the stuck queue to the timeout handler")
Reviewed-by: Michal Simek
Thanks,
Michal
From: Srinivas Neeli
Bit enlarging is observed for CANFD2.0 when brp is 1,
So change brp_min value to 2.
Signed-off-by: Srinivas Neeli
Signed-off-by: Michal Simek
---
drivers/net/can/xilinx_can.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/can
ypes from "int" to "u32" and initialized with a
default value. Fixed sparse warning.
Addresses-Coverity: "incompatible_param"
Addresses-Coverity: "UNINIT(Using uninitialized value)"
Signed-off-by: Srinivas Neeli
Signed-off-by: Michal Simek
---
drivers/net/
Hi,
recently some small patches come to our internal tree. We started to use
coverity which found 2 issues (last two patches) which is simply to fix.
Thanks,
Michal
Srinivas Neeli (3):
can: xilinx_can: Limit CANFD brp to 2
can: xilinx_can: Check return value of set_reset_mode
can: xilinx_
From: Srinivas Neeli
Check return value of set_reset_mode() for error.
Addresses-Coverity: "check_return"
Signed-off-by: Srinivas Neeli
Signed-off-by: Michal Simek
---
drivers/net/can/xilinx_can.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drive
On 23. 06. 20 23:27, Brendan Higgins wrote:
> On Sat, Jun 20, 2020 at 1:59 AM kernel test robot wrote:
>>
>> Hi Brendan,
>>
>> It's probably a bug fix that unveils the link errors.
>>
>> tree: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
>> master
>> head: 4333a9b0b67
ode */
> +/* Extended Multicast Filtering mode */
> #define XAE_RAF_EMULTIFLTRENBL_MASK 0x1000
> #define XAE_RAF_STATSRST_MASK0x2000 /* Stats. Counter
> Reset */
> #define XAE_RAF_RXBADFRMEN_MASK 0x4000 /* Recv Bad Frame
> Enable */
>
Acked-by: Michal Simek
Thanks,
Michal
On 21. 02. 19 12:03, Michal Simek wrote:
> On 21. 02. 19 11:24, Paul Kocialkowski wrote:
>> Hi,
>>
>> On Wed, 2019-02-20 at 07:58 +0100, Michal Simek wrote:
>>> Hi,
>>>
>>> On 19. 02. 19 18:25, Andrew Lunn wrote:
>>>>> Thanks f
On 21. 02. 19 11:24, Paul Kocialkowski wrote:
> Hi,
>
> On Wed, 2019-02-20 at 07:58 +0100, Michal Simek wrote:
>> Hi,
>>
>> On 19. 02. 19 18:25, Andrew Lunn wrote:
>>>> Thanks for the suggestion! So I had a closer look at that driver to try
>>>&
Hi,
On 19. 02. 19 18:25, Andrew Lunn wrote:
>> Thanks for the suggestion! So I had a closer look at that driver to try
>> and see what could go wrong and it looks like I found a few things
>> there.
>
> Hi Paul
>
> Yes, this driver has issues. If i remember correctly, it got merged
> while i was
On 4.6.2018 17:06, Nicolas Ferre wrote:
> On 25/05/2018 at 23:44, Jennifer Dahm wrote:
>> The Zynq ethernet hardware has checksum offloading bugs that cause
>> small UDP packets (<= 2 bytes) to be sent with an incorrect checksum
>> (0x) and forwarded UDP packets to be re-checksummed, which is
>
On 27.4.2018 09:55, Marc Kleine-Budde wrote:
> On 04/27/2018 09:49 AM, Michal Simek wrote:
>> On 26.4.2018 23:13, Luc Van Oostenryck wrote:
>>> The method ndo_start_xmit() is defined as returning an 'netdev_tx_t',
>>> which is a typedef for an enum type, but
On 26.4.2018 23:13, Luc Van Oostenryck wrote:
> The method ndo_start_xmit() is defined as returning an 'netdev_tx_t',
> which is a typedef for an enum type, but the implementation in this
> driver returns an 'int'.
>
> Fix this by returning 'netdev_tx_t' in this driver too.
>
> Signed-off-by: Luc
On 24.4.2018 15:16, Luc Van Oostenryck wrote:
> The method ndo_start_xmit() is defined as returning an 'netdev_tx_t',
> which is a typedef for an enum type, but the implementation in this
> driver returns an 'int'.
>
> Fix this by returning 'netdev_tx_t' in this driver too.
>
> Signed-off-by: Luc
On 29.11.2017 11:01, Geert Uytterhoeven wrote:
> On 64-bit (e.g. powerpc64/allmodconfig):
>
> drivers/net/ethernet/xilinx/ll_temac_main.c: In function
> 'temac_start_xmit_done':
> drivers/net/ethernet/xilinx/ll_temac_main.c:633:22: warning: cast to
> pointer from integer of different siz
On 14.9.2017 16:34, Andrew Lunn wrote:
> On Thu, Sep 14, 2017 at 12:46:31PM +0530, Fahad Kunnathadi wrote:
>> To clear Speed Selection in MDIO control register(0x10),
>> ie, clear bits 6 and 13 to zero while keeping other bits same.
>> Before AND operation,The Mask value has to be perform with bitw
On 11.8.2017 15:33, Andrew Lunn wrote:
> On Fri, Aug 11, 2017 at 02:48:53PM +0200, Michal Simek wrote:
>> Using tabs instead of space for indentaion
>>
>> Signed-off-by: Michal Simek
>> Reviewed-by: Andrew Lunn
>
> Hi Michal
>
> Thanks for rebasing.
>
Using tabs instead of space for indentation.
Signed-off-by: Michal Simek
Reviewed-by: Andrew Lunn
---
Changes in v3:
- Fix commit message s/indentaion/indentation./
reported-by Andrew Lunn
- Rebase on the top of net-next.
HEAD commit: f5b589488ea5ed3bb6168b1a4e7f7b95841d8513
Changes in v2
On 9.8.2017 06:05, David Miller wrote:
> From: Michal Simek
> Date: Tue, 8 Aug 2017 11:32:25 +0200
>
>> Using tabs instead of space for indentaion
>>
>> Signed-off-by: Michal Simek
>
> This really isn't appropriate for the 'net' tree, it
Using tabs instead of space for indentaion
Signed-off-by: Michal Simek
Reviewed-by: Andrew Lunn
---
Changes in v2:
- Rebased on the top of net-next.
HEAD commit: 3b2b69efeca734b78bc85fd02253b0465bb2bec7
Suggested by David Miller
drivers/net/phy/Kconfig | 42
Using tabs instead of space for indentaion
Signed-off-by: Michal Simek
---
drivers/net/phy/Kconfig | 42 +-
1 file changed, 21 insertions(+), 21 deletions(-)
diff --git a/drivers/net/phy/Kconfig b/drivers/net/phy/Kconfig
index 928fd892f167..5d8cce3fab57
the code
didn't reflect that properly.
Changed that to only use the RXNEMP interrupt and thereby got rid of the
bug.
Signed-off-by: Matthias Auchmann
Acked-by: Kedareswara rao Appana
Signed-off-by: Michal Simek
---
drivers/net/can/xilinx_can.c | 18 +-
1 file chang
bus with candump)
Signed-off-by: Andrea Scian
Reviewed-by: Kedareswara rao Appana
Signed-off-by: Michal Simek
---
drivers/net/can/xilinx_can.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/net/can/xilinx_can.c b/drivers/net/can/xilinx_can.c
index 05ea2820d27b
__axienet_device_reset(lp, XAXIDMA_TX_CR_OFFSET);
> + __axienet_device_reset(lp, XAXIDMA_RX_CR_OFFSET);
>
> axienet_iow(lp, XAE_MDIO_MC_OFFSET, mdio_mcreg);
> axienet_mdio_wait_until_ready(lp);
>
Can you please send this directly to mainline?
And put my:
Reviewed-by: Michal Simek
Thanks,
Michal
On 13.10.2016 16:40, Tobias Klauser wrote:
> On 2016-10-13 at 14:23:49 +0200, Michal Simek wrote:
>> On 13.10.2016 13:28, Tobias Klauser wrote:
>>> The dev parameter passed to __axienet_device_reset() is not used inside
>>> the function, so remove it.
>>&g
On 2.9.2016 13:46, Zubair Lutfullah Kakakhel wrote:
> Hi,
>
> Thanks for the valuable feedback.
> Comments inline
>
>
> On 09/02/2016 11:27 AM, Michal Simek wrote:
>> On 2.9.2016 12:06, Zubair Lutfullah Kakakhel wrote:
>>> Hi,
>>>
>>> On 09/
On 2.9.2016 12:06, Zubair Lutfullah Kakakhel wrote:
> Hi,
>
> On 09/02/2016 07:25 AM, Michal Simek wrote:
>> On 1.9.2016 18:50, Zubair Lutfullah Kakakhel wrote:
>>> The Xilinx AXI Interrupt Controller IP block is used by the MIPS
>>> based xilfpga platform.
>
On 1.9.2016 18:50, Zubair Lutfullah Kakakhel wrote:
> Now that the driver is generic and used by multiple archs,
> get_irq is too generic.
>
> Rename get_irq to xintc_get_irq to avoid any conflicts
>
> Signed-off-by: Zubair Lutfullah Kakakhel
>
> ---
> V3 -> V4
> New patch.
> ---
> arch/microb
On 1.9.2016 18:51, Zubair Lutfullah Kakakhel wrote:
> At the moment, if the emaclite device doesn't find a mac address
> from any source, it simply uses 0x0 with a warning printed.
>
> Instead of using a 0x0 mac address, use a randomly generated one.
>
> Signed-off-by: Zubair Lutfullah Kakakhel
On 1.9.2016 18:50, Zubair Lutfullah Kakakhel wrote:
> IRQs from peripherals such as i2c/uart/ethernet come via
> the AXI Interrupt controller.
>
> Select it in Kconfig for xilfpga and add the DT node
>
> Signed-off-by: Zubair Lutfullah Kakakhel
>
> ---
> V3 -> V4
> No change
>
> V2 -> V3
> No
On 2.9.2016 09:05, Michal Simek wrote:
> On 1.9.2016 18:50, Zubair Lutfullah Kakakhel wrote:
>> IRQs from peripherals such as i2c/uart/ethernet come via
>> the AXI Interrupt controller.
>>
>> Select it in Kconfig for xilfpga and add the DT node
>>
>> S
On 1.9.2016 18:50, Zubair Lutfullah Kakakhel wrote:
> The Xilinx AXI Interrupt Controller IP block is used by the MIPS
> based xilfpga platform.
>
> Move the interrupt controller code out of arch/microblaze so that
> it can be used by everyone
>
> Signed-off-by: Zubair Lutfullah Kakakhel
>
> --
On 1.9.2016 18:50, Zubair Lutfullah Kakakhel wrote:
> The Xilinx AXI Interrupt Controller IP block is used by the MIPS
> based xilfpga platform.
>
> Move the interrupt controller code out of arch/microblaze so that
> it can be used by everyone
if this is just move that you should setup your git r
lon > electrons.com>; alexandre.bell...@free-electrons.com;
>> netdev@vger.kernel.org; linux-ker...@vger.kernel.org;
>> devicet...@vger.kernel.org; Punnaiah Choudary Kalluri
>> ; Michal Simek ; Anirudha
>> Sarangi
>> Subject: Re: [RFC PATCH 2/3] net: macb: Add supp
On 8.8.2016 09:15, Kedareswara rao Appana wrote:
> Device-tree binding documentation for xilinx gmiitorgmii converter.
>
> Signed-off-by: Kedareswara rao Appana
> ---
> Changes for v4:
> --> Modified compatible as suggested by Rob.
> --> Removed underscores from the converter node name as suggest
ister. When
> the
> - * CPU is in big endian we need to program swaped mode for management
> + * CPU is in big endian we need to program swapped mode for management
> * descriptor access.
> */
> static bool hw_is_native_io(void __iomem *addr)
>
Remove dot at the end o
v)
>
> mac = of_get_mac_address(np);
> if (mac)
> - memcpy(bp->dev->dev_addr, mac, ETH_ALEN);
> + ether_addr_copy(bp->dev->dev_addr, mac);
> else
> macb_get_hwaddr(bp);
>
>
Acked-by: Michal Simek
M
> @@ -496,7 +496,7 @@ static void macb_update_stats(struct macb *bp)
>
> WARN_ON((unsigned long)(end - p - 1) != (MACB_TPF - MACB_PFR) / 4);
>
> - for(; p < end; p++, offset += 4)
> + for (; p < end; p++, offset += 4)
> *p += bp->macb_reg_readl(bp, offset);
> }
>
>
Acked-by: Michal Simek
Thanks,
Michal
On 13.3.2016 20:10, Moritz Fischer wrote:
> This commit takes care of the coding style warnings
> that are mostly due to a different comment style and
> lines over 80 chars, as well as a dangling else.
>
> Signed-off-by: Moritz Fischer
> ---
> drivers/net/ethernet/cadence/macb.c | 101
> +++
E) {
> netdev_dbg(bp->dev,
> - "RX buffer must be multiple of %d bytes,
> expanding\n",
> - RX_BUFFER_MULTIPLE);
> +"RX buffer must be multiple of %d bytes,
> expanding\n",
> +RX_BUFFER_MULTIPLE);
> bp->rx_buffer_size =
> roundup(bp->rx_buffer_size, RX_BUFFER_MULTIPLE);
> }
> @@ -1368,7 +1369,7 @@ static void gem_free_rx_buffers(struct macb *bp)
> for (i = 0; i < RX_RING_SIZE; i++) {
> skb = bp->rx_skbuff[i];
>
> - if (skb == NULL)
> + if (!skb)
> continue;
>
> desc = &bp->rx_ring[i];
> @@ -1776,7 +1777,8 @@ static void macb_sethashtable(struct net_device *dev)
> unsigned int bitnr;
> struct macb *bp = netdev_priv(dev);
>
> - mc_filter[0] = mc_filter[1] = 0;
> + mc_filter[0] = 0;
> + mc_filter[1] = 0;
>
> netdev_for_each_mc_addr(ha, dev) {
> bitnr = hash_get_index(ha->addr);
>
Acked-by: Michal Simek
M
On 9.3.2016 18:22, David Miller wrote:
> From: Michal Simek
> Date: Wed, 9 Mar 2016 17:29:39 +0100
>
>> On 7.3.2016 18:13, Nicolas Ferre wrote:
>>> Le 07/03/2016 17:17, Moritz Fischer a écrit :
>>>> Hi Nicolas,
>>>>
>>>> this series d
On 7.3.2016 18:13, Nicolas Ferre wrote:
> Le 07/03/2016 17:17, Moritz Fischer a écrit :
>> Hi Nicolas,
>>
>> this series deals with most of the checkpatch warnings
>> generated for macb. There are two BUG_ON()'s that I didn't touch, yet,
>> that were suggested by checkpatch, that I can address in a
On 10/22/2015 11:02 AM, Arnd Bergmann wrote:
> On Thursday 22 October 2015 08:34:53 Appana Durga Kedareswara Rao wrote:
>>> On Thursday 22 October 2015 10:16:02 Kedareswara rao Appana wrote:
The driver only supports memory-mapped I/O [by ioremap()], so
readl/writel is actually the right t
Hi,
On 07/31/2015 11:53 PM, Nathan Sullivan wrote:
> On Tue, Jul 28, 2015 at 03:34:51AM +, Punnaiah Choudary Kalluri wrote:
>> Ok. I will send you updated patch for mdio support soon and we will finalize
>> next
>> Course of actions if it doesn't break the existing flow.
>>
>> Thanks,
>> Pun
Hi Nicolas,
have you had a time to look at this?
Thanks,
Michal
On 07/13/2015 06:48 AM, Punnaiah Choudary Kalluri wrote:
> This patch is to add support for the design that has multiple ethernet
> mac controllers and single mdio bus connected to multiple phy devices.
> i.e mdio lines are connecte
main.c:590:6: warning: symbol
'temac_adjust_link' was not declared. Should it be static?
Signed-off-by: Michal Simek
---
drivers/net/ethernet/xilinx/ll_temac_main.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/net/ethernet/xilinx/ll_temac_m
On 05/07/2015 05:30 PM, Julia Lawall wrote:
> On Thu, 7 May 2015, Michal Simek wrote:
>
>> From: Michal Simek
>>
>> Use one return statement instead of two to simplify the code.
>> Both are returning the same value.
>>
>> Signed-off-by: Michal Sime
On 05/05/2015 03:57 PM, Joe Perches wrote:
> On Tue, 2015-05-05 at 11:25 +0200, Michal Simek wrote:
>> From: Peter Crosthwaite
>>
>> The AXI-DMA rx-delay interrupt can sometimes be triggered
>> when there are 0 outstanding packets received. This is due
>> to t
52 matches
Mail list logo