From: David Ahern
Date: Sat, 10 Sep 2016 12:09:51 -0700
> The motivation for this series is that ICMP Unreachable - Fragmentation
> Needed packets are not handled properly for VRFs. Specifically, the
> FIB lookup in __ip_rt_update_pmtu fails so no nexthop exception is
> created with the reduced M
From: SF Markus Elfring
Date: Sat, 10 Sep 2016 09:15:37 +0200
> From: Markus Elfring
> Date: Sat, 10 Sep 2016 09:10:01 +0200
>
> A few update suggestions were taken into account
> from static source code analysis.
Series applied.
From: SF Markus Elfring
Date: Sat, 10 Sep 2016 10:57:37 +0200
> A few update suggestions were taken into account
> from static source code analysis.
Series applied.
From: Thadeu Lima de Souza Cascardo
Date: Fri, 9 Sep 2016 17:42:30 -0300
> When userspace tries to create datapaths and the module is not loaded,
> it will simply fail. With this patch, the module will be automatically
> loaded.
>
> Signed-off-by: Thadeu Lima de Souza Cascardo
Applied to net-
From: Eric Dumazet
Date: Fri, 09 Sep 2016 14:22:45 -0700
> From: Eric Dumazet
>
> Willem noticed that we could avoid an rbtree lookup if the
> the attempt to coalesce incoming skb to the last skb failed
> for some reason.
>
> Since most ooo additions are at the tail, this is definitely
> worth
From: Raghu Vatsavayi
Date: Fri, 9 Sep 2016 13:08:25 -0700
> +int octeon_mbox_read(struct octeon_mbox *mbox)
> +{
> + int ret = 0;
> + union octeon_mbox_message msg;
> +
Please always order local variable declarations from longest
to shortest line.
Please audit your entire submission fo
From: sthem...@exchange.microsoft.com
Date: Fri, 9 Sep 2016 12:45:24 -0700
> From: Stephen Hemminger
>
> These functions are used by other code misc-next tree.
>
> This reverts commit 30d1de08c87ddde6f73936c3350e7e153988fe02.
>
> Signed-off-by: Stephen Hemminger
Applied.
From: Chris Brandt
Date: Wed, 7 Sep 2016 14:57:09 -0400
> Due to a mistake in the hardware manual, the FWSLC and POST1-4 registers
> were not documented and left out of the driver for RZ/A making the CAM
> feature non-operational.
> Additionally, when the offset values for POST1-4 are left blank
From: Saeed Mahameed
Date: Fri, 9 Sep 2016 17:35:16 +0300
> This series from Mohamad improves the driver load/unload flows
> to seamlessly handle pci errors and device internal errors recovery
> reset flows.
Series applied, thanks.
From: Javier Martinez Canillas
Date: Fri, 9 Sep 2016 08:43:12 -0400
> This trivial series replace the open coding to check for a Kconfig symbol
> being built-in or module, with IS_ENABLED() macro that does exactly that.
>
> Using the macro makes the code more readable by helping abstract away s
From: Christophe Leroy
Date: Fri, 9 Sep 2016 14:26:18 +0200 (CEST)
> This set optimises the freescale fs_enet ethernet driver:
> 1/ Merge of RX and TX NAPI functions in order to limit the amount of
> interrupts
> 2/ Do not unmap DMA when packets len is below copybreak, otherwise there
> is no be
From: Hadar Hen Zion
Date: Thu, 8 Sep 2016 16:23:44 +0300
> This patchset introduces ip tunnel manipulation support using the TC
> subsystem.
Series applied, thanks.
On Mon, Aug 1, 2016 at 2:23 PM, Amir Levy wrote:
> Adding more Thunderbolt(TM) register definitions
> and some helper macros.
Thinking about this again I would prefer it if you would put your
definitions into a separate file under icm/ (even if there is some
duplication). The style (bitfields vs.
Being unsuccessful at getting help so far, can anyone think of who or
where else I could ask for help on this issue?
On Sat, Aug 27, 2016 at 4:55 PM, Quentin Barnes wrote:
> Several years ago, I wrote an iptables module that rewrites packets'
> destination addresses based on the value in the DSCP
On Mon, Aug 1, 2016 at 2:23 PM, Amir Levy wrote:
> This first patch updates the registers file to
> reflect that it isn't only for Cactus Ridge.
> No functional change intended.
>
> Signed-off-by: Amir Levy
> ---
> drivers/thunderbolt/nhi_regs.h | 6 +++---
> 1 file changed, 3 insertions(+), 3 d
On Wed, Aug 31, 2016 at 1:28 PM, Greg KH wrote:
> On Mon, Aug 01, 2016 at 03:23:45PM +0300, Amir Levy wrote:
>> This is version 6 of Thunderbolt(TM) driver for non-Apple hardware.
>>
>> Changes since v5:
>> - Removed the padding of short packets in receive
>> - Replaced RW semaphore with mutex
>
On 9/10/16 4:05 PM, Cyrill Gorcunov wrote:
> On Sat, Sep 10, 2016 at 10:31:35AM -0600, David Ahern wrote:
>>
>> Would you mind adding the destroy capability as well? The udp version
>> should be close to what is needed for raw sockets. See udp_diag_destroy
>> and udp_abort.
>
> Should be something
On Sat, Sep 10, 2016 at 10:31:35AM -0600, David Ahern wrote:
>
> Would you mind adding the destroy capability as well? The udp version
> should be close to what is needed for raw sockets. See udp_diag_destroy
> and udp_abort.
Should be something like below. Didn't tested it yet so for review only
While migrating the bcm_sf2 driver to use b53_common, we left a small
piece untouched where we kept our local copy of the per-port
port_vlan_ctl bitmask value. This value is now maintained by b53_device
so we need to use it instead of our local (and now stale) copy of it.
Fixes: f458995b9ad8 ("net
On Sat, Sep 10, 2016 at 10:31:35AM -0600, David Ahern wrote:
> On 9/9/16 12:26 PM, Cyrill Gorcunov wrote:
> > In criu we are actively using diag interface to collect sockets
> > present in the system when dumping applications. And while for
> > unix, tcp, udp[lite], packet, netlink it works as expe
Allow an L3 master device to act as the loopback for that L3 domain.
For IPv4 the device can also have the address 127.0.0.1.
Signed-off-by: David Ahern
---
include/net/l3mdev.h | 6 +++---
net/ipv4/route.c | 8 ++--
net/ipv6/route.c | 12 ++--
3 files changed, 19 insertion
This patch adds the infrastructure to the output path to pass an skb
to an l3mdev device if it has a hook registered. This is the Tx parallel
to l3mdev_ip{6}_rcv in the receive path and is the basis for removing
the existing hook that returns the vrf dst on the fib lookup.
Signed-off-by: David Ahe
A previous patch added l3mdev flow update making these hooks
redundant. Remove them.
Signed-off-by: David Ahern
---
net/ipv4/ip_output.c| 3 +--
net/ipv4/route.c| 12 ++--
net/ipv4/xfrm4_policy.c | 2 +-
net/ipv6/ip6_output.c | 2 --
net/ipv6/ndisc.c| 11 ++--
No longer needed
Signed-off-by: David Ahern
---
drivers/net/vrf.c | 41 -
include/net/l3mdev.h | 11 ---
net/ipv6/ip6_output.c | 9 +
net/l3mdev/l3mdev.c | 24
4 files changed, 1 insertion(+), 84 deletions(-
No longer needed
Signed-off-by: David Ahern
---
drivers/net/vrf.c| 38 --
include/net/l3mdev.h | 12
include/net/route.h | 10 --
net/ipv4/raw.c | 6 --
net/ipv4/udp.c | 6 --
net/l3mdev/l3mdev.c | 31 --
No longer used
Signed-off-by: David Ahern
---
drivers/net/vrf.c | 5 ++---
include/net/flow.h | 3 +--
2 files changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/net/vrf.c b/drivers/net/vrf.c
index ccce59fbb2b3..55674b0e65b7 100644
--- a/drivers/net/vrf.c
+++ b/drivers/net/vrf.c
@@
Flip the IPv4 output path to use the l3mdev tx out hook. The VRF dst
is not returned on the first FIB lookup. Instead, the dst on the
skb is switched at the beginning of the IPv4 output processing to
send the packet to the VRF driver on xmit.
Signed-off-by: David Ahern
---
drivers/net/vrf.c | 64
No longer used
Signed-off-by: David Ahern
---
include/net/l3mdev.h | 29 -
1 file changed, 29 deletions(-)
diff --git a/include/net/l3mdev.h b/include/net/l3mdev.h
index a5e506eb51de..a586035c97cb 100644
--- a/include/net/l3mdev.h
+++ b/include/net/l3mdev.h
@@ -107,2
No longer used
Signed-off-by: David Ahern
---
drivers/net/vrf.c| 21 -
include/net/l3mdev.h | 21 -
2 files changed, 42 deletions(-)
diff --git a/drivers/net/vrf.c b/drivers/net/vrf.c
index 3a34f547c578..ccce59fbb2b3 100644
--- a/drivers/net/vrf.c
+++
Flip the IPv6 output path to use the l3mdev tx out hook. The VRF dst
is not returned on the first FIB lookup. Instead, the dst on the
skb is switched at the beginning of the IPv6 output processing to
send the packet to the VRF driver on xmit.
Link scope addresses (linklocal and multicast) need spe
The motivation for this series is that ICMP Unreachable - Fragmentation
Needed packets are not handled properly for VRFs. Specifically, the
FIB lookup in __ip_rt_update_pmtu fails so no nexthop exception is
created with the reduced MTU. As a result connections stall if packets
larger than the small
Add l3mdev hook to set FLOWI_FLAG_SKIP_NH_OIF flag and update oif/iif
in flow struct if its oif or iif points to a device enslaved to an L3
Master device. Only 1 needs to be converted to match the l3mdev FIB
rule. This moves the flow adjustment for l3mdev to a single point
catching all lookups. It
On Fri, Sep 9, 2016 at 1:42 PM, Thadeu Lima de Souza Cascardo
wrote:
> When userspace tries to create datapaths and the module is not loaded,
> it will simply fail. With this patch, the module will be automatically
> loaded.
>
> Signed-off-by: Thadeu Lima de Souza Cascardo
Acked-by: Pravin B She
On Sat, Sep 10, 2016 at 11:11 AM, David Miller wrote:
> From: David Ahern
> Date: Sat, 10 Sep 2016 10:25:27 -0600
>
>> On 9/9/16 4:46 PM, Mahesh Bandewar (महेश बंडेवार) wrote:
>>> On Fri, Sep 9, 2016 at 3:26 PM, David Ahern
>>> wrote:
On 9/9/16 3:53 PM, Mahesh Bandewar wrote:
> diff --
From: David Ahern
Date: Sat, 10 Sep 2016 10:25:27 -0600
> On 9/9/16 4:46 PM, Mahesh Bandewar (महेश बंडेवार) wrote:
>> On Fri, Sep 9, 2016 at 3:26 PM, David Ahern wrote:
>>> On 9/9/16 3:53 PM, Mahesh Bandewar wrote:
diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
index 0c5415b05e
On 9/9/16 12:26 PM, Cyrill Gorcunov wrote:
> In criu we are actively using diag interface to collect sockets
> present in the system when dumping applications. And while for
> unix, tcp, udp[lite], packet, netlink it works as expected,
> the raw sockets do not have. Thus add it.
>
> CC: David S. M
On 9/9/16 4:46 PM, Mahesh Bandewar (महेश बंडेवार) wrote:
> On Fri, Sep 9, 2016 at 3:26 PM, David Ahern wrote:
>> On 9/9/16 3:53 PM, Mahesh Bandewar wrote:
>>> diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
>>> index 0c5415b05ea9..95edd1737ab5 100644
>>> --- a/drivers/net/Kconfig
>>> +++ b/
On 9/8/16 6:35 PM, Jojy Varghese wrote:
> Thanks for the feedback guys. I appreciate it.
>
> I am working with 4.4.3 kernel. I will try to reproduce the issue
> with the kernel tree at
> https://git.kernel.org/cgit/linux/kernel/git/davem/net.git.
>
> In the meantime, the only data I have now is
On Fri, Sep 9, 2016 at 2:29 PM, John Fastabend wrote:
> e1000 supports a single TX queue so it is being shared with the stack
> when XDP runs XDP_TX action. This requires taking the xmit lock to
> ensure we don't corrupt the tx ring. To avoid taking and dropping the
> lock per packet this patch ad
>
> Please add more detail to the commit message and add a proper
> "Fixes: " tag right before your signoff.
OK, will repost v2
Since commit 4f0087812648 ("sctp: apply rhashtable api to send/recv
path"), sctp uses transport rhashtable with .obj_cmpfn sctp_hash_cmp,
in which it compares the members of the transport with the rhashtable
args to check if it's the right transport.
But sctp uses the transport without holding it
On 9/10/2016 1:22 AM, Shuah Khan wrote:
Update vDSO Makefile to work under selftests. vDSO will not be run as part
of selftests suite and will not included in install targets. They can be
^ be
built separately for now.
Signed-off-by: Shuah Khan
[...]
MBR,
Hello.
On 9/10/2016 1:22 AM, Shuah Khan wrote:
Update ptp Makefile to work under selftests. ptp will not be run as part
of selftests suite and will not included in install targets. They can be
^ be
built separately for now.
Signed-off-by: Shuah Khan
[...]
Din webmail kvot har överskridit kvoten, vilket är 2 GB. de för närvarande
uppgick till 2,3 GB.
Att återuppliva och öka sin andel av webbmail, klicka på följande länk eller
kopiera länken för att uppdatera ditt konto för webbaserad e-post
Att aktivera den.
https://www.emailmeform.com/builder/for
From: Wei Yongjun
Fixes the following sparse warning:
drivers/net/ethernet/stmicro/stmmac/dwmac-stm32.c:172:1: warning:
symbol 'stm32_dwmac_pm_ops' was not declared. Should it be static?
Signed-off-by: Wei Yongjun
---
drivers/net/ethernet/stmicro/stmmac/dwmac-stm32.c | 3 ++-
1 file changed,
From: Wei Yongjun
Fix missing unlock before return from function macb_start_xmit()
in the error handling case.
Fixes: 007e4ba3ee13 ("net: macb: initialize checksum when using
checksum offloading")
Signed-off-by: Wei Yongjun
---
drivers/net/ethernet/cadence/macb.c | 2 +-
1 file changed, 1 inse
We'd like to eventually remove NO_IRQ on powerpc, so remove usages of it
from powerpc-only drivers.
Signed-off-by: Michael Ellerman
---
drivers/net/ethernet/freescale/fman/fman_mac.h | 2 +-
drivers/net/ethernet/freescale/fs_enet/mac-fcc.c | 2 +-
drivers/net/ethernet/freescale/fs_enet/mac-f
On Mon, Sep 5, 2016 at 3:14 PM, Dmitry Vyukov wrote:
> On Mon, Sep 5, 2016 at 3:08 PM, Tejun Heo wrote:
>> Hello,
>>
>> On Sat, Sep 03, 2016 at 12:58:33PM +0200, Dmitry Vyukov wrote:
>>> > I've seen it only several times in several months, so I don't it will
>>> > be helpful.
>>>
>>>
>>> Bad news
From: Markus Elfring
Date: Sat, 10 Sep 2016 10:38:04 +0200
Adjust the indentation for a call of the macro "DPRINTK" in this function.
Signed-off-by: Markus Elfring
---
drivers/atm/zatm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/atm/zatm.c b/drivers/atm/zatm.c
From: Markus Elfring
Date: Sat, 10 Sep 2016 10:21:15 +0200
* The script "checkpatch.pl" can point information out like the following.
WARNING: Prefer kcalloc over kzalloc with multiply
Thus fix the affected source code place.
* Replace the specification of a data type by a pointer derefere
From: Markus Elfring
Date: Sat, 10 Sep 2016 10:07:38 +0200
Replace the specification of a data structure by a pointer dereference
as the parameter for the operator "sizeof" to make the corresponding size
determination a bit safer according to the Linux coding style convention.
Signed-off-by: Mar
From: Markus Elfring
Date: Sat, 10 Sep 2016 09:55:53 +0200
* A multiplication for the size determination of a memory allocation
indicated that an array data structure should be processed.
Thus use the corresponding function "kmalloc_array".
This issue was detected by using the Coccinelle s
From: Markus Elfring
Date: Sat, 10 Sep 2016 10:54:04 +0200
A few update suggestions were taken into account
from static source code analysis.
Markus Elfring (4):
Use kmalloc_array() in start_tx()
Improve a size determination in zatm_open()
Replace one kzalloc() call by kcalloc()
Fix inde
From: Markus Elfring
Date: Sat, 10 Sep 2016 08:56:03 +0200
The script "checkpatch.pl" can point out that assignments should usually
not be performed within condition checks.
Thus move an assignment for a local variable to a separate statement
in this function.
Signed-off-by: Markus Elfring
---
From: Markus Elfring
Date: Sat, 10 Sep 2016 08:30:09 +0200
Replace the specification of a data structure by a reference for a field
in a local variable as the parameter for the operator "sizeof" to make
the corresponding size determination a bit safer according to
the Linux coding style conventio
From: Markus Elfring
Date: Sat, 10 Sep 2016 08:48:17 +0200
* The script "checkpatch.pl" can point out that assignments should usually
not be performed within condition checks.
Thus move an assignment for a local variable to a separate statement
in this function.
* Replace the specification
From: Markus Elfring
Date: Sat, 10 Sep 2016 08:18:10 +0200
Replace the specification of a data structure by a pointer dereference
as the parameter for the operator "sizeof" to make the corresponding size
determination a bit safer according to the Linux coding style convention.
Signed-off-by: Mar
From: Markus Elfring
Date: Sat, 10 Sep 2016 08:02:06 +0200
* A multiplication for the size determination of a memory allocation
indicated that an array data structure should be processed.
Thus use the corresponding function "kmalloc_array".
This issue was detected by using the Coccinelle s
From: Markus Elfring
Date: Sat, 10 Sep 2016 09:10:01 +0200
A few update suggestions were taken into account
from static source code analysis.
Markus Elfring (5):
Use kmalloc_array() in get_scq()
Improve another size determination in get_scq()
Improve another size determination in ns_init_c
On Fri, 9 Sep 2016 16:22:41 -0600
Shuah Khan wrote:
> Move runnable code (tests) from Documentation to selftests and update
> Makefiles to work under selftests.
>
> Jon Corbet and I discussed this in an email thread and as per that
> discussion, this patch series moves all the tests that are un
60 matches
Mail list logo