Rahul,
> On 24 Apr 2020, at 15:58, Rahul wrote:
>
> Hello,
>
> Request to have my fix reviewed for the issue:
> JDK-8242999 : http/2 client may not handle continuation frames correctly.
>
> The fix updates jdk.internal.net.http.Stream.incoming(Http2Frame frame) to
> handle
> the
Hi Rahul,
That looks very good!
Thanks for taking that on.
Not related to your fix, but could you update the
code that creates the HttpClient to explicitly require no
proxy? I suggest to update:
166 client =
HttpClient.newBuilder().sslContext(sslContext).build();
to:
Thanks for the review comments.
I have updated the webrev :
http://cr.openjdk.java.net/~pconcannon/rayayada/8242999/webrevs/webrev.01/
On 27/04/2020, 12:42, "Daniel Fuchs" wrote:
Hi Rahul,
That looks very good!
Thanks for taking that on.
Not related to your fix, but
On 27/04/2020 14:04, Rahul wrote:
Thanks for the review comments.
I have updated the webrev :
http://cr.openjdk.java.net/~pconcannon/rayayada/8242999/webrevs/webrev.01/
Thanks Rahul!
LGTM.
-- daniel
Rahul,
> On 27 Apr 2020, at 14:04, Rahul wrote:
>
> Thanks for the review comments.
> I have updated the webrev :
> http://cr.openjdk.java.net/~pconcannon/rayayada/8242999/webrevs/webrev.01/
Seems you took my suggestion too literally ;-)
I capitalised some of the text to clearly demarcate it
Hi Chris,
Thank you for letting know, will update.
-- rahul
From: Chris Hegarty
Date: Monday 27 April 2020 at 17:00
To: Rahul , OpenJDK Network Dev list
Subject: Re: RFR 8242999: http/2 client may not handle continuation frames
correctly
Rahul,
On 27 Apr 2020, at 14:04, Rahul
Thanks for the comments. The webrev was updated:
http://cr.openjdk.java.net/~sviswanathan/Vladimir/8243099/webrev.02/
Only the code was changed here. Changes in the documentation will be discussed
separately.
Changes:
1. The LinuxSocketOptions.c was updated according to Vyom comment.
Note, the
The changes for ADq doc update that includes explanation for this technology:
/**
* ADQ (Application Device Queues) is an open technology to help address
network traffic challenges by improving application
* throughput and latency, and, most importantly, by enabling greater
predictability in app
Hi Vladimir,
changes looks much better now, i still see that
function(IncomingNapiIdSupported) & variable(IncomingNapiIdOptSupported)
does not follow Java naming convention.
private static final boolean IncomingNapiIdOptSupported =+
platformSocketOptions.IncomingNapiIdSupported();
Thanks,