Christopher Hegarty - Sun Microsystems Ireland wrote:
On 17/09/2009 21:18, Alan Bateman wrote:
Christopher Hegarty -Sun Microsystems Ireland wrote:
Max (Weijun) Wang wrote:
HttpURLConnection.java:
I think "if (authScheme.equals(BASIC))" can be written as
"authScheme == BASIC", and possibl
On 17/09/2009 21:18, Alan Bateman wrote:
Christopher Hegarty -Sun Microsystems Ireland wrote:
Max (Weijun) Wang wrote:
HttpURLConnection.java:
I think "if (authScheme.equals(BASIC))" can be written as
"authScheme == BASIC", and possibly you can use switch/case in
several places
Thanks M
Christopher Hegarty -Sun Microsystems Ireland wrote:
Max (Weijun) Wang wrote:
HttpURLConnection.java:
I think "if (authScheme.equals(BASIC))" can be written as
"authScheme == BASIC", and possibly you can use switch/case in
several places
Thanks Max, these changes certainly make the code
Max (Weijun) Wang wrote:
HttpURLConnection.java:
I think "if (authScheme.equals(BASIC))" can be written as "authScheme
== BASIC", and possibly you can use switch/case in several places
Thanks Max, these changes certainly make the code more readable.
Updated webrev can be found at:
http:
HttpURLConnection.java:
I think "if (authScheme.equals(BASIC))" can be written as
"authScheme == BASIC", and possibly you can use switch/case in several
places
Thanks
Max
On Sep 17, 2009, at 6:55 PM, Christopher Hegarty -Sun Microsystems
Ireland wrote:
I removed the use of char (sch
I removed the use of char (schemeId) completed and replaced it the the
new AuthScheme enum. This makes the code much cleaner. Thanks Max and
Alan for this suggestion.
Updated webrev can be found at:
http://cr.openjdk.java.net/~chegar/6882594/webrev.1/webrev/
Thanks,
-Chris.
Christopher Hega