Max (Weijun) Wang wrote:
HttpURLConnection.java:
I think "if (authScheme.equals(BASIC))" can be written as "authScheme
== BASIC", and possibly you can use switch/case in several places
Thanks Max, these changes certainly make the code more readable.
Updated webrev can be found at:
http://cr.openjdk.java.net/~chegar/6882594/webrev.1/webrev/
Thanks,
-Chris.
Thanks
Max
On Sep 17, 2009, at 6:55 PM, Christopher Hegarty -Sun Microsystems
Ireland wrote:
I removed the use of char (schemeId) completed and replaced it the the
new AuthScheme enum. This makes the code much cleaner. Thanks Max and
Alan for this suggestion.
Updated webrev can be found at:
http://cr.openjdk.java.net/~chegar/6882594/webrev.1/webrev/
Thanks,
-Chris.
Christopher Hegarty - Sun Microsystems Ireland wrote:
Hi Jessie, Michael, Alan,
6882594: Remove static dependency on NTLM authentication
Webrev:
http://cr.openjdk.java.net/~chegar/6882594/webrev.0
The HTTP client implementation
(sun.net.www.protocol.http.HttpURLConnection) loads the NTLM
Authentication classes even if no authentication is used. These
classes should not be loaded unless required. Also, make NTLM a
runtime dependency rather than a static one.
I took the liberty of cleaning up some imports along the way.
-Chris.