On Wed, Aug 31, 2016 at 10:03:03AM -0700, Kevin J. McCarthy wrote:
> On Sat, Aug 13, 2016 at 05:30:52PM -0400, Damien Riegel wrote:
> > The purpose of this pachset is to rewrite the way Mutt handles logging
> > when compiled with the debug mode.
>
> Just to add a quick comment, I have noted this p
* On 31 Aug 2016, Damien Riegel wrote:
>
> Fair enough! There are some guidelines [1] but maybe they could be more
> detailed to have consistent style for new contributions. For instance,
> the expected output of `indent` is not obvious, and it seems to be
> missing some arguments to be closer to
> > > @@ -162,6 +162,7 @@
> > > WHERE const char *ReleaseDate;
> > >
> > > WHERE HASH *Groups;
> > > +WHERE HASH *Labels;
> >
> > A bit off topic, what do people think of the `WHERE` macro? To me, it
> > only makes tools like cscope confused and doesn't improve readability, I
> > would really
On Wed, Aug 31, 2016 at 02:10:50PM -0700, David Champion wrote:
> * On 31 Aug 2016, Kevin J. McCarthy wrote:
> > On Wed, Aug 31, 2016 at 11:42:34AM -0400, Damien Riegel wrote:
> > > On Tue, Aug 30, 2016 at 06:18:37PM -0700, d...@bikeshed.us wrote:
> > > Your patch mixes tabulations and whitespaces
At 17:59 -0700 30 Aug 2016, d...@bikeshed.us wrote:
Mailboxrx allows you to define a regular expression and replacement
template for mailbox names. Wherever status_format's %f is expanded,
the folder name will be matched in turn against each mailboxrx
expression. If any expression matches, a re
I've been using this patch in my build for quite a while now (from the
logs in my dotfiles repo it looks like a bit over 3 years) and it's been
working well for me. I have added the attached patch on top to allow me
to use folder-hooks to change the replacements in use.
commit 2de07b2
Author: Aa
* On 31 Aug 2016, Damien Riegel wrote:
>
> It also makes use of mutt_label_complete which doesn't exist at this
> point. If there are patches that need to be reviewed in order, it would
> be nice to group them in a numeroted serie/patchset.
Yes, they were sent in order but I didn't realize that
* On 31 Aug 2016, Kevin J. McCarthy wrote:
> On Wed, Aug 31, 2016 at 11:42:34AM -0400, Damien Riegel wrote:
> > On Tue, Aug 30, 2016 at 06:18:37PM -0700, d...@bikeshed.us wrote:
> > Your patch mixes tabulations and whitespaces. I believe mutt's policy is
> > whitespaces only, so it would be nice t
* On 31 Aug 2016, Damien Riegel wrote:
> > /* Set CurrentMenu to MENU_MAIN before executing any folder
> > @@ -1270,6 +1273,8 @@
> > (option (OPTREADONLY) || op ==
> > OP_MAIN_CHANGE_FOLDER_READONLY) ?
> > MUTT_READONLY :
On Sat, Aug 13, 2016 at 05:30:52PM -0400, Damien Riegel wrote:
> The purpose of this pachset is to rewrite the way Mutt handles logging
> when compiled with the debug mode.
Just to add a quick comment, I have noted this patch series and will get
to it.
However, from my point of view, rewriting th
:+1:!! I'm glad, I'm not the only one who saw a need for this.
Thanks!
Yoshiki.
On (Aug-30-16|17:53), d...@bikeshed.us wrote:
> curs_main.c | 2 +-
> init.h | 8
> mutt.h | 1 +
> 3 files changed, 10 insertions(+), 1 deletions(-)
>
>
> # HG changeset patch
> # User David
On Wed, Aug 31, 2016 at 11:42:34AM -0400, Damien Riegel wrote:
> On Tue, Aug 30, 2016 at 06:18:37PM -0700, d...@bikeshed.us wrote:
> Your patch mixes tabulations and whitespaces. I believe mutt's policy is
> whitespaces only, so it would be nice to use only whitespaces for all
> new code.
Just to
On Tue, Aug 30, 2016 at 04:18:43PM -0700, David Champion wrote:
> Now that we're solidly past 1.6, and since I've taken a couple of
> weekends to firm up some work, I'm going to shoot out a few patches
> that I've been hoarding for-- well, years.
>
> @Kevin, I don't mean to dump these on you. I'l
Hi David,
On Tue, Aug 30, 2016 at 06:03:37PM -0700, d...@bikeshed.us wrote:
> curs_main.c | 5
> doc/manual.xml.head | 5 +++-
> enter.c | 18 +
> globals.h | 1 +
> headers.c | 46 -
>
On Mon, Aug 29, 2016 at 02:49:34PM +, Antonio Radici wrote:
> On Sun, Aug 28, 2016 at 05:37:30PM +0200, Oswald Buddenhagen wrote:
> > i just attempted to build mutt against openssl 1.1, and got this:
> >
> > mutt_ssl.c:636:18: error: storage size of ‘xsc’ isn’t known
> >X509_STORE_CTX xsc;
Hi,
On Wed, Aug 31, 2016 at 12:20:59AM -0700, David Champion wrote:
> * On 30 Aug 2016, Oswald Buddenhagen wrote:
> > > When $flag_safe is set, flagged messages cannot be deleted.
> > >
> > note that many of your patches have a "malformed" summary: you should
> > use imperative (or simple past,
On Mon, Aug 29, 2016 at 11:24:13AM +0200, Fabian Groffen wrote:
> While trying to compile Mutt on Solaris, I found that since
>
> 6837:ce71d168c819
>
> getaddrinfo is used for hostname resolution, which needs socket libs.
> Please find a patch for inspiration. As far as I can tell, we always
> n
On Tue, Aug 30, 2016 at 06:18:37PM -0700, d...@bikeshed.us wrote:
> enter.c | 27 ++-
> 1 files changed, 26 insertions(+), 1 deletions(-)
>
>
> # HG changeset patch
> # User David Champion
> # Date 1472606303 25200
> # Tue Aug 30 18:18:23 2016 -0700
> # Node ID b18
There are mostly fair comments. I've had this patch for many years in
the middle of a patch queue and I'd forgotten it was still rough. I'll
withdraw this - I'm not going to find time for updating it.
* On 30 Aug 2016, Oswald Buddenhagen wrote:
> On Tue, Aug 30, 2016 at 04:34:37PM -0700, d...@b
* On 30 Aug 2016, Oswald Buddenhagen wrote:
> > When $flag_safe is set, flagged messages cannot be deleted.
> >
> note that many of your patches have a "malformed" summary: you should
> use imperative (or simple past, but kevin appears to prefer the former).
> you're supposed to describe a transi
20 matches
Mail list logo