- Original Message -
> ---
> src/gallium/auxiliary/tgsi/tgsi_ureg.c | 43
>
> 1 file changed, 16 insertions(+), 27 deletions(-)
>
> diff --git a/src/gallium/auxiliary/tgsi/tgsi_ureg.c
> b/src/gallium/auxiliary/tgsi/tgsi_ureg.c
> index 75be6cf..082fec3
Could you add some comments? It's not obvious what's the difference between
local temporaries and temporaries, and what is their purpose.
Jose
- Original Message -
> ---
> src/gallium/auxiliary/tgsi/tgsi_ureg.c | 54
>
> src/gallium/auxiliary/tgsi/tgs
- Original Message -
> The 'is_branch' TGSI opcode info flag was being interpreted
> incorrectly by tgsi_text.c as if it implied that the opcode requires
> a
> label token -- that's not the case on e.g. IF, BGNLOOP or ENDLOOP.
IF, BGNLOOP or ENDLOOP used to have a label. And some old shade
This doesn't look like a "winsys" per se, but rather an auxiliary library to
create winsys and screens, meant to be used by state trackers. Is this right?
If so then I believe the right place would be somewhere src/gallium/auxiliary .
Jose
- Original Message -
> The goal is to have a un
Except where I made explicit remarks, the series looks sensible to me overall.
Jose
- Original Message -
> Most of these changes affect various parts of the gallium auxiliary
> libraries and they aren't directly related to compute by themselves,
> but they turned out to be useful for the
On 24.03.2012 21:18, Andy Furniss wrote:
Christian König wrote:
That wasn't working as supposed.
What is the status of the recent interlaced commits?
AFAICT not enabled yet - I did have a look by doing
Correct, well I started to implement deinterlacing, and both bob and
weave at least does
- Original Message -
> Jakob Bornecrantz writes:
>
> > - Original Message -
> >> Jakob Bornecrantz writes:
> >>
> >> >> +libws_loader_la_LIBADD = \
> >> >> + $(top_srcdir)/src/gallium/winsys/sw/null/libws_null.la
> >> >> +
> >> >> +if HAVE_XLIB_LOADER_GALLIUM
> >> >> +libws_load
On 26.03.2012 14:56, Jose Fonseca wrote:
This doesn't look like a "winsys" per se, but rather an auxiliary library to
create winsys and screens, meant to be used by state trackers. Is this right?
If so then I believe the right place would be somewhere src/gallium/auxiliary .
Jose
The same is t
- Original Message -
> On 26.03.2012 14:56, Jose Fonseca wrote:
> > This doesn't look like a "winsys" per se, but rather an auxiliary
> > library to create winsys and screens, meant to be used by state
> > trackers. Is this right?
> >
> > If so then I believe the right place would be somewh
Jose Fonseca writes:
> This doesn't look like a "winsys" per se, but rather an auxiliary library to
> create winsys and screens, meant to be used by state trackers. Is this right?
>
> If so then I believe the right place would be somewhere src/gallium/auxiliary
> .
>
Essentially it's an interfa
Jose Fonseca writes:
> - Original Message -
>> The 'is_branch' TGSI opcode info flag was being interpreted
>> incorrectly by tgsi_text.c as if it implied that the opcode requires
>> a
>> label token -- that's not the case on e.g. IF, BGNLOOP or ENDLOOP.
>
> IF, BGNLOOP or ENDLOOP used to
On 03/24/2012 03:09 AM, Benjamin Franzke wrote:
The extension is already exposed for GLES1, but the APIspec
doesnt allow the usage of GL_BGRA_EXT in glTex(Sub)Image2D.
---
src/mesa/main/APIspec.xml |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/mesa/main/APIspec.x
On 03/24/2012 11:13 AM, Dave Airlie wrote:
From: Dave Airlie
attempt 2 : drop the regen files
This adds the xml file covering ARB_blend_func_extended.
A regen is required after commit.
Signed-off-by: Dave Airlie
Looks good to me.
Reviewed-by: Kenneth Graunke
__
Looks good.
Jose
- Original Message -
> Fixes Coverity resource leak defect.
>
> NOTE: This is candidate for the 8.0 branch.
>
> Signed-off-by: Vinson Lee
> ---
> src/mesa/main/mipmap.c |1 +
> 1 files changed, 1 insertions(+), 0 deletions(-)
>
> diff --git a/src/mesa/main/mipmap
On 03/23/2012 11:16 PM, Vinson Lee wrote:
Fixes Coverity resource leak defect.
NOTE: This is candidate for the 8.0 branch.
Signed-off-by: Vinson Lee
---
src/mesa/main/mipmap.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/mesa/main/mipmap.c b/src/mesa/main/mipm
On Sat, 24 Mar 2012 18:20:13 +, Dave Airlie wrote:
> On Sat, Mar 24, 2012 at 6:13 PM, Dave Airlie wrote:
> > From: Dave Airlie
> >
> > attempt 2 : drop the regen files
> > This adds the xml file covering ARB_blend_func_extended.
> >
> > A regen is required after commit.
> >
> > Signed-off-by
On 03/23/2012 03:27 PM, nobled wrote:
---
These are based on the sorting-the-xml patches I forgot to push a while back:
http://lists.freedesktop.org/archives/mesa-dev/2012-January/017610.html
Which I'll push along with these if they're okay to commit.
src/mapi/glapi/gen/ARB_depth_buffer_float.
---
v3: Handle memory allocation failure.
src/gallium/auxiliary/tgsi/tgsi_ureg.c | 49 ++--
1 file changed, 22 insertions(+), 27 deletions(-)
diff --git a/src/gallium/auxiliary/tgsi/tgsi_ureg.c
b/src/gallium/auxiliary/tgsi/tgsi_ureg.c
index 75be6cf..ed613ce 100644
---
v3: Handle memory allocation failure. Add comment on the purpose of
ureg_DECL_local_temporary.
src/gallium/auxiliary/tgsi/tgsi_ureg.c | 58
src/gallium/auxiliary/tgsi/tgsi_ureg.h |8 +
2 files changed, 60 insertions(+), 6 deletions(-)
diff --gi
The GL_EXT_unpack_subimage extension just allows GL_UNPACK_ROW_LENGTH,
GL_UNPACK_SKIP_PIXELS and GL_UNPACK_SKIP_ROWS on GLES2. This tries
setting those three values and if the extension is available it will
assert that no error is thrown, otherwise it will assert that
GL_INVALID_ENUM is thrown. It
Structured branch instructions like IF, ELSE, BGNLOOP, ENDLOOP no
longer require a label argument, make it optional for them.
---
src/gallium/auxiliary/tgsi/tgsi_text.c | 19 +--
1 file changed, 9 insertions(+), 10 deletions(-)
diff --git a/src/gallium/auxiliary/tgsi/tgsi_text.c
https://bugs.freedesktop.org/show_bug.cgi?id=47248
--- Comment #4 from Joel 2012-03-26 11:07:59 PDT ---
Thanks Kenneth, you're right.
I had hit a bug where `make distclean` wasn't removing the old bison-generated
files. This might explain why my last two bisects went bad.
--
Configure bugmail:
This set doesn't contain any driver support, I've gotten softpipe mostly working
(it fails one of my piglit tests) and r600g passes all of them.
The bit I'm most unsure about is the GLSL support, since I can't find hw that
does more than 1 dual-source RT, so I've no idea how they would expect the
From: Dave Airlie
Though I don't think we'll ever expose > 1.
Signed-off-by: Dave Airlie
---
src/gallium/docs/source/screen.rst |2 +-
src/gallium/drivers/r300/r300_screen.c |2 +-
src/gallium/drivers/r600/r600_pipe.c |4 +++-
src/gallium/drivers/softpipe/sp_screen.c |
From: Dave Airlie
This adds the blend mode mapping, it also uses the var->index in the
glsl to tgsi convertor - this is the other half of my using 4 in the GLSL
compiler.
Signed-off-by: Dave Airlie
---
src/mesa/state_tracker/st_atom_blend.c |8
src/mesa/state_tracker/st_extens
From: Dave Airlie
Add implementations of the two API functions,
Add a new strings to uint mapping for index bindings
Add the blending mode validation for SRC1 + SRC_ALPHA_SATURATE
Add get for MAX_DUAL_SOURCE_DRAW_BUFFERS
The GLSL patch will setup the indices.
Signed-off-by: Dave Airlie
---
sr
From: Dave Airlie
This adds index support to the GLSL compiler.
I'm not 100% sure of my approach here, esp without how output ordering
happens wrt location, index pairs, in the "mark" function.
Since current hw doesn't ever have a location > 0 with an index > 0,
we don't have to work out if the
Christian König wrote:
Hui? Well i thought I got weave working also, obviously need to take a
look at it again. Anyway, this isn't really interesting until somebody
implements a temporal and/or temporal-spatial deinterlacing. I just
wanted to have the needed infrastructure ready and public avail
On Mon, Mar 26, 2012 at 2:14 PM, Dave Airlie wrote:
> src/mesa/main/blend.c | 11
> src/mesa/main/get.c | 3 +
> src/mesa/main/mtypes.h | 4 ++
> src/mesa/main/shader_query.cpp | 103
> ++--
> src/mesa/main/shaderapi.c
Christian König writes:
>[...]
> On 26.03.2012 17:20, Francisco Jerez wrote:
>> Essentially it's an interface to enumerate the graphic devices that are
>> present in the system (and by extension to create screens on them,
>> enumeration alone is useless without having a way to do something with
>>
On Tue, Mar 13, 2012 at 10:28 AM, Jakob Bornecrantz wrote:
> - Original Message -
>> On Mon, Mar 12, 2012 at 8:05 PM, Jakob Bornecrantz wrote:
>> > Hi all
>> >
>> > We well over due for a 8.0.1 release, so I thought
>> > we do it aggressively this week. A quick rc tomorrow
>> > and a rele
- Original Message -
> Christian König writes:
> >[...]
> > On 26.03.2012 17:20, Francisco Jerez wrote:
> >> Essentially it's an interface to enumerate the graphic devices
> >> that are
> >> present in the system (and by extension to create screens on them,
> >> enumeration alone is usel
- Original Message -
> On Tue, Mar 13, 2012 at 10:28 AM, Jakob Bornecrantz
> wrote:
> > - Original Message -
> >> On Mon, Mar 12, 2012 at 8:05 PM, Jakob Bornecrantz
> >> wrote:
> >> > Hi all
> >> >
> >> > We well over due for a 8.0.1 release, so I thought
> >> > we do it aggressiv
Having to explicitly dereference is irritating and bloats the code,
when we can detect and do the right thing (at the expense of type
safety, given that we're taking an ir_instruction to manage this
instead of ir_rvalue).
---
src/glsl/ir_builder.cpp |8
src/mesa/main/ff_f
---
src/mesa/main/ff_fragment_shader.cpp | 11 ---
1 files changed, 0 insertions(+), 11 deletions(-)
diff --git a/src/mesa/main/ff_fragment_shader.cpp
b/src/mesa/main/ff_fragment_shader.cpp
index afc17dc..7b83043 100644
--- a/src/mesa/main/ff_fragment_shader.cpp
+++ b/src/mesa/main/ff_
The C++ constructors with placement new, while functional, are
extremely verbose, leading to generation of simple GLSL IR expressions
like (a * b + c * d) expanding to many lines of code and using lots of
temporary variables. By creating a new ir_builder.h that puts simple
generators in our namesp
Now we can fold a bunch of our expression setup in ff_fragment_shader
into single-line, parseable commits.
---
src/glsl/ir_builder.cpp | 85 ++
src/glsl/ir_builder.h| 12 +
src/mesa/main/ff_fragment_shader.cpp | 66 +++-
However, as is often the case with writing helper functions, we end up
with more code overall and another API to understand. I'm tempted to
not commit this code unless one either the ARB to GLSL IR work or the
FFVS work finds it to be useful.
Some of the remaining awkward GLSL IR code in ff_fragm
This lets us significantly shorten p->instructions->push_tail(ir), and
will be used in a few more places.
---
src/glsl/ir_builder.cpp |6 +++
src/glsl/ir_builder.h|8
src/mesa/main/ff_fragment_shader.cpp | 78 --
3 files c
---
src/glsl/ir_builder.cpp | 26 +
src/glsl/ir_builder.h|3 ++
src/mesa/main/ff_fragment_shader.cpp | 66 +-
3 files changed, 46 insertions(+), 49 deletions(-)
diff --git a/src/glsl/ir_builder.cpp b/src/glsl/ir_buil
---
src/glsl/ir_builder.cpp | 11 +
src/glsl/ir_builder.h|1 +
src/mesa/main/ff_fragment_shader.cpp | 42 +-
3 files changed, 23 insertions(+), 31 deletions(-)
diff --git a/src/glsl/ir_builder.cpp b/src/glsl/ir_builder.c
Fixes piglit GL_ARB_texture_buffer_object/get
---
src/mesa/main/texobj.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/mesa/main/texobj.c b/src/mesa/main/texobj.c
index 97bef35..d7dee4f 100644
--- a/src/mesa/main/texobj.c
+++ b/src/mesa/main/texobj.c
@@ -153,6 +153,7
We're supposed to just immediately call it. Fixes piglit
GL_ARB_texture_buffer_object/dlist
---
src/mesa/main/dlist.c |3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/src/mesa/main/dlist.c b/src/mesa/main/dlist.c
index f113573..8cfb97c 100644
--- a/src/mesa/main/dlist.c
On Mon, 26 Mar 2012 19:14:01 +0100, Dave Airlie wrote:
> From: Dave Airlie
>
> Add implementations of the two API functions,
> Add a new strings to uint mapping for index bindings
> Add the blending mode validation for SRC1 + SRC_ALPHA_SATURATE
> Add get for MAX_DUAL_SOURCE_DRAW_BUFFERS
>
> The
I've got a question for GLSL 1.40 that could use some interpretation:
Section 1.2.5 in the spec says:
"The following features, previously deprecated, are removed:
...
Fixed functionality for a programmable stage. Supply shaders for
all stages currently being used."
What exactly
This should fit in well with our lower_mat_op_to_vec code: now, in
addition to having expressions on each column of a matrix, we also
split the columns to separate variables so they can be tracked
individually by the copy propagation, dead code, and other passes.
This optimizes out some more code
The builtins we have are generally optimized, having been
hand-written. This avoids generating bad code when an optimization
pass prints debug output.
---
src/glsl/builtins/tools/generate_builtins.py |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/glsl/builtins/tools
This change (before the previous two) produced a .23% +/- .11%
performance improvement in Unigine Tropics at 1024x768 on IVB.
Total instructions: 269270 -> 262649
614/2148 programs affected (28.6%)
179386 -> 172765 instructions in affected programs (3.7% reduction)
v2: Move some of the logic of f
I've had this code laying around almost done for a long time. The
idea is like opt_structure_splitting, that we've got a bunch of
transforms at the GLSL IR level that only understand scalars and
vectors, which just skip complicated dereferences. While driver
backends may manage some optimization
By making a bool fs_reg only have a defined low bit (matching CMP
output), instead of being a full 0 or 1 value, we reduce the ANDs
generated in logic chains like:
if (v_texcoord.x < 0.0 || v_texcoord.x > texwidth ||
v_texcoord.y < 0.0 || v_texcoord.y > 1.0)
discard;
My concern or
Jose Fonseca writes:
>[...]
>> In my
>> understanding it's a set of primitives that abstract the platform
>> specific details of the implementation, where "details" include:
>> - device binding
>> - memory management
>> - command submission
>
>> My proposal boils down to including "device enume
The goal is to have a uniform interface to create winsys and
pipe_screen instances for any driver, exposing the device enumeration
capabilities that might be supported by the operating system (for now
there's a "drm" back-end using udev and a "sw" back-end that always
returns the same built-in devi
It simplifies things slightly, and besides, it makes possible to
execute the trivial tests on a hardware device instead of being
limited to software rendering.
Reviewed-by: Jakob Bornecrantz
---
v3: Move ws_loader to auxiliary/ and rename to pipe-loader.
configure.ac |
Reviewed-by: Jakob Bornecrantz
---
v3: Move ws_loader to auxiliary/ and rename to pipe-loader.
configure.ac |1 +
src/gallium/state_trackers/gbm/gbm_drm.c |5 +-
.../state_trackers/gbm/gbm_gallium_drmint.h|3 +
src/gallium/targe
https://bugs.freedesktop.org/show_bug.cgi?id=47930
Bug #: 47930
Summary: Use InitializeNativeTargetDisassembler() on LLVM >=
3.1
Classification: Unclassified
Product: Mesa
Version: git
Platform: Other
OS/Versio
On Mon, Mar 26, 2012 at 9:17 PM, Eric Anholt wrote:
> On Mon, 26 Mar 2012 19:14:01 +0100, Dave Airlie wrote:
>> From: Dave Airlie
>>
>> Add implementations of the two API functions,
>> Add a new strings to uint mapping for index bindings
>> Add the blending mode validation for SRC1 + SRC_ALPHA_S
56 matches
Mail list logo