Seeing as they were only used once (in the same function they were
defined), having them as context members seemed rather pointless.
Remove them entirely (rather than using local variables) since the
chipset generation checks are actually just as straightforward.
While we're at it, clean up the r
Seeing as they were only used once (in the same function they were
defined), having them as context members seemed rather pointless.
Remove them entirely (rather than using local variables) since the
chipset generation checks are actually just as straightforward.
While we're at it, clean up the r
It seems that GT1/GT2 sorts of variations are here to stay, and more
special cases will likely be required in the future. Checking by PCI ID
via the IS_xxx_GTx macros is cumbersome; introducing a new 'gt' field
analogous to intel->gen will make this easier.
Signed-off-by: Kenneth Graunke
---
sr
---
src/mesa/main/api_validate.c |9 ++---
1 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/src/mesa/main/api_validate.c b/src/mesa/main/api_validate.c
index 1fcf5cd..9338f4c 100644
--- a/src/mesa/main/api_validate.c
+++ b/src/mesa/main/api_validate.c
@@ -257,7 +257,8 @@ _mes
https://bugs.freedesktop.org/show_bug.cgi?id=38789
Jure Repinc changed:
What|Removed |Added
Status|NEW |RESOLVED
Resolution|
This is required for D3D1x and supported by hardware.
---
src/gallium/auxiliary/draw/draw_pipe_offset.c |6 ++
src/gallium/auxiliary/util/u_dump_state.c |1 +
src/gallium/docs/source/cso/rasterizer.rst|2 ++
src/gallium/drivers/trace/tr_dump_state.c |1 +
src/galliu
---
.../state_trackers/d3d1x/gd3d11/d3d11_screen.h |3 +--
1 files changed, 1 insertions(+), 2 deletions(-)
diff --git a/src/gallium/state_trackers/d3d1x/gd3d11/d3d11_screen.h
b/src/gallium/state_trackers/d3d1x/gd3d11/d3d11_screen.h
index 3674731..ef23b7d 100644
--- a/src/gallium/state_t
---
src/gallium/drivers/nv50/nv50_3d.xml.h |2 +-
src/gallium/drivers/nv50/nv50_state.c|2 ++
src/gallium/drivers/nv50/nv50_stateobj.h |2 +-
src/gallium/drivers/nvc0/nvc0_3d.xml.h |2 ++
src/gallium/drivers/nvc0/nvc0_state.c|2 ++
src/gallium/drivers/nvc0/nvc0_stat
---
src/gallium/drivers/r600/evergreen_state.c |2 +-
src/gallium/drivers/r600/r600_state.c |2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/gallium/drivers/r600/evergreen_state.c
b/src/gallium/drivers/r600/evergreen_state.c
index 3b7844f..7a6b246 100644
---
Hello All
I am using Mesa-7.10.2 stack.
I am trying to run EGL with egl_gallium state trackers
(GLES=>EGL=>egl_gallium=>
fbdev) over fbdev with following
configuration
./configure --prefix=/opt/mesa-arm-genoa-new --host=arm-linux
--build=i686-linux --enable-gles2 --with-x=no
--with-egl-plat
er(struct native_surface *nsurf)
> {
> printf("%s%s\n", __FUNCTION__, __FILE__);
> struct fbdev_surface *fbsurf = fbdev_surface(nsurf);
>
> if (!fbsurf->is_current)
> return TRUE;
>
> if(fbsurf->type == FBDEV_SURFACE_TYPE_PIXMAP) //Vivek
>
https://bugs.freedesktop.org/show_bug.cgi?id=41162
--- Comment #1 from zox...@gmail.com 2011-09-24 11:30:09 PDT ---
This does not happen with the equivalent OpenGL functions.
--
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
--- You are receiving this mail because: -
On Sat, 24 Sep 2011 01:53:21 -0700, Kenneth Graunke
wrote:
> It seems that GT1/GT2 sorts of variations are here to stay, and more
> special cases will likely be required in the future. Checking by PCI ID
> via the IS_xxx_GTx macros is cumbersome; introducing a new 'gt' field
> analogous to intel
On Fri, 23 Sep 2011 23:45:54 -0700, Kenneth Graunke
wrote:
> I mistakenly set GEN7_PS_MAX_THREAD_SHIFT to 23; it's actually 24 on
> Ivybridge. Not only did this halve our thread count, it caused us to
> write 1 into a bit 23, which is marked as MBZ (must be zero).
> Furthermore, it made us write
On Fri, 2011-09-23 at 14:25 -0700, Mickey Lyle wrote:
> First- This may really be the wrong place for this, if so kindly point me in
> the right direction and I will buzz off!
>
> I'm trying to run Half Life 2 through Wine on Xubuntu 11.04 using
> xorg-edgers and the r600g driver. Here's what I ge
On Sat, Sep 24, 2011 at 7:47 AM, Christoph Bumiller
wrote:
> This is required for D3D1x and supported by hardware.
> ---
> src/gallium/auxiliary/draw/draw_pipe_offset.c | 6 ++
> src/gallium/auxiliary/util/u_dump_state.c | 1 +
> src/gallium/docs/source/cso/rasterizer.rst | 2
Hi Paul,
In enable.c:
1. At line 307, s/GL_CLIP_PLANE0/GL_CLIP_DISTANCE0/ to be consistent.
2. Need to check that p < ctx->Const.MaxClipPlanes.
3. In _mesa_IsEnabled(), need to s/GL_CLIP_PLANE/GL_CLIP_DISTANCE/,
add the two extra switch cases for planes 6,7 and check the plane
index against ctx
On Fri, 23 Sep 2011 17:36:16 -0700
Ben Widawsky wrote:
> Clean the code up, and always use a BO when creating a new buffer.
> I've not seen any regressions but haven't yet tried this on < Gen6.
>
> Cc: Chad Versace
> Cc: Eric Anholt
> Cc: Mesa Devs
> Signed-off-by: Ben Widawsky
> ---
I scre
Signed-off-by: Matt Turner
---
The last discussion about using automake ("[RFC] Convert mesa to
automake/libtool")
ended without anything happening, probably because the branch wasn't ready.
This patch is an attempt to get the ball rolling again. Without ripping out
the entire existing build sys
On 24 September 2011 15:44, Brian Paul wrote:
> Hi Paul,
>
> In enable.c:
>
> 1. At line 307, s/GL_CLIP_PLANE0/GL_CLIP_DISTANCE0/ to be consistent.
>
> 2. Need to check that p < ctx->Const.MaxClipPlanes.
>
> 3. In _mesa_IsEnabled(), need to s/GL_CLIP_PLANE/GL_CLIP_DISTANCE/,
> add the two extra s
20 matches
Mail list logo