On 12.07.2013 16:06, Jose Fonseca wrote:
> The tradition has been to use "C" suffix for conditional opcodes, instead of
> "_IF". That said, I don't feel too strongly either way.
>
Except the 'C' suffix usually (ok, we only have BREAKC) indicates a
single condition value where non-zero means tru
On 07/12/2013 08:06 AM, Jose Fonseca wrote:
The tradition has been to use "C" suffix for conditional opcodes, instead of
"_IF". That said, I don't feel too strongly either way.
I agree that the current naming is confusing. And I like the fact that the new
and old opcodes don't overlap, which
The tradition has been to use "C" suffix for conditional opcodes, instead of
"_IF". That said, I don't feel too strongly either way.
I agree that the current naming is confusing. And I like the fact that the new
and old opcodes don't overlap, which means there is no way we inadvertently get
th
TGSI_OPCODE_KIL and KILP had confusing names. The former was conditional
kill (if any src component < 0). The later was unconditional kill.
At one time KILP was supposed to work with NV-style condition
codes/predicates but we never had that in TGSI.
This patch renames both opcodes:
TGSI_OPCODE