Pass and return tgsi_token buffers instead of pipe_shader_state.
And update softpipe driver (the only user of this function).
---
src/gallium/auxiliary/util/u_pstipple.c| 28
src/gallium/auxiliary/util/u_pstipple.h|5 ++--
src/gallium/drivers/softpipe/sp
Use the new helper functions in the tgsi_transform.h file to emit
declarations and instructions.
---
src/gallium/auxiliary/util/u_pstipple.c | 187 ++-
1 file changed, 62 insertions(+), 125 deletions(-)
diff --git a/src/gallium/auxiliary/util/u_pstipple.c
b/src/galli
Fixes polygon stipple if both DO_PSTIPPLE_IN_DRAW_MODULE and
DO_PSTIPPLE_IN_HELPER_MODULE are zero/off.
---
src/gallium/drivers/softpipe/sp_state_derived.c |1 +
1 file changed, 1 insertion(+)
diff --git a/src/gallium/drivers/softpipe/sp_state_derived.c
b/src/gallium/drivers/softpipe/sp_stat
---
src/gallium/drivers/softpipe/sp_fs.h |3 +--
src/gallium/drivers/softpipe/sp_fs_exec.c |3 +--
src/gallium/drivers/softpipe/sp_state_shader.c |2 +-
3 files changed, 3 insertions(+), 5 deletions(-)
diff --git a/src/gallium/drivers/softpipe/sp_fs.h
b/src/gallium/dri
To match tgsi_alloc_tokens().
---
src/gallium/auxiliary/tgsi/tgsi_parse.c | 10 ++
src/gallium/auxiliary/tgsi/tgsi_parse.h |3 +++
2 files changed, 13 insertions(+)
diff --git a/src/gallium/auxiliary/tgsi/tgsi_parse.c
b/src/gallium/auxiliary/tgsi/tgsi_parse.c
index 5bf8f48..f2370ed
---
src/gallium/auxiliary/util/u_pstipple.c | 30 --
1 file changed, 12 insertions(+), 18 deletions(-)
diff --git a/src/gallium/auxiliary/util/u_pstipple.c
b/src/gallium/auxiliary/util/u_pstipple.c
index 5c6c8fc..ba80956 100644
--- a/src/gallium/auxiliary/util/u_pst
---
src/gallium/drivers/softpipe/sp_state_shader.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/gallium/drivers/softpipe/sp_state_shader.c
b/src/gallium/drivers/softpipe/sp_state_shader.c
index 8d18ca9..58a2498 100644
--- a/src/gallium/drivers/softpipe/sp
https://bugs.freedesktop.org/show_bug.cgi?id=79662
lu hua changed:
What|Removed |Added
Status|NEW |RESOLVED
Resolution|---
https://bugs.freedesktop.org/show_bug.cgi?id=79662
lu hua changed:
What|Removed |Added
Status|RESOLVED|VERIFIED
--- Comment #12 from lu hua ---
Verif
I was too hasty with my "Tested-by." While it worked in a
shared-glapi configuration, it broke the build with the following:
./configure --prefix=/usr --build=x86_64-pc-linux-gnu
--host=x86_64-cros-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
This lets me remove a dlopen("libglapi.so") hack from chrome, and
avoid adding one to waffle, yay.
I suspect a lot people were forced into the dlopen hack, a quick
search found a few, see
https://bugs.freedesktop.org/show_bug.cgi?id=57702
Tested-by: Frank Henigman
On Sat, Oct 25, 2014 at 11:21 P
On Thu, Oct 30, 2014 at 9:55 AM, Ian Romanick wrote:
> On 10/29/2014 02:31 PM, Matt Turner wrote:
>> ... or on Gen >= 7 at all. We use load_payload to gather results for the
>> FB write(s) now, so we never write to MRFs directly. It's still called
>> after lower_load_payload() since that will gene
On Thu, Oct 30, 2014 at 10:57 AM, Thomas Helland
wrote:
> Are the affected shaders from some commercial game that I might
> have in my steam-collection? Would be nice to extract a real-life
> shader that experiences this not-so-good behavior.
Yes.
Games with improvements:
- Planeshift (one sha
2014-10-30 17:38 GMT+01:00 Ian Romanick :
> On 10/29/2014 11:59 PM, Matt Turner wrote:
>> On Wed, Oct 29, 2014 at 6:11 PM, Thomas Helland
>> wrote:
>>> This series does some initial work to make expansion of
>>> the get_range function a lot cleaner.
>>> It also adds a couple simple initial ranges.
https://bugs.freedesktop.org/show_bug.cgi?id=54080
Daniel Scharrer changed:
What|Removed |Added
CC||dan...@constexpr.org
--
You are recei
A couple bikesheds and nits below...
On 10/29/2014 05:25 PM, Jason Ekstrand wrote:
> diff --git a/src/util/bitcount.h b/src/util/bitcount.h
> new file mode 100644
> index 000..87d92d5
> --- /dev/null
> +++ b/src/util/bitcount.h
> @@ -0,0 +1,196 @@
> +/*
> + * Mesa 3-D graphics library
> + *
>
On 10/29/2014 02:31 PM, Matt Turner wrote:
> ... or on Gen >= 7 at all. We use load_payload to gather results for the
> FB write(s) now, so we never write to MRFs directly. It's still called
> after lower_load_payload() since that will generate MOVs to MRFs on
> platforms with MRFs.
>
> No differe
This patch is
Reviewed-by: Ian Romanick
On 10/29/2014 05:25 PM, Jason Ekstrand wrote:
> ---
> src/mesa/main/bitset.h | 1 +
> src/mesa/main/macros.h | 27 ---
> src/util/macros.h | 27 +++
> 3 files changed, 28 insertions(+), 27 deletions(-)
This patch is
Reviewed-by: Ian Romanick
On 10/29/2014 05:25 PM, Jason Ekstrand wrote:
> ---
> .../drivers/dri/i965/brw_fs_copy_propagation.cpp | 2 +-
> src/mesa/drivers/dri/i965/brw_fs_live_variables.h | 2 +-
> .../drivers/dri/i965/brw_performance_monitor.c | 2 +-
> .../drivers/
On Thu, Oct 30, 2014 at 12:38 PM, Ian Romanick wrote:
> On 10/29/2014 11:59 PM, Matt Turner wrote:
>> On Wed, Oct 29, 2014 at 6:11 PM, Thomas Helland
>> wrote:
>>> This series does some initial work to make expansion of
>>> the get_range function a lot cleaner.
>>> It also adds a couple simple in
On 10/29/2014 11:59 PM, Matt Turner wrote:
> On Wed, Oct 29, 2014 at 6:11 PM, Thomas Helland
> wrote:
>> This series does some initial work to make expansion of
>> the get_range function a lot cleaner.
>> It also adds a couple simple initial ranges.
>> These patches are by no means perfect, but I
---
src/glsl/geom-wide-lines.c | 60 +++-
1 file changed, 42 insertions(+), 18 deletions(-)
diff --git a/src/glsl/geom-wide-lines.c b/src/glsl/geom-wide-lines.c
index c9fee09..42bb811 100644
--- a/src/glsl/geom-wide-lines.c
+++ b/src/glsl/geom-wide-lines.
On 10/30/2014 09:08 AM, Neil Roberts wrote:
Brian Paul writes:
We've always put GL state into the attribute group specified by the GL
specification. Putting the new clip control state anywhere but in the
gl_context::Transform group would be inconsistent.
I think Mathias was asking whether i
If no command line argument is given, draw 50 points (25 lines).
---
src/glsl/geom-stipple-lines.c | 59 -
1 file changed, 41 insertions(+), 18 deletions(-)
diff --git a/src/glsl/geom-stipple-lines.c b/src/glsl/geom-stipple-lines.c
index 8b051a3..fa24605
On Wed, Oct 29, 2014 at 8:25 PM, Jason Ekstrand wrote:
> diff --git a/src/gallium/drivers/nouveau/codegen/nv50_ir_peephole.cpp
> b/src/gallium/drivers/nouveau/codegen/nv50_ir_peephole.cpp
> index 719f980..e4d4126 100644
> --- a/src/gallium/drivers/nouveau/codegen/nv50_ir_peephole.cpp
> +++ b/src/
Brian Paul writes:
> We've always put GL state into the attribute group specified by the GL
> specification. Putting the new clip control state anywhere but in the
> gl_context::Transform group would be inconsistent.
I think Mathias was asking whether it could be put under a different
*meta*
On 10/29/2014 11:13 PM, Mathias Fröhlich wrote:
Hi Neil,
On Tuesday, October 28, 2014 18:22:33 Neil Roberts wrote:
On inspection it looks like this would potentially break
_mesa_meta_Clear when it is using GLSL because that does not save the
MESA_META_TRANSFORM state.
I wonder if MESA_META_TR
Hi,
Mathias Fröhlich writes:
> That moved to MESA_META_TRANSFORM due to a review request. As I
> understood the rationale, it's already connected to the
> gl_context::Transform variable by the GL spec, so it belongs into
> transform also for meta operations. Brian, or what was there an other
> r
I would think that the LLVM backend should be able recognize that it's
spilling an array of literals.
Marek
On Thu, Oct 30, 2014 at 1:43 PM, Marek Olšák wrote:
> Hi Tom,
>
> Could you please elaborate on how we should change the TGSI->LLVM translation?
>
> Marek
>
> On Fri, Oct 17, 2014 at 4:49
Hi Tom,
Could you please elaborate on how we should change the TGSI->LLVM translation?
Marek
On Fri, Oct 17, 2014 at 4:49 PM, Tom Stellard wrote:
> On Wed, Oct 15, 2014 at 05:32:11PM -0700, Kenneth Graunke wrote:
>> Consider GLSL code such as:
>>
>>const ivec2 offsets[] =
>> ivec2[](i
Hi,
On Tuesday, October 28, 2014 19:43:23 Neil Roberts wrote:
> I think if you change the clip depth mode without changing the clip
> origin then only the _NEW_VIEWPORT state would be set. Does that mean we
> have to add _NEW_VIEWPORT to the state for the gen7_clip_state atom as
> well to make su
https://bugs.freedesktop.org/show_bug.cgi?id=84566
--- Comment #47 from Iago Toral ---
(In reply to Jason Ekstrand from comment #46)
> (In reply to Iago Toral from comment #43)
> > Jason, we are running into some issues when attempting to use
> > _mesa_format_convert for glReadPixels and glGetTex
https://bugs.freedesktop.org/show_bug.cgi?id=85268
Michel Dänzer changed:
What|Removed |Added
Status|NEW |RESOLVED
Resolution|---
On Wed, Oct 29, 2014 at 5:30 PM, Kristian Høgsberg wrote:
> On Tue, Oct 28, 2014 at 5:30 PM, Matt Turner wrote:
>> On Tue, Oct 28, 2014 at 3:59 PM, Matt Turner wrote:
> - assert(stage == MESA_SHADER_FRAGMENT);
I like removing these asserts from the function bodies, but I'm
c
On Wed, Oct 29, 2014 at 6:11 PM, Thomas Helland
wrote:
> This series does some initial work to make expansion of
> the get_range function a lot cleaner.
> It also adds a couple simple initial ranges.
> These patches are by no means perfect, but I hope
> they will provide some feedback and ideas.
>
35 matches
Mail list logo