On Fri, Oct 3, 2014 at 10:03 PM, Jason Ekstrand wrote:
> Previously, we were allowing the register allocation code to do the
> computation for us in ra_set_finalize. However, the runtime for this
> computation is O(c^4 * g) where c is the number of classes and g is the
> number of GRF registers.
Signed-off-by: Jason Ekstrand
---
src/mesa/drivers/dri/i965/brw_fs_reg_allocate.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/mesa/drivers/dri/i965/brw_fs_reg_allocate.cpp
b/src/mesa/drivers/dri/i965/brw_fs_reg_allocate.cpp
index 32669f6..fd34941 100644
--- a/src/me
Previously, we were allowing the register allocation code to do the
computation for us in ra_set_finalize. However, the runtime for this
computation is O(c^4 * g) where c is the number of classes and g is the
number of GRF registers. However, these q-values are directly computable
based on the wa
This shouldn't be a functional change since reg_belongs_to_class is just a
wrapper around BITSET_TEST. It just makes the code a little easier to
read.
Signed-off-by: Jason Ekstrand
---
src/util/register_allocate.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/util/regi
On Wed, Oct 1, 2014 at 2:07 PM, Jason Ekstrand wrote:
> Signed-off-by: Jason Ekstrand
> ---
> src/mesa/drivers/dri/i965/intel_blit.c | 90
> --
> src/mesa/drivers/dri/i965/intel_blit.h | 10
> 2 files changed, 73 insertions(+), 27 deletions(-)
>
> diff --git
On Sat, Sep 27, 2014 at 12:57 PM, Matt Turner wrote:
> My attempts to clarify the code with _compacted/_uncompacted prefixed
> variables apparently failed. Hopefully this is clearer.
Heh. Maybe the 'shift' variables could use a better names? (compact_shift?)
Regardless, series
Reviewed-by: Jorda
https://bugs.freedesktop.org/show_bug.cgi?id=84570
Kai changed:
What|Removed |Added
CC||ibull...@aspyr.com
Summary|Borderlands
https://bugs.freedesktop.org/show_bug.cgi?id=84570
--- Comment #1 from Ian C. Bullard ---
A little more information (I'm a developer at Aspyr Media):
DynamicLights' name is misleading, when set to false *all* lighting except for
ambient light is turned off. That's why everything looks so flat w
This looks reasonable to me.
Acked-by: Sinclair Yeh
On Thu, Oct 02, 2014 at 09:49:04AM -0600, Brian Paul wrote:
> On Windows, the Piglit primitive-restart test was failing a
> glGetError()==0 assertion when it was run w/out any command line
> arguments. Piglit's all.py script only runs primiti
https://bugs.freedesktop.org/show_bug.cgi?id=84242
--- Comment #16 from Alan Modra ---
It looks like the overlapping FDE error is caused by a bunch of zero address
range FDEs in /usr/lib/llvm-3.5/lib/libclangCodeGen.a(CGStmtOpenMP.o). These
do have the potential to cause an exception handling pr
Sorry for not replying earlier, I didn't see your answer.
On Thu, Sep 4, 2014 at 12:33 AM, Matt Turner wrote:
> Did you change the leading whitespace on purpose?
Not really, I can un-change that. I have an emacs config that's
supposedly what mesa wants, but it may be incorrect.
>> - } suppo
Looks great. Thanks.
I haven't read SDMA docs though, so I can't tell if the SDMA patckets
are correct.
Reviewed-by: Marek Olšák
Marek
On Fri, Oct 3, 2014 at 11:55 AM, Michel Dänzer wrote:
> From: Michel Dänzer
>
> Based on the corresponding SI support.
>
> Signed-off-by: Michel Dänzer
> --
Kenneth Graunke writes:
> On Thursday, October 02, 2014 11:28:35 AM Ian Romanick wrote:
>> Since this is Curro's code, I'm CC'ing me.
>>
>> On 10/01/2014 03:12 AM, Iago Toral Quiroga wrote:
>> > in_var calls the ir_variable constructor, which dups the variable name.
>> > ---
>> > src/glsl/built
On 02.10.2014 19:14, Marek Olšák wrote:
1) We should have our own copyright in the new file.
Other than that:
Reviewed-by: Marek Olšák
The following things can be done in a separate patch.
2) I recommend removing the CMASK and FMASK checking and replacing it
with nr_samples > 1 (for SI too).
From: Michel Dänzer
Based on the corresponding SI support.
Signed-off-by: Michel Dänzer
---
v3:
* Add AMD copyright header
* Add 009910_MICRO_TILE_MODE_NEW register field definitions
* Call r600_need_dma_space before r600_context_bo_reloc in
cik_sdma_do_copy_buffer
* Drop x and z parameters t
On Thursday, October 02, 2014 11:28:35 AM Ian Romanick wrote:
> Since this is Curro's code, I'm CC'ing me.
>
> On 10/01/2014 03:12 AM, Iago Toral Quiroga wrote:
> > in_var calls the ir_variable constructor, which dups the variable name.
> > ---
> > src/glsl/builtin_functions.cpp | 8 +---
> >
Ian Romanick writes:
> Since this is Curro's code, I'm CC'ing me.
>
> On 10/01/2014 03:12 AM, Iago Toral Quiroga wrote:
>> in_var calls the ir_variable constructor, which dups the variable name.
>> ---
>> src/glsl/builtin_functions.cpp | 8 +---
>> 1 file changed, 5 insertions(+), 3 deletion
Am 02.10.2014 um 22:37 schrieb Alex Deucher:
On Thu, Oct 2, 2014 at 1:51 PM, Christian König wrote:
Am 02.10.2014 um 19:34 schrieb Marek Olšák:
From: Marek Olšák
This fixes a crash when exiting Firefox. I have really no idea how Firefox
does it. It seems to involve multiple contexts and mult
Am 03.10.2014 um 03:53 schrieb Ilia Mirkin:
On Thu, Oct 2, 2014 at 7:59 PM, Emil Velikov wrote:
On 02/10/14 06:41, Ilia Mirkin wrote:
On Mon, Sep 29, 2014 at 8:33 PM, Emil Velikov wrote:
On 29/09/14 17:24, Matt Turner wrote:
On Mon, Sep 29, 2014 at 9:16 AM, Emil Velikov wrote:
So all in a
19 matches
Mail list logo