The theory of the guardband is that you extend the clip volume to avoid
expensive clipping computation, and just let fragments outside the viewport
get clipped by the drawable's bounds. But if a smaller-than-window-size
viewport is set, and we don't also happen to have a scissor set, then
renderin
When you're comparing to the spec, you're trying to immediately see what
numbered dword of the packet your bit ends up in.
---
src/mesa/drivers/dri/i965/gen6_clip_state.c | 21 -
src/mesa/drivers/dri/i965/gen7_clip_state.c | 25 ++---
2 files changed, 18
Kenneth Graunke writes:
> The OWord Dual Block Write message doesn't have a response length, so it
> was surprising to a non-null destination register in the disassembly.
> Not only that, but seeing g0 was especially confusing, as writing to g0
> would destroy critical payload information that's
On 11/15/2012 02:59 PM, Matt Turner wrote:
---
include/GLES2/gl2ext.h | 318 +---
1 files changed, 301 insertions(+), 17 deletions(-)
Yes, please.
Acked-by: Kenneth Graunke
___
mesa-dev mailing list
m
This fix makes both signed format tests in gles3 conformance pass.
Signed-off-by: Anuj Phogat
---
src/mesa/drivers/dri/intel/intel_mipmap_tree.c |8 ++--
1 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/mesa/drivers/dri/intel/intel_mipmap_tree.c
b/src/mesa/drivers/dri/
This patch fixes two issues in decoding signed formats:
1. Handle a corner case when base code word value is -128. As per
OpenGL ES 3.0 specification -128 is not an allowed value and should
be truncated to -127.
2. Converting a decoded 16 bit signed data to 16 bit unsigned data by
adding 2 ^ 15 giv
---
include/GLES2/gl2ext.h | 318 +---
1 files changed, 301 insertions(+), 17 deletions(-)
diff --git a/include/GLES2/gl2ext.h b/include/GLES2/gl2ext.h
index c21e2ac..65b8e80 100644
--- a/include/GLES2/gl2ext.h
+++ b/include/GLES2/gl2ext.h
@@ -1,7 +1,7
---
include/GLES2/gl2.h |5 ++---
1 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/include/GLES2/gl2.h b/include/GLES2/gl2.h
index e1d3b87..b7fe76e 100644
--- a/include/GLES2/gl2.h
+++ b/include/GLES2/gl2.h
@@ -1,7 +1,7 @@
#ifndef __gl2_h_
#define __gl2_h_
-/* $Revision: 1060
---
include/GLES/glext.h | 219 --
1 files changed, 212 insertions(+), 7 deletions(-)
diff --git a/include/GLES/glext.h b/include/GLES/glext.h
index 130e4b0..5b46ae6 100644
--- a/include/GLES/glext.h
+++ b/include/GLES/glext.h
@@ -1,7 +1,7 @@
#ifn
---
include/EGL/eglext.h | 10 +-
1 files changed, 9 insertions(+), 1 deletions(-)
diff --git a/include/EGL/eglext.h b/include/EGL/eglext.h
index 974b2c0..a5c9009 100644
--- a/include/EGL/eglext.h
+++ b/include/EGL/eglext.h
@@ -34,7 +34,7 @@ extern "C" {
/* Header file version number
The OWord Dual Block Write message doesn't have a response length, so it
was surprising to a non-null destination register in the disassembly.
Not only that, but seeing g0 was especially confusing, as writing to g0
would destroy critical payload information that's needed for most SEND
messages.
I
Andreas Boll writes:
> Those are recently introduced on master.
Given that we use git ls-tree to get a giant list of files to put in
tarballs, it seems like a little grep and sed could go a long way here.
pgprd2RHv29ns.pgp
Description: PGP signature
On Thu, Nov 15, 2012 at 11:18 AM, Andreas Boll
wrote:
> fixes regression introduced in 907844107252260c646aca361191ef7f121f3d23
>
> Targets for making lexx.yy.c program_parse.tab.c and program_parse.tab.h
Typo, s/lexx/lex/
> got moved into its own Makefile
>
> Cc: Matt Turner
> ---
> Makefile.
---
include/GLES/glext.h | 219 --
1 files changed, 212 insertions(+), 7 deletions(-)
diff --git a/include/GLES/glext.h b/include/GLES/glext.h
index 130e4b0..5b46ae6 100644
--- a/include/GLES/glext.h
+++ b/include/GLES/glext.h
@@ -1,7 +1,7 @@
#ifn
---
include/EGL/eglext.h | 10 +-
1 files changed, 9 insertions(+), 1 deletions(-)
diff --git a/include/EGL/eglext.h b/include/EGL/eglext.h
index 974b2c0..a5c9009 100644
--- a/include/EGL/eglext.h
+++ b/include/EGL/eglext.h
@@ -34,7 +34,7 @@ extern "C" {
/* Header file version number
---
include/GLES2/gl2ext.h | 318 +---
1 files changed, 301 insertions(+), 17 deletions(-)
diff --git a/include/GLES2/gl2ext.h b/include/GLES2/gl2ext.h
index c21e2ac..65b8e80 100644
--- a/include/GLES2/gl2ext.h
+++ b/include/GLES2/gl2ext.h
@@ -1,7 +1,7
---
include/GLES2/gl2.h |5 ++---
1 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/include/GLES2/gl2.h b/include/GLES2/gl2.h
index e1d3b87..b7fe76e 100644
--- a/include/GLES2/gl2.h
+++ b/include/GLES2/gl2.h
@@ -1,7 +1,7 @@
#ifndef __gl2_h_
#define __gl2_h_
-/* $Revision: 1060
MinGW has snprintf.
The patch fixes these warnings with the MinGW SCons build.
src/gallium/auxiliary/util/u_snprintf.c:459:1: warning: no previous prototype
for ‘util_vsnprintf’ [-Wmissing-prototypes]
src/gallium/auxiliary/util/u_snprintf.c:1436:1: warning: no previous prototype
for ‘util_snpri
Fixes draw_buffers_test3 and 6 explicit_attrib_location tests from.
gles3conform
---
This is how this should be fixed, right? Modifying the table in
glsl_parser_extras.cpp would have incorrectly allowed
#extension GL_ARB_explicit_attrib_location : enable
in GLES 2?
src/glsl/glsl_parser.yy
Those are recently introduced on master.
Cc: Matt Turner
---
Makefile.am |3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index eafc460..b22458e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,6 +102,7 @@ EXTRA_FILES = \
src/mapi/es2
fixes regression introduced in 907844107252260c646aca361191ef7f121f3d23
Targets for making lexx.yy.c program_parse.tab.c and program_parse.tab.h
got moved into its own Makefile
Cc: Matt Turner
---
Makefile.am |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Makefile.am
Kenneth Graunke writes:
> There's no point: opt_algebraic() doesn't use any liveness information.
>
> Signed-off-by: Kenneth Graunke
Reviewed-by: Eric Anholt
pgpQwZqMiKNO2.pgp
Description: PGP signature
___
mesa-dev mailing list
mesa-dev@lists.free
Kenneth Graunke writes:
> In addition to registers used by instructions, fs_visitor maintains
> direct references to certain "special" values used for inputs/outputs.
>
> When I added VGRF compaction, I overlooked these, believing that these
> direct references weren't used once instructions were
Ian gave some off-list feedback for this list.
This series has this code flow: The driver.context_init calls
_mesa_initialize_context which in turn calls back into the driver
(driver.InitializeVersionFeatures).
But, Ian suggested that instead I pull the dispatch table init
functions out of _mesa_
For the series:
Reviewed-by: Marek Olšák
Marek
On Thu, Nov 15, 2012 at 5:46 PM, wrote:
> From: Alex Deucher
>
> Rather than disabling the depth buffer.
>
> v2: use INVALID hw format rather than ~0U
>
> Signed-off-by: Alex Deucher
> ---
> src/gallium/drivers/radeonsi/si_state.c | 13 +
On Don, 2012-11-15 at 18:48 +0100, Marek Olšák wrote:
> On Thu, Nov 15, 2012 at 3:30 PM, Michel Dänzer wrote:
> > On Don, 2012-11-15 at 04:43 +0100, Marek Olšák wrote:
> >>
> >> For the asynchronous SwapBuffers to work, there must be a separate X
> >> connection, because Xlib isn't thread-safe at
On Thu, Nov 15, 2012 at 5:28 PM, Christian König
wrote:
> On 15.11.2012 17:00, alexdeuc...@gmail.com wrote:
>>
>> From: Alex Deucher
>>
>> Rather than disabling the depth buffer.
>
> I would still prefer to use *_INVALID as the invalid function return value
> here.
>
> Just imagine a release buil
Kenneth Graunke writes:
> brw_optimize.c's brw_opcodes table was a copy of brw_disasm.c's
> opcode_descs table, but with an additional field: is_arith. Now that
> I've deleted that, the two are identical. Keep the one in brw_disasm.c.
> ---
> src/mesa/drivers/dri/i965/brw_context.h | 7 --
On Thu, Nov 15, 2012 at 6:47 PM, Mathias Fröhlich
wrote:
>
> Marek,
>
> Regarding swap handling, there was a lengthy discussion about this topic at
> XDC in Nürnberg.
> May be Keith can comment on that as he also presented these ideas.
> But short, the overall aim of this discusstion was to make t
On Thu, Nov 15, 2012 at 3:30 PM, Michel Dänzer wrote:
> On Don, 2012-11-15 at 04:43 +0100, Marek Olšák wrote:
>>
>> For the asynchronous SwapBuffers to work, there must be a separate X
>> connection, because Xlib isn't thread-safe at all.
>>
>> Now the bad news. The DRI invalidate events may be re
Marek,
Regarding swap handling, there was a lengthy discussion about this topic at
XDC in Nürnberg.
May be Keith can comment on that as he also presented these ideas.
But short, the overall aim of this discusstion was to make the dri2 buffer swap
more asynchronous.
This does not exactly solve t
On Don, 2012-11-15 at 17:58 +0100, Michel Dänzer wrote:
> On Don, 2012-11-15 at 11:46 -0500, alexdeuc...@gmail.com wrote:
> > From: Alex Deucher
> >
> > Rather than disabling the depth buffer.
>
> How about doing both? The assertions will be useful for debugging cases
> that aren't handled pro
On Don, 2012-11-15 at 11:46 -0500, alexdeuc...@gmail.com wrote:
> From: Alex Deucher
>
> Rather than disabling the depth buffer.
How about doing both? The assertions will be useful for debugging cases
that aren't handled properly, but disabling the CB/DB buffers could
avoid trouble in those cas
From: Alex Deucher
Clean up a few magic numbers and rework the code a bit.
Signed-off-by: Alex Deucher
Reviewed-by: Christian König
Reviewed-by: Michel Dänzer
---
src/gallium/drivers/radeonsi/si_state.c | 22 ++
src/gallium/drivers/radeonsi/sid.h |2 ++
2 files
From: Alex Deucher
v2: use INVALID hw format rather than ~0U
Signed-off-by: Alex Deucher
---
src/gallium/drivers/radeonsi/si_state.c |5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/src/gallium/drivers/radeonsi/si_state.c
b/src/gallium/drivers/radeonsi/si_state.c
i
From: Alex Deucher
Rather than disabling the depth buffer.
v2: use INVALID hw format rather than ~0U
Signed-off-by: Alex Deucher
---
src/gallium/drivers/radeonsi/si_state.c | 13 +
1 files changed, 5 insertions(+), 8 deletions(-)
diff --git a/src/gallium/drivers/radeonsi/si_sta
On 15.11.2012 17:00, alexdeuc...@gmail.com wrote:
From: Alex Deucher
Rather than disabling the depth buffer.
I would still prefer to use *_INVALID as the invalid function return
value here.
Just imagine a release build with an undetected bug, writing *_INVALID
would still result in well def
https://bugs.freedesktop.org/show_bug.cgi?id=57044
Brad King changed:
What|Removed |Added
CC||brad.k...@kitware.com
--
You are receiving
---
lib/Target/AMDGPU/AMDGPU.h | 1 +
lib/Target/AMDGPU/AMDGPUTargetMachine.cpp| 1 +
lib/Target/AMDGPU/R600VolatileLoadSetter.cpp | 51
3 files changed, 53 insertions(+)
create mode 100644 lib/Target/AMDGPU/R600VolatileLoadSetter.cpp
diff --g
From: Alex Deucher
Clean up a few magic numbers and rework the code a bit.
Signed-off-by: Alex Deucher
Reviewed-by: Christian König
Reviewed-by: Michel Dänzer
---
src/gallium/drivers/radeonsi/si_state.c | 22 ++
src/gallium/drivers/radeonsi/sid.h |2 ++
2 files
From: Alex Deucher
Signed-off-by: Alex Deucher
---
src/gallium/drivers/radeonsi/si_state.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/gallium/drivers/radeonsi/si_state.c
b/src/gallium/drivers/radeonsi/si_state.c
index c5ae49a..b4e09ed 100644
--- a/src/gallium/
From: Alex Deucher
Rather than disabling the depth buffer.
Signed-off-by: Alex Deucher
---
src/gallium/drivers/radeonsi/si_state.c |9 +++--
1 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/src/gallium/drivers/radeonsi/si_state.c
b/src/gallium/drivers/radeonsi/si_state.c
https://bugs.freedesktop.org/show_bug.cgi?id=57044
Hrvoje Senjan changed:
What|Removed |Added
CC||hrvoje.sen...@gmail.com
--
You are rece
On 11/14/2012 12:33 PM, Dmitry Cherkassov wrote:
Signed-off-by: Dmitry Cherkassov
---
src/gallium/include/pipe/p_context.h |5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/src/gallium/include/pipe/p_context.h
b/src/gallium/include/pipe/p_context.h
index 88e12b2..c5d
On Don, 2012-11-15 at 04:43 +0100, Marek Olšák wrote:
>
> For the asynchronous SwapBuffers to work, there must be a separate X
> connection, because Xlib isn't thread-safe at all.
>
> Now the bad news. The DRI invalidate events may be received too late.
> We can't wait for the events in glXSwapB
On Thu, Nov 15, 2012 at 8:46 AM, Michel Dänzer wrote:
> On Mit, 2012-11-14 at 14:14 -0500, alexdeuc...@gmail.com wrote:
>> From: Alex Deucher
>>
>> Clean up a few magic numbers and rework the code a bit.
>>
>> Signed-off-by: Alex Deucher
>
> Reviewed-by: Michel Dänzer
>
> I agree with Marek's c
On Mit, 2012-11-14 at 14:14 -0500, alexdeuc...@gmail.com wrote:
> From: Alex Deucher
>
> Clean up a few magic numbers and rework the code a bit.
>
> Signed-off-by: Alex Deucher
Reviewed-by: Michel Dänzer
I agree with Marek's comments on patches 1-2, also there are some typos
in the commit l
https://bugs.freedesktop.org/show_bug.cgi?id=52034
Andreas Boll changed:
What|Removed |Added
Status|NEEDINFO|RESOLVED
Resolution|---
Waffle 1.2.0 - 15 Nov 2012
==
Waffle 1.2.0 is now available.
Download:
http://people.freedesktop.org/~chadversary/waffle/files/release/waffle-1.2.0/waffle-1.2.0.tar.xz
sha256 sum:
95a3755980f2415f152f6238e952b5d4d817ae854b71e34f08830925bbc12d3c
waffle-1.2.0
49 matches
Mail list logo