Re: [patch] more about iterators

2004-03-30 Thread Alfredo Braunstein
Andre Poenitz wrote: >> Please note that the end iterator now is DocumentIterator(inset) or >> DocumentIteratorEnd(inset), which was the begin() iterator before. > > Is there any place where we actually need the end() iterator + > operator--() combo? The user code is not simpler after your change

Re: [patch] more about iterators

2004-03-30 Thread Andre Poenitz
On Mon, Mar 29, 2004 at 01:10:58PM +0200, Alfredo Braunstein wrote: > this patch > > 1) makes DocumentIterator (btw, too long name) Change it to 'DocIterator' then. Would be consitent with the file name, too. > store an inset * member. With this we can come back from the > past-the-last positio

Re: [patch] more about iterators

2004-03-29 Thread Angus Leeming
Alfredo Braunstein wrote: >> It looks *much* more readable to my novice eyes. Although I'm used >> to lower case when it comes to iterators. > > Updated patch in lowercase. Doesn't it look just beautiful? ;-) -- Angus

Re: [patch] more about iterators

2004-03-29 Thread Alfredo Braunstein
Angus Leeming wrote: > It looks *much* more readable to my novice eyes. Although I'm used to > lower case when it comes to iterators. Updated patch in lowercase. Alfredo ? DviOut-1.4.0.lyx ? Markers.C ? Markers.h ? PosIterator.C-bold ? PosIterator.h-bold ? lyxrow_funcs.C-bad1 ? paragraph.C-bad1

Re: [patch] more about iterators

2004-03-29 Thread Alfredo Braunstein
Angus Leeming wrote: Thanks for the answer! > It looks *much* more readable to my novice eyes. Although I'm used to > lower case when it comes to iterators. > > const_par_iterator it = par_iterator_begin(); > const_par_iterator const end = par_iterator_end(); should be solvable

Re: [patch] more about iterators

2004-03-29 Thread Angus Leeming
Alfredo Braunstein wrote: > this patch > > 1) makes DocumentIterator (btw, too long name) store an inset * > member. With this we can come back from the past-the-last position > (and go forward from the one-before-start one, which is the same > one) > > I've introduced then stale functions > Doc

[patch] more about iterators

2004-03-29 Thread Alfredo Braunstein
this patch 1) makes DocumentIterator (btw, too long name) store an inset * member. With this we can come back from the past-the-last position (and go forward from the one-before-start one, which is the same one) I've introduced then stale functions DocumentIterator{Begin,End}(InsetBase &) that r