Re: [patch] factor out cursor code

2007-08-13 Thread Alfredo Braunstein
Jean-Marc Lasgouttes wrote: > Alfredo Braunstein <[EMAIL PROTECTED]> > writes: > >> I take it you mean ++cur.top(). Would it help to call it >> CursorSlice::forwardPos ? > > Definitely. ++ does not tell whether you increase the index, the pit > or the pos. > >> If fact it is rather weird, and t

Re: [patch] factor out cursor code

2007-08-13 Thread Jean-Marc Lasgouttes
Alfredo Braunstein <[EMAIL PROTECTED]> writes: > I take it you mean ++cur.top(). Would it help to call it > CursorSlice::forwardPos ? Definitely. ++ does not tell whether you increase the index, the pit or the pos. > If fact it is rather weird, and the "proof" is that we don't need this > featur

Re: [patch] factor out cursor code

2007-08-13 Thread Abdelrazak Younes
Alfredo Braunstein wrote: Jean-Marc Lasgouttes wrote: requires much more thinking to be sure of what it means. The original version in particular can go outside of insets and continue from there, which is not the case of the CursorSlice one. If fact it is rather weird, and the "proof" is tha

Re: [patch] factor out cursor code

2007-08-13 Thread Alfredo Braunstein
Jean-Marc Lasgouttes wrote: > > Alfredo Braunstein <[EMAIL PROTECTED]> > writes: >> This patch removes some code duplication in DocIterator (in particular >> removes forwardPosNoDescend that if nothing else, has an ugly name), by >> moving the part of forwardPos that acts on flat cursorslices to

Re: [patch] factor out cursor code

2007-08-12 Thread Jean-Marc Lasgouttes
Alfredo Braunstein <[EMAIL PROTECTED]> writes: > This patch removes some code duplication in DocIterator (in particular > removes forwardPosNoDescend that if nothing else, has an ugly name), by > moving the part of forwardPos that acts on flat cursorslices to > CursorSlice::operator++. Comments?

[patch] factor out cursor code

2007-08-12 Thread Alfredo Braunstein
This patch removes some code duplication in DocIterator (in particular removes forwardPosNoDescend that if nothing else, has an ugly name), by moving the part of forwardPos that acts on flat cursorslices to CursorSlice::operator++. Comments? A/ CursorSlice.cpp | 65