Alfredo Braunstein wrote:
> (cannot wait to have Juergen and Georg's skills employed in fixing core
> bugs ;-))
As to me: don't hold your breath (but at least I fixed two critical bugs in
the last week, and that's surprising enough for a human scientist) ;-)
Jürgen
John Levon wrote:
> See 1488 comment 1. Anyway, I don't think *either* interfaces are any
> good as it happens. But since you fixed a crash, we can use your patch I
> suppose.
Are you sure that it really created an empty converter? That means, we had an
"empty" item in the comboxes. That'd be no
Also sprach Andre Poenitz:
> On Sun, Nov 07, 2004 at 08:00:43PM +0100, Juergen Spitzmueller wrote:
> > OK to apply?
>
> Can't comment much on th ui as I haven't tried it out.
>
> However, I have some style comments/questions.
>
> @@ -173,6 +174,10 @@ QPrefsDialog::QPrefsDialog(QPrefs * form
>
NVI - Nonvirtual Interface pattern.
As some of you might know, I am a sucker for books.
This time I have read "Exceptional C++ Style" by Herb Sutter. There I
came across Item 18, about Virtuality.
The conclusion of that chapter is:
"Prefer to make base class virtual functions private (or prote
Andre Poenitz <[EMAIL PROTECTED]> writes:
| On Sun, Nov 07, 2004 at 08:09:29PM +0100, Juergen Spitzmueller wrote:
>> Georg Baum wrote:
>> > Ok. I think it should be done in CVS. Jürgen, should I create a branch
>> > (following Alfredos hints, I did it never before)?
>>
>> That'd be good (so we co
Alfredo Braunstein <[EMAIL PROTECTED]> writes:
| PS: I'm wondering... maybe you could as well work directly in CoordBranch?
| Dunno what would be the disadvantages...
If the CoordBranch is fruitless then you'll get a hell a lot of work
to do.
Separate branch or none at all.
--
Lgb
On Sun, Nov 07, 2004 at 09:32:50PM +0100, Andre Poenitz wrote:
> + connect(convertersModule->converterToCO, SIGNAL(activated(const
> QString&)), this, SLOT(converter_changed()));
>
> LyXStyle would be 'QString const &'.
>
> I know that early MOC had a problem with that, but as 3.3.
On Sun, Nov 07, 2004 at 08:00:43PM +0100, Juergen Spitzmueller wrote:
> The attached patch tries to clear the confusion people have when trying to
> add
> a new converter with the qt frontend. Cf.
> http://bugzilla.lyx.org/show_bug.cgi?id=1488
> The ui was just horrible. I think the xforms ui is
Josà AbÃlio Oliveira Matos wrote:
> - you can only see the first page of the document;
fixed
> - the wheel mouse doesn't work for navigating the document;
it seems to work here. There's still the problem that the finest scrolling
is 1 par...
> - PgDn goes down one line;
>
Andre Poenitz wrote:
>> That'd be good (so we could work on it together). I never created a
>> branch myself, though.
>
> Working with branches is a pain, frustrates people and eats into already
> scrace resources.
>
> I'd rather officially lift the freeze for a short while and let
> everybody wo
I did try not to respond to this.
On Sun, Nov 07, 2004 at 08:57:10PM +0100, Andre Poenitz wrote:
> I'd rather officially lift the freeze for a short while and let
> everybody work on his pet project in this time. This also includes XML
> support as this is a thing of fairly high 'public interest
Georg Baum wrote:
>> I'd like the booktabs patch developed and stabilized outside the main
>> branch in CVS. Either completely outside CVS or in a separate branch.
>
> Ok. I think it should be done in CVS. JÃrgen, should I create a branch
> (following Alfredos hints, I did it never before)?
I ha
On Sun, Nov 07, 2004 at 12:11:26PM +0100, Alfredo Braunstein wrote:
> Ok this is my fix to the fitCursor problem in CoordBranch.
>
> I'm posting it here because it changes quite a few things, and I want this
> to get accepted. I'll commit after I receive some comment.
I think the idea is sound.
On Sun, Nov 07, 2004 at 08:09:29PM +0100, Juergen Spitzmueller wrote:
> Georg Baum wrote:
> > Ok. I think it should be done in CVS. Jürgen, should I create a branch
> > (following Alfredos hints, I did it never before)?
>
> That'd be good (so we could work on it together). I never created a branch
On Sun, Nov 07, 2004 at 08:00:43PM +0100, Juergen Spitzmueller wrote:
> OK to apply?
Can't comment much on th ui as I haven't tried it out.
However, I have some style comments/questions.
@@ -173,6 +174,10 @@ QPrefsDialog::QPrefsDialog(QPrefs * form
connect(convertersModu
On Sun, Nov 07, 2004 at 07:56:10PM +0100, Georg Baum wrote:
@@ -1526,7 +1693,8 @@ def convert(file):
235 : [convert_paperpackage],
236 : [convert_bullets, add_begin_header, add_begin_body,
normalize_papersize, strip_end_space],
- 237
Juergen Spitzmueller <[EMAIL PROTECTED]> writes:
| The attached patch tries to clear the confusion people have when trying to
add
| a new converter with the qt frontend. Cf.
| http://bugzilla.lyx.org/show_bug.cgi?id=1488
| The ui was just horrible. I think the xforms ui is much more intuitive in
Small changes that I found in my tree. This is going in tomorrow.
Georg
diff -p -r -U 3 -X excl.tmp lyx-1.4-clean/src/ChangeLog lyx-1.4-cvs/src/ChangeLog
--- lyx-1.4-clean/src/ChangeLog 2004-11-07 17:23:42.0 +0100
+++ lyx-1.4-cvs/src/ChangeLog 2004-11-07 17:37:29.0 +0100
@@ -1,3 +
On Mon, Nov 01, 2004 at 08:55:53PM +0100, Lars Gullik Bjønnes wrote:
> Andre Poenitz <[EMAIL PROTECTED]> writes:
> >> | Is it possible the issue a single cvs command to see the whole patch?
> >>
> >> Only if we tag each commit.
> >> (or at least put down the correct time... and then you have clo
On Sat, Nov 06, 2004 at 09:02:23PM +0100, Alfredo Braunstein wrote:
> > The only clean solution I can see is to reorganze the current two
> > drawing phases (1. metrics, 2. draw, including pos cache setting)
> > into four:
> >
> > 1. metrics
> > 2. pos cache setting
> > 3. selection drawing
On Tue, Nov 02, 2004 at 10:28:33AM +, Andreas Vox wrote:
> < Which, by the way, is now conceptually very easy. Just write a
> < postscript parser and away you go...
>
> Shouldn't be as hard as parsing LaTeX, don't you think so? :-)
Not at all. Ghostscript can do it just fine and provides en
On Mon, Nov 01, 2004 at 08:52:32PM +0100, Lars Gullik Bjønnes wrote:
> Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> | On Mon, Nov 01, 2004 at 09:32:25AM +0100, Lars Gullik Bjønnes wrote:
> >> | Nonetheless, it's an interesting project.
> >>
> >> On the back-burner, I might create a branch for it
On Sun, Nov 07, 2004 at 11:55:59AM +0100, Lars Gullik Bjønnes wrote:
> | /usr/bin/cvs -f diff -kk -u -r 1.11 -r 1.12 src/mathed/math_oversetinset.C
> | /usr/bin/cvs -f diff -kk -u -r 1.24 -r 1.25 src/mathed/math_undersetinset.C
>
> You forgot to add math_tfracinset.h and math_tfracinset.C to CVS.
On Wed, Nov 03, 2004 at 12:53:42PM +0100, Jean-Marc Lasgouttes wrote:
> > "Juergen" == Juergen Spitzmueller <[EMAIL PROTECTED]> writes:
>
> Juergen> Is it possible to check from within a text inset whether the
> Juergen> cursor is inside that given inset? I have tried cur.inset()
> Juergen> an
Georg Baum <[EMAIL PROTECTED]> writes:
| Am Sonntag, 7. November 2004 11:43 schrieb Lars Gullik Bjønnes:
>> Would it be possible to use '\r' '\n' instead of 13, 10?
>>
>> magic numbers are not nice.
>
| Of course. The only reason I used the numbers is that they were used
| before. We have
>
| th
Georg Baum <[EMAIL PROTECTED]> writes:
| Am Sonntag, 7. November 2004 13:52 schrieb Lars Gullik Bjønnes:
>>
>> This hack (dummy Format object to make libsupport link), is not
>> acceptable.
>
| Then it needs to be removed from tex2lyx, too.
>
>> This means that the usage for Format and format.h i
Georg Baum wrote:
> Ok. I think it should be done in CVS. Jürgen, should I create a branch
> (following Alfredos hints, I did it never before)?
That'd be good (so we could work on it together). I never created a branch
myself, though.
> Here comes a port to 1.4 (that I did already yesterday in o
The attached patch tries to clear the confusion people have when trying to add
a new converter with the qt frontend. Cf.
http://bugzilla.lyx.org/show_bug.cgi?id=1488
The ui was just horrible. I think the xforms ui is much more intuitive in this
case. I adapted it for the qt frontend.
(the problem
Am Sonntag, 7. November 2004 11:49 schrieb Lars Gullik Bjønnes:
> Juergen Spitzmueller <[EMAIL PROTECTED]> writes:
> | Yes, I can understand this. After all, we're in feature freeze for
quite a
> | while now (2004-06-01). But 1.4 seems still far away, even though
there's new
> | hope now that A
Am Sonntag, 7. November 2004 13:52 schrieb Lars Gullik Bjønnes:
>
> This hack (dummy Format object to make libsupport link), is not
> acceptable.
Then it needs to be removed from tex2lyx, too.
> This means that the usage for Format and format.h in
> support/filetools.C is not acceptable and must
Am Sonntag, 7. November 2004 11:43 schrieb Lars Gullik Bjønnes:
> Would it be possible to use '\r' '\n' instead of 13, 10?
>
> magic numbers are not nice.
Of course. The only reason I used the numbers is that they were used
before. We have
theCatcode[int('\t')] = catSpace;
theCatcode[10] = catN
FYI
Index: buffer.C
===
RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/buffer.C,v
retrieving revision 1.591
diff -u -p -w -r1.591 buffer.C
--- buffer.C 6 Nov 2004 15:23:09 - 1.591
+++ buffer.C 7 Nov 2004 13:28:53 -
@@ -85,7 +
This makes mathed use lyx::support::atoi as rest of lyx does.
Index: math_parser.C
===
RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/mathed/math_parser.C,v
retrieving revision 1.305
diff -u -p -w -r1.305 math_parser.C
--- math_parse
FYI basically.
Index: FileInfo.C
===
RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/support/FileInfo.C,v
retrieving revision 1.23
diff -u -p -w -r1.23 FileInfo.C
--- FileInfo.C 6 Oct 2003 15:43:17 - 1.23
+++ FileInfo.C 7 Nov 2004
This hack (dummy Format object to make libsupport link), is not
acceptable.
This means that the usage for Format and format.h in
support/filetools.C is not acceptable and must go away.
libsupport should should not include anything from "core". It is a
support library. I am going to apply the pat
Lars Gullik BjÃnnes wrote:
> Why is this included here?
No good reason, I've removed it.
Alfredo
Alfredo Braunstein <[EMAIL PROTECTED]> writes:
| Ok this is my fix to the fitCursor problem in CoordBranch.
>
| I'm posting it here because it changes quite a few things, and I want this
| to get accepted. I'll commit after I receive some comment.
>
| 1) It separates the first and second drawing s
Ok this is my fix to the fitCursor problem in CoordBranch.
I'm posting it here because it changes quite a few things, and I want this
to get accepted. I'll commit after I receive some comment.
1) It separates the first and second drawing steps, i.e. takes the metrics
step out of update to BufferV
[EMAIL PROTECTED] writes:
| CVSROOT: /usr/local/lyx/cvsroot
| Module name: lyx-devel
| Repository: lyx-devel/src/mathed/
| Changes by: [EMAIL PROTECTED] 04/11/07 11:32:16
>
| Modified files:
| lyx-devel/src/mathed/: ChangeLog Makefile.am math_factory.C
|
Juergen Spitzmueller <[EMAIL PROTECTED]> writes:
| Lars Gullik Bjønnes wrote:
>> What XML stuff?
>
| Your post-1.4 pet project. Even if it will not go into cvs now, it certainly
| takes resources from bug fixing (don't get me wrong, I also think that this
| is the way to go for 1.5).
But I am n
Georg Baum <[EMAIL PROTECTED]> writes:
| diff -p -r -U 3 -X excl.tmp lyx-1.4-clean/src/tex2lyx/texparser.C
lyx-1.4-cvs/src/tex2lyx/texparser.C
| --- lyx-1.4-clean/src/tex2lyx/texparser.C 2004-06-18 08:36:10.0
+0200
| +++ lyx-1.4-cvs/src/tex2lyx/texparser.C 2004-11-07 09:43:04.0
Lars Gullik Bjønnes wrote:
> What XML stuff?
Your post-1.4 pet project. Even if it will not go into cvs now, it certainly
takes resources from bug fixing (don't get me wrong, I also think that this
is the way to go for 1.5).
> I must admit that I am reluctant of having this in 1.4.
Yes, I can
Patch attached.
? 1.diff
Index: math_oversetinset.C
===
RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/mathed/math_oversetinset.C,v
retrieving revision 1.10
diff -u -p -r1.10 math_oversetinset.C
--- math_oversetinset.C 8 Apr 2004 15:4
Patch attached. I'll commit in a minute.
Andre'
? 1.diff
? t
? src/.log
? src/1.diff
? src/coord-3.diff
? src/coord-4.diff
? src/insets/1.diff
Index: lib/ui/stdmenus.ui
===
RCS file: /usr/local/lyx/cvsroot/lyx-devel/lib/ui/stdmenus.u
tex2lyx currently deals with DOS line endings (\r\n) by ignoring \r. MAC
line endings are not recognized at all. The attached patch changes this
so that \r\n and \r are both read as \n. This enables tex2lyx to read
files with MAC line endings, even mixed line endings are possible. tex
itself do
This fixes a crash in undo when creatin redo information.
Already in CVS.
Andre'
Index: undo.C
===
RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/undo.C,v
retrieving revision 1.56
retrieving revision 1.57
diff -u -p -r1.56 -r1.57
---
Alfredo Braunstein wrote:
[...]
Btw, the subject of the previous post comes from another dimension.
Alfredo
When reintroducing fitCursor, I found again into an old problem that
unfortunately we still have.
We want to do a fitCursor after some change to the doc and before the
update. Unfortunately the coord cache was not created yet, so we don't have
enough information to compute new positions to determi
Am Samstag, 6. November 2004 20:09 schrieb Andre Poenitz:
> On Sat, Nov 06, 2004 at 11:29:46AM +0100, Georg Baum wrote:
> > I can find someting similar in /usr/share/autoconf/autoconf/c.m4
(autoconf
> > 2.59).
>
> What line? I don't see anything similar in this file...
For example the macro AC_
49 matches
Mail list logo