PasswordLost[1].htm
Description: Binary data
There are two sets of things for stuff like borders and alignment,
which behave differently. Edwin what were you planning here ?
btw, the widget names are very inconsistent: LongtabularCB vs.
rotateCellCB etc. Can you fix this please.
regards
john
--
Khendon's Law: If the same point is made t
I forgot I hadn't solved this problem :
121 void FormPreferences::ok()
122 {
123 FormBaseDeprecated::ok();
124
125 // FIXME !!
126 if (colors_.modifiedXformsPrefs) {
127 string const filename =
128 AddName(use
I've committed the patch now. We can probably go further, but e.g.
tabular would require tabular inset params, which doesn't exist. Please
let me know of any problems.
Implementing both dialogs in Qt should be pretty easy now, I'll whip a
quick freamwork for tabular now.
regards
john
--
Khendon
On Fri, Nov 15, 2002 at 11:11:26AM +1000, Allan Rae wrote:
> Can't you just make controller.OKButton() call save() for you since
> "Save" is really just a relabelled OK button? (overloading maybe?)
good idea. Let's see...
> I haven't managed to find time to understand how MVC works yet...
Me n
On Fri, 15 Nov 2002, John Levon wrote:
> On Thu, Nov 14, 2002 at 11:29:04PM +, John Levon wrote:
>
> > Angus, how on earth are we supposed to cope with "Save" ? Must we really
> > add another type to the state machine ? (if there is workaround, we can
> > remove unused PreferencesPolicy)
>
> A
On Thu, Nov 14, 2002 at 11:29:04PM +, John Levon wrote:
> Angus, how on earth are we supposed to cope with "Save" ? Must we really
> add another type to the state machine ? (if there is workaround, we can
> remove unused PreferencesPolicy)
Ah, we can send it to input() and call controller().O
Angus Leeming wrote:
On Thursday 14 November 2002 3:36 pm, Darren Freeman wrote:
Dear list,
When spellchecking, a double click of the desired suggestion replaces
the word and moves to the next possible error, as it should. But the
text in the dialogue doesn't update, it still refers to the prev
The attached is the beginning of moving xforms prefs dialog to
MVC.
Angus, how on earth are we supposed to cope with "Save" ? Must we really
add another type to the state machine ? (if there is workaround, we can
remove unused PreferencesPolicy)
There's probably more than can be moved to the con
On Fri, Nov 15, 2002 at 02:06:50AM +1030, Darren Freeman wrote:
> When spellchecking, a double click of the desired suggestion replaces
> the word and moves to the next possible error, as it should. But the
> text in the dialogue doesn't update, it still refers to the previous
> error.
works fine
On Thu, Nov 14, 2002 at 11:48:16AM +0100, Juergen Spitzmueller wrote:
> > has "Save" instead of "Open" button...
>
> This is because of:
> dlg.setMode(QFileDialog::AnyFile);
Qt really is moronic. We want to be able to open a new file too, I
think.
regards
john
--
Khendon's Law: If the same poi
On Thu, Nov 14, 2002 at 03:41:37PM +0100, Juergen Spitzmueller wrote:
> It does not work because qt cannot read the file mask strings given in
> ControlInclude. The patch modifies them (also tested with xforms).
applied thanks
the filter we put in the dialog looks odd ... do we need the duplica
On Thursday 14 November 2002 3:36 pm, Darren Freeman wrote:
> Dear list,
>
> When spellchecking, a double click of the desired suggestion replaces
> the word and moves to the next possible error, as it should. But the
> text in the dialogue doesn't update, it still refers to the previous
> error.
Dear list,
the spelchecker status bar is still corrupted. Attached is a screenshot
at 100%. When I looked at it glosely in GIMP I realised that the weird
characters are actually two copies of 100% on top of each other, one
normal size and a second much smaller over the % sign of the first.
Hope i
Dear list,
When spellchecking, a double click of the desired suggestion replaces
the word and moves to the next possible error, as it should. But the
text in the dialogue doesn't update, it still refers to the previous
error.
Have fun,
Darren
> "Ben" == Ben Stanley <[EMAIL PROTECTED]> writes:
Ben> I am writing to let it be known that I consider this bug affects
Ben> me as well, and that I consider it to be rather serious. Could
Ben> you please re-consider the back-porting issue?
The problem is to find someone who has both the time
On Thursday 14 November 2002 3:08 pm, Juergen Spitzmueller wrote:
> Angus Leeming wrote:
> > When the combox is changed. Would you like to test out the patch, as you
> > know this stuff better than I do? Say yeah and I'll post it ;-)
>
> The problem is that, for real life reasons, I should not even
Angus Leeming wrote:
> When the combox is changed. Would you like to test out the patch, as you
> know this stuff better than I do? Say yeah and I'll post it ;-)
The problem is that, for real life reasons, I should not even dare to think of
the lyx code the following week. After that, it'll be a
On Thu, Nov 14, 2002 at 10:05:07AM +0900, Rob Lahaye wrote:
> >Because clicking on it does not open a dialog.
>
> Why it doesn't?
> I can imagine at least one toggle that needs to be set
> in a Index List dialog:
>
> o add Index to TOC.
>
> (Similar to the toggle in the BibTeX dialog).
>
>
On Thursday 14 November 2002 2:41 pm, Juergen Spitzmueller wrote:
> It does not work because qt cannot read the file mask strings given in
> ControlInclude. The patch modifies them (also tested with xforms).
> The same is still broken for insert->ASCII (as lines|as paragraphs).
>
> Thanks,
> Jürgen
On Thursday 14 November 2002 2:43 pm, Juergen Spitzmueller wrote:
> Juergen Spitzmueller wrote:
> > Good. The difference between the old and the new (and qt) method is,
> > AFAICS, that the warning now comes after applying while it came on class
> > change in the dialog before. I don't know what is
Juergen Spitzmueller wrote:
> Good. The difference between the old and the new (and qt) method is,
> AFAICS, that the warning now comes after applying while it came on class
> change in the dialog before. I don't know what is better though.
which depends of course where we invoke your new check (w
It does not work because qt cannot read the file mask strings given in
ControlInclude. The patch modifies them (also tested with xforms).
The same is still broken for insert->ASCII (as lines|as paragraphs).
Thanks,
Jürgen.
Index: src/frontends/controllers/ChangeLog
===
Angus Leeming wrote:
> Thanks Jürgen for the feedback. I've modified CheckChoiceClass to this:
Good. The difference between the old and the new (and qt) method is, AFAICS,
that the warning now comes after applying while it came on class change in
the dialog before. I don't know what is better th
On Thursday 14 November 2002 7:45 am, Juergen Spitzmueller wrote:
> > Thereafter, FormDocument::CheckChoiceClass can go the way of the dodo
> > also I think.
>
> But not this part:
>
> if (lyxrc.auto_reset_options) {
> params.textclass = tc;
>
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> On Wed, Nov 13, 2002 at 03:53:18PM +0100, Jean-Marc Lasgouttes
John> wrote:
>> bug and explain what arguments should be passed to beforeChange(),
>> what is the exact difference between text and getLyxText(), and so
>> on...
John> See b
Edwin Leuven wrote:
> has "Save" instead of "Open" button...
This is because of:
dlg.setMode(QFileDialog::AnyFile);
(FileDialog.C, 67)
which is needed to save a new file (with qt3). I suppose the solution is to
distinct between an open and a save file dialog.
Jürgen.
has "Save" instead of "Open" button...
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> On Thu, Nov 14, 2002 at 10:14:22AM +0100, Jean-Marc Lasgouttes
Andre> wrote: [And I would not mind calling 't' 'text', as it is
Andre> almost everywhere else in the code.]
>> I _would_ mind personally: text is a member of BufferVie
On Thu, Nov 14, 2002 at 10:14:22AM +0100, Jean-Marc Lasgouttes wrote:
> Andre> [And I would not mind calling 't' 'text', as it is almost
> Andre> everywhere else in the code.]
>
> I _would_ mind personally: text is a member of BufferView, and so we
> are hiding it with a local variable which is di
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> On Wed, Nov 13, 2002 at 08:08:45PM +, John Levon wrote:
>> + LyXText * t(users->getLyXText());
Andre> Could you _please_ use
Andre> LyXText * t = users->getLyXText();
Andre> here?
I prefer this too.
Andre> [And I would no
> "Martin" == Martin Vermeer <[EMAIL PROTECTED]> writes:
>> And then reLyX cannot know which layout corresponds to \caption.
Martin> Not *easily*... the surrounding float should tell. And even if
Martin> not, this is not fatal.
I think this is a complicated solution for a simple problem. We
On Wed, Nov 13, 2002 at 08:08:45PM +, John Levon wrote:
> + LyXText * t(users->getLyXText());
Could you _please_ use
LyXText * t = users->getLyXText();
here?
I personally find this _much_ more readable and 90% of the rest of LyX are
like this. [And I would not mind calling 't' 'text
33 matches
Mail list logo