labath added a comment.
Yes, please use a command-line argument to pass that information into python.
http://reviews.llvm.org/D19067
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commit
labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.
This sounds a lot like the problem that has been plaguing our darwin buildbot
(interestingly, I have never seen it happen on linux). Thanks for tracking that
down.
I am not sure I understand
labath added a comment.
So, I think I have already fixed the problem with r266192.
This seems a bit like using a sledgehammer to kill a fly. If anything, I'd add
an assert somewhere that makes sure the file names are in the right form to
begin with.
http://reviews.llvm.org/D19215
_
labath resigned from this revision.
labath removed a reviewer: labath.
labath added a comment.
Looks good, but I'll defer to Zachary.
http://reviews.llvm.org/D19216
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-
Author: labath
Date: Mon Apr 18 06:01:41 2016
New Revision: 266598
URL: http://llvm.org/viewvc/llvm-project?rev=266598&view=rev
Log:
Fixup r266327
Fix XFAILed tests in TestThreadStates for the new signature of
wait_for_running_event.
Modified:
lldb/trunk/packages/Python/lldbsuite/test/func
Author: labath
Date: Mon Apr 18 07:18:35 2016
New Revision: 266605
URL: http://llvm.org/viewvc/llvm-project?rev=266605&view=rev
Log:
Attempt to fix darwin build after header refactor in llvm (r266595)
Modified:
lldb/trunk/source/API/SBHostOS.cpp
Modified: lldb/trunk/source/API/SBHostOS.cpp
U
tfiala closed this revision.
tfiala added a comment.
Closing with commit:
r266624
http://reviews.llvm.org/D19214
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
tfiala added a comment.
In http://reviews.llvm.org/D19215#403844, @labath wrote:
> So, I think I have already fixed the problem with r266192.
I was able to replicate just prior to applying the change, but I'll double
check.
Regarding r266192 (which came through when I wasn't looking, sorry),
Author: tfiala
Date: Mon Apr 18 11:09:21 2016
New Revision: 266624
URL: http://llvm.org/viewvc/llvm-project?rev=266624&view=rev
Log:
fix a race is the LLDB test suite results collection
The race boiled down to this:
If a test worker queue is able to run the test inferior and
clean up before the
fjricci updated this revision to Diff 54077.
fjricci added a comment.
Pass the lldb lib directory to python swig scripts
http://reviews.llvm.org/D19067
Files:
CMakeLists.txt
scripts/Python/finishSwigPythonLLDB.py
scripts/finishSwigWrapperClasses.py
Index: scripts/finishSwigWrapperClasses
tfiala added a comment.
> I was able to replicate just prior to applying the change, but I'll double
> check.
Yeah that change didn't cover all the cases. The test_filename that comes from
this call stack (in startTest), originating within the unittest2 framework, has
the .pyc (assuming this
tfiala updated this revision to Diff 54078.
tfiala added a comment.
Change inspect.getfile() => inspect.getsourcefile().
http://reviews.llvm.org/D19215
Files:
packages/Python/lldbsuite/test/result_formatter.py
Index: packages/Python/lldbsuite/test/result_formatter.py
tfiala updated this revision to Diff 54079.
tfiala added a comment.
Whoops - don't include the 'raise' call.
http://reviews.llvm.org/D19215
Files:
packages/Python/lldbsuite/test/result_formatter.py
Index: packages/Python/lldbsuite/test/result_formatter.py
labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.
Ok, makes sense then, thanks for making sure it's necessary.
I don't quite understand how the string makes it's way there though, as the
only place setting this field in the entire repository
fjricci created this revision.
fjricci added reviewers: ADodds, zturner, tfiala.
fjricci added subscribers: sas, lldb-commits.
When we receive an svr4 packet from the remote, we check for new modules
and add them to the list of images in the target. However, we did not
do the same for modules whic
zturner added inline comments.
Comment at: packages/Python/lldbsuite/test/test_runner/lldb_utils.py:1
@@ +1,2 @@
+"""
+The LLVM Compiler Infrastructure
I feel like this entire file should go under `lldbsuite/support`. If it's
under `test/test_runner` we can't us
It seems very strange to me to be changing a .pyc filename to a .py
filename. I think we should try to understand where the .pyc filename is
coming from to begin with, and this is just masking the real error.
On Mon, Apr 18, 2016 at 10:10 AM Pavel Labath via lldb-commits <
lldb-commits@lists.llvm
Yep, I agree with that now. Wasn't the case when I originally wrote it,
but yeah that can move. I'll adjust that.
On Mon, Apr 18, 2016 at 10:57 AM, Zachary Turner wrote:
> zturner added inline comments.
>
>
> Comment at: packages/Python/lldbsuite/test/test_runner/lldb_utils.py
tfiala added a subscriber: tfiala.
tfiala added a comment.
Yep, I agree with that now. Wasn't the case when I originally wrote it,
but yeah that can move. I'll adjust that.
http://reviews.llvm.org/D19216
___
lldb-commits mailing list
lldb-commits@
IIRC, python will generate byte-compiled ".pyc" versions of the ".py" files
automatically (and helpfully leave them in the CWD...) We turned that off for
the testsuite through some Python magic I don't think I ever knew, but if I did
I've certainly forgotten it... Anyway, sounds like that got
That's normal, but why would that cause an issue for the test suite? What
is leading to it thinking that it should execute a .pyc file in the first
place?
On Mon, Apr 18, 2016 at 11:25 AM Jim Ingham wrote:
> IIRC, python will generate byte-compiled ".pyc" versions of the ".py"
> files automatic
That I don't know. But we really shouldn't be generating the .pyc files, they
just litter the test directories and I don't think they are much help.
Jim
> On Apr 18, 2016, at 11:29 AM, Zachary Turner wrote:
>
> That's normal, but why would that cause an issue for the test suite? What is
> l
They make the test suite run faster. when a file wasn't changed.
On Mon, Apr 18, 2016 at 11:34 AM Jim Ingham wrote:
> That I don't know. But we really shouldn't be generating the .pyc files,
> they just litter the test directories and I don't think they are much help.
>
> Jim
>
> > On Apr 18, 2
(not sure how much though, as I haven't actually measured it)
On Mon, Apr 18, 2016 at 11:40 AM Zachary Turner wrote:
> They make the test suite run faster. when a file wasn't changed.
>
> On Mon, Apr 18, 2016 at 11:34 AM Jim Ingham wrote:
>
>> That I don't know. But we really shouldn't be gene
tfiala added a comment.
In http://reviews.llvm.org/D19215#404143, @zturner wrote:
> It seems very strange to me to be changing a .pyc filename to a .py
> filename. I think we should try to understand where the .pyc filename is
> coming from to begin with, and this is just masking the real erro
tfiala added a comment.
> The __file__ for lldbinline.py-based tests is getting set to .pyc via the
> unittest2 loader. This callstack comes from inserting this code into
> lldbinline.py:
>
> diff --git a/packages/Python/lldbsuite/test/lldbinline.py
> b/packages/Python/lldbsuite/test/lldb
cameron314 updated the summary for this revision.
cameron314 removed rL LLVM as the repository for this revision.
cameron314 updated this revision to Diff 54095.
cameron314 added a comment.
I've updated the diff to include a fix for the race between Detach and Stop.
This has been working nicely f
cameron314 updated this revision to Diff 54098.
cameron314 added a comment.
Oops, uploaded wrong diff a minute ago. Here's the one with the full fix.
http://reviews.llvm.org/D19122
Files:
include/lldb/Target/Process.h
source/Target/Process.cpp
Index: source/Target/Process.cpp
=
clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.
Looks good.
http://reviews.llvm.org/D19122
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/li
tfiala added a comment.
Side note:
Okay I think the mystery of this was caught by Jim. When we started accepting
usage of .pycs again, we're allowing the python runtime to select using the pyc
if available and not older than the .py file. This makes it possible to get a
test file that is som
tfiala updated this revision to Diff 54102.
tfiala added a comment.
Final change: this change:
1. has the lldbinline.py test intercept its __file parameter and convert from
.pyc to .py before storing to the test.test_filename attribute.
2. has the test event creation mechanism and test_event usa
Author: tfiala
Date: Mon Apr 18 15:26:56 2016
New Revision: 24
URL: http://llvm.org/viewvc/llvm-project?rev=24&view=rev
Log:
ensure lldbinline remembers .py extension
This ensure lldbinline.test_file paths are tracked as .py
files rather than .pyc files.
Also, this change adds an assert
tfiala closed this revision.
tfiala added a comment.
Closed via commit:
r24
http://reviews.llvm.org/D19215
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
tfiala added inline comments.
Comment at: source/Plugins/Process/gdb-remote/ProcessGDBRemote.cpp:4907
@@ -4883,2 +4906,3 @@
+m_process->GetTarget().ModulesDidUnload (removed_modules, false);
new_modules.ForEach ([&target](const lldb::ModuleSP module_sp) -> bool
tfiala updated this revision to Diff 54115.
tfiala added a comment.
Moves optional_with into its own lldbsuite/support module.
http://reviews.llvm.org/D19216
Files:
packages/Python/lldbsuite/support/optional_with.py
packages/Python/lldbsuite/test/dosep.py
packages/Python/lldbsuite/test/te
zturner accepted this revision.
zturner added a comment.
This revision is now accepted and ready to land.
thanks
http://reviews.llvm.org/D19216
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/
cameron314 removed rL LLVM as the repository for this revision.
cameron314 updated this revision to Diff 54134.
cameron314 added a comment.
I've added a test for this patch.
http://reviews.llvm.org/D19124
Files:
packages/Python/lldbsuite/test/expression_command/ir-interpreter/Makefile
pack
fjricci added inline comments.
Comment at: source/Plugins/Process/gdb-remote/ProcessGDBRemote.cpp:4907
@@ -4883,2 +4906,3 @@
+m_process->GetTarget().ModulesDidUnload (removed_modules, false);
new_modules.ForEach ([&target](const lldb::ModuleSP module_sp) -> bool
Hello everyone,
LLVM buildmaster will be updated and restarted after 6 PM Pacific time
today.
Thanks
Galina
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
Author: chaoren
Date: Mon Apr 18 20:09:37 2016
New Revision: 266702
URL: http://llvm.org/viewvc/llvm-project?rev=266702&view=rev
Log:
Fix Windows build.
Modified:
lldb/trunk/source/Host/windows/Windows.cpp
Modified: lldb/trunk/source/Host/windows/Windows.cpp
URL:
http://llvm.org/viewvc/llvm
omjavaid created this revision.
omjavaid added reviewers: tberghammer, rengolin, clayborg.
omjavaid added a subscriber: lldb-commits.
Herald added subscribers: danalbert, tberghammer, rengolin, aemerson.
This patch provides a fix for wrong plt entry size generated for binaries built
with gcc and
tfiala accepted this revision.
tfiala added a comment.
This revision is now accepted and ready to land.
LGTM.
Comment at: source/Plugins/Process/gdb-remote/ProcessGDBRemote.cpp:4907
@@ -4883,2 +4906,3 @@
+m_process->GetTarget().ModulesDidUnload (removed_modules, false);
Author: tfiala
Date: Mon Apr 18 23:20:35 2016
New Revision: 266710
URL: http://llvm.org/viewvc/llvm-project?rev=266710&view=rev
Log:
test infra cleanup: convert test_runner lib into package
Also does the following:
* adopts PEP8 naming convention for OptionalWith class (now
optional_with).
* mo
tfiala closed this revision.
tfiala added a comment.
Closed via commit:
r266710
commit 4ef9c1c5dcb05a159929cd3b407481ed86a73ef5 (HEAD -> master,
origin/master, origin/HEAD)
Author: Todd Fiala
Date: Mon Apr 18 21:20:35 2016
test infra cleanup: convert test_runner lib into packag
44 matches
Mail list logo