tfiala closed this revision. tfiala added a comment. Closed via commit: r266710
commit 4ef9c1c5dcb05a159929cd3b407481ed86a73ef5 (HEAD -> master, origin/master, origin/HEAD) Author: Todd Fiala <todd.fi...@gmail.com> Date: Mon Apr 18 21:20:35 2016 test infra cleanup: convert test_runner lib into package Also does the following: * adopts PEP8 naming convention for OptionalWith class (now optional_with). * moves test_runner/lldb_utils.py to lldbsuite/support/optional_with.py. * packages tests in a subpackage of test_runner per recommendations in http://the-hitchhikers-guide-to-packaging.readthedocs.org/en/latest/creation.html Tests can be run from within pacakges/Python/lldbsuite/test via this command: python -m unittest discover test_runner The primary cleanup this allows is avoiding the need to muck with the PYTHONPATH variable from within the source files. This also aids some of the static code checkers as they don't need to run code to determine the proper python path. git-svn-id: https://llvm.org/svn/llvm-project/lldb/trunk@266710 91177308-0d34-0410-b5e6-96231b3b80d8 http://reviews.llvm.org/D19216 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits