Re: [PATCH v5 2/3] printf: break kunit into test cases

2025-03-06 Thread Petr Mladek
On Fri 2025-02-21 15:34:31, Tamir Duberstein wrote: > Move all tests into `printf_test_cases`. This gives us nicer output in > the event of a failure. > > Combine `plain_format` and `plain_hash` into `hash_pointer` since > they're testing the same scenario. > > Signed-off-by: Tamir Duberstein >

[PATCH 05/13] MIPS: make setup_zero_pages() use memblock

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" Allocating the zero pages from memblock is simpler because the memory is already reserved. This will also help with pulling out memblock_free_all() to the generic code and reducing code duplication in arch::mem_init(). Signed-off-by: Mike Rapoport (Microsoft)

Re: [PATCH v3 net-next 06/13] net: enetc: add RSS support for i.MX95 ENETC PF

2025-03-06 Thread Jakub Kicinski
On Tue, 4 Mar 2025 15:21:54 +0800 Wei Fang wrote: > Add Receive side scaling (RSS) support for i.MX95 ENETC PF to improve > the network performance and balance the CPU loading. The main changes > are as follows. > > 1. Since i.MX95 ENETC (v4) use NTMP 2.0 to manage the RSS table, which > is diffe

Re: [PATCH] book3s64/radix : Align section vmemmap start address to PAGE_SIZE

2025-03-06 Thread Donet Tom
On 3/6/25 9:41 AM, Aneesh Kumar K.V wrote: Donet Tom writes: On 3/3/25 18:32, Aneesh Kumar K.V wrote: Donet Tom writes: A vmemmap altmap is a device-provided region used to provide backing storage for struct pages. For each namespace, the altmap should belong to that same namespace. If t

Re: PowerPC: sleftests/powerpc fails to compile linux-next

2025-03-06 Thread Madhavan Srinivasan
On 3/6/25 10:30 PM, Venkat Rao Bagalkote wrote: > Greetings!! > > I see selftests/powerpc fails to compile on next-20250306. > > This error has been introduced in next-20250218. Make is successful on > next-20250217. > > > Attached is the .config used. > &g

Re: [PATCH v4] powerpc/hugetlb: Disable gigantic hugepages if fadump is active

2025-03-06 Thread Sourabh Jain
On 06/03/25 00:47, Ritesh Harjani (IBM) wrote: Sourabh Jain writes: Hello Ritesh, On 04/03/25 10:27, Ritesh Harjani (IBM) wrote: Sourabh Jain writes: Hello Ritesh, Thanks for the review. On 02/03/25 12:05, Ritesh Harjani (IBM) wrote: Sourabh Jain writes: The fadump kernel boots

Re: [PATCH] PCI/AER: Add kernel.aer_print_skip_mask to control aer log

2025-03-06 Thread Bijie Xu
On Tue, 4 Mar 2025 17:22:30 -0600, Bjorn Helgaas wrote: > Can you take a look at this and see if it's going the right direction > for you, or if it needs extensions to do what you need? Thanks for your suggestion. I've taken sometime to review that patch you suggested. It solves part of the probl

Re: [PATCH v5 1/3] printf: convert self-test to KUnit

2025-03-06 Thread Tamir Duberstein
On Thu, Mar 6, 2025 at 9:25 AM Tamir Duberstein wrote: > > On Thu, Mar 6, 2025 at 7:25 AM Petr Mladek wrote: > > > > On Fri 2025-02-21 15:34:30, Tamir Duberstein wrote: > > > Convert the printf() self-test to a KUnit test. > > > > > > [...] > > > > > > 2. What was the motivation to remove the tra

Re: [PATCH v5 1/3] printf: convert self-test to KUnit

2025-03-06 Thread Petr Mladek
On Fri 2025-02-21 15:34:30, Tamir Duberstein wrote: > Convert the printf() self-test to a KUnit test. > > In the interest of keeping the patch reasonably-sized this doesn't > refactor the tests into proper parameterized tests - it's all one big > test case. > > Signed-off-by: Tamir Duberstein >

RE: [EXTERNAL] Re: [PATCH v4 1/2] watchdog: Add a new flag WDIOF_STOP_MAYSLEEP

2025-03-06 Thread George Cherian
Hi Guenter, I am summarizing the topics we discussed in multiple threads here. >>On 3/5/25 03:01, Ahmad Fatoum wrote: >> Hi George, >> Hi Guenter, >> >> On 05.03.25 11:34, George Cherian wrote: why is armada_37xx_wdt also here? The stop function in that driver may not sleep. >>> Marek,

Re: [RFC kvm-unit-tests PATCH] lib: Use __ASSEMBLER__ instead of __ASSEMBLY__

2025-03-06 Thread Thomas Huth
On 22/02/2025 02.45, Sean Christopherson wrote: Convert all non-x86 #ifdefs from __ASSEMBLY__ to __ASSEMBLER__, and remove all manual __ASSEMBLY__ #defines. __ASSEMBLY_ was inherited blindly from the Linux kernel, and must be manually defined, e.g. through build rules or with the aforementioned

PowerPC: Observing Kernel softlockup while running ftrace selftest

2025-03-06 Thread Venkat Rao Bagalkote
Greetings!!! I am observing soft lock up's while running ftrace selftest on linux-next kernel. Kernel Version: next-20250305 make run_tests TAP version 13 1..2 # timeout set to 0 # selftests: ftrace: poll # Error: Polling file is not specified not ok 1 selftests: ftrace: poll # exit=255 # ti

[PATCH 13/13] arch, mm: make releasing of memory to page allocator more explicit

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" The point where the memory is released from memblock to the buddy allocator is hidden inside arch-specific mem_init()s and the call to memblock_free_all() is needlessly duplicated in every artiste cure and after introduction of arch_mm_preinit() hook, mem_init()

[PATCH 02/13] csky: move setup_initrd() to setup.c

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" Memory used by initrd should be reserved as soon as possible before there any memblock allocations that might overwrite that memory. This will also help with pulling out memblock_free_all() to the generic code and reducing code duplication in arch::mem_init().

Re: [PATCH] book3s64/radix : Align section vmemmap start address to PAGE_SIZE

2025-03-06 Thread Aneesh Kumar K . V
Donet Tom writes: > On 3/3/25 18:32, Aneesh Kumar K.V wrote: >> Donet Tom writes: >> >>> A vmemmap altmap is a device-provided region used to provide >>> backing storage for struct pages. For each namespace, the altmap >>> should belong to that same namespace. If the namespaces are >>> created u

Re: [RFC kvm-unit-tests PATCH] lib: Use __ASSEMBLER__ instead of __ASSEMBLY__

2025-03-06 Thread Sean Christopherson
On Thu, Mar 06, 2025, Thomas Huth wrote: > On 22/02/2025 02.45, Sean Christopherson wrote: > > Convert all non-x86 #ifdefs from __ASSEMBLY__ to __ASSEMBLER__, and remove > > all manual __ASSEMBLY__ #defines. __ASSEMBLY_ was inherited blindly from > > the Linux kernel, and must be manually defined,

Re: [PATCH v3 net-next 01/13] net: enetc: add initial netc-lib driver to support NTMP

2025-03-06 Thread Jakub Kicinski
On Tue, 4 Mar 2025 15:21:49 +0800 Wei Fang wrote: > +config NXP_NETC_LIB > + tristate "NETC Library" Remove the string after "tristate", the user should not be prompted to make a choice for this, since the consumers "select" this config directly. > + help > + This module provides c

[PATCH 08/13] xtensa: split out printing of virtual memory layout to a function

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" This will help with pulling out memblock_free_all() to the generic code and reducing code duplication in arch::mem_init(). Signed-off-by: Mike Rapoport (Microsoft) --- arch/xtensa/mm/init.c | 97 ++- 1 file changed, 50 i

Re: [PATCH v3 net-next 07/13] net: enetc: check if the RSS hfunc is toeplitz

2025-03-06 Thread Jakub Kicinski
On Tue, 4 Mar 2025 15:21:55 +0800 Wei Fang wrote: > Both ENETC v1 and ENETC v4 only support the toeplitz algorithm for RSS, > so add a check for RSS hfunc. Rejecting unsupported configurations is considered a fix, please send it to net with a Fixes tag. -- pw-bot: cr

[PATCH 06/13] nios2: move pr_debug() about memory start and end to setup_arch()

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" This will help with pulling out memblock_free_all() to the generic code and reducing code duplication in arch::mem_init(). Signed-off-by: Mike Rapoport (Microsoft) --- arch/nios2/kernel/setup.c | 2 ++ arch/nios2/mm/init.c | 2 -- 2 files changed, 2 inser

[PATCH 01/13] arm: mem_init: use memblock_phys_free() to free DMA memory on SA1111

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" This will help to pull out memblock_free_all() to generic code. Signed-off-by: Mike Rapoport (Microsoft) --- arch/arm/mm/init.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/arch/arm/mm/init.c b/arch/arm/mm/init.c index 5345d21889

[PATCH 11/13] arch, mm: streamline HIGHMEM freeing

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" All architectures that support HIGHMEM have their code that frees high memory pages to the buddy allocator while __free_memory_core() is limited to freeing only low memory. There is no actual reason for that. The memory map is completely ready by the time memblo

[PATCH 09/13] arch, mm: set max_mapnr when allocating memory map for FLATMEM

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" max_mapnr is essentially the size of the memory map for systems that use FLATMEM. There is no reason to calculate it in each and every architecture when it's anyway calculated in alloc_node_mem_map(). Drop setting of max_mapnr from architecture code and set it o

[PATCH 00/13] arch, mm: reduce code duplication in mem_init()

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" Hi, Every architecture has implementation of mem_init() function and some even more than one. All these release free memory to the buddy allocator, most of them set high_memory to the end of directly addressable memory and many of them set max_mapnr for FLATMEM

[PATCH 07/13] s390: make setup_zero_pages() use memblock

2025-03-06 Thread Mike Rapoport
From: "Mike Rapoport (Microsoft)" Allocating the zero pages from memblock is simpler because the memory is already reserved. This will also help with pulling out memblock_free_all() to the generic code and reducing code duplication in arch::mem_init(). Signed-off-by: Mike Rapoport (Microsoft)

Re: [PATCH 00/13] arch, mm: reduce code duplication in mem_init()

2025-03-06 Thread Andrew Morton
On Thu, 6 Mar 2025 20:51:10 +0200 Mike Rapoport wrote: > Every architecture has implementation of mem_init() function and some > even more than one. All these release free memory to the buddy > allocator, most of them set high_memory to the end of directly > addressable memory and many of them s

Re: [EXTERNAL] Re: [PATCH v4 1/2] watchdog: Add a new flag WDIOF_STOP_MAYSLEEP

2025-03-06 Thread Guenter Roeck
On Thu, Mar 06, 2025 at 12:18:20PM +, George Cherian wrote: > Hi Guenter, > > I am summarizing the topics we discussed in multiple threads here. > > >>On 3/5/25 03:01, Ahmad Fatoum wrote: > >> Hi George, > >> Hi Guenter, > >> > >> On 05.03.25 11:34, George Cherian wrote: > why is armada

Re: [PATCH v5 2/3] printf: break kunit into test cases

2025-03-06 Thread Tamir Duberstein
On Thu, Mar 6, 2025 at 11:44 AM Petr Mladek wrote: > > On Fri 2025-02-21 15:34:31, Tamir Duberstein wrote: > > Move all tests into `printf_test_cases`. This gives us nicer output in > > the event of a failure. > > > > Combine `plain_format` and `plain_hash` into `hash_pointer` since > > they're te