[PATCH] Fix some minor errors in mpc5200 psc i2s driver

2008-10-19 Thread Jon Smirl
Fix missing unsigned for irqsave flags in psc i2s driver Make attribute visiblity static Collect all sysfs errors before checking status Signed-off-by: Jon Smirl <[EMAIL PROTECTED]> --- sound/soc/fsl/mpc5200_psc_i2s.c | 12 ++-- 1 files changed, 6 insertions(+), 6 deletions(-) diff --g

[PATCH] Add the of_find_i2c_device_by_node function

2008-10-19 Thread Jon Smirl
Add the of_find_i2c_device_by_node function. This allows you to follow a reference in the device tree to an i2c device node and then locate the linux device instantiated by the device tree. Example use, an i2s codec controlled by i2c. Depends on patch exporting i2c root bus symbol. Signed-off-by:

Re: [PATCH] Fix some minor errors in mpc5200 psc i2s driver

2008-10-19 Thread Grant Likely
On Sun, Oct 19, 2008 at 09:49:11AM -0400, Jon Smirl wrote: > Fix missing unsigned for irqsave flags in psc i2s driver > Make attribute visiblity static > Collect all sysfs errors before checking status > > Signed-off-by: Jon Smirl <[EMAIL PROTECTED]> Acked-by: Grant Likely <[EMAIL PROTECTED]> > -

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Guennadi Liakhovetski
(modified the cc-list somewhat) On Sat, 18 Oct 2008, Rogério Brito wrote: > systems. Here is something that I get with a vanilla linkstation_defconfig: > > - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - > drivers/rtc/hctosys.c: unable to open rtc device (rtc0) > - - - - - -

Re: [PATCH] Add the of_find_i2c_device_by_node function

2008-10-19 Thread Anton Vorontsov
Hi Jon, On Sun, Oct 19, 2008 at 10:00:40AM -0400, Jon Smirl wrote: > Add the of_find_i2c_device_by_node function. This allows you to follow > a reference in the device tree to an i2c device node and then locate > the linux device instantiated by the device tree. Example use, an i2s > codec control

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Jon Smirl
On Sun, Oct 19, 2008 at 4:59 PM, Guennadi Liakhovetski <[EMAIL PROTECTED]> wrote: > (modified the cc-list somewhat) > > On Sat, 18 Oct 2008, Rogério Brito wrote: > >> systems. Here is something that I get with a vanilla linkstation_defconfig: >> >> - - - - - - - - - - - - - - - - - - - - - - - - -

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Guennadi Liakhovetski
On Sun, 19 Oct 2008, Jon Smirl wrote: > On Sun, Oct 19, 2008 at 4:59 PM, Guennadi Liakhovetski > <[EMAIL PROTECTED]> wrote: > > > > Yes, there seems to be a problem here now. The i2c adapter does not get > > probed, i.e., of-matching doesn't work. A quick look through other > > device-trees, using

Re: [PATCH] Add the of_find_i2c_device_by_node function

2008-10-19 Thread Jon Smirl
On Sun, Oct 19, 2008 at 5:20 PM, Anton Vorontsov <[EMAIL PROTECTED]> wrote: > Hi Jon, > > On Sun, Oct 19, 2008 at 10:00:40AM -0400, Jon Smirl wrote: >> Add the of_find_i2c_device_by_node function. This allows you to follow >> a reference in the device tree to an i2c device node and then locate >> t

Re: [PATCH] Add the of_find_i2c_device_by_node function

2008-10-19 Thread Anton Vorontsov
On Sun, Oct 19, 2008 at 05:50:15PM -0400, Jon Smirl wrote: > On Sun, Oct 19, 2008 at 5:20 PM, Anton Vorontsov > <[EMAIL PROTECTED]> wrote: > > Hi Jon, > > > > On Sun, Oct 19, 2008 at 10:00:40AM -0400, Jon Smirl wrote: > >> Add the of_find_i2c_device_by_node function. This allows you to follow > >>

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Jon Smirl
On Sun, Oct 19, 2008 at 5:49 PM, Guennadi Liakhovetski <[EMAIL PROTECTED]> wrote: > On Sun, 19 Oct 2008, Jon Smirl wrote: > >> On Sun, Oct 19, 2008 at 4:59 PM, Guennadi Liakhovetski >> <[EMAIL PROTECTED]> wrote: >> > >> > Yes, there seems to be a problem here now. The i2c adapter does not get >> >

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Guennadi Liakhovetski
On Sun, 19 Oct 2008, Jon Smirl wrote: > i2c-mpc.c has: > > static const struct of_device_id mpc_i2c_of_match[] = { > {.compatible = "fsl-i2c",}, > {}, > }; > MODULE_DEVICE_TABLE(of, mpc_i2c_of_match); > > > /* Structure for a device driver */ > static struct of_platform_driver mpc_i

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Jon Smirl
On Sun, Oct 19, 2008 at 6:28 PM, Guennadi Liakhovetski <[EMAIL PROTECTED]> wrote: > On Sun, 19 Oct 2008, Jon Smirl wrote: > >> i2c-mpc.c has: >> >> static const struct of_device_id mpc_i2c_of_match[] = { >> {.compatible = "fsl-i2c",}, >> {}, >> }; >> MODULE_DEVICE_TABLE(of, mpc_i2c_of_m

Re: [PATCH] powerpc: remove device_type = "board-control"

2008-10-19 Thread David Gibson
On Sat, Oct 18, 2008 at 04:23:52AM +0400, Anton Vorontsov wrote: > We don't want to encourage the bogus device_type usage. > > The device type isn't used in the code, so we can simply remove it from > the documentation and dts files. > > Boards should specify proper compatible entries instead. >

[PATCH] Revert to real-base = 12MB on 32-bit CHRP

2008-10-19 Thread Paul Mackerras
Commit 9b09c6d909dfd8de96b99b9b9c808b94b0a71614 ("powerpc: Change the default link address for pSeries zImage kernels") changed the real-base value in the CHRP note added by addnote to the zImage from 12MB to 32MB. It turns out that this causes unnecessary extra reboots on old 32-bit CHRP machines

Re: [PATCH] Add the of_find_i2c_device_by_node function

2008-10-19 Thread Benjamin Herrenschmidt
On Mon, 2008-10-20 at 02:03 +0400, Anton Vorontsov wrote: > > This is the original mail > > http://lkml.org/lkml/2008/6/13/290 > > http://lkml.org/lkml/2008/6/12/8 > > I can't find the ones patching i2c. > > Well, I didn't disagree with the change. I think this is good change > (and good catch

Re: [PATCH] powerpc: enable heap randomization for linkstations

2008-10-19 Thread Guennadi Liakhovetski
On Sun, 19 Oct 2008, Jon Smirl wrote: > Is i2c-mpc built into your kernel? It's not going to module auto-load > because the names don't match - fsl-i2c and i2c-mpc. It is built into the kernel. Thanks Guennadi > > But a message on init and make sure it is loading. > static int __init fsl_i2c_i

Re: [PATCH] Support for relocatable kdump kernel

2008-10-19 Thread Michael Ellerman
> > Forwarded Message > > From: Mohan Kumar M <[EMAIL PROTECTED]> > > To: [EMAIL PROTECTED] > > Cc: linuxppc-dev@ozlabs.org, [EMAIL PROTECTED] > > Subject: [PATCH] Support for relocatable kdump kernel > > Date: Mon, 13 Oct 2008 05:04:20 +0530 > > > > Support for relocatable kdump