On Tue, Feb 05 2008, Stephen Rothwell wrote:
> WARNING: drivers/cdrom/viocd.o(.text+0x504): Section mismatch in reference
> from the function .viocd_probe() to the function .init.text:.find_capability()
>
> Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]>
> ---
> drivers/cdrom/viocd.c |2
Hi Yuri,
> Does anybody use swap with some of the 8xx-based boards supported in
> powerpc branch ?
modded DBox2 boxes do. Unfortunately, i don't have such a modded box.
The tuxbox project currently uses a really ugly hack to support swapping:
http://git.bocc.de/cgi-bin/gitweb.cgi?p=dbox2.git;a=
On (05/02/08 11:01), Benjamin Herrenschmidt didst pronounce:
>
> >
> > It's a virtual address so it depends on the value of CONFIG_KERNEL_START
> > as to whether this is a user program address or not.
>
> Shouldn't it be PAGE_OFFSET ? I mean, CONFIG_KERNEL_START should work
> on powerpc, but sti
The patch to legacy_serial.c (1a7507c7da2df6856e085e0fbb0c9ea8c12ac4e,
Reduce code duplication in legacy_serial, add UART parent types) changed
the semantics for opb ports from type = "opb" || compatible = "ibm,opb"
to type = "opb" && compatible = "ibm,opb".
The result is serial ports on our QS21s
On Mon, 4 Feb 2008 10:51:21 +0100
Sven Luther <[EMAIL PROTECTED]> wrote:
> On Sun, Feb 03, 2008 at 05:29:05PM +0100, Bernhard Reiter wrote:
> > Dear linux powerpc Maintainers and Users,
> >
> > recently I have tried to compile a new kernel on a Debian sarge ppc
> > system (PowerBook5,6 MacRISC3 P
On Fri, Feb 01, 2008 at 09:23:47AM -0700, Grant Likely wrote:
> On 2/1/08, Kumar Gala <[EMAIL PROTECTED]> wrote:
> >
> > > --- a/Documentation/powerpc/booting-without-of.txt
> > > +++ b/Documentation/powerpc/booting-without-of.txt
> > > @@ -1675,7 +1675,6 @@ platforms are moved over to use the flat
* Andrew Morton <[EMAIL PROTECTED]> [2008-02-04 23:40]:
> We did this wrong. We should have introduced a new reserve_bootmem_foo()
> and migrated over to that in stages. Once all callers are migrated, remove
> the old interface.
Well, my original proposal was to add a new function but then someo
Hello.
Andrew Morton wrote:
>> This is from ppc32:
>> CC arch/powerpc/mm/mem.o
>>arch/powerpc/mm/mem.c: In function 'do_init_bootmem':
>>arch/powerpc/mm/mem.c:256: error: too few arguments to function
>>'reserve_bootmem'
>>arch/powerpc/mm/mem.c:261: error: too few arguments to functi
* Tony Breeds <[EMAIL PROTECTED]> [2008-02-05 16:16:48]:
> On Sun, Jan 27, 2008 at 07:32:59PM +0530, Sripathi Kodi wrote:
> > Hi Paul,
> >
> > On PPC, I see a disparity between clock_getres implementations in the
> > vdso and syscall. I am using a IBM Openpower hardware and 2.6.24 kernel
> > with
In message: [PATCH] Fix legacy serial search for opb bus ports
on 05/02/2008 Michael Ellerman wrote:
> The patch to legacy_serial.c (1a7507c7da2df6856e085e0fbb0c9ea8c12ac4e,
> Reduce code duplication in legacy_serial, add UART parent types) changed
> the semantics for opb ports from type = "opb" |
This patch adds support for the framebuffers with non-native
endianness. This is done via FBINFO_FOREIGN_ENDIAN flag that will
be used by the drivers. Depending on the host endianness this flag
will be overwritten by FBINFO_BE_MATH internal flag, or cleared.
Tested to work on MPC8360E-RDK (BE) + F
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
---
drivers/video/offb.c | 15 ---
1 files changed, 12 insertions(+), 3 deletions(-)
diff --git a/drivers/video/offb.c b/drivers/video/offb.c
index 452433d..d7b3dcc 100644
--- a/drivers/video/offb.c
+++ b/drivers/video/offb.c
@@ -24
On Feb 4, 2008, at 8:40 PM, David Gibson wrote:
> On Fri, Feb 01, 2008 at 08:46:32AM -0600, Kumar Gala wrote:
>>
>> On Feb 1, 2008, at 1:54 AM, David Gibson wrote:
>>
>>> On Thu, Jan 24, 2008 at 06:41:24PM -0500, Paul Gortmaker wrote:
> [snip]
+ [EMAIL PROTECTED],0 {
>>>
>>> I'm not
On 2/5/08, Josh Boyer <[EMAIL PROTECTED]> wrote:
> > I mean, if you have not included 4xx support in the kernel, as is the
> > case here, it does not make sense to add the 4xx bootwrapper code, no ?
>
> It does, in a manner. There are both generic and platform specific
> pieces to the bootwrapper.
On Tue, 5 Feb 2008 15:39:26 +0100
Sven Luther <[EMAIL PROTECTED]> wrote:
> On Tue, Feb 05, 2008 at 07:08:33AM -0600, Josh Boyer wrote:
> > On Mon, 4 Feb 2008 10:51:21 +0100
> > Sven Luther <[EMAIL PROTECTED]> wrote:
> >
> > > On Sun, Feb 03, 2008 at 05:29:05PM +0100, Bernhard Reiter wrote:
> > >
On Tue, Feb 05, 2008 at 07:08:33AM -0600, Josh Boyer wrote:
> On Mon, 4 Feb 2008 10:51:21 +0100
> Sven Luther <[EMAIL PROTECTED]> wrote:
>
> > On Sun, Feb 03, 2008 at 05:29:05PM +0100, Bernhard Reiter wrote:
> > > Dear linux powerpc Maintainers and Users,
> > >
> > > recently I have tried to comp
On Tue, 5 Feb 2008 08:24:38 -0700
"Grant Likely" <[EMAIL PROTECTED]> wrote:
> On 2/5/08, Josh Boyer <[EMAIL PROTECTED]> wrote:
> > > I mean, if you have not included 4xx support in the kernel, as is the
> > > case here, it does not make sense to add the 4xx bootwrapper code, no ?
> >
> > It does,
On Feb 4, 2008, at 11:44 PM, Stephen Rothwell wrote:
>>
>> +aw = *(u32 *)of_get_property(dev->node, "#address-cells", NULL);
>> +sw = *(u32 *)of_get_property(dev->node, "#size-cells", NULL);
>
> What happens if either of these properties is missing?
Should we add __must_check to of_get_p
On Tue, Feb 05, 2008 at 09:38:20AM -0600, Josh Boyer wrote:
> Taking a step back though, there will always be odd cases like this as
> we move forward. Toolchain XXX will eventually not support instruction
> which will eventually be used, etc. I'll try to make this
> specific case work beca
On Thu, Jan 31, 2008 at 01:57:25PM +0800, Zhang Wei wrote:
>
>
> > -Original Message-
> > From: Kumar Gala [mailto:[EMAIL PROTECTED]
> >
> > On Jan 30, 2008, at 4:30 AM, Zhang Wei wrote:
> >
> > > Change lots of static variable to mport private. And add
> > mport to some
> > > functi
On Thu, Jan 31, 2008 at 02:30:13PM +0800, Zhang Wei wrote:
> > -Original Message-
> > From: Kumar Gala [mailto:[EMAIL PROTECTED]
> > when we have multiple ports are the device IDs on the ports intended
> > to be unique only to a port or unique across all ports?
> >
> I consider each RIO
On 2/5/08, David Gibson <[EMAIL PROTECTED]> wrote:
> On Fri, Feb 01, 2008 at 09:23:47AM -0700, Grant Likely wrote:
> > cell-index has been useful for things like clock controllers to know
> > what offset into a shared clock control register or something like
> > that and a driver would pass the cel
On Wed, Jan 30, 2008 at 06:30:53PM +0800, Zhang Wei wrote:
> The RapidIO system size will auto probe in RIO setup. The route
> table and rionet_active in rionet.c are changed to be allocated
> dynamically according the system size.
> + port->sys_size = (in_be32((priv->regs_win + RIO_PEF_CAR)
In message: Re: [PATCH 2/10] sbc8560: Add v1 device tree source for Wind River
SBC8560 board
on 01/02/2008 David Gibson wrote:
> On Thu, Jan 24, 2008 at 06:41:24PM -0500, Paul Gortmaker wrote:
> > This adds a v1 device tree source for the Wind River SBC8560 board. The
> > biggest difference betw
The ICAP device in Xilinx FPGAs differs slightly between different
FPGAs. The driver needs an additional attribute in the device tree to
distinguish this.
Signed-off-by: Stephen Neuendorffer <[EMAIL PROTECTED]>
---
Documentation/powerpc/booting-without-of.txt | 14 ++
1 files chang
Stephen Rothwell wrote:
> WARNING: vmlinux.o(.text+0x25dca0): Section mismatch in reference from the
> function .veth_probe() to the function .init.text:.veth_probe_one()
>
> Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]>
> ---
> drivers/net/iseries_veth.c |2 +-
> 1 files changed, 1 in
Since we have mfdcri() and mtdcri() as macros, we can't use constructions, such
as "mtdcri(base, reg, mfdcri(base, reg) | val)". In this case the mfdcri() stuff
is not evaluated first. It's evaluated inside the mtdcri() macro and we have
the dcr_ind_lock spinlock acquired twice. To avoid this error
On Tue, Feb 05, 2008 at 06:44:32PM +0300, Anton Vorontsov wrote:
> This patch adds support for the framebuffers with non-native
> endianness. This is done via FBINFO_FOREIGN_ENDIAN flag that will
> be used by the drivers. Depending on the host endianness this flag
> will be overwritten by FBINFO_BE
> Applied that patch and UP kernel built ok, and then crashed in the
> same place with the memset() to a user-looking address from kmem_cache_alloc()
>
> So the percpu changes are innocent ... something else since 2.6.24 is
> to blame. Only 5749 commits :-) I'll start bisecting.
The bisection na
Currently, update_mmu_cache will crash if given a no-access PTE. There's no
need to synchronize dcache/icache unless it's an exec mapping -- however,
due to the existence of older glibc versions that execute out of a
read-but-no-exec page, readability is tested instead.
This assumes no exec-only
On Tue, 2008-02-05 at 10:23 +, Mel Gorman wrote:
> On (05/02/08 11:01), Benjamin Herrenschmidt didst pronounce:
> >
> > >
> > > It's a virtual address so it depends on the value of CONFIG_KERNEL_START
> > > as to whether this is a user program address or not.
> >
> > Shouldn't it be PAGE_OF
On Tue, 2008-02-05 at 21:36 +0300, Valentine Barshak wrote:
> Since we have mfdcri() and mtdcri() as macros, we can't use constructions,
> such
> as "mtdcri(base, reg, mfdcri(base, reg) | val)". In this case the mfdcri()
> stuff
> is not evaluated first. It's evaluated inside the mtdcri() macro
On Tue, 2008-02-05 at 13:43 -0600, Scott Wood wrote:
> Currently, update_mmu_cache will crash if given a no-access PTE. There's no
> need to synchronize dcache/icache unless it's an exec mapping -- however,
> due to the existence of older glibc versions that execute out of a
> read-but-no-exec pa
On Thu, 31 Jan 2008 10:14:58 +1100
Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote:
>
> On Wed, 2008-01-30 at 07:16 +0100, Stefan Roese wrote:
> > On Wednesday 16 January 2008, Josh Boyer wrote:
> > > On Wed, 16 Jan 2008 20:53:59 +1100
> > >
> > > Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote
> Jeff, any chance this can get into .25 soon? I have another patch
> queued up behind this one that requires it, and I don't see it in any
> of your trees or branches.
>
> Or, if you aren't opposed, I can take it through Paul's tree with your
> Ack.
In case my "it's fine" wasn't enough, here's
On Tue, 2008-02-05 at 09:50 -0500, Paul Gortmaker wrote:
> In message: [PATCH] Fix legacy serial search for opb bus ports
> on 05/02/2008 Michael Ellerman wrote:
>
> > The patch to legacy_serial.c (1a7507c7da2df6856e085e0fbb0c9ea8c12ac4e,
> > Reduce code duplication in legacy_serial, add UART pare
On Tue, 2008-02-05 at 23:01 +1100, Michael Ellerman wrote:
> The patch to legacy_serial.c (1a7507c7da2df6856e085e0fbb0c9ea8c12ac4e,
> Reduce code duplication in legacy_serial, add UART parent types) changed
> the semantics for opb ports from type = "opb" || compatible = "ibm,opb"
> to type = "opb"
On Tue, Feb 05, 2008 at 09:44:23AM -0600, Kumar Gala wrote:
>
> On Feb 4, 2008, at 8:40 PM, David Gibson wrote:
>
> > On Fri, Feb 01, 2008 at 08:46:32AM -0600, Kumar Gala wrote:
> >>
> >> On Feb 1, 2008, at 1:54 AM, David Gibson wrote:
> >>
> >>> On Thu, Jan 24, 2008 at 06:41:24PM -0500, Paul Gor
On Jan 31, 2008, at 12:56 PM, Kim Phillips wrote:
> according to the 8349EA ref man, pci2 IRQ is 67. Thanks to Peter
> Van Ackeren for finding this.
>
> Signed-off-by: Kim Phillips <[EMAIL PROTECTED]>
> ---
> arch/powerpc/boot/dts/mpc834x_mds.dts |2 +-
> 1 files changed, 1 insertions(+), 1 d
On Jan 31, 2008, at 11:36 AM, Scott Wood wrote:
> asm/commproc.h was renamed to asm/cpm1.h
> sysdev/commproc.h was renamed to platforms/8xx/mpc8xx.h
> m8xx_pic_init was renamed to mpc8xx_pics_init
>
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> arch/powerpc/platforms/8xx/adder875.c |
On Jan 31, 2008, at 7:40 PM, Kim Phillips wrote:
> the 8313 rdb has a ds1339 at address 0x68.
>
> Signed-off-by: Kim Phillips <[EMAIL PROTECTED]>
> ---
> arch/powerpc/boot/dts/mpc8313erdb.dts |4
> 1 files changed, 4 insertions(+), 0 deletions(-)
applied.
- k
__
On Feb 3, 2008, at 5:21 PM, Bryan O'Donoghue wrote:
> Previous patch submission contained tabs munged into whitespace.
>
> This patch adds the clock-frequency parameter in decimal instead of
> hex.
>
> Signed-off-by: Bryan O'Donoghue <[EMAIL PROTECTED]>
> ---
applied.
- k
___
On Feb 2, 2008, at 1:02 PM, Jon Loeliger wrote:
>
> Cleaned up IRQ layout and removed unsused ISU allocations.
> Fixed RTC address typo from /dts-v1/ conversion.
> Incorporated list suggestions to use an "iomega," vendor prefix,
> and to use a node reference rather than a hard path.
>
> Signed-of
On Feb 4, 2008, at 6:27 PM, Andy Fleming wrote:
> Some of the more recent e300 cores have the same performance monitor
> implementation as the e500. e300 isn't book-e, so the name isn't
> really appropriate. In preparation for e300 support, rename a bunch
> of fsl_booke things to say fsl_emb (F
On Feb 1, 2008, at 6:09 PM, Kim Phillips wrote:
> arch/powerpc/platforms/83xx/mpc832x_rdb.c: In function
> ‘mpc832x_rdb_setup_arch’:
> arch/powerpc/platforms/83xx/mpc832x_rdb.c:104: warning: ‘np’ is used
> uninitialized in this function
>
> Signed-off-by: Kim Phillips <[EMAIL PROTECTED]>
> --
On Feb 4, 2008, at 6:28 PM, Andy Fleming wrote:
> The e300 c3 and c4 variants support hardware performance monitor
> counters which
> are identical to those found in the e500.
>
> Signed-off-by: Andy Fleming <[EMAIL PROTECTED]>
> ---
> arch/powerpc/kernel/cputable.c |6 ++
> arch/powerpc
On Feb 1, 2008, at 6:09 PM, Kim Phillips wrote:
> calling platform_device_register after platform_device_alloc causes
> this:
>
> kobject (c3841a70): tried to init an initialized object, something
> is seriously wrong.
> Call Trace:
> [c381fe20] [c0007bb8] show_stack+0x3c/0x194 (unreliable)
> [
Please pull from 'for-2.6.25' branch of
master.kernel.org:/pub/scm/linux/kernel/git/galak/powerpc.git for-2.6.25
to receive the following updates:
(based on a recent pull of linus's tree)
arch/powerpc/boot/dts/adder875-redboot.dts |1
arch/powerpc/boot/dts/adder875-uboot.dts
Please pull from 'for-2.6.25' branch of
master.kernel.org:/pub/scm/linux/kernel/git/galak/powerpc.git for-2.6.25
to receive the following updates:
(Found a few patches I missed.)
arch/powerpc/boot/dts/adder875-redboot.dts |1
arch/powerpc/boot/dts/adder875-uboot.dts|
>
> From: Anton Vorontsov <[EMAIL PROTECTED]>
> Subject: [POWERPC] qe_lib: fix few fluffy negligences
>
> One is intoduced by me (of_node_put() absence) and another was
> present already (not checking for NULL).
>
> Found by Stephen Rothwell.
>
> Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
>
50 matches
Mail list logo