Re: [PATCH/RFC] powerpc: DBox2 Board Support

2007-12-23 Thread Stephen Rothwell
On Sat, 22 Dec 2007 20:13:31 +0100 Jochen Friedrich <[EMAIL PROTECTED]> wrote: > > +++ b/arch/powerpc/platforms/8xx/dbox2.h > + > +#include Nothing in this header files uses anything in that one, so don't include it. > +++ b/arch/powerpc/platforms/8xx/dbox2_setup.c > + > +char *dbox2_manuf_name[

Re: [patch v3] PS3: Fix printing of os-area magic numbers

2007-12-23 Thread Geert Uytterhoeven
On Sat, 22 Dec 2007, Geoff Levand wrote: > +static void dump_field(char *s, const u8 *f, unsigned int size) > +{ > +#if defined(DEBUG) > + unsigned int i; > + > + for (i = 0; i < size; i++) > + s[i] = isprint(f[i]) ? f[i] : '.'; > + s[i] = 0; > +#endif > +} Sorry for nitpic

Re: [PATCH 0/4] PowerPC: implement GPIO API

2007-12-23 Thread Segher Boessenkool
>>> OF device tree GPIOs bindings are similar to IRQs: >> >> But GPIOs are a very different thing. Most importantly, the "number" >> of a GPIO is completely local to the GPIO controller. > > Yes... just as interrupt specifiers are local to their interrupt > domain. Sure, but an interrupt domain c

Re: [PATCH 1/4] [POWERPC] Implement GPIO API embryo

2007-12-23 Thread Segher Boessenkool
> I think part of what's happening here is due to the patch's history. That doesn't make it right though ;-) > Obviously a > driver for a particular gpio controller would generally need to assert > that the controller's #gpio-cells has the correct value for this > controller type, after which cod

Re: [PATCH 0/4] PowerPC: implement GPIO API

2007-12-23 Thread Anton Vorontsov
On Sun, Dec 23, 2007 at 10:53:05AM +0100, Segher Boessenkool wrote: [...] > >>> [EMAIL PROTECTED] { > >>> gpios = ; > >>> gpio-parent = <&pario0>; > >> > >> Not every GPIO controller has banks. > > > > That's just bad terminology in the example. "bank pin" means an > > arbitrary format gpio sp

Re: [PATCH 1/3] [POWERPC] FSL UPM: routines to manage FSL UPMs

2007-12-23 Thread Anton Vorontsov
On Sun, Dec 23, 2007 at 01:24:57PM +1100, Stephen Rothwell wrote: > On Fri, 21 Dec 2007 23:39:25 +0300 Anton Vorontsov <[EMAIL PROTECTED]> wrote: > > > > +int fsl_upm_get_for(struct device_node *node, const char *name, > > + struct fsl_upm *upm) > > +{ > > + int ret; > > + struct

Re: [PATCH 2/3] [POWERPC][NAND] FSL UPM NAND driver

2007-12-23 Thread Anton Vorontsov
On Sun, Dec 23, 2007 at 01:33:29PM +1100, Stephen Rothwell wrote: > On Fri, 21 Dec 2007 23:41:30 +0300 Anton Vorontsov <[EMAIL PROTECTED]> wrote: > > > > +static int __devinit upm_chip_probe(struct of_device *ofdev, > > + const struct of_device_id *ofid) > > +{ > > +

Re: [PATCH 1/3] [POWERPC] FSL UPM: routines to manage FSL UPMs

2007-12-23 Thread Anton Vorontsov
On Sun, Dec 23, 2007 at 02:59:35PM +0300, Anton Vorontsov wrote: [..] > > > +static inline void fsl_upm_start_pattern(struct fsl_upm *upm, u32 > > > pat_offset) > > > +{ > > > + spin_lock_irqsave(&upm_lock, upm_lock_flags); > > > > I may be wrong, but don't we need the "flags" argument to > > spi

Re: [Cbe-oss-dev] Time for cell code reshuffle?

2007-12-23 Thread Christoph Hellwig
On Sun, Dec 23, 2007 at 12:47:42PM +0900, Jeremy Kerr wrote: > Hi all, > > > To the question, where what it should go, I'd leave the decision to > > Jeremy, but my current idea would be: > > > > arch/powerpc/platforms/cell/spufs -> arch/powerpc/spufs > > I'd suggest arch/powerpc/sysdev/spufs to k

Re: [PATCH 1/3] [POWERPC] FSL UPM: routines to manage FSL UPMs

2007-12-23 Thread Anton Vorontsov
On Sun, Dec 23, 2007 at 03:17:35PM +0300, Anton Vorontsov wrote: > On Sun, Dec 23, 2007 at 02:59:35PM +0300, Anton Vorontsov wrote: > [..] > > > > +static inline void fsl_upm_start_pattern(struct fsl_upm *upm, u32 > > > > pat_offset) > > > > +{ > > > > + spin_lock_irqsave(&upm_lock, upm_lock

Re: [Cbe-oss-dev] Time for cell code reshuffle?

2007-12-23 Thread Geert Uytterhoeven
On Sun, 23 Dec 2007, Christoph Hellwig wrote: > On Sun, Dec 23, 2007 at 12:47:42PM +0900, Jeremy Kerr wrote: > > > To the question, where what it should go, I'd leave the decision to > > > Jeremy, but my current idea would be: > > > > > > arch/powerpc/platforms/cell/spufs -> arch/powerpc/spufs > >

Re: [PATCH] Add information on enabling sound on the MPC8641 HPCN

2007-12-23 Thread Olof Johansson
On Sat, Dec 22, 2007 at 09:35:44PM -0600, Timur Tabi wrote: > Add a comment to the DTS file for the MPC8641 HPCN describing a wiring change > needed to get sound working on this board. > > Signed-off-by: Timur Tabi <[EMAIL PROTECTED]> > --- > > For a two-line comment, I thought the DTS would be t

[PATCH] powerpc: DBox2 Board Support

2007-12-23 Thread Jochen Friedrich
This patch adds device tree source, default config and setup code for DBox2 devices. Signed-off-by: Jochen Friedrich <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/dbox2.dts | 263 arch/powerpc/configs/dbox2_defconfig | 1042 ++ arch/powerpc/platf

Re: [PATCH] powerpc: DBox2 Board Support

2007-12-23 Thread Jochen Friedrich
Jochen Friedrich schrieb: > This patch adds device tree source, default config and setup code for > DBox2 devices. please ignore this posting. This patch doesn't compile cleanly, i'll repost a fixed patch. Thanks, Jochen ___ Linuxppc-dev mailing list

[PATCHv2] powerpc: DBox2 Board Support

2007-12-23 Thread Jochen Friedrich
This patch adds device tree source, default config and setup code for DBox2 devices. Signed-off-by: Jochen Friedrich <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/dbox2.dts | 263 arch/powerpc/configs/dbox2_defconfig | 1042 ++ arch/powerpc/platf

Re: [patch v3] PS3: Fix printing of os-area magic numbers

2007-12-23 Thread Geoff Levand
On 12/23/2007 01:51 AM, Geert Uytterhoeven wrote: > On Sat, 22 Dec 2007, Geoff Levand wrote: >> +static void dump_field(char *s, const u8 *f, unsigned int size) >> +{ >> +#if defined(DEBUG) >> +unsigned int i; >> + >> +for (i = 0; i < size; i++) >> +s[i] = isprint(f[i]) ? f[i] :

[patch v4] PS3: Fix printing of os-area magic numbers

2007-12-23 Thread Geoff Levand
Subject: ps3: Fix printing of os-area magic numbers Fix a bug in the printing of the os-area magic numbers which assumed that magic numbers were zero terminated strings. The magic numbers are represented in memory as integers. If the os-area sections are not initialized correctly they could cont

[PATCH/RFC] powerpc: Move definition of buffer descriptor to cpm.h

2007-12-23 Thread Jochen Friedrich
Buffer descriptors are used by both CPM1 and CPM2. Move the definitions from the cpm dependent include file to common cpm.h Signed-off-by: Jochen Friedrich <[EMAIL PROTECTED]> --- include/asm-powerpc/commproc.h | 65 --- include/asm-powerpc/cpm.h | 73

[PATCH] i2c: adds support for i2c bus on Frescale CPM1/CPM2 controllers

2007-12-23 Thread Jochen Friedrich
Using the port of 2.4 code from Vitaly Bordug <[EMAIL PROTECTED]> and the actual algorithm used by the i2c driver of the DBox code on cvs.tuxboc.org from Tmbinc, Gillem ([EMAIL PROTECTED]). Renamed i2c-rpx.c and i2c-algo-8xx.c to i2c-cpm.c and converted the driver to an of_platform_driver. Signed-

[PATCH] Do not fail build if mkimage is not available

2007-12-23 Thread Michael Buesch
This fixes the boot image wrapper script to not fail the kernel build if mkimage is not available. As some distributions don't ship the mkimage program and I am not interested in uboot images anyway, I don't want to fail the whole kernel build process because of this unneeded dependency. Simply dr

Re: [PATCH] Do not fail build if mkimage is not available

2007-12-23 Thread Josh Boyer
On Sun, 23 Dec 2007 20:31:08 +0100 Michael Buesch <[EMAIL PROTECTED]> wrote: > This fixes the boot image wrapper script to not fail the kernel > build if mkimage is not available. > As some distributions don't ship the mkimage program and I am not > interested in uboot images anyway, I don't want

Re: [PATCH] Do not fail build if mkimage is not available

2007-12-23 Thread Michael Buesch
On Sunday 23 December 2007 21:05:16 Josh Boyer wrote: > On Sun, 23 Dec 2007 20:31:08 +0100 > Michael Buesch <[EMAIL PROTECTED]> wrote: > > > This fixes the boot image wrapper script to not fail the kernel > > build if mkimage is not available. > > As some distributions don't ship the mkimage progr

Re: [Cbe-oss-dev] Time for cell code reshuffle?

2007-12-23 Thread Luca Barbato
Geert Uytterhoeven wrote: > On Sun, 23 Dec 2007, Christoph Hellwig wrote: >> Strong NACK for fs/spufs/ fs code is the smallest part of the spu >> support, and all this nasty lowlevel code doesn't belong into fs/ at >> all. > > drivers/spu/? > arch/spu/? -- Luca Barbato Gentoo Council Member

Build breakage on powerpc with 2.6.24-rc6-mm1

2007-12-23 Thread Balbir Singh
Hi, I see the following error with the iseries_veth driver in 2.6.24-rc6-mm1 drivers/net/iseries_veth.c: In function ‘veth_init_connection’: drivers/net/iseries_veth.c:818: warning: unused variable ‘rc’ drivers/net/iseries_veth.c: In function ‘veth_probe_one’: drivers/net/iseries_veth.c:1086: err

Re: Yet more patches added to for-2.6.25/master branches

2007-12-23 Thread Paul Mackerras
David Woodhouse writes: > http://patchwork.ozlabs.org/linuxppc/patch?id=15192 ? Not my bailiwick. Send it to the RTC subsystem maintainer or Andrew Morton. You can put Acked-by me on it if you like. Paul. ___ Linuxppc-dev mailing list Linuxppc-dev@oz

Re: [PATCH/RFC] powerpc: DBox2 Board Support

2007-12-23 Thread David Gibson
On Sat, Dec 22, 2007 at 08:13:31PM +0100, Jochen Friedrich wrote: > This patch adds device tree source, default config and setup code for > DBox2 devices. [snip] > diff --git a/arch/powerpc/boot/dts/dbox2.dts b/arch/powerpc/boot/dts/dbox2.dts > new file mode 100644 > index 000..8d91510 > --- /

Re: [RESEND DTC PATCH 2/2] Add support for binary includes.

2007-12-23 Thread David Gibson
On Sat, Dec 22, 2007 at 07:57:17AM -0600, Scott Wood wrote: > On Sat, Dec 22, 2007 at 01:51:30PM +1100, David Gibson wrote: > > On Fri, Dec 21, 2007 at 11:09:21AM -0600, Scott Wood wrote: > > > OK. I was being lazy. :-P > > > > In general I'd approve, but having to invoke dtc in the right place >

Re: [PATCH 1/21] [POWERPC] Reworking machine check handling and Fix 440/440A

2007-12-23 Thread Josh Boyer
On Fri, 21 Dec 2007 15:39:21 +1100 Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote: > Index: linux-merge/arch/powerpc/kernel/traps.c > === > --- linux-merge.orig/arch/powerpc/kernel/traps.c 2007-12-20 > 11:34:43.0 +1100

Re: Build breakage on powerpc with 2.6.24-rc6-mm1

2007-12-23 Thread Stephen Rothwell
Hi Balbir, Thanks for the report. On Mon, 24 Dec 2007 04:11:58 +0530 Balbir Singh <[EMAIL PROTECTED]> wrote: > > I see the following error with the iseries_veth driver in 2.6.24-rc6-mm1 > > drivers/net/iseries_veth.c: In function ‘veth_init_connection’: > drivers/net/iseries_veth.c:818: warning:

Re: drivers/net/iseries_veth.c dubious sysfs usage

2007-12-23 Thread Stephen Rothwell
Hi Greg, On Wed, 12 Dec 2007 23:08:29 -0800 Greg KH <[EMAIL PROTECTED]> wrote: > > Hm, ok, it's odd as you are the only driver in the whole tree doing > something like this, but it seems semi-resonable, so I can't complain :) > > I'll fix the core up to allow you to do this, thanks for the > expl

SCSI errors on powerpc with 2.6.24-rc6-mm1

2007-12-23 Thread Balbir Singh
Hi, I've just seen this on my dmesg, this is new, never seen this before on this box and it happens only with this version of the kernel. In this configuration, the page size is set to 64K and I've enabled fake NUMA nodes on PowerPC. tce_buildmulti_pSeriesLP: plpar_tce_put failed. rc=-4

Re: Build breakage on powerpc with 2.6.24-rc6-mm1

2007-12-23 Thread Greg KH
On Mon, Dec 24, 2007 at 01:43:53PM +1100, Stephen Rothwell wrote: > Hi Balbir, > > Thanks for the report. > > On Mon, 24 Dec 2007 04:11:58 +0530 Balbir Singh <[EMAIL PROTECTED]> wrote: > > > > I see the following error with the iseries_veth driver in 2.6.24-rc6-mm1 > > > > drivers/net/iseries_ve

Re: drivers/net/iseries_veth.c dubious sysfs usage

2007-12-23 Thread Greg KH
On Mon, Dec 24, 2007 at 01:52:08PM +1100, Stephen Rothwell wrote: > Hi Greg, > > On Wed, 12 Dec 2007 23:08:29 -0800 Greg KH <[EMAIL PROTECTED]> wrote: > > > > Hm, ok, it's odd as you are the only driver in the whole tree doing > > something like this, but it seems semi-resonable, so I can't compla