deletion(-)
>
> diff --git a/MAINTAINERS b/MAINTAINERS
> index ebf7fa9a814d..76b6db4074ce 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -19633,7 +19633,7 @@ F: include/linux/qnx6_fs.h
>
> QORIQ DPAA2 FSL-MC BUS DRIVER
> M: Stuart Yoder
> -M: Laurentiu
> +++ b/Documentation/devicetree/bindings/soc/fsl/rcpm.txt
> @@ -0,0 +1,63 @@
> +* Run Control and Power Management
> +---
> +The RCPM performs all device-level tasks associated with device run control
> +and power management.
> +
> +Required properites:
> +
From: Stuart Yoder
some restructuring of epapr paravirt init resulted in
ppc_md.power_save being set, and then overwritten to
NULL during machine_init. This patch splits the
initialization of ppc_md.power_save out into a postcore
init call.
Signed-off-by: Stuart Yoder
---
-v3
-changed
From: Stuart Yoder
some restructuring of epapr paravirt init resulted in
ppc_md.power_save being set, and then overwritten to
NULL during machine_init. This patch splits the
initialization of ppc_md.power_save out into a postcore
init call.
Signed-off-by: Stuart Yoder
---
-v3
-changed
save
> to an initcall
>
> On Wed, 2014-04-30 at 15:20 -0500, Stuart Yoder wrote:
> > From: Stuart Yoder
> >
> > some restructuring of epapr paravirt init resulted in
> > ppc_md.power_save being set, and then overwritten to
> > NULL during machine_init. This
From: Stuart Yoder
some restructuring of epapr paravirt init resulted in
ppc_md.power_save being set, and then overwritten to
NULL during machine_init. This patch splits the
initialization of ppc_md.power_save out into a postcore
init call.
Signed-off-by: Stuart Yoder
---
-v2: don't it
From: Stuart Yoder
some restructuring of epapr paravirt init resulted in
ppc_md.power_save being set, and then overwritten to
NULL during machine_init. This patch splits the
initialization of ppc_md.power_save out into a postcore
init call.
Signed-off-by: Stuart Yoder
---
arch/powerpc/kernel
init of power_save to
> an initcall
>
>
> On 30.04.14 21:54, Stuart Yoder wrote:
> > From: Stuart Yoder
> >
> > some restructuring of epapr paravirt init resulted in
> > ppc_md.power_save being set, and then overwritten to
> > NULL during machine_init. T
So the patch should look something like this (on a 3.8 kernel):
diff --git a/arch/powerpc/kernel/head_booke.h b/arch/powerpc/kernel/head_booke.h
index 5f051ee..92b675a 100644
--- a/arch/powerpc/kernel/head_booke.h
+++ b/arch/powerpc/kernel/head_booke.h
@@ -286,13 +286,13 @@ label:
andis.
On Thu, Apr 11, 2013 at 1:33 PM, Kumar Gala wrote:
>
> On Apr 5, 2013, at 2:53 AM, Bhushan Bharat-R65777 wrote:
>
>> Hi Kumar/Benh,
>>
>> After further looking into the code I think that if we correct the vector
>> range below in DebugDebug handler then we do not need the change I provided
>> in
From: Stuart Yoder
For 32-bit, CONFIG_EPAPR_PARAVIRT pulls in both epapr_paravirt.c
and epapr_hcalls.c which contains the 32-bit paravirt idle loop.
For 64-bit, the paravirt idle loop is in idle_book3e.S and that
source file is included only if CONFIG_PPC_BOOK3E_64 defined.
This patch makes
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-v2
-deo is EREF specific, changed name of property
arch/powerpc/boot/dts/fsl/e500mc_power_isa.dtsi |1 +
arch/powerpc/boot/dts/fsl/e5500_power_isa.dtsi |1 +
2 files changed, 2 insertions(+)
diff --git a/arch/powerpc/boot/dts
From: Stuart Yoder
-also define a binding for fsl,eref-* properties
Signed-off-by: Stuart Yoder
---
-v3
-converted EREF specific properties to fsl,eref-*
.../devicetree/bindings/powerpc/fsl/cpus.txt | 21 +++
arch/powerpc/boot/dts/fsl/e6500_power_isa.dtsi | 65
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
arch/powerpc/boot/dts/fsl/e500mc_power_isa.dtsi |1 +
arch/powerpc/boot/dts/fsl/e5500_power_isa.dtsi |1 +
2 files changed, 2 insertions(+)
diff --git a/arch/powerpc/boot/dts/fsl/e500mc_power_isa.dtsi
b/arch/powerpc/boot/dts/fsl
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-v2
-fix some typos
arch/powerpc/boot/dts/fsl/e6500_power_isa.dtsi | 65
1 file changed, 65 insertions(+)
create mode 100644 arch/powerpc/boot/dts/fsl/e6500_power_isa.dtsi
diff --git a/arch/powerpc/boot/dts/fsl
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
arch/powerpc/boot/dts/fsl/e6500_power_isa.dtsi | 66
1 file changed, 66 insertions(+)
create mode 100644 arch/powerpc/boot/dts/fsl/e6500_power_isa.dtsi
diff --git a/arch/powerpc/boot/dts/fsl/e6500_power_isa.dtsi
b
On Mon, Mar 4, 2013 at 2:40 AM, Jia Hongtao wrote:
> A PCIe erratum of mpc85xx may causes a core hang when a link of PCIe
> goes down. when the link goes down, Non-posted transactions issued
> via the ATMU requiring completion result in an instruction stall.
> At the same time a machine-check exce
On Mon, Feb 18, 2013 at 6:52 AM, Varun Sethi wrote:
[cut]
> +static phys_addr_t get_phys_addr(struct fsl_dma_domain *dma_domain, unsigned
> long iova)
> +{
> + u32 win_cnt = dma_domain->win_cnt;
> + struct dma_window *win_ptr =
> + &dma_domain->win_arr[0]
Some more comments...
On Mon, Feb 18, 2013 at 6:52 AM, Varun Sethi wrote:
> +/* Handling access violations */
> +#define make64(high, low) (((u64)(high) << 32) | (low))
> +
> +struct pamu_isr_data {
> + void __iomem *pamu_reg_base;/* Base address of PAMU regs*/
> + unsigned int co
Have not got through the entire file, but have a few comments...
+/*
+ * Set the PAACE type as primary and set the coherency required domain
+ * attribute
+ */
+static void pamu_setup_default_xfer_to_host_ppaace(struct paace *ppaace)
+{
+ set_bf(ppaace->addr_bitfields, PAACE_AF_PT, PAACE_PT_
This patch was submitted separately to linuxppc-dev (and was already
applied). You don't need it in this patch set, right?
Stuart
On Mon, Feb 18, 2013 at 6:52 AM, Varun Sethi wrote:
> The pci controller structure has a provision to store the device strcuture
> pointer of the corresponding platf
On Tue, Feb 19, 2013 at 1:47 PM, Scott Wood wrote:
>
> This patch addresses boot-time invalidations only. How will you handle
> hugetlb invalidations (or indirect entry invalidations, once that becomes
> supported)?
We do envision that "direct guest TLB management" is an opt-in option
that a gue
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-removed KVM prefix to patch subject, patch is not KVM specific
arch/powerpc/kernel/epapr_hcalls.S |2 ++
arch/powerpc/kernel/idle_book3e.S | 32 ++--
2 files changed, 32 insertions(+), 2 deletions(-)
diff
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-v3
-whitespace cleanup, deleted stray comma, added comment
arch/powerpc/kernel/epapr_hcalls.S |2 ++
arch/powerpc/kernel/idle_book3e.S | 32 ++--
2 files changed, 32 insertions(+), 2 deletions(-)
diff
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-v2
-macro'ized loop in idle_book3e.S to avoid code
duplication, paravirt loop is now in idle_book3e.S
arch/powerpc/kernel/epapr_hcalls.S |2 ++
arch/powerpc/kernel/idle_book3e.S | 30 --
2
From: Stuart Yoder
loop was derived from book3e_idle()
Signed-off-by: Stuart Yoder
---
arch/powerpc/kernel/epapr_hcalls.S | 63
1 file changed, 63 insertions(+)
diff --git a/arch/powerpc/kernel/epapr_hcalls.S
b/arch/powerpc/kernel/epapr_hcalls.S
index
From: Stuart Yoder
without setting the stack limit like this there is the possibility
of stack overflow which corrupts the thread info but
is not detected by stack overflow detection
Signed-off-by: Stuart Yoder
---
arch/powerpc/kernel/entry_32.S | 12 ++--
1 files changed, 10
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-v4: fixed build issues in exception-64s.h and exceptions-64s.S
arch/powerpc/include/asm/exception-64s.h |4 ++--
arch/powerpc/include/asm/thread_info.h |6 ++
arch/powerpc/kernel/entry_32.S | 24
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-v3
-moved CURRENT_THREAD_INFO out from under the assembly only
#define as per comments on mailing list
-reversed logic of 64-bit #ifdef for CURRENT_THREAD_INFO
macro
-this patch is a pre-requisite for the idle hcall which I
am
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-this patch is a pre-requisite for the idle hcall which I
am trying to get into Alex's KVM tree, so ideally would like
Ben's ack and get this applied to Alex's tree
-built/tested with a 32-bit booke kernel, built a 64-bit
bo
From: Stuart Yoder
Signed-off-by: Stuart Yoder
---
-this patch is a pre-requisite for the idle hcall which I
am trying to get into Alex's KVM tree, so ideally would like
Ben's ack and get this applied to Alex's tree
-built/tested with a 32-bit booke kernel, built a 64-bit
book
On Tue, Mar 27, 2012 at 8:30 AM, Kumar Gala wrote:
>
> On Mar 27, 2012, at 7:15 AM, Varun Sethi wrote:
>
>> FSL MPIC supports 16 bit vectors so our vector number space isn't
>> restricted to 256 vectors. We should use the MPIC_LARG_VECTORS flag
>> while intializing the MPIC. This also prevents us
On Thu, Jan 19, 2012 at 1:21 PM, Stuart Yoder wrote:
> On Wed, Jan 18, 2012 at 3:10 PM, Benjamin Herrenschmidt
> wrote:
>> On Wed, 2012-01-18 at 16:35 +0200, Laurentiu Tudor wrote:
>>> This patch adds a menuconfig option that allows controlling
>>> the la
On Wed, Jan 18, 2012 at 3:10 PM, Benjamin Herrenschmidt
wrote:
> On Wed, 2012-01-18 at 16:35 +0200, Laurentiu Tudor wrote:
>> This patch adds a menuconfig option that allows controlling
>> the lazy interrupt disabling feature implemented by this
>> commit:
>>
>> commit d04c56f73c30a5e593202ecfcf25
From: Stuart Yoder
-changed name from 'no-reset' to 'pic-not-reset' be consisent with
Meador Inge's open pic binding patch
-update definition
Signed-off-by: Stuart Yoder
---
Documentation/powerpc/dts-bindings/fsl/mpic.txt |7 +--
1 files changed, 5 insertions
From: Stuart Yoder
define the binding for compatible = "fsl,mpic", including
the definition of 4-cell interrupt specifiers. The
3rd and 4th cells are needed to define additional
types of interrupt source outside the "normal"
external and internal interrupts in FSL SoCs. De
From: Stuart Yoder
define the binding for compatible = "fsl,mpic", including
the definition of 4-cell interrupt specifiers. The
3rd and 4th cells are needed to define additional
types of interrupt source outside the "normal"
external and internal interrupts in FSL SoCs. De
From: Stuart Yoder
With the previous string comparison, a device tree
compatible of "foo-bar" would match as compatible
with a driver looking for "foo".
Signed-off-by: Stuart Yoder
---
drivers/of/fdt.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --gi
From: Stuart Yoder
With the previous string comparison, a device tree
compatible of "foo-bar" would match as compatible
with a driver looking for "foo".
Signed-off-by: Stuart Yoder
---
drivers/of/fdt.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --gi
> How about right here: http://fdt.secretlab.ca/
>
> I've only just created the site. I'll fill in some documentation and
> structure in the next few days. Feel free to create an account and
> start adding stuff.
>
> We'll need to talk about how best to manage bindings and have some
> form of re
> Lets *not* do it on power.org. I'd like to see the bindings used by
> more than just powerpc people, and power.org might become a bit of a
> mental barrier for non-powerpc folks. kernel.org would be a good
> host. So would ozlabs or infradead. Or I'd be happy to maintain one
> on secretlab.
On Thu, Aug 27, 2009 at 9:43 PM, Benjamin
Herrenschmidt wrote:
> On Thu, 2009-08-27 at 16:36 -1000, Mitch Bradley wrote:
>> The idea of a wiki as a registration authority is a good one, but I'm
>> not volunteering to maintain it :-)
>
> here goes my hope :-)
>
> Do we have wiki's we could use on po
document level/sense encoding info for IPIC
interrupt controllers
Signed-off-by: Stuart Yoder <[EMAIL PROTECTED]>
---
Documentation/powerpc/booting-without-of.txt | 19 ++-
1 files changed, 18 insertions(+), 1 deletions(-)
diff --git a/Documentation/powerpc/booting-w
document level and sense information for the Freescale
IPIC interrupt controller
Signed-off-by: Stuart Yoder <[EMAIL PROTECTED]>
---
Documentation/powerpc/booting-without-of.txt | 18 +-
1 files changed, 17 insertions(+), 1 deletions(-)
diff --git a/Documentation/p
document level and sense information for the Freescale
IPIC interrupt controller
Signed-off-by: Stuart Yoder <[EMAIL PROTECTED]>
---
Documentation/powerpc/booting-without-of.txt | 20 +++-
1 files changed, 19 insertions(+), 1 deletions(-)
diff --git a/Documentation/p
45 matches
Mail list logo