Re: (subset) [PATCH 00/35] Reorganize kerneldoc parameter names

2024-12-20 Thread Srinivas Kandagatla
> @@ > > [...] Applied, thanks! [31/35] slimbus: messaging: Reorganize kerneldoc parameter names commit: 52d3d7f7a77ee9afc6a846b415790e13e1434847 Best regards, -- Srinivas Kandagatla

Re: [PATCH v2 05/10] sysfs: treewide: constify attribute callback of bin_is_visible()

2024-11-08 Thread Srinivas Kandagatla
-by: Thomas Weißschuh --- drivers/cxl/port.c | 2 +- drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 2 +- drivers/infiniband/hw/qib/qib_sysfs.c | 2 +- drivers/mtd/spi-nor/sysfs.c | 2 +- thanks for the patch. Acked-by: Srinivas Kandagatla #nvmem --srini

Re: [PATCH v2 04/10] nvmem: core: calculate bin_attribute size through bin_size()

2024-11-08 Thread Srinivas Kandagatla
On 03/11/2024 17:03, Thomas Weißschuh wrote: Stop abusing the is_bin_visible() callback to calculate the attribute size. Instead use the new, dedicated bin_size() one. Signed-off-by: Thomas Weißschuh --- Thanks for the patch, LGTM. Acked-by: Srinivas Kandagatla --srini drivers

Re: [PATCH] ASoC: do not include pm_runtime.h if not used

2023-03-09 Thread Srinivas Kandagatla
On 07/03/2023 10:30, Claudiu Beznea wrote: diff --git a/sound/soc/qcom/lpass-sc7180.c b/sound/soc/qcom/lpass-sc7180.c index 41db6617e2ed..dc892fac4baa 100644 --- a/sound/soc/qcom/lpass-sc7180.c +++ b/sound/soc/qcom/lpass-sc7180.c @@ -12,7 +12,6 @@ #include #include #include -#include

Re: [PATCH v4 0/5] nvmem: nintendo-otp: Add new driver for the Wii and Wii U OTP

2021-08-10 Thread Srinivas Kandagatla
On 01/08/2021 08:38, Emmanuel Gil Peyrot wrote: The OTP is a read-only memory area which contains various keys and signatures used to decrypt, encrypt or verify various pieces of storage. Its size depends on the console, it is 128 bytes on the Wii and 1024 bytes on the Wii U (split into eight

Re: [PATCH v2 19/39] docs: ABI: stable: make files ReST compatible

2020-10-30 Thread Srinivas Kandagatla
n/ABI/stable/firewire-cdev| 4 + Documentation/ABI/stable/sysfs-acpi-pmprofile | 22 +++-- Documentation/ABI/stable/sysfs-bus-firewire | 3 + Documentation/ABI/stable/sysfs-bus-nvmem | 19 ++-- for nvmem parts: Acked-by: Srinivas Kandagatla --srini Documentation/ABI/s

[PATCH v2] PCI: designware: add host_init error handling

2016-12-07 Thread Srinivas Kandagatla
access registers even in error cases. Typical case in qcom controller driver is to turn off clks in case of errors, if designware code continues to read/write register when clocks are turned off the board would reboot/lockup. Signed-off-by: Srinivas Kandagatla --- Currently designware code does

Re: [RFC PATCH] PCI: designware: add host_init() error handling

2016-12-02 Thread Srinivas Kandagatla
On 02/12/16 10:32, Joao Pinto wrote: Hi Srinivas, Às 11:51 AM de 12/1/2016, Srinivas Kandagatla escreveu: drivers/pci/host/pci-dra7xx.c | 4 +++- drivers/pci/host/pci-exynos.c | 4 +++- drivers/pci/host/pci-imx6.c | 4 +++- drivers/pci/host/pci-keystone.c

[RFC PATCH] PCI: designware: add host_init() error handling

2016-12-01 Thread Srinivas Kandagatla
access registers even in error cases. Typical case in qcom controller driver is to turn off clks in case of errors, if designware code continues to read/write register when clocks are turned off the board would reboot/lockup. Signed-off-by: Srinivas Kandagatla --- Currently designware code does

[PATCH 3.6.0- 0/2] POWERPC: use module_platform_driver macro

2012-10-10 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla Running below Coccinelle lookup pattern like below on the latest kernel showed about 52 hits. This patch series is a subset of those 52 patches, so that it will be easy for maintainers to review. Hopefully these patches will get rid of some code duplication in kernel

[PATCH 3.6.0- 1/2] powerpc/mpc52xx: use module_platform_driver macro

2012-10-10 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch removes some code duplication by using module_platform_driver. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/platforms/52xx/mpc52xx_lpbfifo.c | 16 +--- 1 files changed, 1 insertions(+), 15 deletions(-) diff --git a/arch/powerpc

[PATCH 3.6.0- 2/2] powerpc/sysdev: use module_platform_driver macro

2012-10-10 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch removes some code duplication by using module_platform_driver. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/sysdev/pmi.c | 13 + 1 files changed, 1 insertions(+), 12 deletions(-) diff --git a/arch/powerpc/sysdev/pmi.c b/arch/powerpc

[PATCH v4 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child

2012-09-18 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc

[PATCH v4 3/5] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child

2012-09-18 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/sys

[PATCH v4 1/5] dt: introduce of_get_child_by_name to get child node by name

2012-09-18 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child_by_name libary function would avoid code

[PATCH v4 0/5] Introduce of_get_child_by_name

2012-09-18 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want to get a child node it

[RESEND PATCH v3 0/5] Introduce of_get_child_by_name

2012-09-18 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want to get a child node it

[RESEND PATCH v3 0/5] Introduce of_get_child_by_name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want to get a child node it

[RESEND PATCH v3 3/5] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/sys

[RESEND PATCH v3 1/5] dt: introduce of_get_child_by_name to get child node by name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child_by_name libary function would avoid code

[RESEND PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc

[PATCH v3 3/5] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/sys

[PATCH v3 0/5] Introduce of_get_child_by_name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want to get a child node it

[PATCH v3 1/5] dt: introduce of_get_child_by_name to get child node by name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child_by_name libary function would avoid code

[PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc

Re: [PATCH v2 3/7] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
On 17/09/12 03:07, Michael Ellerman wrote: > On Fri, 2012-09-14 at 09:19 +0100, Srinivas KANDAGATLA wrote: >> From: Srinivas Kandagatla >> >> As follow-up to "dt: introduce of_get_child_by_name to get child node by >> name." patch, This patch removes some of

Re: [PATCH v2 2/7] dt/powerpc: Use of_get_child_by_name to get a named child.

2012-09-14 Thread Srinivas KANDAGATLA
My bad... Will skip this patch in next patch-set... On 14/09/12 14:06, Rob Herring wrote: > On 09/14/2012 03:18 AM, Srinivas KANDAGATLA wrote: >> From: Srinivas Kandagatla >> >> As follow-up to "dt: introduce of_get_child_by_name to get child node by >> name.&qu

Re: [PATCH v2 4/7] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.

2012-09-14 Thread Srinivas KANDAGATLA
Thanks for pointing the typo.. On 14/09/12 14:05, Rob Herring wrote: > On 09/14/2012 03:19 AM, Srinivas KANDAGATLA wrote: >> From: Srinivas Kandagatla >> >> As follow-up to "dt: introduce of_get_child_by_name to get child node by >> name." patch, This patch

[PATCH v2 4/7] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.

2012-09-14 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/sys

[PATCH v2 3/7] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-14 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc

[PATCH v2 2/7] dt/powerpc: Use of_get_child_by_name to get a named child.

2012-09-14 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/ker

[PATCH v2 0/7] Introduce of_get_child_by_name.

2012-09-14 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want to get a child node it

[PATCH v2 1/7] dt: introduce of_get_child_by_name to get child node by name.

2012-09-14 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child_by_name libary function would avoid code