[PATCH] powerpc: Don't use --- in kernel logs

2025-02-11 Thread Christophe Leroy
When a kernel log containing --- at the start of a line is copied into a patch message, 'git am' drops everything located after that ---. Replace --- by to avoid that. Signed-off-by: Christophe Leroy --- arch/powerpc/kernel/process.c | 8 arch/powerpc/xmon/xmon.c | 2 +- 2 fi

[PATCH v2] powerpc/code-patching: Fix KASAN hit by not flagging text patching area as VM_ALLOC

2025-02-11 Thread Christophe Leroy
Erhard reported the following KASAN hit while booting his PowerMac G4 with a KASAN-enabled kernel 6.13-rc6: BUG: KASAN: vmalloc-out-of-bounds in copy_to_kernel_nofault+0xd8/0x1c8 Write of size 8 at addr f100 by task chronyd/1293 CPU: 0 UID: 123 PID: 1293 Comm: chronyd Tainted: G

Re: [PATCH 2/9] net: bcmasp: Add missing of_node_get() before of_find_node_by_name()

2025-02-11 Thread zhangzekun (A)
在 2025/2/12 13:52, Krzysztof Kozlowski 写道: On 07/02/2025 02:31, Zhang Zekun wrote: of_find_node_by_name() will decrease the refcount of the device_node. So, get the device_node before passing to it. Fixes: 490cb412007d ("net: bcmasp: Add support for ASP2.0 Ethernet controller") Signed-off-by

Re: [PATCH 2/9] net: bcmasp: Add missing of_node_get() before of_find_node_by_name()

2025-02-11 Thread Krzysztof Kozlowski
On 07/02/2025 02:31, Zhang Zekun wrote: > of_find_node_by_name() will decrease the refcount of the device_node. > So, get the device_node before passing to it. > > Fixes: 490cb412007d ("net: bcmasp: Add support for ASP2.0 Ethernet > controller") > Signed-off-by: Zhang Zekun > --- > drivers/net/

Re: [PATCH v3 3/4] PCI/DPC: Run recovery on device that detected the error

2025-02-11 Thread Shuai Xue
在 2025/2/12 05:23, Sathyanarayanan Kuppuswamy 写道: On 2/7/25 1:34 AM, Shuai Xue wrote: The current implementation of pcie_do_recovery() assumes that the recovery process is executed on the device that detected the error. However, the DPC driver currently passes the error port that experienced

Re: [PATCH 1/9] of: Add warpper function of_find_node_by_name_balanced()

2025-02-11 Thread Krzysztof Kozlowski
On 07/02/2025 02:31, Zhang Zekun wrote: > There are many drivers use of_find_node_by_name() with a not-NULL > device_node pointer, and a number of callers would require a call to > of_node_get() before using it. There are also some drivers who forget > to call of_node_get() which would cause a ref

Re: [PATCH 1/2] ASoC: dt-bindings: imx-card: Add playback-only and capture-only property

2025-02-11 Thread Shengjiu Wang
On Tue, Feb 11, 2025 at 11:32 PM Frank Li wrote: > > On Tue, Feb 11, 2025 at 11:57:36AM +0800, Shengjiu Wang wrote: > > Refer to audio graph card, add playback-only and capture-only property > > for imx-audio-card.yaml for the case that only playback or capture > > is supported. > > > > Signed-off

Re: [PATCH 2/2] ASoC: imx-card: Add playback_only or capture_only support

2025-02-11 Thread Shengjiu Wang
On Tue, Feb 11, 2025 at 11:34 PM Frank Li wrote: > > On Tue, Feb 11, 2025 at 11:57:37AM +0800, Shengjiu Wang wrote: > > With the DPCM case, the backend only support capture or > > playback, then the linked frontend can only support > > capture or playback, but frontend can't automatically > > enab

Re: [PATCH v3 1/4] PCI/DPC: Rename pdev to err_port for dpc_handler

2025-02-11 Thread Shuai Xue
在 2025/2/12 05:17, Sathyanarayanan Kuppuswamy 写道: On 2/7/25 1:34 AM, Shuai Xue wrote: The irq handler is registered for error port which recevie DPC interrupt. Rename pdev to err_port. No functional changes. Signed-off-by: Shuai Xue --- I think you can combine patch 1 & 2 into a single

Re: [PATCH net-next] net: freescale: ucc_geth: remove unused PHY_INIT_TIMEOUT and PHY_CHANGE_TIME

2025-02-11 Thread patchwork-bot+netdevbpf
Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski : On Sun, 9 Feb 2025 13:27:44 +0100 you wrote: > Both definitions are unused. Last users have been removed with: > > 1577ecef7666 ("netdev: Merge UCC and gianfar MDIO bus drivers") > 728de4c927a3 ("ucc_geth: migrate uc

[powerpc:merge] BUILD SUCCESS 21b6db21f1fb239416c69d97412d63882f6e3a6e

2025-02-11 Thread kernel test robot
14.2.0 arc allmodconfigclang-18 arc allmodconfiggcc-13.2.0 arc allyesconfigclang-18 arc allyesconfiggcc-13.2.0 arc defconfiggcc-14.2.0 arc randconfig-00

[powerpc:next-test] BUILD SUCCESS 6aa989ab2bd0d37540c812b4270006ff794662e7

2025-02-11 Thread kernel test robot
randconfig-002-20250211gcc-13.2.0 arm allmodconfigclang-18 arm allmodconfiggcc-14.2.0 arm allyesconfigclang-18 arm allyesconfiggcc-14.2.0 arm

Re: [PATCH v3 3/4] PCI/DPC: Run recovery on device that detected the error

2025-02-11 Thread Sathyanarayanan Kuppuswamy
On 2/7/25 1:34 AM, Shuai Xue wrote: The current implementation of pcie_do_recovery() assumes that the recovery process is executed on the device that detected the error. However, the DPC driver currently passes the error port that experienced the DPC event to pcie_do_recovery(). Use the SOURCE

Re: [PATCH v3 1/4] PCI/DPC: Rename pdev to err_port for dpc_handler

2025-02-11 Thread Sathyanarayanan Kuppuswamy
On 2/7/25 1:34 AM, Shuai Xue wrote: The irq handler is registered for error port which recevie DPC interrupt. Rename pdev to err_port. No functional changes. Signed-off-by: Shuai Xue --- I think you can combine patch 1 & 2 into a single patch. Change wise, it looks fine to me. Reviewed-

Re: [PATCH v3] fs: introduce getfsxattrat and setfsxattrat syscalls

2025-02-11 Thread Arnd Bergmann
On Tue, Feb 11, 2025, at 18:22, Andrey Albershteyn wrote: > From: Andrey Albershteyn > > Introduce getfsxattrat and setfsxattrat syscalls to manipulate inode > extended attributes/flags. The syscalls take parent directory fd and > path to the child together with struct fsxattr. > > This is an alte

Re: [PATCH] ASoC: fsl_micfil: Add decimation filter bypass mode support

2025-02-11 Thread Mark Brown
On Thu, 06 Feb 2025 11:03:06 +0800, Shengjiu Wang wrote: > When decimation filter bypass mode is enabled, PDM data can be > written into FIFO directly without any processing. > > The interface of this mode is DSD big endian format, when > user needs this format, then this mode is enabled. > > Thi

Re: [PATCH v3] fs: introduce getfsxattrat and setfsxattrat syscalls

2025-02-11 Thread H. Peter Anvin
On February 11, 2025 9:22:47 AM PST, Andrey Albershteyn wrote: >From: Andrey Albershteyn > >Introduce getfsxattrat and setfsxattrat syscalls to manipulate inode >extended attributes/flags. The syscalls take parent directory fd and >path to the child together with struct fsxattr. > >This is an al

[PATCH v3] fs: introduce getfsxattrat and setfsxattrat syscalls

2025-02-11 Thread Andrey Albershteyn
From: Andrey Albershteyn Introduce getfsxattrat and setfsxattrat syscalls to manipulate inode extended attributes/flags. The syscalls take parent directory fd and path to the child together with struct fsxattr. This is an alternative to FS_IOC_FSSETXATTR ioctl with a difference that file don't n

[PATCH v2] powerpc/crash: Fix non-smp kexec preparation

2025-02-11 Thread Eddie James
In non-smp configurations, crash_kexec_prepare is never called in the crash shutdown path. One result of this is that the crashing_cpu variable is never set, preventing crash_save_cpu from storing the NT_PRSTATUS elf note in the core dump. Fixes: c7255058b543 ("powerpc/crash: save cpu register dat

[PATCH v13 11/11] powerpc: mm: Support page table check

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure On creation and clearing of a page table mapping, instrument such calls by invoking page_table_check_pte_set and page_table_check_pte_clear respectively. These calls serve as a sanity check against illegal mappings. Enable ARCH_SUPPORTS_PAGE_TABLE_CHECK for all platforms. See

[PATCH v13 10/11] powerpc: mm: Use set_pte_at_unchecked() for internal usages

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure In the new set_ptes() API, set_pte_at() (a special case of set_ptes()) is intended to be instrumented by the page table check facility. There are however several other routines that constitute the API for setting page table entries, including set_pmd_at() among others. Such rou

[PATCH v13 09/11] powerpc: mm: Implement *_user_accessible_page() for ptes

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure Page table checking depends on architectures providing an implementation of p{te,md,ud}_user_accessible_page. With refactorisations made on powerpc/mm, the pte_access_permitted() and similar methods verify whether a userland page is accessible with the required permissions. Si

[PATCH v13 08/11] powerpc: mm: Add pud_pfn() stub

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure The page table check feature requires that pud_pfn() be defined on each consuming architecture. Since only 64-bit, Book3S platforms allow for hugepages at this upper level, and since the calling code is gated by a call to pud_user_accessible_page(), which will return zero, incl

[PATCH v13 07/11] mm: Provide address parameter to p{te,md,ud}_user_accessible_page()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure On several powerpc platforms, a page table entry may not imply whether the relevant mapping is for userspace or kernelspace. Instead, such platforms infer this by the address which is being accessed. Add an additional address argument to each of these routines in order to prov

[PATCH v13 06/11] mm/page_table_check: Reinstate address parameter in [__]page_table_check_pte_clear()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure This reverts commit aa232204c468 ("mm/page_table_check: remove unused parameter in [__]page_table_check_pte_clear"). Reinstate previously unused parameters for the purpose of supporting powerpc platforms, as many do not encode user/kernel ownership of the page in the pte, but

[PATCH v13 05/11] mm/page_table_check: Reinstate address parameter in [__]page_table_check_pmd_clear()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure This reverts commit 1831414cd729 ("mm/page_table_check: remove unused parameter in [__]page_table_check_pmd_clear"). Reinstate previously unused parameters for the purpose of supporting powerpc platforms, as many do not encode user/kernel ownership of the page in the pte, but

[PATCH v13 04/11] mm/page_table_check: Reinstate address parameter in [__]page_table_check_pud_clear()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure This reverts commit 931c38e16499 ("mm/page_table_check: remove unused parameter in [__]page_table_check_pud_clear"). Reinstate previously unused parameters for the purpose of supporting powerpc platforms, as many do not encode user/kernel ownership of the page in the pte, but

[PATCH v13 02/11] mm/page_table_check: Reinstate address parameter in [__]page_table_check_pmd_set()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure This reverts commit a3b837130b58 ("mm/page_table_check: remove unused parameter in [__]page_table_check_pmd_set"). Reinstate previously unused parameters for the purpose of supporting powerpc platforms, as many do not encode user/kernel ownership of the page in the pte, but in

[PATCH v13 03/11] mm/page_table_check: Provide addr parameter to page_table_check_pte_set()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure To provide support for powerpc platforms, provide an addr parameter to the page_table_check_pte_set() routine. This parameter is needed on some powerpc platforms which do not encode whether a mapping is for user or kernel in the pte. On such platforms, this can be inferred form

[PATCH v13 01/11] mm/page_table_check: Reinstate address parameter in [__]page_table_check_pud_set()

2025-02-11 Thread Andrew Donnellan
From: Rohan McLure This reverts commit 6d144436d954 ("mm/page_table_check: remove unused parameter in [__]page_table_check_pud_set"). Reinstate previously unused parameters for the purpose of supporting powerpc platforms, as many do not encode user/kernel ownership of the page in the pte, but in

[PATCH v13 00/11] Support page table check on PowerPC

2025-02-11 Thread Andrew Donnellan
Support page table check on all PowerPC platforms. This works by serialising assignments, reassignments and clears of page table entries at each level in order to ensure that anonymous mappings have at most one writable consumer, and likewise that file-backed mappings are not simultaneously also an

Re: [PATCH] powerpc/crash: Fix non-smp kexec preparation

2025-02-11 Thread Eddie James
On 2/11/25 01:38, Christophe Leroy wrote: Le 10/02/2025 à 20:52, Eddie James a écrit : [Vous ne recevez pas souvent de courriers de eaja...@linux.ibm.com. Découvrez pourquoi ceci est important à https://aka.ms/LearnAboutSenderIdentification ] In non-smp configurations, crash_kexec_prepare

Re: [PATCH 2/2] ASoC: imx-card: Add playback_only or capture_only support

2025-02-11 Thread Frank Li
On Tue, Feb 11, 2025 at 11:57:37AM +0800, Shengjiu Wang wrote: > With the DPCM case, the backend only support capture or > playback, then the linked frontend can only support > capture or playback, but frontend can't automatically > enable only capture or playback, it needs the input > from dt-bind

Re: [PATCH 1/2] ASoC: dt-bindings: imx-card: Add playback-only and capture-only property

2025-02-11 Thread Frank Li
On Tue, Feb 11, 2025 at 11:57:36AM +0800, Shengjiu Wang wrote: > Refer to audio graph card, add playback-only and capture-only property > for imx-audio-card.yaml for the case that only playback or capture > is supported. > > Signed-off-by: Shengjiu Wang > --- > .../devicetree/bindings/sound/imx-a

Re: [kvm-unit-tests PATCH v2 15/18] Add kvmtool_params to test specification

2025-02-11 Thread Alexandru Elisei
Hi Drew, On Thu, Jan 23, 2025 at 04:53:29PM +0100, Andrew Jones wrote: > On Mon, Jan 20, 2025 at 04:43:13PM +, Alexandru Elisei wrote: > > arm/arm64 supports running tests under kvmtool, but kvmtool's syntax for > > running a virtual machine is different than qemu's. To run tests using the > >

Re: [PATCH 1/9] of: Add warpper function of_find_node_by_name_balanced()

2025-02-11 Thread Rob Herring
On Fri, Feb 7, 2025 at 9:37 AM Laurent Pinchart wrote: > > Hi Zekun, > > On Fri, Feb 07, 2025 at 07:28:23PM +0800, zhangzekun (A) wrote: > > 在 2025/2/7 16:24, Oleksij Rempel 写道: > > > On Fri, Feb 07, 2025 at 09:31:09AM +0800, Zhang Zekun wrote: > > >> There are many drivers use of_find_node_by_nam

Re: (subset) [PATCH 4/9] dt-bindings: mfd: Convert fsl,mcu-mpc8349emitx binding to YAML

2025-02-11 Thread Lee Jones
On Sun, 26 Jan 2025 19:58:59 +0100, J. Neuschäfer wrote: > Convert mcu-mpc8349emitx.txt to YAML and list the compatible strings > currently in use. > > Applied, thanks! [4/9] dt-bindings: mfd: Convert fsl,mcu-mpc8349emitx binding to YAML commit: 252c95ec3802a5f447df58253575b52aa741c1a1 -

Re: [PATCH 0/2] ASoC: imx-card: support playback or capture only

2025-02-11 Thread Daniel Baluta
On Tue, Feb 11, 2025 at 5:58 AM Shengjiu Wang wrote: > > Be similar to audio graph card, support playback or capture only > for imx-audio-card. > > Shengjiu Wang (2): > ASoC: dt-bindings: imx-card: Add playback-only and capture-only > property > ASoC: imx-card: Add playback_only or capture

Re: [PATCH 1/9] of: Add warpper function of_find_node_by_name_balanced()

2025-02-11 Thread Laurent Pinchart
On Tue, Feb 11, 2025 at 07:26:18PM +0800, zhangzekun (A) wrote: > 在 2025/2/10 18:03, Laurent Pinchart 写道: > > On Mon, Feb 10, 2025 at 02:47:28PM +0800, zhangzekun (A) wrote: > >>> I think we all agree that of_find_node_by_name() is miused, and that it > >>> shows the API isn't optimal. What we have

Re: [PATCH 1/9] of: Add warpper function of_find_node_by_name_balanced()

2025-02-11 Thread zhangzekun (A)
在 2025/2/10 18:03, Laurent Pinchart 写道: Hi Zekun, On Mon, Feb 10, 2025 at 02:47:28PM +0800, zhangzekun (A) wrote: I think we all agree that of_find_node_by_name() is miused, and that it shows the API isn't optimal. What we have different opinions on is how to make the API less error-prone. I

Re: [PATCH] powerpc: Transliterate author name and remove FIXME

2025-02-11 Thread Thorsten Blum
On 7. Jan 2025, at 13:16, Thorsten Blum wrote: > On 23. Nov 2024, at 11:19, Christophe Leroy wrote: >> Isn't our file just a copy of the one from binutils ? Shouldn't we adjust it >> based on commit https://github.com/bminor/binutils-gdb/commit/2ce18a16268a ? > > It looks like it's a copy and the