All of the APIs are missing the Kernel-doc comments. Hence, add them.
Signed-off-by: Manivannan Sadhasivam
---
drivers/pci/controller/dwc/pcie-designware-ep.c | 92 +
1 file changed, 92 insertions(+)
diff --git a/drivers/pci/controller/dwc/pcie-designware-ep.c
b/drivers
Now that the API is available, let's make use of it. It also handles the
reinitialization of DWC non-sticky registers in addition to sending the
notification to EPF drivers.
Signed-off-by: Manivannan Sadhasivam
---
drivers/pci/controller/dwc/pcie-qcom-ep.c | 2 +-
1 file changed, 1 insertion(+),
The PCIe link can go to LINK_DOWN state in one of the following scenarios:
1. Fundamental (PERST#)/hot/warm reset
2. Link transition from L2/L3 to L0
In those cases, LINK_DOWN causes some non-sticky DWC registers to loose the
state (like REBAR, PTM_CAP etc...). So the drivers need to reinitialize
"core_init_notifier" flag is set by the glue drivers requiring refclk from
the host to complete the DWC core initialization. Also, those drivers will
send a notification to the EPF drivers once the initialization is fully
completed using the pci_epc_init_notify() API. Only then, the EPF drivers
wil
Currently, dw_pcie_ep_init_registers() API is directly called by the glue
drivers requiring active refclk from host. But for the other drivers, it is
getting called implicitly by dw_pcie_ep_init(). This is due to the fact
that this API initializes DWC EP specific registers and that requires an
acti
The goal of the dw_pcie_ep_init_complete() API is to initialize the DWC
specific registers post registering the controller with the EP framework.
But the naming doesn't reflect its functionality and causes confusion. So,
let's rename it to dw_pcie_ep_init_registers() to make it clear that it
initi
The DWC glue drivers requiring an active reference clock from the PCIe host
for initializing their PCIe EP core, set a flag called 'core_init_notifier'
to let DWC driver know that these drivers need a special attention during
initialization. In these drivers, access to the hw registers (like DBI)
b
For DWC glue drivers supporting PERST# (currently Qcom and Tegra194), some
of the DWC resources like eDMA should be cleaned up during the PERST#
assert time.
So let's introduce a dw_pcie_ep_cleanup() API that could be called by these
drivers to cleanup the DWC specific resources. Currently, it jus
dw_pcie_ep_exit() API is undoing what the dw_pcie_ep_init() API has done
already (at least partly). But the API name dw_pcie_ep_exit() is not quite
reflecting that. So let's rename it to dw_pcie_ep_deinit() to make the
purpose of this API clear. This also aligns with the DWC host driver.
Signed-of
deinit() callback was solely introduced for the pcie-rcar-gen4 driver where
it is used to do platform specific resource deallocation. And this callback
is called right at the end of the dw_pcie_ep_exit() API. So it doesn't
matter whether it is called within or outside of dw_pcie_ep_exit() API.
So
Hello,
This series is the continuation of previous work by Vidya Sagar [1] to fix the
issues related to accessing DBI register space before completing the core
initialization in some EP platforms like Tegra194/234 and Qcom EP.
Since Vidya is busy, I took over the series based on his consent (off-
Hello:
This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski :
On Wed, 21 Feb 2024 17:46:21 + you wrote:
> * Update the Kernel Doc for gelic_descr_set_tx_cmdstat()
> and gelic_net_setup_netdev() so that documented name
> and the actual name of the function match.
>
> * M
On Fri, 16 Feb 2024 15:59:41 +, Oliver Upton wrote:
> The general expectation with debugfs is that any initialization failure
> is nonfatal. Nevertheless, kvm_arch_create_vm_debugfs() allows
> implementations to return an error and kvm_create_vm_debugfs() allows
> that to fail VM creation.
>
>
On Fri, 23 Feb 2024 13:46:53 -0500
Steven Rostedt wrote:
> Now one thing I could do is to not remove the parameter, but just add:
>
> WARN_ON_ONCE((src) != __data_offsets->item##_ptr_);
>
> in the __assign_str() macro to make sure that it's still the same that is
> assigned. But I'm not s
On Fri, 23 Feb 2024 14:50:49 -0500
Kent Overstreet wrote:
> Tangentially related though, what would make me really happy is if we
> could create the string with in the TP__fast_assign() section. I have to
> have a bunch of annoying wrappers right now because the string length
> has to be known wh
On Fri, Feb 23, 2024 at 01:46:53PM -0500, Steven Rostedt wrote:
> On Fri, 23 Feb 2024 10:30:45 -0800
> Jeff Johnson wrote:
>
> > On 2/23/2024 9:56 AM, Steven Rostedt wrote:
> > > From: "Steven Rostedt (Google)"
> > >
> > > [
> > >This is a treewide change. I will likely re-create this patch
On 2/23/2024 9:56 AM, Steven Rostedt wrote:
> From: "Steven Rostedt (Google)"
>
> [
>This is a treewide change. I will likely re-create this patch again in
>the second week of the merge window of v6.9 and submit it then. Hoping
>to keep the conflicts that it will cause to a minimum.
>
On Fri, 23 Feb 2024 10:30:45 -0800
Jeff Johnson wrote:
> On 2/23/2024 9:56 AM, Steven Rostedt wrote:
> > From: "Steven Rostedt (Google)"
> >
> > [
> >This is a treewide change. I will likely re-create this patch again in
> >the second week of the merge window of v6.9 and submit it then.
On Fri, 23 Feb 2024 12:56:34 -0500
Steven Rostedt wrote:
> Note, the same updates will need to be done for:
>
> __assign_str_len()
> __assign_rel_str()
> __assign_rel_str_len()
Correction: The below macros do not pass in their source to the entry
macros, so they will not need to be update
Hello,
here come two patches that I created while debugging an issue around USB
on MPC8313.
Best regards
Uwe
Uwe Kleine-König (2):
usb: gadget: fsl: Add of device table to enable module autoloading
usb: gadget: fsl: Increase size of name buffer for endpoints
drivers/usb/gadget/udc/fsl_udc_
With this table added, the fsl_usb2_udc module is automatically loaded
by udev in the presence of a matching device.
Signed-off-by: Uwe Kleine-König
---
drivers/usb/gadget/udc/fsl_udc_core.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/usb/gadget/udc/fsl_udc_core.c
b/
This fixes a W=1 warning about sprintf writing up to 16 bytes into a
buffer of size 14. There is no practical relevance because there are not
more than 32 endpoints.
Signed-off-by: Uwe Kleine-König
---
Hello,
I hesitated to add a Fixes: trailer because the problem is never hit in
practise. Anyho
On Wed, 21 Feb 2024 12:37:10 +, Richard Fitzgerald wrote:
> snd_soc_card_get_kcontrol() must be holding a read lock on
> card->controls_rwsem while walking the controls list.
>
> Compare with snd_ctl_find_numid().
>
> The existing function is renamed snd_soc_card_get_kcontrol_locked()
> so th
Hi Andy,
On Thu, 22 Feb 2024 17:47:34 +0200
Andy Shevchenko wrote:
...
> > +static int qmc_hdlc_xlate_slot_map(struct qmc_hdlc *qmc_hdlc,
> > + u32 slot_map, struct qmc_chan_ts_info
> > *ts_info)
> > +{
> > + DECLARE_BITMAP(ts_mask_avail, 64);
> > + DECLARE_BIT
Michael Ellerman writes:
> Nathan Lynch via B4 Relay
> writes:
>> From: Nathan Lynch
>>
>> The PAPR spec spells the function name as
>>
>> "ibm,reset-pe-dma-windows"
>>
>> but in practice firmware uses the singular form:
>
> Just to be clear, you're talking about IBM firmware on PowerVM
> mach
On 2/23/24 00:38, Christophe Leroy wrote:
> Le 22/02/2024 à 18:07, Sean Anderson a écrit :
>> [Vous ne recevez pas souvent de courriers de sean.ander...@linux.dev.
>> Découvrez pourquoi ceci est important à
>> https://aka.ms/LearnAboutSenderIdentification ]
>>
>> cgr_lock may be locked with inte
On Fri, Feb 16, 2024 at 5:00 PM Oliver Upton wrote:
>
> The general expectation with debugfs is that any initialization failure
> is nonfatal. Nevertheless, kvm_arch_create_vm_debugfs() allows
> implementations to return an error and kvm_create_vm_debugfs() allows
> that to fail VM creation.
>
> C
On Thu, 14 Dec 2023 20:36:05 +0300, George Stark wrote:
> In the probe() callback in case of error mutex is destroyed being locked
> which is not allowed so unlock the mutex before destroying.
>
>
Applied, thanks!
[01/10] leds: aw2013: unlock mutex before destroying it
commit: eb0f0a751
There are two places where pointer p is being assigned a value that
is never read, the pointer is re-assingned later. The assignments
are redundant and can be removed.
Cleans up two clang scan build warnings:
drivers/soc/fsl/dpio/qbman-portal.c:662:3: warning: Value stored to 'p'
is never read [de
On 22/02/2024 04:50, Shengjiu Wang wrote:
> On Wed, Feb 21, 2024 at 7:10 PM Hans Verkuil wrote:
>>
>> On 19/02/2024 13:56, Mauro Carvalho Chehab wrote:
>>> Em Mon, 19 Feb 2024 12:05:02 +0800
>>> Shengjiu Wang escreveu:
>>>
Hi Mauro
On Sat, Feb 17, 2024 at 5:19 PM Mauro Carvalho Che
On 2/23/24 02:28, David Laight wrote:
From: Christophe Leroy
Sent: 23 February 2024 10:07
...
+/* Ethernet headers are 14 bytes and NET_IP_ALIGN is used to align them */
+#define IP_ALIGNMENT (14 + NET_IP_ALIGN)
Only if no VLAN.
When using VLANs it is 4 bytes more. But why do you mind that
On Fri, 23 Feb 2024 02:42:22 +0100
Erhard Furtner wrote:
> Greetings!
>
> Looks like my Talos II (running a BE kernel+system) fails some of the kernels
> internal unit tests. At running drm_gem_shmem_test via 'modprobe -v
> drm_gem_shmem_test' I get:
KASAN gets some additional information out
On Fri, 23 Feb 2024 09:06:56 +
Christophe Leroy wrote:
> Yes, with second patch is magically works, meaning the patch description
> is not correct because the problem for powerpc it not at all related to
> memory alignment but to endianness. And endianness should have been
> fixed by patch
From: Christophe Leroy
> Sent: 23 February 2024 10:07
...
> > +/* Ethernet headers are 14 bytes and NET_IP_ALIGN is used to align them */
> > +#define IP_ALIGNMENT (14 + NET_IP_ALIGN)
>
> Only if no VLAN.
>
> When using VLANs it is 4 bytes more. But why do you mind that at all ?
Wasn't one archi
Andy, Yury,
On Thu, 22 Feb 2024 13:50:48 -0800
Yury Norov wrote:
> On Thu, Feb 22, 2024 at 05:49:59PM +0100, Herve Codina wrote:
> > Hi Andy, Yury,
> >
> > On Thu, 22 Feb 2024 17:39:27 +0200
> > Andy Shevchenko wrote:
> >
> > ...
> > > > + * bitmap_scatter() for the bitmap scatter detailed
Le 22/02/2024 à 03:55, Charlie Jenkins a écrit :
> The test cases for ip_fast_csum and csum_ipv6_magic were failing on a
> variety of architectures that are big endian or do not support
> misalgined accesses. Both of these test cases are changed to support big
> and little endian architectures.
Le 22/02/2024 à 03:55, Charlie Jenkins a écrit :
> The checksum functions use the types __wsum and __sum16. These need to
> be explicitly casted to, because will cause sparse errors otherwise.
This is not the correct fix. When you forcibly cast, you shut up sparse
and hide warnings but you don'
Le 23/02/2024 à 08:00, Charlie Jenkins a écrit :
> On Fri, Feb 23, 2024 at 06:58:14AM +, Christophe Leroy wrote:
>>
>>
>> Le 23/02/2024 à 07:12, Charlie Jenkins a écrit :
>>> On Fri, Feb 23, 2024 at 05:59:07AM +, Christophe Leroy wrote:
Hi Erhard, hi Charlie,
Le 23/02/2024
38 matches
Mail list logo