On 14/12/17 02:32, Bryant G. Ly wrote:
> When enabling SR-IOV in pseries platform,
> the VF bar properties for a PF are reported on
> the device node in the device tree.
>
> This patch adds the IOV Bar resources to Linux
> structures from the device tree for later use
> when configuring SR-IOV by
On 14/12/17 02:32, Bryant G. Ly wrote:
> After initial validation of SR-IOV resources, firmware will
> associate PEs to the dynamic VFs created within this call. This
> patch adds the association of PEs to the PF array of PE numbers
> indexed by VF.
>
> Signed-off-by: Bryant G. Ly
> Signed-off-by
On Sun, 17 Dec 2017 20:58:54 -0600
Josh Poimboeuf wrote:
> On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote:
> > On Tue, 12 Dec 2017 08:05:01 -0600
> > Josh Poimboeuf wrote:
> >
> > > On Tue, Dec 12, 2017 at 12:39:12PM +0100, Torsten Duwe wrote:
> > > > Hi all,
> > > >
> > >
On 12/14/2017 10:12 AM, Viresh Kumar wrote:
+ Gautham,
@Gautham: Can you please help reviewing this one ?
On 13-12-17, 13:49, Abhishek Goel wrote:
@@ -693,6 +746,8 @@ static int powernv_cpufreq_target_index(struct
cpufreq_policy *policy,
{
struct powernv_smp_call_data freq_data;
On 14/12/17 02:32, Bryant G. Ly wrote:
> When pseries SR-IOV is enabled and after a PF driver
> has resumed from EEH, platform has to be notified
> of the event so the child VFs can be allowed to
> resume their normal recovery path.
>
> This patch makes the EEH operation allow unfreeze
> platform
On 14/12/17 02:32, Bryant G. Ly wrote:
> To correctly use EEH code one has to make
> sure that the EEH_PE_VF is set for dynamic created
> VFs. Therefore this patch allocates an eeh_pe of
> eeh type EEH_PE_VF and associates PE with parent.
>
> Signed-off-by: Bryant G. Ly
> Signed-off-by: Juan J. A
On Wed, 2017-12-13 at 09:32 -0600, Bryant G. Ly wrote:
> To correctly use EEH code one has to make
> sure that the EEH_PE_VF is set for dynamic created
> VFs. Therefore this patch allocates an eeh_pe of
> eeh type EEH_PE_VF and associates PE with parent.
>
> Signed-off-by: Bryant G. Ly
> Signed-o
On Wed, 2017-12-13 at 09:32 -0600, Bryant G. Ly wrote:
> When pseries SR-IOV is enabled and after a PF driver
> has resumed from EEH, platform has to be notified
> of the event so the child VFs can be allowed to
> resume their normal recovery path.
>
> This patch makes the EEH operation allow unfr
On Wed, 2017-12-13 at 09:32 -0600, Bryant G. Ly wrote:
> Devices can go offline when EEH is reported. This patch adds
> a change to the kernel object and lets udev know of error.
> When device resumes a change is also set reporting device as
> online. Therefore, EEH events are better propagated to
On Mon, Dec 18, 2017 at 02:39:06PM +1100, Balbir Singh wrote:
> On Mon, Dec 18, 2017 at 1:58 PM, Josh Poimboeuf wrote:
> > On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote:
> >> On Tue, 12 Dec 2017 08:05:01 -0600
> >> Josh Poimboeuf wrote:
> >>
> >> > On Tue, Dec 12, 2017 at 12:39:
On 14/12/17 02:32, Bryant G. Ly wrote:
> Devices can go offline when EEH is reported. This patch adds
> a change to the kernel object and lets udev know of error.
> When device resumes a change is also set reporting device as
> online. Therefore, EEH events are better propagated to user
> space for
On 14/12/17 02:32, Bryant G. Ly wrote:
> Add EEH platform operations for pseries to update VF
> config space. With this change after EEH, the VF
> will have updated config space for pseries platform.
>
> Signed-off-by: Bryant G. Ly
> Signed-off-by: Juan J. Alvarez
> ---
> arch/powerpc/platforms
On Mon, Dec 18, 2017 at 1:58 PM, Josh Poimboeuf wrote:
> On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote:
>> On Tue, 12 Dec 2017 08:05:01 -0600
>> Josh Poimboeuf wrote:
>>
>> > On Tue, Dec 12, 2017 at 12:39:12PM +0100, Torsten Duwe wrote:
>> > > Hi all,
>> > >
>> > > The "Power Ar
On 12/17/17 8:51 PM, Nicolin Chen wrote:
Nicolin Chen (11):
ASoC: fsl_ssi: Rename fsl_ssi_private to fsl_ssi
ASoC: fsl_ssi: Cache pdev->dev pointer
ASoC: fsl_ssi: Refine all comments
ASoC: fsl_ssi: Rename registers and fields macros
ASoC: fsl_ssi: Refine indentations and wrappings
On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote:
> On Tue, 12 Dec 2017 08:05:01 -0600
> Josh Poimboeuf wrote:
>
> > On Tue, Dec 12, 2017 at 12:39:12PM +0100, Torsten Duwe wrote:
> > > Hi all,
> > >
> > > The "Power Architecture 64-Bit ELF V2 ABI" says in section 2.3.2.3:
> > >
>
Some regmap code looks redudant. So simplify it.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 27 +++
sound/soc/fsl/fsl_ssi.h | 4
2 files changed, 15 insertions(+), 16 deletions(-)
diff
Since this i2smode also includes the setting of Network mode, it
should have it in the name. This patch also adds its MASK define.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 24
sound/soc/fs
The name fsl_ssi_rxtx_reg_val is too long to read comfortably.
So this patch shortens it by using an array (fsl_ssi_regvals,
renamed from fsl_ssi_reg_val). To do that, it also introduces
two macros (TX and RX) to replace the wrapper structure. This
will also help further cleanups.
Meanwhile, it un
Simplify the variable name. This reduces one over-80-character line.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/sound/soc/fsl/fsl_ssi.c
Shortens the variable name to save space, useful for dev_err outputs.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 32
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/s
This patches unifies the error message in the "failed to " format.
It also reduces the length of one line and adds spaces to an operator.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 16
1 file c
This patch just simply unifies the coding style.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 239 +---
sound/soc/fsl/fsl_ssi.h | 2 +-
sound/soc/fsl/fsl_ssi_dbg.c |
This patch renames CCSR_SSI_xxx to REG_SSI_xxx and SSI_xxx_yyy style.
It also slightly reduces the length of them to save some space.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 374 +-
This patch refines the comments by:
1) Removing all out-of-date comments
2) Removing all not-so-useful comments
3) Unifying the styles of all comments
4) Shortening comments to be more conise
5) Adding comments to improve code readablity
6) Moving all register related comments to fsl_ssi.h
7) Addin
There should be no trouble to understand dev = pdev->dev.
This can save some space to have more print info or save
some wrapped lines.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 64 --
Shorten the private data structure to save some wrapped lines.
Signed-off-by: Nicolin Chen
Tested-by: Maciej S. Szmigiero
Reviewed-by: Maciej S. Szmigiero
---
sound/soc/fsl/fsl_ssi.c | 456 +++-
1 file changed, 220 insertions(+), 236 deletions(-)
di
==Changelog==
v3->v4
* Revised PATCH-03 "Refine all comments" by adding Timur's inputs
* Rebased all other patches
v2->v3
* Added Tested-by and Reviewed-by from Maciej
* Revised PATCH-03 "Refine all comments" by adding Maciej's advice
* Revised PATCH-05 "Refine indentations and wrappings"
* R
Some functions definitions have either the initial open brace and/or
the closing brace outside of column 1.
Move those braces to column 1.
This allows various function analyzers like gnu complexity to work
properly for these modified functions.
Miscellanea:
o Remove extra trailing ; and blank l
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> There is only one caller of the trivial function find_dev_pagemap left,
> so just merge it into the caller.
>
> Signed-off-by: Christoph Hellwig
Looks good,
Reviewed-by: Dan Williams
...and all of these pass the nvdimm unit tests, so
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> From: Logan Gunthorpe
>
> This new interface is similar to how struct device (and many others)
> work. The caller initializes a 'struct dev_pagemap' as required
> and calls 'devm_memremap_pages'. This allows the pagemap structure to
> be
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> From: Logan Gunthorpe
>
> 'struct page_map' is a private structure of 'struct dev_pagemap' but the
> latter replicates all the same fields as the former so there isn't much
> value in it. Thus drop it in favour of a completely public str
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> __radix_tree_insert already checks for duplicates and returns -EEXIST in
> that case, so remove the duplicate (and racy) duplicates check.
>
> Signed-off-by: Christoph Hellwig
> Reviewed-by: Logan Gunthorpe
> ---
> kernel/memremap.c |
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> All callers are gone now.
>
> Signed-off-by: Christoph Hellwig
> ---
Nice,
Reviewed-by: Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> Change the calling convention so that get_dev_pagemap always consumes the
> previous reference instead of doing this using an explicit earlier call to
> put_dev_pagemap in the callers.
>
> The callers will still need to put the final refe
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
> This is a pretty big function, which should be out of line in general,
> and a no-op stub if CONFIG_ZONE_DEVICЕ is not set.
>
> Signed-off-by: Christoph Hellwig
> Reviewed-by: Logan Gunthorpe
[..]
> +/**
> + * get_dev_pagemap() - take a
On Fri, Dec 15, 2017 at 5:48 PM, Dan Williams wrote:
> On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote:
>> We can just pass this on instead of having to do a radix tree lookup
>> without proper locking 2 levels into the callchain.
>>
>> Signed-off-by: Christoph Hellwig
>
> Yeah, the loo
On Fri, Dec 15, 2017 at 10:01 PM, Mathieu Malaterre wrote:
> On Fri, Dec 15, 2017 at 9:52 PM, Mathieu Malaterre wrote:
>> On Fri, Dec 15, 2017 at 8:50 PM, Mathieu Malaterre wrote:
>>> Hi there,
>>>
>>> Does anyone has working defconfig for a Mac Mini G4 ?
>>>
>>> Here is what I tried:
>>>
>>> $
37 matches
Mail list logo