From: "khand...@linux.vnet.ibm.com"
Value of 'valid' is zero when 'esid' is zero and it does not matter
when 'esid' is non-zero. Hence the variable 'value' can be dropped
from the conditional statement. This patch does that.
Signed-off-by: Anshuman Khandual
---
arch/powerpc/xmon/xmon.c | 2 +-
On 07/21/2015 11:24 AM, Vasant Hegde wrote:
> On 07/20/2015 03:10 AM, Jacek Anaszewski wrote:
>> Hi Vasant,
>>
>
> Jacek,
>
>> I've revised your patch and found few more issues.
>> Please refer to my comments below.
>
> Thanks.
>
> .../...
>
Please don't exceed 75 character line leng
On Fri, 2015-07-17 at 13:28 +0800, Zumeng Chen wrote:
> On 2015年07月17日 12:07, Michael Ellerman wrote:
> > On Fri, 2015-07-17 at 09:27 +0800, Zumeng Chen wrote:
> >> On 2015年07月16日 17:04, Michael Ellerman wrote:
> >>> On Thu, 2015-07-16 at 13:57 +0800, Zumeng Chen wrote:
> Hi All,
>
>
On Mon, 2015-07-20 at 20:45 +1000, Alexey Kardashevskiy wrote:
> The existing code stores the amount of memory allocated for a TCE table.
> At the moment it uses @offset which is a virtual offset in the TCE table
> which is only correct for a one level tables and it does not include
> memory alloca
On 07/20/2015 03:10 AM, Jacek Anaszewski wrote:
> Hi Vasant,
>
Jacek,
> I've revised your patch and found few more issues.
> Please refer to my comments below.
Thanks.
.../...
>>>
>>> Please don't exceed 75 character line length limit.
>>
>> Ok. I will fix it.. But I thought 80 character is t
On Mon, 2015-07-20 at 08:41 -0500, Segher Boessenkool wrote:
> On Mon, Jul 20, 2015 at 04:24:22PM +0530, Ananth N Mavinakayanahalli wrote:
> > There is a potential gain to be had with a direct
> > jump instead of a breakpoint, but the caveats need to be traded off
> > with the complexity it brings
On Mon, Jul 20, 2015 at 08:45:51PM +1000, Alexey Kardashevskiy wrote:
> The existing code stores the amount of memory allocated for a TCE table.
> At the moment it uses @offset which is a virtual offset in the TCE table
> which is only correct for a one level tables and it does not include
> memory
On 07/21/2015 07:07 AM, Michael Ellerman wrote:
> On Mon, 2015-20-07 at 02:58:43 UTC, Anshuman Khandual wrote:
>> This patch adds one helper function 'sigcontext_vmx_regs' which computes
>> quad word aligned pointer for 'vmx_reserve' array element in sigcontext
>> structure making the code more rea
On Mon, 2015-22-06 at 20:59:20 UTC, Nathan Fontenot wrote:
> Update the cpu dlpar add/remove paths to do better error recovery when
> a failure occurs during the add/remove operation. This includes adding
> some pr_info and pr_debug statements.
So I'm happy with the idea there, but ..
> diff --g
On Tue, Jul 21, 2015 at 12:53:07PM +1000, Michael Ellerman wrote:
> On Sun, 2015-07-19 at 11:21 +0900, Masami Hiramatsu wrote:
> > On 2015/07/16 19:56, Ananth N Mavinakayanahalli wrote:
> > > Kprobes uses a breakpoint instruction to trap into execution flow
> > > and the probed instruction is singl
Hi folks,
Just letting you know that powerpc next is open.
So now is the time to start sending patches for 4.3.
Ben & I now have a shared powerpc tree on kernel.org, so that is the place you
should be looking at if you want to see what's in next:
https://git.kernel.org/cgit/linux/kernel/git/p
On Tue, 2015-07-21 at 12:45 +1000, Anton Blanchard wrote:
> Hi Ian,
>
> > From: Ian Munsie
> >
> > If the system has a PCI device with a memory-controller device node,
> > kexec-lite would spew hundreds of double free warnings and eventually
> > segfault. This would result in a "kexec load faile
On Tue, 2015-07-21 at 12:45 +1000, Anton Blanchard wrote:
> Hi Ian,
>
> > From: Ian Munsie
> >
> > If the system has a PCI device with a memory-controller device node,
> > kexec-lite would spew hundreds of double free warnings and eventually
> > segfault. This would result in a "kexec load faile
On Sun, 2015-07-19 at 11:21 +0900, Masami Hiramatsu wrote:
> On 2015/07/16 19:56, Ananth N Mavinakayanahalli wrote:
> > Kprobes uses a breakpoint instruction to trap into execution flow
> > and the probed instruction is single-stepped from an alternate location.
> >
> > On some architectures like
Hi Ian,
> From: Ian Munsie
>
> If the system has a PCI device with a memory-controller device node,
> kexec-lite would spew hundreds of double free warnings and eventually
> segfault. This would result in a "kexec load failed" message from
> petitboot.
>
> This was due to kexec_memory_map() sea
On Mon, 2015-20-07 at 02:58:43 UTC, Anshuman Khandual wrote:
> This patch adds one helper function 'sigcontext_vmx_regs' which computes
> quad word aligned pointer for 'vmx_reserve' array element in sigcontext
> structure making the code more readable.
>
> diff --git a/arch/powerpc/kernel/signal_6
From: Tim Gardner
drivers/macintosh/ans-lcd.c:201:1: warning: data definition has no type or
storage class
module_init(anslcd_init);
^
drivers/macintosh/ans-lcd.c:201:1: error: type defaults to 'int' in declaration
of 'module_init' [-Werror=implicit-int]
gcc version 4.9.3 (Ubuntu 4.9.3-1ubun
Madhavan Srinivasan [ma...@linux.vnet.ibm.com] wrote:
| This patchset enables Nest Instrumentation support on powerpc.
| POWER8 has per-chip Nest Intrumentation which provides various
| per-chip metrics like memory, powerbus, Xlink and Alink
| bandwidth.
|
| Cc: Michael Ellerman
| Cc: Benjamin
On 07/20/2015 11:46 AM, Jacek Anaszewski wrote:
> On 19.07.2015 23:40, Jacek Anaszewski wrote:
> [...]
> +/* Platform driver probe */
> +static int powernv_led_probe(struct platform_device *pdev)
> +{
> +int num_leds;
> +struct device_node *led_node;
> +struct po
On 07/15/2015 08:32 AM, Robert Baldyga wrote:
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/pch_udc.c | 14 --
1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/gadget/udc/pch_udc.c b/
On 07/15/2015 08:31 AM, Robert Baldyga wrote:
So far it was necessary for usb functions to set ep->driver_data in
endpoint obtained from autoconfig to non-null value, to indicate that
endpoint is claimed by function (in autoconfig it was checked if endpoint
has set this field to non-null value,
On 07/17/2015 05:46 AM, Thomas Huth wrote:
> The EPOW interrupt handler uses rtas_get_sensor(), which in turn
> uses rtas_busy_delay() to wait for RTAS becoming ready in case it
> is necessary. But rtas_busy_delay() is annotated with might_sleep()
> and thus may not be used by interrupts handlers l
On 15/07/15 10:52, Konstantin Khlebnikov wrote:
> This code is used only when CONFIG_PREEMPT=n and only in non-atomic context:
> xen_in_preemptible_hcall is set only in privcmd_ioctl_hypercall().
> Thus preempt_count is zero and should_resched() is equal to need_resched().
Applied to for-linus-4.3
On Mon, Jul 20, 2015 at 04:24:22PM +0530, Ananth N Mavinakayanahalli wrote:
> There is a potential gain to be had with a direct
> jump instead of a breakpoint, but the caveats need to be traded off
> with the complexity it brings in.
>
> For now, mark OPTPROBES na for powerpc.
If we haven't yet i
> -Original Message-
> From: Joakim Tjernlund [mailto:joakim.tjernl...@transmode.se]
> Sent: Monday, July 20, 2015 3:57 PM
> To: net...@vger.kernel.org; Liberman Igal-B31950; Bucur Madalin-Cristian-
> B32716
> Cc: linuxppc-dev@lists.ozlabs.org; linux-ker...@vger.kernel.org
> Subject: Re: [R
Hi Joakim,
It seems we just need to align to the API introduced by Thomas Petazzoni
in 3be2a49e.
Madalin
> -Original Message-
> From: Joakim Tjernlund [mailto:joakim.tjernl...@transmode.se]
> Sent: Monday, July 20, 2015 3:16 PM
> To: net...@vger.kernel.org; Liberman Igal-B31950
> Cc: lin
On Mon, 2015-07-20 at 12:28 +, Madalin-Cristian Bucur wrote:
> Hi Joakim,
>
> It seems we just need to align to the API introduced by Thomas Petazzoni
> in 3be2a49e.
>
> Madalin
So it seems, any idea when the next spin will be ready?
Could you also push it onto
http://git.freescale.com/gi
On Mon, 2015-07-20 at 12:18 +, Madalin-Cristian Bucur wrote:
> Hi Joakim
>
> > -Original Message-
> > From: Joakim Tjernlund [mailto:joakim.tjernl...@transmode.se]
> > Sent: Monday, July 20, 2015 10:57 AM
> > To: linuxppc-dev@lists.ozlabs.org; net...@vger.kernel.org; Bucur Madalin-
> >
Now we save the domain number in pci_host_bridge,
we could remove pci_bus_assign_domain_nr() and
clean the domain member in pci_bus.
Signed-off-by: Yijing Wang
---
drivers/pci/pci.c |5 -
drivers/pci/pci.h |9 -
drivers/pci/probe.c | 11 +++
include/linux/pci.h
Hi Joakim
> -Original Message-
> From: Joakim Tjernlund [mailto:joakim.tjernl...@transmode.se]
> Sent: Monday, July 20, 2015 10:57 AM
> To: linuxppc-dev@lists.ozlabs.org; net...@vger.kernel.org; Bucur Madalin-
> Cristian-B32716
> Cc: linux-ker...@vger.kernel.org
> Subject: Re: [PATCH RFC 0
Now platform specific sysdata is saved in pci_bus,
and pcibios_root_bridge_prepare() need to know
the sysdata. Later, we would move pcibios_root_bridge_prepare()
prior to root bus creation, so we need to make
pci_host_bridge hold sysdata.
Signed-off-by: Yijing Wang
---
arch/ia64/pci/pci.c |2
Pcibios_root_bridge_prepare() in powerpc set root bus
speed, it's not the preparation for pci host bridge.
For better separation of host bridge and root bus creation,
It's need to rename it to another weak function.
Signed-off-by: Yijing Wang
---
arch/powerpc/include/asm/machdep.h |2 +
On Wed, 2015-04-29 at 12:29 +0300, Igal.Liberman wrote:
> From: Igal Liberman
>
> This patch adds the Ethernet MAC driver support.
>
> Signed-off-by: Igal Liberman
> ---
> drivers/net/ethernet/freescale/fman/inc/mac.h | 125 +
> drivers/net/ethernet/freescale/fman/mac/Makefile |3
Save domain in pci_host_bridge, so we could get domain
from pci_host_bridge, and at the end of series, we could
clean up the arch specific pci_domain_nr(). For arm/arm64,
the domain argument is pointless, because they enable
CONFIG_PCI_DOMAINS_GENERIC, PCI core would assign domain
number for them,
Introduce pci_host_assign_domain_nr() to assign domain number
for pci_host_bridge.
Signed-off-by: Yijing Wang
---
drivers/pci/pci.c | 24 +++-
drivers/pci/pci.h |1 +
2 files changed, 20 insertions(+), 5 deletions(-)
diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
i
Now pci_host_bridge holds the domain number, we could
introduce common pci_domain_nr(), and remove platform specific code.
Signed-off-by: Yijing Wang
---
arch/alpha/include/asm/pci.h |2 --
arch/ia64/include/asm/pci.h |1 -
arch/microblaze/include/asm/pci.h |2 --
arch/mic
pci_get_new_domain_nr() is only used in drivers/pci/pci.c,
remove the declaration in include/linux/pci.h.
Signed-off-by: Yijing Wang
---
drivers/pci/pci.c |4 ++--
include/linux/pci.h |3 ---
2 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/pci/pci.c b/drivers/pci
Pci_host_bridge hold the domain number, we need
to assign domain number prior to root bus creation,
because root bus need to know the domain number
to check whether it's alreay exist. Also it's
preparation for separating pci_host_bridge creation
from pci_create_root_bus().
Signed-off-by: Yijing Wa
pci_bus_assign_domain_nr() is only called in probe.c,
Move pci_bus_assign_domain_nr() declaration into
drivers/pci/pci.h.
Signed-off-by: Yijing Wang
---
drivers/pci/pci.h |9 +
include/linux/pci.h |6 --
2 files changed, 9 insertions(+), 6 deletions(-)
diff --git a/drivers
Kbuild test robot found we passed a pci_dev * to
pci_domain_nr(). In old IA64 specific pci_domain_nr()
It was macro defines:
#define PCI_CONTROLLER(busdev) ((struct pci_controller *) busdev->sysdata)
#define pci_domain_nr(busdev)(PCI_CONTROLLER(busdev)->segment)
Both pci_dev * and pci_bus * h
This series is splitted out from previous patchset
"Refine PCI scan interfaces and make generic pci host bridge".
It try to clean up all platform pci_domain_nr(), save domain
in pci_host_bridge, so we could get domain number from the
common interface.
v11->v12:
Introduce wrap function pci_creat
Kprobes uses a breakpoint instruction to trap into execution flow
and the probed instruction is single-stepped from an alternate location.
On some architectures like x86, under certain conditions, the OPTPROBES
feature enables replacing the probed instruction with a jump instead,
resulting in a si
To be used for features we will not support on a particular architecture.
The git log that adds this needs to provide the justification 'why?'
Signed-off-by: Ananth N Mavinakayanahalli
---
Documentation/features/arch-support.txt |1 +
1 file changed, 1 insertion(+)
diff --git a/Documentatio
The existing code stores the amount of memory allocated for a TCE table.
At the moment it uses @offset which is a virtual offset in the TCE table
which is only correct for a one level tables and it does not include
memory allocated for intermediate levels. When multilevel TCE table is
requested, WA
On Sun, Jul 19, 2015 at 11:21:50AM +0900, Masami Hiramatsu wrote:
> On 2015/07/16 19:56, Ananth N Mavinakayanahalli wrote:
> > Kprobes uses a breakpoint instruction to trap into execution flow
> > and the probed instruction is single-stepped from an alternate location.
> >
> > On some architecture
On powernv platform, IOV BAR would be shifted if necessary. While the log
message is not correct when disabling VFs.
This patch fixes this by print correct message based on the offset value.
Signed-off-by: Wei Yang
---
arch/powerpc/platforms/powernv/pci-ioda.c |5 +++--
1 file changed, 3 in
On Sat, Jul 18, 2015 at 07:45:17PM -0400, Paul Gortmaker wrote:
> [[PATCH] macintosh/ans-lcd: fix build failure after module_init/exit
> relocation] On 17/07/2015 (Fri 14:20) Luis Henriques wrote:
>
> > After commit 0fd972a7d91d ("module: relocate module_init from init.h to
> > module.h")
> > an
From: Tang Yuantian
PowerPC E500MC serial SoCs, like T2080 T1040 and T4240, use RCPM
to manage power consumption. This patch adds hot plug feature to
RCPM driver.
Signed-off-by: Chenhui Zhao
Signed-off-by: Tang Yuantian
---
arch/powerpc/include/asm/fsl_pm.h | 2 ++
arch/powerpc/sysdev/fsl_rc
Whoops - subject line was supposed to say "kexec-lite: ..."
-Ian
___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev
From: Ian Munsie
If the system has a PCI device with a memory-controller device node,
kexec-lite would spew hundreds of double free warnings and eventually
segfault. This would result in a "kexec load failed" message from
petitboot.
This was due to kexec_memory_map() searching for "memory" nodes
On Mon, 2015-07-20 at 09:54 +0200, Joakim Tjernlund wrote:
> On Wed, 2015-04-01 at 19:19 +0300, Madalin Bucur wrote:
> > This introduces the Freescale Data Path Acceleration Architecture
> > (DPAA) Ethernet driver (dpaa_eth) that builds upon the DPAA QMan,
> > BMan, PAMU and FMan drivers to deliver
On Wed, 2015-04-01 at 19:19 +0300, Madalin Bucur wrote:
> This introduces the Freescale Data Path Acceleration Architecture
> (DPAA) Ethernet driver (dpaa_eth) that builds upon the DPAA QMan,
> BMan, PAMU and FMan drivers to deliver Ethernet connectivity on
> the Freescale DPAA QorIQ platforms.
>
From: Zhao Qiang
p1010rdb-pb use the irq[4:5] for inta and intb to pcie,
it is active-high, so set it.
Signed-off-by: Zhao Qiang
Change-Id: I29db41b4a8b5a67c18151099884edda6de4d9d1a
Reviewed-on: http://git.am.freescale.net:8181/9915
Tested-by: Review Code-CDREVIEW
Reviewed-by: Xiaobo Xie
Revi
53 matches
Mail list logo