On Thu, Sep 13, 2012 at 06:55:29PM +0800, Shaohui Xie wrote:
> Error handle in case of DDR ECC off is wrong, sysfs entries have not been
> created, so edac_mc_free which frees a mci instance should not be called.
> Also, free mci's memory in this case.
Jus FYI: I ran into the same error in edac_mc
Signed-off-by: Alexandre Bounine
Reported-by: Robert P. J. Day
Cc: Robert P. J. Day
---
include/linux/rio.h |3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/include/linux/rio.h b/include/linux/rio.h
index 1a7b6c7..ba382f2 100644
--- a/include/linux/rio.h
+++ b/include/
On 2012-09-14 ag...@denx.de wrote:
> Eric Millbrandt wrote:
>
...
>
> Better use:
>
> diff --git a/sound/soc/fsl/Kconfig b/sound/soc/fsl/Kconfig index
> d701330..4563b28 100644
> --- a/sound/soc/fsl/Kconfig
> +++ b/sound/soc/fsl/Kconfig
> @@ -6,7 +6,7 @@ config SND_SOC_FSL_UTILS
>
> menuconfig S
On Thu, Aug 30, 2012 at 12:40:04PM +0200, Joakim Tjernlund wrote:
> mpc_i2c_stop() only initiates STOP but does not wait for it to
> hit the I2C bus. This is a problem when using I2C devices which
> uses fairly long clock stretching just before STOP if you also
> have an i2c-mux which may switch to
Wolfram Sang wrote on 2012/09/14 16:02:34:
>
> On Thu, Aug 30, 2012 at 12:40:04PM +0200, Joakim Tjernlund wrote:
> > mpc_i2c_stop() only initiates STOP but does not wait for it to
> > hit the I2C bus. This is a problem when using I2C devices which
> > uses fairly long clock stretching just before
My bad...
Will skip this patch in next patch-set...
On 14/09/12 14:06, Rob Herring wrote:
> On 09/14/2012 03:18 AM, Srinivas KANDAGATLA wrote:
>> From: Srinivas Kandagatla
>>
>> As follow-up to "dt: introduce of_get_child_by_name to get child node by
>> name." patch, This patch removes some of t
Thanks for pointing the typo..
On 14/09/12 14:05, Rob Herring wrote:
> On 09/14/2012 03:19 AM, Srinivas KANDAGATLA wrote:
>> From: Srinivas Kandagatla
>>
>> As follow-up to "dt: introduce of_get_child_by_name to get child node by
>> name." patch, This patch removes some of the code duplication i
On 09/14/2012 03:18 AM, Srinivas KANDAGATLA wrote:
> From: Srinivas Kandagatla
>
> As follow-up to "dt: introduce of_get_child_by_name to get child node by
> name." patch, This patch removes some of the code duplication in the
> driver by replacing it with of_get_child_by_name instead.
>
> Signe
On 09/14/2012 03:19 AM, Srinivas KANDAGATLA wrote:
> From: Srinivas Kandagatla
>
> As follow-up to "dt: introduce of_get_child_by_name to get child node by
> name." patch, This patch removes some of the code duplication in the
> driver by replacing it with of_get_child_by_name instead.
>
> Signe
>
>> -Original Message-
>> From: Chris Ball [mailto:c...@laptop.org]
>> Sent: Wednesday, September 12, 2012 4:59 AM
>> To: Kumar Gala
>> Cc: Huang Changming-R66093; linuxppc-dev@lists.ozlabs.org list;
>> linux- m...@vger.kernel.org; Anton Vorontsov
>> Subjec
From: Srinivas Kandagatla
As follow-up to "dt: introduce of_get_child_by_name to get child node by
name." patch, This patch removes some of the code duplication in the
driver by replacing it with of_get_child_by_name instead.
Signed-off-by: Srinivas Kandagatla
---
arch/powerpc/sysdev/qe_lib/qe
From: Srinivas Kandagatla
As follow-up to "dt: introduce of_get_child_by_name to get child node by
name." patch, This patch removes some of the code duplication in the
driver by replacing it with of_get_child_by_name instead.
Signed-off-by: Srinivas Kandagatla
---
arch/powerpc/platforms/powern
From: Srinivas Kandagatla
As follow-up to "dt: introduce of_get_child_by_name to get child node by
name." patch, This patch removes some of the code duplication in the
driver by replacing it with of_get_child_by_name instead.
Signed-off-by: Srinivas Kandagatla
---
arch/powerpc/kernel/prom.c |
From: Srinivas Kandagatla
This patch series introduces of_get_child_by_name function to get a
child node by its name in a given parent node and also removes code
duplication in some of the existing driver code by using of_get_child_by_name.
Normally if a driver want to get a child node it woul
From: Srinivas Kandagatla
This patch introduces of_get_child_by_name function to get a child node
by its name in a given parent node.
Without this patch each driver code has to iterate the parent and do
a string compare, However having of_get_child_by_name libary function would
avoid code duplic
Eric Millbrandt wrote:
mpc52xx socs need to have FSL_SOC defined to build their drivers
(i2c-mpc, ASoC)
No, i2c-mpc depends on PPC only. And FSL_SOC enables code we do not
use on mpc52xx. For ASoC please see comment below.
Signed-off-by: Eric Millbrandt
diff --git a/arch/powerpc/platform
This was originally motivated by a desire to see the mapping between
logical and hardware cpu numbers.
But it seemed that it made more sense to just add a command to dump
(most of) the paca.
With no arguments "dp" will dump the paca for the current cpu.
It also takes an argument, eg. "dp 3" whic
This patch adds a crypto driver which provides a powerpc accelerated
implementation of SHA-1, accelerated in that it is written in asm.
Original patch by Paul, minor fixups for upstream by moi.
Lightly tested on 64-bit with the test program here:
http://michael.ellerman.id.au/files/junkcode/sha
On Fri, 2012-09-14 at 16:03 +1000, Michael Ellerman wrote:
> This was originally motivated by a desire to see the mapping between
> logical and hardware cpu numbers.
Thanks to everyone who reminded me that the paca is 64-bit only :)
New patch on the way.
cheers
_
Signed-off-by: Chunhe Lan
---
arch/powerpc/configs/85xx/p1023rds_defconfig |6 ++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/configs/85xx/p1023rds_defconfig
b/arch/powerpc/configs/85xx/p1023rds_defconfig
index 26e541c..b80bcc6 100644
--- a/arch/powerpc/co
20 matches
Mail list logo