Hannes Hering wrote:
This patch introduces two exports to allow modules to use memory notifiers.
Signed-off-by: Hannes Hering <[EMAIL PROTECTED]>
---
diff --git a/drivers/base/memory.c b/drivers/base/memory.c
index 8ce6de5..937e825 100644
--- a/drivers/base/memory.c
+++ b/drivers/base/memory.c
> -Original Message-
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On
> Behalf Of Grant Likely
> Sent: Friday, May 09, 2008 9:25 PM
> To: Jin Zhengxiong
> Cc: [EMAIL PROTECTED]; linuxppc-dev@ozlabs.org
> Subject: Re: [PATCH 1/4 V2] booting-without-of for Freescale MSI
>
> On Fri,
>
> ...
>
> > +static int fsl_msi_host_match(struct irq_host *h, struct
> device_node
> > +*node) {
> > + /* Exact match*/
> > + return h->of_node == node;
> > +}
>
> This is the default behaviour, so technically you don't need
> this routine - but I'm not fussed.
You are right, I notice
Add a check to online_pages() to test for failure of
walk_memory_resource(). This fixes a condition where a failure
of walk_memory_resource() can lead to online_pages() returning
success without the requested pages being onlined.
Signed-off-by: Geoff Levand <[EMAIL PROTECTED]>
---
I'm not entire
On May 12, 2008, at 5:12 PM, Anton Vorontsov wrote:
On Mon, May 12, 2008 at 04:55:16PM -0500, Timur Tabi wrote:
Anton Vorontsov wrote:
I don't know the IP block name... what is it for the 83xx/86xx
watchdogs?
My point was that we developers should just pick a name and run
with it.
That'
Having to muck with the build and set DEBUG just to
get lmb_dump_all() to print things isn't very useful.
So use pr_info() and use an early boot param
"lmb=debug" so we can simply ask users to reboot
with this option when we need some debugging from
them.
Signed-off-by: David S. Miller <[EMAIL P
When allocating, if we will align up the size when making
the reservation, we should also align the size for the
check that the space is actually available.
The simplest thing is to just aling the size up from
the beginning, then we can use plain 'size' throughout.
Signed-off-by: David S. Miller
While diagnosing Mikael's bug where half of his RAM disappeared
in 2.6.26-rc2 I found one bug (which I don't think fixes his
problem, but waiting for an updated set of debugging logs from
him) and an improvement to the debugging provided by the current
LMB code.
___
Hi,
I've had some trouble with this change.
Badari Pulavarty wrote:
> Provide walk_memory_resource() for ppc64. PPC maintains
> logic memory region mapping in lmb.memory structures. Walk
> through these structures and do the callbacks for the
> contiguous chunks.
...
> --- linux-2.6.25-rc3.ori
+ compatible = "mpc83xx_wdt", "fsl,mpc8610-wdt";
You should put the most specific entry first.
Segher
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
On Mon, May 12, 2008 at 04:55:16PM -0500, Timur Tabi wrote:
> Anton Vorontsov wrote:
>
>> I don't know the IP block name... what is it for the 83xx/86xx
>> watchdogs?
>
> My point was that we developers should just pick a name and run with it.
> That's where the name "Elo" came from. None of of
Anton Vorontsov wrote:
I don't know the IP block name... what is it for the 83xx/86xx
watchdogs?
My point was that we developers should just pick a name and run with it.
That's where the name "Elo" came from. None of official Freescale
documentation calls the DMA controller on 85xx parts "
On Mon, May 12, 2008 at 04:42:41PM -0500, Timur Tabi wrote:
> Anton Vorontsov wrote:
>
>> They're completely different watchdogs...
>
> But the drivers both generally do the same thing, just with different
> timers?
All the watchdogs do the same thing, generally...
> I think the best option is
Anton Vorontsov wrote:
They're completely different watchdogs...
But the drivers both generally do the same thing, just with different
timers?
I think the best option is to just pick a name for the IP block that
mpc83xx_wdt.c supports and use that name for the driver as well.
__
On Mon, May 12, 2008 at 04:20:59PM -0500, Timur Tabi wrote:
> Anton Vorontsov wrote:
>> On Mon, May 12, 2008 at 04:01:06PM -0500, Timur Tabi wrote:
>>> Scott Wood wrote:
>>>
It avoids confusion. I vote for renaming.
>>> Me too. How about fsl_wdt.c?
>>
>> fsl_wdt sounds too generic, I think i
Anton Vorontsov wrote:
On Mon, May 12, 2008 at 04:01:06PM -0500, Timur Tabi wrote:
Scott Wood wrote:
It avoids confusion. I vote for renaming.
Me too. How about fsl_wdt.c?
fsl_wdt sounds too generic, I think it would conflict with
at least booke_wdt.c.. no?
Yeah, that makes sense. What
On Mon, May 12, 2008 at 04:01:06PM -0500, Timur Tabi wrote:
> Scott Wood wrote:
>
>> It avoids confusion. I vote for renaming.
>
> Me too. How about fsl_wdt.c?
fsl_wdt sounds too generic, I think it would conflict with
at least booke_wdt.c.. no?
--
Anton Vorontsov
email: [EMAIL PROTECTED]
irc:
Scott Wood wrote:
It avoids confusion. I vote for renaming.
Me too. How about fsl_wdt.c?
Or we could come up with a name for that particular WDT device, like we
did with the 85xx DMA controller.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs
Anton Vorontsov wrote:
On Mon, May 12, 2008 at 02:24:20PM -0500, Kumar Gala wrote:
we should rename it to mpc8xxx_wdt.c
I don't see much sense in renaming the files just because the driver
now supports another line of processors... Do you really want the rename?
Please repeat if so.
It avoi
On Mon, May 12, 2008 at 02:24:20PM -0500, Kumar Gala wrote:
>
> On May 12, 2008, at 1:52 PM, Anton Vorontsov wrote:
>
>> On MPC86xx the watchdog could be enabled only at power-on-reset, and
>> could not be disabled afterwards. We must ping the watchdog from the
>> kernel until the userspace handles
Calls to copy_to_user() or copy_from_user() can fail
when copying N bytes, where N is a constant less than 8,
but not 1, 2, 4, or 8.
Signed-off-by: Dave Scidmore <[EMAIL PROTECTED]>
Signed-off-by: Nate Case <[EMAIL PROTECTED]>
---
include/asm-powerpc/uaccess.h |4 ++--
1 files changed, 2 inse
> -Original Message-
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of
Grant Likely
> Sent: Monday, May 12, 2008 12:46 PM
> To: Stephen Neuendorffer
> Cc: linuxppc-dev@ozlabs.org; git-dev
> Subject: Re: [PATCH] Xilinx: framebuffer: add compatibility for ml507
dvi core.
>
>
On Mon, May 12, 2008 at 1:10 PM, Stephen Neuendorffer
<[EMAIL PROTECTED]> wrote:
>
> The best possibility that I see is glopping the compatibility
> information about what cores are compatible with which drivers and
> generating something. This is moderately better than blindly treating
> all
Hi Kumar,
>> Also move the probe code into subsys_initcall, because we want start
>> pinging the watchdog ASAP, and misc devices are available in
>> subsys_initcall.
>>
>> Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
>> ---
>> drivers/watchdog/Kconfig |4 +-
>> drivers/watchdog/mpc8
On May 12, 2008, at 1:52 PM, Anton Vorontsov wrote:
On MPC86xx the watchdog could be enabled only at power-on-reset, and
could not be disabled afterwards. We must ping the watchdog from the
kernel until the userspace handles it.
MPC83xx CPUs are only differ in a way that watchdog could be disa
The best possibility that I see is glopping the compatibility
information about what cores are compatible with which drivers and
generating something. This is moderately better than blindly treating
all cores with the same major version as interface compatible, but still
has the potential to blin
Anton Vorontsov wrote:
+ enabled = in_be32(&wd_base->swcrr) & SWCRR_SWEN;
+#ifdef CONFIG_PPC_86xx
+ if (!enabled) {
+ dev_info(&dev->dev, "could not be enabled by software\n");
+ ret = -ENOSYS;
+ goto err_unmap;
+ }
+#endif
What happen
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
---
arch/powerpc/boot/dts/mpc8610_hpcd.dts |6 ++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/boot/dts/mpc8610_hpcd.dts
b/arch/powerpc/boot/dts/mpc8610_hpcd.dts
index 5030533..67fd2c7 100644
--- a/arch/pow
Since mpc83xx_wdt driver is able to handle MPC86xx watchdogs now,
we want to regster the device appropriately.
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
---
arch/powerpc/sysdev/fsl_soc.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/powerpc/sysdev/fsl_soc
On MPC86xx the watchdog could be enabled only at power-on-reset, and
could not be disabled afterwards. We must ping the watchdog from the
kernel until the userspace handles it.
MPC83xx CPUs are only differ in a way that watchdog could be disabled
once, but after it was enabled via software it beco
On Mon, May 12, 2008 at 11:31 AM, Stephen Neuendorffer
<[EMAIL PROTECTED]> wrote:
>
> Not easily. As we discussed before, there is nowhere that really
> specifies this information. In some cases I've modified the device tree
> generator to understand what is backward compatible, as with ns1655
Not easily. As we discussed before, there is nowhere that really
specifies this information. In some cases I've modified the device tree
generator to understand what is backward compatible, as with ns16550,
but for other cores it makes more sense to me to put this compatibility
information with
Francois Romieu wrote:
Julia Lawall <[EMAIL PROTECTED]> :
[...]
diff -u -p a/drivers/net/fs_enet/fs_enet-main.c
b/drivers/net/fs_enet/fs_enet-main.c
--- a/drivers/net/fs_enet/fs_enet-main.c2008-04-27 11:41:11.0
+0200
+++ b/drivers/net/fs_enet/fs_enet-main.c2008-05-12 09
Julia Lawall <[EMAIL PROTECTED]> :
[...]
> diff -u -p a/drivers/net/fs_enet/fs_enet-main.c
> b/drivers/net/fs_enet/fs_enet-main.c
> --- a/drivers/net/fs_enet/fs_enet-main.c 2008-04-27 11:41:11.0
> +0200
> +++ b/drivers/net/fs_enet/fs_enet-main.c 2008-05-12 09:41:52.0
>
Timur Tabi wrote:
> Update function of_find_property() to return NULL if the device_node passed
> to it is also NULL. Otherwise, passing NULL will cause a null pointer
> dereference.
>
> Signed-off-by: Timur Tabi <[EMAIL PROTECTED]>
Paul, please pick this up for 2.6.26. The legacy_serial driver
On Fri, 9 May 2008, Kumar Gala wrote:
>
> On May 8, 2008, at 3:22 PM, Sam Ravnborg wrote:
>
> > On Thu, May 08, 2008 at 09:16:10AM -0500, Kumar Gala wrote:
> > >
> > > On May 5, 2008, at 3:44 PM, Sam Ravnborg wrote:
> > >
> > > > > >
> > > > > >
> > > > > > Let me know if this does address your qu
On May 2, 2008, at 1:03 PM, Andy Fleming wrote:
Signed-off-by: Andy Fleming <[EMAIL PROTECTED]>
---
arch/powerpc/platforms/85xx/mpc85xx_mds.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
applied.
- k
___
Linuxppc-dev mailing list
Linu
On May 5, 2008, at 5:17 PM, Jeremy McNicoll wrote:
The following adds local bus, flash and MTD partition nodes for
sbc8548. As well, a compatible field for the soc node, so that
of_platform_bus_probe() will pick it up.
Something that is provided through this newly added epld node
is the Hardwa
On May 12, 2008, at 7:35 AM, Anton Vorontsov wrote:
DIU platform code should not just write to the PIXIS' BRDCFG0
register,
it should set and clear its own bits only, otherwise it will break
firmware setup (in fact it breaks second uart).
Also get rid of magic numbers in the related code.
S
On May 4, 2008, at 1:46 PM, Anton Vorontsov wrote:
This patch adds device tree nodes for NOR and NAND flashes and places
board-control node inside the localbus.
defconfig and board file updated appropriately.
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
---
Heh, this is v2. The flash s
On May 2, 2008, at 6:56 PM, Andy Fleming wrote:
The 8568 MDS needs some configuration changes to the PHY in order to
work properly. These are done in the firmware, normally, but Linux
shouldn't need to rely on the firmware running such things (someone
could disable the PHY support in the firmw
On Apr 29, 2008, at 10:53 AM, Anton Vorontsov wrote:
As of current mainline tree, TULIP driver is unusable on MPC8610HPCD
boards. There is a patch[1] floating around (and also included in the
BSP), which tries to heal the situation, though the ethernet is still
unusable. Practically it takes ag
On May 9, 2008, at 5:06 PM, Timur Tabi wrote:
Update the defconfig for the Freescale MPC8610 HPCD board. Enable
module
support. Disable support for all NICs except for the on-board
ULI526x.
Enable support for the Freescale DIU driver. Increase the maximum
zone order
to 12, so that the D
On Mon, 12 May 2008 15:38:26 +0200 (CEST)
Julia Lawall wrote:
> From: Julia Lawall <[EMAIL PROTECTED]>
Acked-by: Vitaly Bordug <[EMAIL PROTECTED]>
>
> The following code appears in the function fs_init_instance in the
> file drivers/net/fs_enet/fs_enet-main.c.
>
> if (fep->ops == NULL) {
On Mon, May 5, 2008 at 11:59 AM, Stephen Neuendorffer
<[EMAIL PROTECTED]> wrote:
> Signed-off-by: Stephen Neuendorffer <[EMAIL PROTECTED]>
> ---
> drivers/video/xilinxfb.c |1 +
> 1 files changed, 1 insertions(+), 0 deletions(-)
>
> diff --git a/drivers/video/xilinxfb.c b/drivers/video/xil
From: Julia Lawall <[EMAIL PROTECTED]>
The following code appears in the function fs_init_instance in the file
drivers/net/fs_enet/fs_enet-main.c.
if (fep->ops == NULL) {
printk(KERN_ERR DRV_MODULE_NAME
": %s No matching ops found (%d).\n",
On Fri, May 9, 2008 at 12:49 PM, Nick <[EMAIL PROTECTED]> wrote:
> Hi,
>
> I am writing a driver to service an interrupt from our fpga. I am calling
> request_irq in the open
> function of my driver. The fpga is connected to external interrupt 1. I am
> using interrupt
> number 65 in the re
Linus,
Please pull from the 'merge' branch of
git://git.kernel.org/pub/scm/linux/kernel/git/paulus/powerpc.git merge
to get 5 commits; one that fixes a compile problem for ARCH=powerpc,
and 4 that fix compile problems for ARCH=ppc. Since 2.6.26 will be
the last release that includes arch/ppc, w
DIU platform code should not just write to the PIXIS' BRDCFG0 register,
it should set and clear its own bits only, otherwise it will break
firmware setup (in fact it breaks second uart).
Also get rid of magic numbers in the related code.
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
---
arc
Hello,
in uboot i have setting the bootargs variable:
=> bootargs debug console=ttyPSC0,115200 root=/dev/ram
=> saveenv
If I'm not wrong, the right sequence of commands should be the following:
$ make ARCH=powerpc mpc5200_defconfig
$ make ARCH=powerpc menuconfig
.. [customizations]...
$ make A
50 matches
Mail list logo