Hi Kumar,
On Thu, 27 Mar 2008 07:45:06 -0500 Kumar Gala <[EMAIL PROTECTED]> wrote:
>
> On Mar 27, 2008, at 12:36 AM, Stephen Rothwell wrote:
> > This will remove some build warnings and doesn't stop us building any
> > drivers that we were building previously with these configs.
> >
> > Signed-off
On Thu, Mar 27, 2008 at 09:23:54PM -0500, Kumar Gala wrote:
>> I think this patch should probably go through the powerpc tree, or
>> -mm. I'll pick up the ones that touch either drivers/dma or
>> crypto/async_tx.
It's a good idea to cc all fsldma patches to linuxppc-dev when they're
posted too,
On Mar 27, 2008, at 7:39 PM, Badari Pulavarty wrote:
ppc kernel maintains information about logical memory blocks in
lmb.memory structure at the boot time. Its not updated for
hotplug memory add/remove. hotplug memory notifier for memory
add/remove now updates lmb.memory.
This information is us
The following features are supported:
plane 0 works as a regular frame buffer, can be accessed by /dev/fb0
plane 1 has two AOIs (area of interest), can be accessed by /dev/fb1 and
/dev/fb2
plane 2 has two AOIs, can be accessed by /dev/fb3 and /dev/fb4
Special ioctls support AOIs
All /dev/fb* can
Add platform code to support Freescale DIU. The platform code includes
framebuffer memory allocation, pixel format, monitor port, etc.
Signed-off-by: York Sun <[EMAIL PROTECTED]>
Signed-off-by: Timur Tabi <[EMAIL PROTECTED]>
---
This patch adds DIU platform support for MPC8610HPCD board, targeting
Thanks for the feedback. The following mails are the v4 patch to add Freescale
DIU framebuffer driver.
York
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
Ok. Thanks.
Acked-by: Yasunori Goto <[EMAIL PROTECTED]>
> Generic helper function to remove section mappings and sysfs entries
> for the section of the memory we are removing. offline_pages() correctly
> adjusted zone and marked the pages reserved.
>
> TODO: Yasunori Goto is working on patche
I'll send it to to.
> -Original Message-
> From: Kumar Gala [mailto:[EMAIL PROTECTED]
> Sent: Friday, March 28, 2008 10:24 AM
> To: Dan Williams
> Cc: Zhang Wei; Andrew Morton; Linux Kernel; linuxppc-dev@ozlabs.org
> Subject: Re: [PATCH] fsldma: The MPC8377MDS board device tree
> node f
On Mar 27, 2008, at 2:37 PM, Dan Williams wrote:
On Wed, Mar 26, 2008 at 12:42 AM, Zhang Wei
<[EMAIL PROTECTED]> wrote:
The fsldma driver is tested on MPC8377MDS board.
The patch adds fsldma driver support into MPC8377MDS device tree.
Signed-off-by: Zhang Wei <[EMAIL PROTECTED]>
---
arch/pow
Hi, Dan,
Sure. The patch can be just a reference to how to config and enable the fsldma
driver in dts file on MPC83xx boards.
Thanks!
Wei.
> -Original Message-
> From: [EMAIL PROTECTED]
> [mailto:[EMAIL PROTECTED] On Behalf Of Dan Williams
> Sent: Friday, March 28, 2008 3:38 AM
> To: Z
On Mar 27, 2008, at 7:45 PM, Michael Ellerman wrote:
On Fri, 2008-03-28 at 10:14 +1100, Paul Mackerras wrote:
Kumar Gala writes:
@@ -1124,7 +1124,7 @@ void __init early_init_devtree(void *params)
parse_early_param();
/* Reserve LMB regions used by kernel, initrd, dt, etc...
On Fri, Mar 28, 2008 at 12:17:33PM +1100, Michael Ellerman wrote:
> drivers/net/pasemi_mac.c is enabled by CONFIG_PASEMI_MAC, which depends on
> PPC64 && PCI. However pasemi_mac.c uses several routines that are only
> built when PPC_PASEMI is selected. This can lead to an unbuildable config:
>
>
drivers/net/pasemi_mac.c is enabled by CONFIG_PASEMI_MAC, which depends on
PPC64 && PCI. However pasemi_mac.c uses several routines that are only
built when PPC_PASEMI is selected. This can lead to an unbuildable config:
ERROR: ".pasemi_dma_start_chan" [drivers/net/pasemi_mac.ko] undefined!
So m
On Fri, 2008-03-28 at 10:14 +1100, Paul Mackerras wrote:
> Kumar Gala writes:
>
> > @@ -1124,7 +1124,7 @@ void __init early_init_devtree(void *params)
> > parse_early_param();
> >
> > /* Reserve LMB regions used by kernel, initrd, dt, etc... */
> > - lmb_reserve(PHYSICAL_START, __pa(kl
On Fri, 28 Mar 2008 10:56:18 +1100
David Gibson <[EMAIL PROTECTED]> wrote:
> On Thu, Mar 27, 2008 at 03:43:31PM +0100, Stefan Roese wrote:
> > This patch creates a common system reset routine for all 40x and 44x
> > systems. Previously only a 44x routine existed. But since this system
> > reset vi
On Thu, Mar 27, 2008 at 03:31:34PM +0100, Laurent Pinchart wrote:
> On Thursday 27 March 2008 11:03, David Gibson wrote:
> > On Thu, Mar 27, 2008 at 10:13:32AM +0100, Laurent Pinchart wrote:
> > > On Wednesday 26 March 2008 13:53, Sergei Shtylyov wrote:
> > > > Laurent Pinchart wrote:
> > [snip]
>
On Thu, Mar 27, 2008 at 03:23:46PM +0300, Sergei Shtylyov wrote:
> Hello.
>
> David Gibson wrote:
>
Laurent Pinchart wrote:
>
>> [snip]
>
Heh, we've gone thru "physmap" before -- it was labelled
Linux-specific name (well, I'd agree with that).
>
>>> physmap stands for physically
On Thu, Mar 27, 2008 at 03:43:31PM +0100, Stefan Roese wrote:
> This patch creates a common system reset routine for all 40x and 44x
> systems. Previously only a 44x routine existed. But since this system
> reset via the debug control register is common for 40x and 44x let's
> share this code for a
Provide walk_memory_resource() for ppc64. PPC maintains
logic memory region mapping in lmb.memory structures. Walk
through these structures and do the callbacks for the
contiguous chunks.
Signed-off-by: Badari Pulavarty <[EMAIL PROTECTED]>
---
arch/powerpc/mm/mem.c | 30 +++
ppc kernel maintains information about logical memory blocks in
lmb.memory structure at the boot time. Its not updated for
hotplug memory add/remove. hotplug memory notifier for memory
add/remove now updates lmb.memory.
This information is useful for eHEA driver to find out the memory
layout and
Hotplug memory notifier for ppc64. This gets invoked by writing
the device-node that needs to be removed to /proc/ppc64/ofdt.
We need to adjust the sections and remove sysfs entries by
calling __remove_pages(). Then call arch specific code to
get rid of htab mappings for the section of memory.
Sig
If the sub-arch doesn't support hpte_removebolted(), gracefully
return failure rather than success.
Signed-off-by: Badari Pulavarty <[EMAIL PROTECTED]>
---
arch/powerpc/mm/hash_utils_64.c | 14 +-
include/asm-powerpc/sparsemem.h |2 +-
2 files changed, 10 insertions(+), 6 deleti
Generic helper function to remove section mappings and sysfs entries
for the section of the memory we are removing. offline_pages() correctly
adjusted zone and marked the pages reserved.
TODO: Yasunori Goto is working on patches to freeup allocations from bootmem.
Signed-off-by: Badari Pulavart
Hi Andrew & Paul,
Here are the updates for hotplug memory remove. Most changes are
PPC specific, but I would like these to be included in next -mm
for easy testing and review, before including in Paul's tree.
eHEA driver folks are verifying if the exported interface
walk_memory_resource() is good
Kumar Gala writes:
> @@ -1124,7 +1124,7 @@ void __init early_init_devtree(void *params)
> parse_early_param();
>
> /* Reserve LMB regions used by kernel, initrd, dt, etc... */
> - lmb_reserve(PHYSICAL_START, __pa(klimit) - PHYSICAL_START);
> + lmb_reserve(__pa(_stext), _end -
Linus,
Olof Johansson has a defconfig update for the pasemi platform that he
would like to have in 2.6.25, so please do:
git pull \
git://git.kernel.org/pub/scm/linux/kernel/git/paulus/powerpc.git merge
Thanks,
Paul.
arch/powerpc/configs/pasemi_defconfig | 142
Add netpoll support to allow use of netconsole.
Signed-off-by: Nate Case <[EMAIL PROTECTED]>
Signed-off-by: Olof Johansson <[EMAIL PROTECTED]>
---
Changed the interrupt handler arguments as found by Valentine. Will push
through powerpc.git with Jeff's ACKs (that were already given).
-Olof
On Thu, 2008-03-27 at 20:02 +0900, Ishizaki Kou wrote:
>
> > I'll try to have a closer look next week, but I'm a bit worried by
> > having all IO go through 2 level of function pointers, the PPE isn't
> > very good at it and this will slow things down more than they
> already
> > are.
>
> Only o
Improve the debugging support of the PS3 bootwraper code:
o Increase the size of the PS3 bootwrapper overlay from 256 to 512 bytes to
allow for more debugging code in the overlay.
o Use the dot symbol to set the size of __system_reset_overlay. The
assembler will then emit an error if the
Incidentally I used some weird .config without preemption and
CONFIG_ENABLE_MUST_CHECK. Heh.
[...]
> + * I don't have specifications for the MCU firmware that is used on the
> + * MPC8349E-mITX/MPC837XRDB boards, I found this register and bits positions
> + * by the trial&error method.
> + */
> +#
* use _stext and _end sybmols when reserving kernel text in the lmb. Use
of these symbols is a bit more robust way to determine the physical start
and size of the kernel text.
* PAGE_OFFSET is not always the start of code, use _stext instead.
* grab PAGE_SIZE and KERNELBASE from asm/page.h lik
Olof Johansson wrote:
On Wed, Mar 26, 2008 at 12:12:30AM -0400, Jeff Garzik wrote:
Olof Johansson wrote:
Hi Jeff,
The below two patches go on top of the previous patches that were acked
by you but applied to pasemi.git for feed up through powerpc.git.
One is a couple of fixes for various corn
On Wed, Mar 26, 2008 at 12:42 AM, Zhang Wei <[EMAIL PROTECTED]> wrote:
> The fsldma driver is tested on MPC8377MDS board.
> The patch adds fsldma driver support into MPC8377MDS device tree.
>
> Signed-off-by: Zhang Wei <[EMAIL PROTECTED]>
> ---
> arch/powerpc/boot/dts/mpc8377_mds.dts | 27 ++
On Wed, Mar 26, 2008 at 12:12:30AM -0400, Jeff Garzik wrote:
> Olof Johansson wrote:
>> Hi Jeff,
>>
>> The below two patches go on top of the previous patches that were acked
>> by you but applied to pasemi.git for feed up through powerpc.git.
>>
>> One is a couple of fixes for various corner cases
Bartlomiej Zolnierkiewicz wrote:
hdparm explicitely marks HDIO_[UNREGISTER,SCAN]_HWIF ioctls as DANGEROUS
and given the number of bugs we can assume that there are no real users:
* DMA has no chance of working because DMA resources are released by
ide_unregister() and they are never allocat
On Wed, Mar 26, 2008 at 11:24:53PM +0300, Anton Vorontsov wrote:
> Despite leds-gpio and leds-of-gpio similar names and purposes, there
> is actually very few code can be shared between the two (both drivers
> are mostly the driver bindings anyway).
>
> Signed-off-by: Anton Vorontsov <[EMAIL PROTE
On Thu, Mar 27, 2008 at 01:56:11AM +0300, Anton Vorontsov wrote:
> On Wed, Mar 26, 2008 at 03:56:37PM -0500, Timur Tabi wrote:
> > Anton Vorontsov wrote:
> >
> > > +config MCU_MPC837XRDB
> > > + tristate "MPC837XRDB MCU driver"
> > > + depends on I2C && MPC837x_RDB && OF_GPIO
> >
> > The MPC8349E
On Wed, Mar 26, 2008 at 11:25:11PM +0300, Anton Vorontsov wrote:
> On the MPC837xRDB boards there is MC9S08QG8 (MCU) chip with the custom
> firmware pre-programmed. This firmware offers to control some of the MCU
> GPIO pins via I2C (two pins, connected to the LEDs, but also available
> from the J2
Timur Tabi wrote:
> This patch enables the FORCE_MAX_ZONEORDER Kconfig option for all PowerPC
> systems. Previously, it was enabled only for 64-bit systems. We also make
> the option selectable from the menu, so that the user can specify different
> values. This is useful for 32-bit systems that
On Thu, Mar 27, 2008 at 10:10:33AM +0100, Laurent Pinchart wrote:
> On Wednesday 26 March 2008 17:59, Scott Wood wrote:
> > This breaks the bootwrapper console.
>
> And of course I forgot about that :-)
>
> The boot wrapper code doesn't have any dpram allocator. Any objection against
> using a c
Since the arch/powerpc PCI subsystem now does a complete re-assignment of
the resources, we can move from the unconditional PCIe PHY reset to the
conditional version. Now the PHY is only reset, if no link is established yet.
An additional PHY reset (one is already done in U-Boot) leads to problems
The PowerPC 440GX Taishan board fails to reset EMAC3 (reset timeout error)
if there's no link. Because of that it fails to find PHY chip. The older
ibm_emac
driver had a workaround for that: the EMAC_CLK_INTERNAL/EMAC_CLK_EXTERNAL
macros,
which toggle the Ethernet Clock Select bit in the SDR0_MFR
This patch adds ibm_newemac PHY clock workaround for 440EP/440GR EMAC
attached to a PHY which doesn't generate RX clock if there is no link.
The code is based on the previous ibm_emac driver stuff. The 440EP/440GR
allows controlling each EMAC clock separately as opposed to global clock
selection fo
Move the "&& skb->ip_summed == CHECKSUM_PARTIAL" part out of
emac_has_feature parameters.
Signed-off-by: Valentine Barshak <[EMAIL PROTECTED]>
---
drivers/net/ibm_newemac/core.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff -pruN linux-2.6.orig/drivers/net/ibm_newemac/core.c
This patch creates a common system reset routine for all 40x and 44x
systems. Previously only a 44x routine existed. But since this system
reset via the debug control register is common for 40x and 44x let's
share this code for all those platforms in ppc4xx_soc.c.
This patch also enables CONFIG_4x
On Thursday 27 March 2008 11:03, David Gibson wrote:
> On Thu, Mar 27, 2008 at 10:13:32AM +0100, Laurent Pinchart wrote:
> > On Wednesday 26 March 2008 13:53, Sergei Shtylyov wrote:
> > > Laurent Pinchart wrote:
> [snip]
> > > Heh, we've gone thru "physmap" before -- it was labelled
> > > L
On Thu, 27 Mar 2008 16:50:14 +0300
Valentine Barshak <[EMAIL PROTECTED]> wrote:
> Josh Boyer wrote:
> > On Tue, 25 Mar 2008 10:22:15 +1100
> > Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote:
> >
> >> On Thu, 2008-03-06 at 16:43 +0300, Valentine Barshak wrote:
> >>> This patch adds ibm_newemac P
Josh Boyer wrote:
On Tue, 25 Mar 2008 10:22:15 +1100
Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote:
On Thu, 2008-03-06 at 16:43 +0300, Valentine Barshak wrote:
This patch adds ibm_newemac PHY clock workaround for 440EP/440GR EMAC
attached to a PHY which doesn't generate RX clock if there is
On Wed, Mar 26, 2008 at 10:15 AM, Matt Sealey <[EMAIL PROTECTED]> wrote:
> I've just been looking into the MPC5200B AC97 driver breakage with the
> latest Git kernel, and found the following patch;
>
> http://ozlabs.org/pipermail/linuxppc-dev/2007-May/035952.html
>
> Is not in the latest tree. A
On Wed, Mar 26, 2008 at 10:48 AM, Matt Sealey <[EMAIL PROTECTED]> wrote:
> Oh yes, I forgot.. also, the new MPC5121E stuff includes a lot of unions and
> defines to make using both PSC formats easier.
>
> Since the MPC5200 and MPC5200B PSC structures are different (CCR size), can
> the
> origin
On Mar 27, 2008, at 12:36 AM, Stephen Rothwell wrote:
This will remove some build warnings and doesn't stop us building any
drivers that we were building previously with these configs.
Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]>
Doesn't this hide issues on the defconfigs most often bu
Hi Paul,
Please pull from:
master.kernel.org:/pub/scm/linux/kernel/git/jwboyer/powerpc-4xx.git for-2.6.26
to pick up the first round of 4xx patches for 2.6.26. There are a few
new board ports, some Xilinx driver updates, and some DCR helper
macros.
Grant has two bootwrapper patches that I wou
Hello.
David Gibson wrote:
Laurent Pinchart wrote:
[snip]
Heh, we've gone thru "physmap" before -- it was labelled Linux-specific
name (well, I'd agree with that).
physmap stands for physically mapped. That doesn't sound
Linux-specific to me, the fact that the MTD driver has the sam
Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote:
> I may have missed something in your patch but if the workarounds are
> specific to a given bridge, they may as well set the top level
> indirections once straight to the right workarounds.
>
> Also, my understanding is that we are pretty much usi
On Thu, Mar 27, 2008 at 10:13:32AM +0100, Laurent Pinchart wrote:
> On Wednesday 26 March 2008 13:53, Sergei Shtylyov wrote:
> > Laurent Pinchart wrote:
[snip]
> > Heh, we've gone thru "physmap" before -- it was labelled Linux-specific
> > name (well, I'd agree with that).
>
> physmap stands
On Thu, Mar 27, 2008 at 10:37:17AM +0100, Laurent Pinchart wrote:
> On Wednesday 26 March 2008 15:52, Segher Boessenkool wrote:
> > > +Dedicated RAM and ROM chips are often used as storage for
> > > temporary or
> > > +permanent data in embedded devices. Possible usage include
> > > non-v
On Wednesday 26 March 2008 15:52, Segher Boessenkool wrote:
> > +Dedicated RAM and ROM chips are often used as storage for
> > temporary or
> > +permanent data in embedded devices. Possible usage include
> > non-volatile
> > +storage in battery-backed SRAM, semi-permanent storage in
On Wednesday 26 March 2008 16:34, Segher Boessenkool wrote:
> >>> {
> >>> +.compatible= "physmap-ram",
> >>> +.data= (void *)"map_ram",
> >>> +},
> >>> +{
> >>> +.compatible= "physmap-rom",
> >>> +.data= (void *)"map_rom",
> >>> +
On Wednesday 26 March 2008 16:40, Sergei Shtylyov wrote:
> Segher Boessenkool wrote:
>
> >> - Using another device node with a compatible value set to
> >> "linear-ram" (or
> >> something similar). This would support both volatile and non-volatile
> >> devices, and a property could be added to sp
On Wednesday 26 March 2008 13:53, Sergei Shtylyov wrote:
> Laurent Pinchart wrote:
>
> >>>Regarding non-volatility nothing prevents a user from using a
> >>>volatile RAM as an MTD device, but there's little point in doing so.
> >>>Would it be acceptable for the "linear-nvram" specification
> >>>n
On Wednesday 26 March 2008 17:59, Scott Wood wrote:
> Laurent Pinchart wrote:
> > @@ -138,7 +137,7 @@
> > device_type = "serial";
> > compatible = "fsl,mpc8248-smc-uart",
> > "fsl,cpm2-smc-uart";
> > -
On Wednesday 26 March 2008 16:57, Scott Wood wrote:
> On Wed, Mar 26, 2008 at 12:20:42PM +0100, Laurent Pinchart wrote:
> > diff --git a/arch/powerpc/boot/dts/ep8248e.dts
b/arch/powerpc/boot/dts/ep8248e.dts
> > index 5d2fb76..756758f 100644
> > --- a/arch/powerpc/boot/dts/ep8248e.dts
> > +++ b/arc
On Wed, 26 Mar 2008, Geoff Levand wrote:
> --- a/arch/powerpc/boot/ps3.c
> +++ b/arch/powerpc/boot/ps3.c
> }
>
> -void platform_init(void)
> +void platform_init(unsigned long null_check)
> {
> const u32 heapsize = 0x100 - (u32)_end; /* 16
On Tue, 25 Mar 2008 16:27:17 -0500 York Sun <[EMAIL PROTECTED]> wrote:
> +#if defined(CONFIG_NOT_COHERENT_CACHE)
> +unsigned int *coherence_data;
> +phys_addr_t *coherence_data_phy;
> +#endif
These identifiers are too general for use as global symbols. I'd suggest
renaming them to diu_coherence_
64 matches
Mail list logo