Hi, Matt,
So glad to see you again!
> -Original Message-
> From: Matt Porter [mailto:[EMAIL PROTECTED]
> On Thu, Jan 31, 2008 at 02:30:13PM +0800, Zhang Wei wrote:
> > > -Original Message-
> > > From: Kumar Gala [mailto:[EMAIL PROTECTED]
> > > when we have multiple ports are the
> -Original Message-
> From: Kumar Gala [mailto:[EMAIL PROTECTED]
>
>
> On Feb 4, 2008, at 11:44 PM, Stephen Rothwell wrote:
>
> >>
> >> + aw = *(u32 *)of_get_property(dev->node, "#address-cells", NULL);
> >> + sw = *(u32 *)of_get_property(dev->node, "#size-cells", NULL);
> >
> > W
Since fdt_node_offset_by_compatible() was converted to the new
fdt_next_node() iterator, a chunk of initialization code became
redundant, but was not removed by oversight. This patch cleans it up.
Signed-off-by: David Gibson <[EMAIL PROTECTED]>
Index: dtc/libfdt/fdt_ro.c
Currently the CHECK_HEADER() macro is defined local to fdt_ro.c.
However, there are a handful of functions (fdt_move, rw_check_header,
fdt_open_into) from other files which could also use it (currently
they open-code something more-or-less identical). Therefore, this
patch moves CHECK_HEADER() to
Add hypervisor-assisted dump to kernel config
Signed-off-by: Linas Vepstas <[EMAIL PROTECTED]>
-
arch/powerpc/Kconfig | 11 +++
1 file changed, 11 insertions(+)
Index: 2.6.25-rc1/arch/powerpc/Kconfig
===
--- 2.6.25-
This patch tracks the size freed. For now it does a simple
rudimentary calculation of the ranges freed. The idea is
to keep it simple at the external shell script level and
send in large chunks for now.
Signed-off-by: Manish Ahuja <[EMAIL PROTECTED]>
-
---
arch/powerpc/platforms/pseries/ph
Routines to
a. invalidate dump
b. Calculate region that is reserved and needs to be freed. This is
exported through sysfs interface.
Unregister has been removed for now as it wasn't being used.
Signed-off-by: Manish Ahuja <[EMAIL PROTECTED]>
-
---
arch/powerpc/platforms/pseries/phyp_
Provide some basic debugging support.
Signed-off-by: Manish Ahuja <[EMAIL PROTECTED]>
Signed-off-by: Linas Vepstas <[EMAIL PROTECTED]>
-
arch/powerpc/platforms/pseries/phyp_dump.c | 61 -
1 file changed, 59 insertions(+), 2 deletions(-)
Index: 2.6.25-rc1/arch/
Set up the actual dump header, register it with the hypervisor.
Signed-off-by: Manish Ahuja <[EMAIL PROTECTED]>
Signed-off-by: Linas Vepstas <[EMAIL PROTECTED]>
--
arch/powerpc/platforms/pseries/phyp_dump.c | 137 +++--
1 file changed, 131 insertions(+), 6 deletions
Check to see if there actually is data from a previously
crashed kernel waiting. If so, Allow user-sapce tools to
grab the data (by reading /proc/kcore). When user-space
finishes dumping a section, it must release that memory
by writing to sysfs. For example,
echo "0x4000 0x1000" > /s
Initial patch for reserving memory in early boot, and freeing it later.
If the previous boot had ended with a crash, the reserved memory would contain
a copy of the crashed kernel data.
Signed-off-by: Manish Ahuja <[EMAIL PROTECTED]>
Signed-off-by: Linas Vepstas <[EMAIL PROTECTED]>
arch/po
Basic documentation for hypervisor-assisted dump.
Signed-off-by: Linas Vepstas <[EMAIL PROTECTED]>
Signed-off-by: Manish Ahuja <[EMAIL PROTECTED]>
Documentation/powerpc/phyp-assisted-dump.txt | 127 +++
1 file changed, 127 insertions(+)
Index: 2.6.25-rc1/Documenta
In light of the recently discovered bug with NOP handling, this adds
some more testcases for NOP handling. Specifically, it adds a helper
program which will add a NOP tag after every existing tag in a dtb,
and runs the standard battery of tests over trees mangled in this way.
For now, this does n
The following series of patches implement a basic framework
for hypervisor-assisted dump. The very first patch provides
documentation explaining what this is :-) . Yes, its supposed
to be an improvement over kdump.
A list of open issues / todo list is included in the documentation.
It also appea
On Saturday, 16 of February 2008, Kamalesh Babulal wrote:
> Hi,
Hi,
> The softlockup is seen from 2.6.25-rc1-git{1,3} and is visible in the
> 2.6.24-rc2 kernel,
> While booting up with the 2.6.25-rc1-git{1,3} and 2.6.25-rc2 kernel(s) on the
> powerbox
Can you update the Bugzilla entry at:
htt
On Sat, Feb 16 2008, Kamalesh Babulal wrote:
> Hi,
>
> The softlockup is seen from 2.6.25-rc1-git{1,3} and is visible in the
> 2.6.24-rc2 kernel,
> While booting up with the 2.6.25-rc1-git{1,3} and 2.6.25-rc2 kernel(s) on the
> powerbox
>
> Loading st.ko module
> BUG: soft lockup - CPU#1 stuck
something about this doesn't look right:
$ grep -rw extra-aflags-y *
arch/ppc/boot/simple/Makefile:EXTRA_AFLAGS := $(extra-aflags-y)
$
AFAIK, there is no supported "extra-aflags-y" variable. and
EXTRA_AFLAGS is deprecated in favour of asflags-y anyway, no?
rday
--
On Sat, 2008-02-16 at 10:39 -0800, Arjan van de Ven wrote:
> > >> > you found a great set of bugs..
> > >> > but to be honest... I suspect it's just best to remove unlikely
> > >> > altogether for these cases; unlikely() is almost a
> > >> > go-faster-stripes thing, and if you don't know how to use
Hi Sean,
On Sat, 16 Feb 2008 15:54:14 -0500, Sean MacLennan wrote:
> Jean Delvare wrote:
> > Hi Sean,
> >
> > On Fri, 15 Feb 2008 23:11:12 -0500, Sean MacLennan wrote:
> >
> >> Here is the of platform patch. I removed the retries and removed the
> >> spaces used for spacing.
> >>
> >> Cheers,
On Feb 16, 2008 9:58 AM, Willy Tarreau <[EMAIL PROTECTED]> wrote:
> Last but not least, gcc 4 tends to emit stupid checks, to the point that I
> have replaced unlikely(x) with (x) in my code when gcc >= 4 is detected. What
> I observe is that the following code :
>
> if (unlikely(p == NULL)) ..
On Tue, 2008-02-12 at 13:10 -0600, Scott Wood wrote:
> Hmm? All I meant was that it'd be nice if there were an option in the
> Linux mtd code to disable the "look for another chip and cause a machine
> check if it isn't there" functionality. It was an aside from the
> dts-variant issue.
Yeah
On Sun, Feb 17, 2008 at 01:45:23AM -0800, Andrew Pinski wrote:
> On Feb 16, 2008 9:58 AM, Willy Tarreau <[EMAIL PROTECTED]> wrote:
> > Last but not least, gcc 4 tends to emit stupid checks, to the point that I
> > have replaced unlikely(x) with (x) in my code when gcc >= 4 is detected.
> > What
>
On Fri, 15 Feb 2008, Anton Vorontsov wrote:
> On Thu, Feb 14, 2008 at 10:49:42PM -0800, Andrew Morton wrote:
> > On Tue, 5 Feb 2008 18:44:32 +0300 Anton Vorontsov <[EMAIL PROTECTED]> wrote:
> > > This patch adds support for the framebuffers with non-native
> > > endianness. This is done via FBINFO_
23 matches
Mail list logo