This patch alters the kernel makefiles to build dtc from the sources
embedded in the previous patch. It also changes the
arch/powerpc/boot/wrapper script to use the embedded dtc, rather than
expecting a copy of dtc already installed on the system.
Signed-off-by: David Gibson <[EMAIL PROTECTED]>
This large patch incorporates a copy of dtc into the kernel source, in
arch/powerpc/boot/dtc-src. This patch only imports the upstream
sources verbatim, a later patches is needed to actually link it into
the kernel Makefiles and use the embedded code during the kernel
build.
Signed-off-by: David
Here is a revised set of patches to merge dtc into the kernel tree.
The various methods suggested for doing some sort of automagic git
pull of the dtc repository into the kernel git all appear to me to be
more trouble than they're worth at this stage. So, at this stage this
is just a raw patch im
The remaining old-style tree checking code: check_root(), check_cpus()
and check_memory() really aren't that useful. They mostly check for
the presence of particular nodes and properties. That's inherently
prone to false-positives, because we could be dealing with an
artificial tree (like many of
On Mon, Dec 17, 2007 at 11:03:04AM -0600, Scott Wood wrote:
> On Mon, Dec 17, 2007 at 04:14:03PM +1100, David Gibson wrote:
[snip]
> > These phy nodes have basically no information in them. PHY nodes are
> > optional -
>
> If they are truly optional, then several Linux drivers (including ucc_geth
Convert pfc8563 i2c driver from old style to new style. The
driver is also modified to support device tree names via the
i2c mod alias mechanism.
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
---
drivers/r
This patch modifies the ds1307, ds1374, and rs5c372 i2c drivers to support
device tree names using the new i2c mod alias support
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
---
arch/powerpc/sysdev/fsl_so
Hi,
I am considering raising the limit on the size of postings to 400k. Does
anyone have a real problem with this? Limiting message size was done to
limit the damage of larges spams (and we don;t get very many of those on
the list) and to ease the pain for people downloading emails over a slow
(
Ignore this patch, I forgot to remove it before mailing the series.
On 12/17/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
>
> Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
> ---
>
> Makefile |3 +++
> 1 files changed, 3 insertions(+), 0 deletions(-)
>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
---
Makefile |3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/Makefile b/Makefile
index c1825aa..15ada3f 100644
--- a/Makefile
+++ b/Makefile
@@ -35,6 +35,9 @@ MAKEFLAGS += -rR --
Follow on to: "Series to add device tree naming to i2c"
Teach module-init-tools about the i2c subsystem.
diff --git a/depmod.c b/depmod.c
index 0281c79..209eb0c 100644
--- a/depmod.c
+++ b/depmod.c
@@ -793,6 +793,7 @@ static struct depfile depfiles[] = {
{ "modules.inputmap", output_input_
Return errors that were being ignored in the mpc-i2c driver
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
---
drivers/i2c/busses/i2c-mpc.c | 30 +-
1 files changed, 17 inserti
This patch allows new style i2c chip drivers to have alias names using
the official kernel aliasing system and MODULE_DEVICE_TABLE(). I've
tested it on PowerPC and x86. This change is required for PowerPC
device tree support.
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <
Convert MPC i2c driver from being a platform_driver to an open firmware
version. Error returns were improved. Routine names were changed from fsl_ to
mpc_ to make them match the file name.
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by:
Temporarily copy the mpc-i2c driver to continue support for the ppc
architecture until it is removed in mid-2008. This file should be deleted as
part of ppc's final removal.
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMAIL PROTECTED]>
Signed-off-by: Jon Smirl <[EMA
Another rework of the i2c for powerpc device tree patch. This version
implements standard alias naming only on the powerpc platform and only for the
device tree names. The old naming mechanism of i2c_client.name,driver_name is
left in place and not changed for non-powerpc platforms. This patch i
Olof Johansson wrote:
> Forgot to export this one. Needed when pasemi_mac is compiled as a module.
>
> Signed-off-by: Olof Johansson <[EMAIL PROTECTED]>
>
> ---
>
> Jeff, since the dma_lib stuff went up through netdev-2.6, please apply and
> feed this one up with the rest.
>
>
> Thanks,
>
> O
On Mon, Dec 17, 2007 at 09:18:13AM -0600, Scott Wood wrote:
> David Gibson wrote:
> > As I think I said about another tree, this mdio-under-bcsr arrangement
> > is pretty strange. What's going on here.
>
> As I answered then, it's just the way the hardware is. I didn't design
> it. :-P
I obvio
On Mon, Dec 17, 2007 at 09:15:17AM -0600, Scott Wood wrote:
> David Gibson wrote:
> > On Wed, Dec 12, 2007 at 04:54:27PM -0600, Scott Wood wrote:
> >> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> > [snip]
> >> diff --git a/arch/powerpc/boot/dts/adder875-redboot.dts
> >> b/arch/powerpc/boot/dts/
On Mon, 2007-12-17 at 11:02 +0100, Christoph Hellwig wrote:
> On Mon, Dec 17, 2007 at 05:35:53PM +1100, Michael Ellerman wrote:
> > To save adding a hook to the dma mapping ops, pci-set_consistent_dma_mask()
> > simply calls the dma_set_mask() hook and then copies the new mask into
> > dev.coheren
This now better describes what the UBoot device tree generator
actually does. In particular:
1) Nodes have a label derived from the device name, and a node name
derived from a generic version of the device type, e.g. 'ethernet',
'serial', etc.
2) Usage of compound nodes (representing more than o
I've updated the generator based on the below feedback. I'll also send
around the updated patch for this section briefly. Comments below.
> -Original Message-
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of
> Grant Likely
> Sent: Monday, December 17, 2007 7:20 AM
> To:
On Mon, 17 Dec 2007 17:04:34 -0600
Olof Johansson <[EMAIL PROTECTED]> wrote:
> There's nothing in holly.c that needs linux/ide.h, just remove it from
> the list of includes.
>
> Signed-off-by: Olof Johansson <[EMAIL PROTECTED]>
Acked-by: Josh Boyer <[EMAIL PROTECTED]>
josh
__
On Mon, Dec 17, 2007 at 06:24:55PM -0500, Jeff Garzik wrote:
> > Index: 2.6.24/arch/powerpc/platforms/pasemi/dma_lib.c
> > ===
> > --- 2.6.24.orig/arch/powerpc/platforms/pasemi/dma_lib.c
> > +++ 2.6.24/arch/powerpc/platforms/pasemi/dma
Olof Johansson wrote:
> Forgot to export this one. Needed when pasemi_mac is compiled as a module.
>
> Signed-off-by: Olof Johansson <[EMAIL PROTECTED]>
>
> ---
>
> Jeff, since the dma_lib stuff went up through netdev-2.6, please apply and
> feed this one up with the rest.
>
>
> Thanks,
>
> O
Jochen Friedrich wrote:
> This patch adds support to use the fixed-link property
> of an ethernet node to fs_enet for the
> CONFIG_PPC_CPM_NEW_BINDING case.
>
> Signed-off-by: Jochen Friedrich <[EMAIL PROTECTED]>
> ---
> drivers/net/fs_enet/fs_enet-main.c |9 -
> 1 files changed, 8 in
There's nothing in holly.c that needs linux/ide.h, just remove it from
the list of includes.
Signed-off-by: Olof Johansson <[EMAIL PROTECTED]>
Index: mm/arch/powerpc/platforms/embedded6xx/holly.c
===
--- mm.orig/arch/powerpc/platfor
On Mon, Dec 17, 2007 at 09:53:31PM +0100, Bartlomiej Zolnierkiewicz wrote:
>
> Hi,
>
> applied but...
>
> > ---
> >
> > On Sun, Nov 18, 2007 at 11:25:09PM +0100, Bartlomiej Zolnierkiewicz wrote:
> > >
> > > * Rename ide_device_add() to ide_device_add_all() and make it accept
> > > 'u8 idx[MA
On Mon, Dec 17, 2007 at 11:40:08AM -0800, Joe Perches wrote:
>
> Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
> ---
> drivers/net/wireless/atmel.c |2 +-
> drivers/net/wireless/bcm43xx/bcm43xx_debugfs.h |2 +-
> drivers/net/wireless/ipw2200.c |2 +-
On Mon, 2007-12-17 at 21:56 +0100, Stefano Brivio wrote:
> On Mon, 17 Dec 2007 11:40:08 -0800
> Joe Perches <[EMAIL PROTECTED]> wrote:
> > diff --git a/drivers/net/ucc_geth_ethtool.c
> b/drivers/net/ucc_geth_ethtool.c
> > index 9a9622c..f8d319b 100644
> > --- a/drivers/net/ucc_geth_ethtool.c
> > ++
On Mon, 17 Dec 2007 11:40:08 -0800
Joe Perches <[EMAIL PROTECTED]> wrote:
> diff --git a/drivers/net/ucc_geth_ethtool.c b/drivers/net/ucc_geth_ethtool.c
> index 9a9622c..f8d319b 100644
> --- a/drivers/net/ucc_geth_ethtool.c
> +++ b/drivers/net/ucc_geth_ethtool.c
> @@ -7,7 +7,7 @@
> *
> * Limit
On Mon, 2007-12-17 at 11:40 -0800, Joe Perches wrote:
> drivers/net/wireless/libertas/cmd.c|4 ++--
> drivers/net/wireless/libertas/scan.c |4 ++--
I will apply these to the libertas tree; please remove them from any
resend of this patch.
If we were using git properl
Maxim Shchetynin <[EMAIL PROTECTED]> wrote:
> +config AZ_FS
> +tristate "AZFS filesystem support"
> +default m
^
STRONG NACK, I hate digging in the menu tree and hunting for things I
don't need.
> +help
> + Non-buffered files
Anton Vorontsov wrote:
> Commit ed7e63a51d46e835422d89c687b8a3e419a4212a has tried to fix
> section mismatch:
>
> WARNING: vmlinux.o(.init.text+0x17278): Section mismatch: reference to
> .exit.text:uec_mdio_exit (between 'ucc_geth_init' and 'uec_mdio_init')
>
> But that mismatch still happens.
>
On Mon, 17 Dec 2007 12:48:17 -0600
Scott Wood wrote:
> Vitaly Bordug wrote:
> > On Mon, 17 Dec 2007 11:03:04 -0600 Scott Wood wrote:
> >>> These phy nodes have basically no information in them. PHY nodes
> >>> are optional -
> >> If they are truly optional, then several Linux drivers (including
On Mon, 2007-12-17 at 23:42 +0300, Vitaly Bordug wrote:
> I'm not really sure we should still care about typos in
> arch/ppc..
Fine by me. I heard tell of a desire to integrate or
rework the power/ppc arches anyway. cheers, Joe
___
Linuxppc-dev mailin
Hi,
On Friday 14 December 2007, Olof Johansson wrote:
> Fix build break of powerpc holly_defconfig:
Sorry for breaking the hol[l]y powerpc platform. ;)
> In file included from arch/powerpc/platforms/embedded6xx/holly.c:24:
> include/linux/ide.h:1206: error: 'CONFIG_IDE_MAX_HWIFS' undeclared her
On Mon, 17 Dec 2007 11:30:14 -0800
Joe Perches wrote:
>
> Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
> ---
> arch/ppc/syslib/ppc8xx_pic.c |2 +-
> arch/ppc/syslib/ppc_sys.c|2 +-
I'm not really sure we should still care about typos in
arch/ppc..
--
Sincerely, Vitaly
__
On Mon, 2007-12-17 at 19:45 +0100, Maxim Shchetynin wrote:
> please, have a look at the following patch. This is a first version of a
> non-buffered filesystem to be used on "ioremapped" devices.
> Thank you in advance for your comments.
Dude, your patch is line-wrapped to hell. Please don't use
...and here once more the same patch as attachment...
(See attached file: linux-2.6.24-rc4-azfs.diff.gz)
Mit freundlichen Grüßen / met vriendelijke groeten / avec regards
Maxim V. Shchetynin
Linux Kernel Entwicklung
IBM Deutschland Entwicklung GmbH
Linux für Cell, Abteilung 325
Hello,
please, have a look at the following patch. This is a first version of a
non-buffered filesystem to be used on "ioremapped" devices.
Thank you in advance for your comments.
Subject: azfs: initial submit of azfs, a non-buffered filesystem
From: Maxim Shchetynin <[EMAIL PROTECTED]>
Non-bu
Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
---
drivers/usb/atm/ueagle-atm.c|2 +-
drivers/usb/class/cdc-acm.c |2 +-
drivers/usb/gadget/at91_udc.h |2 +-
drivers/usb/gadget/fsl_usb2_udc.c |2 +-
drivers/usb/gadget/omap_udc.c |2 +-
drivers/usb
On Mon, 17 Dec 2007 11:30:12 -0800
Joe Perches <[EMAIL PROTECTED]> wrote:
>
> Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
> ---
> arch/powerpc/boot/4xx.c |2 +-
> arch/powerpc/kernel/legacy_serial.c |2 +-
> arch/powerpc/sysdev/bestcomm/bestcomm.h |2 +-
> arch
>+config AZ_FS
>+ tristate "AZFS filesystem support"
>+ default m
I do not think it should default to anything.
>+#define AZFS_SUPERBLOCK_FLAGS MS_NOEXEC | \
>+ MS_SYNCHRONOUS | \
>+ MS_DIRSYNC | \
>+
Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
---
include/asm-ppc/8xx_immap.h |2 +-
include/asm-ppc/commproc.h |2 +-
include/asm-ppc/reg_booke.h |2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/asm-ppc/8xx_immap.h b/include/asm-ppc/8xx_immap.h
index 13
Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
---
arch/powerpc/boot/4xx.c |2 +-
arch/powerpc/kernel/legacy_serial.c |2 +-
arch/powerpc/sysdev/bestcomm/bestcomm.h |2 +-
arch/powerpc/sysdev/mmio_nvram.c|2 +-
4 files changed, 4 insertions(+), 4 deleti
Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
---
arch/ppc/syslib/ppc8xx_pic.c |2 +-
arch/ppc/syslib/ppc_sys.c|2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/ppc/syslib/ppc8xx_pic.c b/arch/ppc/syslib/ppc8xx_pic.c
index e8619c7..bce9a75 100644
--- a/arch/pp
Signed-off-by: Joe Perches <[EMAIL PROTECTED]>
---
include/asm-powerpc/8xx_immap.h |2 +-
include/asm-powerpc/commproc.h|2 +-
include/asm-powerpc/iseries/hv_lp_event.h |2 +-
include/asm-powerpc/reg_booke.h |2 +-
include/asm-powerpc/smu.h
Vitaly Bordug wrote:
> On Mon, 17 Dec 2007 11:03:04 -0600 Scott Wood wrote:
>>> These phy nodes have basically no information in them. PHY nodes
>>> are optional -
>> If they are truly optional, then several Linux drivers (including
>> ucc_geth, which this board uses) are broken, as they'll erro
On 12/17/07, Stephen Neuendorffer <[EMAIL PROTECTED]> wrote:
>
> When the driver no longer requires the port number, it's easy to drop.
> Until then, I'll keep it in.
>
> Also, I'm not so sure that moving to completely generic names is really
> worth the effort... All the 'semantically' interestin
On Mon, 17 Dec 2007 11:03:04 -0600
Scott Wood wrote:
> > > + phy1: [EMAIL PROTECTED] {
> > > + reg = <1>;
> > > + device_type = "ethernet-phy";
> > > + };
> >
> > These phy nodes have basically no information in the
When the driver no longer requires the port number, it's easy to drop. Until
then, I'll keep it in.
Also, I'm not so sure that moving to completely generic names is really worth
the effort... All the 'semantically' interesting' information is already in
the device tree somewhere else. In th
On Mon, 17 Dec 2007 11:20:46 -0600
Scott Wood <[EMAIL PROTECTED]> wrote:
> Kim Phillips wrote:
> > On Mon, 17 Dec 2007 11:03:04 -0600
> > Scott Wood <[EMAIL PROTECTED]> wrote:
> >> The driver doesn't seem to be in-tree... Kim, what do(es) the external
> >> driver(s) look like? Do they use OF at a
Kim Phillips wrote:
> On Mon, 17 Dec 2007 11:03:04 -0600
> Scott Wood <[EMAIL PROTECTED]> wrote:
>> The driver doesn't seem to be in-tree... Kim, what do(es) the external
>> driver(s) look like? Do they use OF at all yet?
>
> yes, it uses OF ifdef CONFIG_PPC_MERGE.
Can we change it to look for s
On Mon, 17 Dec 2007 11:03:04 -0600
Scott Wood <[EMAIL PROTECTED]> wrote:
> On Mon, Dec 17, 2007 at 04:14:03PM +1100, David Gibson wrote:
> > > + [EMAIL PROTECTED] {
> > > + device_type = "crypto";
> > > + model = "SEC2";
> > > + compatible =
On Mon, Dec 17, 2007 at 04:14:03PM +1100, David Gibson wrote:
> > + [EMAIL PROTECTED] {
> > + device_type = "crypto";
> > + model = "SEC2";
> > + compatible = "talitos";
>
> This device_type/compatible/model stuff is also crap, althou
David Gibson wrote:
> On Wed, Dec 12, 2007 at 04:54:27PM -0600, Scott Wood wrote:
>> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> [snip]
>> diff --git a/arch/powerpc/boot/dts/adder875-redboot.dts
>> b/arch/powerpc/boot/dts/adder875-redboot.dts
>> new file mode 100644
>> index 000..4d28220
>
This patch adds kdump support using the new PPC crash shutdown hook to the
ehea driver.
The reworked implementation follows the feedback I got. The crash handler
now just iterates over two simple arrays instead of handling linked lists.
Further feedback will be appreciated.
ehea kdump support RFC
On 12/17/07, Peter Korsgaard <[EMAIL PROTECTED]> wrote:
> > "Grant" == Grant Likely <[EMAIL PROTECTED]> writes:
>
> Hi,
>
> >> > 3) Uartlite requires a port-number property for the console to work.
> >>
> >> Why? In general we try to avoid magical sequence numbers - cell-index
> >> should
David Gibson wrote:
> As I think I said about another tree, this mdio-under-bcsr arrangement
> is pretty strange. What's going on here.
As I answered then, it's just the way the hardware is. I didn't design
it. :-P
>> +[EMAIL PROTECTED] {
>> +#address-cells = <1>;
>> +
On 12/13/07, Stephen Neuendorffer <[EMAIL PROTECTED]> wrote:
> This now better describes what the UBoot device tree generator actually does.
> In particular:
>
> 1) Nodes have a label derived from the device name, and a node name
> derived from the device type.
> 2) Usage of compound nodes (repre
Folks,
Tese patches have all been applied to the DTC repo and pushed out:
* [master] dtc: Don't build tests as part of "all"
* [master^] libfdt: Add more documentation (patch the seventh)
* [master~2] libfdt: Add more documentation (patch the sixth)
* [master~3] dtc: Fix silly typo in dtc-ch
So, like, the other day David Gibson mumbled:
> On Sun, Dec 16, 2007 at 07:10:02PM +0100, Segher Boessenkool wrote:
> >
> > Hopefully some version that stores path strings in the properties
> > in /aliases, and not phandles.
Yes.
> > Or does that current version of DTC
> > do that correctly alre
> "Grant" == Grant Likely <[EMAIL PROTECTED]> writes:
Hi,
>> > 3) Uartlite requires a port-number property for the console to work.
>>
>> Why? In general we try to avoid magical sequence numbers - cell-index
>> should *only* be used when it's needed to index or program some shared
>> r
Commit ed7e63a51d46e835422d89c687b8a3e419a4212a has tried to fix
section mismatch:
WARNING: vmlinux.o(.init.text+0x17278): Section mismatch: reference to
.exit.text:uec_mdio_exit (between 'ucc_geth_init' and 'uec_mdio_init')
But that mismatch still happens.
This patch actually fixing section mis
On Mon, Dec 17, 2007 at 05:35:53PM +1100, Michael Ellerman wrote:
> To save adding a hook to the dma mapping ops, pci-set_consistent_dma_mask()
> simply calls the dma_set_mask() hook and then copies the new mask into
> dev.coherenet_dma_mask.
How is this supposed to work? There are various device
> Jeremy, please ack the spufs changes if you are ok with the patch.
Yep, fine by me.
Acked-by: Jeremy Kerr <[EMAIL PROTECTED]>
Cheers,
Jeremy
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
67 matches
Mail list logo