> -Original Message-
> From: Anton Vorontsov [mailto:[EMAIL PROTECTED]
> Sent: Saturday, October 27, 2007 10:38 PM
> To: Sergei Shtylyov
> Cc: Anton Vorontsov; [EMAIL PROTECTED]; Li Yang-r58472;
> [EMAIL PROTECTED]; linuxppc-dev@ozlabs.org
> Subject: Re: [PATCH] ucc_geth: add support for
On Sunday 28 October 2007 11:08, Johannes Berg wrote:
>
> > I was hoping that FOUNTAIN_TP_ONLY_PRODUCT_ID (0x30A) behaves similar
> > to Geyser in this regard. If you know that this assumption is incorrect
> > then we need to rename atp_is_older_fountain() to atp_is_fountain()
> > anf add this pro
On Fri, 2007-10-26 at 17:29 +1000, Stephen Rothwell wrote:
> On Fri, 26 Oct 2007 16:54:43 +1000 (EST) Michael Ellerman <[EMAIL PROTECTED]>
> wrote:
> >
> > +++ b/arch/powerpc/platforms/pseries/eeh.c
> > @@ -841,11 +841,8 @@ void eeh_restore_bars(struct pci_dn *pdn)
> > if ((pdn->eeh_mode & EE
On Sun, 2007-10-28 at 22:06 -0500, Olof Johansson wrote:
> > And I don't care, I will continue adding them because the opposite
> is
> > fugly :-)
>
> Yeah , I know what you mean . This looks so much more natural .
Who said it has to be consistent ? :-)
I use spaces before ? and ! mostly. In fa
I wrote:
> @@ -601,10 +601,8 @@ void timer_interrupt(struct pt_regs * regs)
That should be
@@ -601,8 +601,6 @@ void timer_interrupt(struct pt_regs * regs)
of course.
Paul.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailm
On Mon, Oct 29, 2007 at 01:50:34PM +1100, Paul Mackerras wrote:
> Currently, process user and system times are advancing twice as fast
> as they should because they are being accounted in two places - in the
> generic code and in timer_interrupt. This fixes it by removing the
> call to account_pro
Hi Paul,
On Mon, Oct 29, 2007 at 01:57:17PM +1100, Paul Mackerras wrote:
> diff --git a/include/asm-powerpc/time.h b/include/asm-powerpc/time.h
> index f058955..eed64bd 100644
> --- a/include/asm-powerpc/time.h
> +++ b/include/asm-powerpc/time.h
> @@ -183,6 +183,7 @@ static inline void set_dec(in
On Mon, Oct 29, 2007 at 01:00:29PM +1100, Benjamin Herrenschmidt wrote:
> On Sun, 2007-10-28 at 20:50 -0500, Olof Johansson wrote:
> > Hi Ben,
> >
> > On Mon, Oct 29, 2007 at 12:05:18PM +1100, Benjamin Herrenschmidt wrote:
> > > @@ -887,6 +886,9 @@ void hash_preload(struct mm_struct *mm,
> > >
The decrementer in Book E and 4xx processors interrupts on the
transition from 1 to 0, rather than on the 0 to -1 transition as on
64-bit server and 32-bit "classic" (6xx/7xx/7xxx) processors.
This fixes the problem by making set_dec subtract 1 from the count for
server and classic processors. Si
Currently, process user and system times are advancing twice as fast
as they should because they are being accounted in two places - in the
generic code and in timer_interrupt. This fixes it by removing the
call to account_process_time in timer_interrupt.
Signed-off-by: Paul Mackerras <[EMAIL PRO
Dmitry Torokhov wrote:
> Hi Joseph,
>
> On Sunday 28 October 2007 19:53, Joseph Jezak wrote:
>> Perhaps this was a debugging message? In any case, this printk
>> causes lots of message log spam on my PB G4 1.67" (PowerBook5,9).
>>
>> This removes the printk.
>>
>
> I don't think we want do delet
Hi Joseph,
On Sunday 28 October 2007 19:53, Joseph Jezak wrote:
> Perhaps this was a debugging message? In any case, this printk
> causes lots of message log spam on my PB G4 1.67" (PowerBook5,9).
>
> This removes the printk.
>
I don't think we want do delete this message outright, we just nee
On Mon, 29 Oct 2007 12:05:18 +1100 Benjamin Herrenschmidt <[EMAIL PROTECTED]>
wrote:
Just to be fair to Olof, "diffstats are good" ...
--
Cheers,
Stephen Rothwell[EMAIL PROTECTED]
http://www.canb.auug.org.au/~sfr/
pgpAdyioH39BR.pgp
Description: PGP signature
__
On Sun, 2007-10-28 at 20:50 -0500, Olof Johansson wrote:
> Hi Ben,
>
> On Mon, Oct 29, 2007 at 12:05:18PM +1100, Benjamin Herrenschmidt wrote:
> > @@ -887,6 +886,9 @@ void hash_preload(struct mm_struct *mm,
> > local_irq_restore(flags);
> > }
> >
> > +/* WARNING: This is called from hash_
Hi Ben,
On Mon, Oct 29, 2007 at 12:05:18PM +1100, Benjamin Herrenschmidt wrote:
> @@ -887,6 +886,9 @@ void hash_preload(struct mm_struct *mm,
> local_irq_restore(flags);
> }
>
> +/* WARNING: This is called from hash_low_64.S, if you change this prototype,
> + * do not forget to
When demoting a process to use 4K HW pages (instead of 64K), which happens
under various circumstances such as doing cache inhibited mappings on
machines that do not support 64K CI pages, the assembly hash code calls
back into the C function flush_hash_page(). This function prototype was
recently
On Mon, Oct 29, 2007 at 10:50:05AM +1100, Stephen Rothwell wrote:
> Hi Olof,
>
> diffstat output is very useful - especially for patches like this that
> touch lots of files. It makes it easier for potential reviewers to see
> if they should be potential reviewers. :-)
Hi,
Good point. I'll inc
Perhaps this was a debugging message? In any case, this printk
causes lots of message log spam on my PB G4 1.67" (PowerBook5,9).
This removes the printk.
Signed-off by: Joseph Jezak <[EMAIL PROTECTED]>
---
diff --git a/drivers/input/mouse/appletouch.c b/drivers/input/mouse/appletouch.c
index f1
On Sat, Oct 27, 2007 at 09:02:32PM +0100, Al Viro wrote:
> diff --git a/include/linux/mv643xx_eth.h b/include/linux/mv643xx_eth.h
> index 3f27239..8df230a 100644
> --- a/include/linux/mv643xx_eth.h
> +++ b/include/linux/mv643xx_eth.h
> @@ -8,6 +8,9 @@
> #define MV643XX_ETH_NAME "mv643
Hi Olof,
diffstat output is very useful - especially for patches like this that
touch lots of files. It makes it easier for potential reviewers to see
if they should be potential reviewers. :-)
--
Cheers,
Stephen Rothwell[EMAIL PROTECTED]
http://www.canb.auug.org.au/~sfr/
On Fri, 2007-10-26 at 14:37 +0200, Jan-Bernd Themann wrote:
> eHEA resources that are allocated via H_CALLs have a unique identifier each.
> These identifiers are necessary to free the resources. A reboot notifier
> is used to free all eHEA resources before the indentifiers get lost, i.e
> before
> I was hoping that FOUNTAIN_TP_ONLY_PRODUCT_ID (0x30A) behaves similar
> to Geyser in this regard. If you know that this assumption is incorrect
> then we need to rename atp_is_older_fountain() to atp_is_fountain()
> anf add this product ID to it.
Ah ok, I forgot about that one. If I were to ven
On Sunday 28 October 2007, Johannes Berg wrote:
>
> > OK, then maybe instead of reverting the change outright we could try the
> > patch below?
>
> That patch works,
Any chance Benjamin could also test it? The behaviour is different
from 2.6.24-rc1 since we call atp_geyser_init for all geysers n
On Fri, Oct 19, 2007 at 03:17:20PM -0500, Olof Johansson wrote:
> Convert the io_req_t members to unsigned int, to allow use on machines
> with more than 16 bits worth of IO ports (i.e. secondary busses on
> ppc64, etc).
Agreed, though I'd prefer if we got rid of kio_addr_t at the same time, and
c
> OK, then maybe instead of reverting the change outright we could try the
> patch below?
That patch works, minor comments:
> Older models of fountains do not support change mode request and
I think there's only one fountain model.
> therefore shoudl be excluded from idle reset attempts.
typo
On Saturday 27 October 2007 07:14:45, you wrote:
> >>>stw r0,INT_FRAME_SIZE+4(r1)
> >>>
> >>>stw r31,INT_FRAME_SIZE+128(r1)
> >>>
> >>>lwz r5,EVENTS_USER_ADDR_OFFSET(r4)
> >>>mr r31,r5 /* r31 to hold new_domain->events_user_addr */
> >>>
> >>>
26 matches
Mail list logo