From: Bryan O'Donoghue
The EHCI packet buffer in/out threshold is programmable for Intel Quark X1000
USB host controller, and the default value is 0x20 dwords. The in/out threshold
can be programmed to 0x80 dwords (512 Bytes) to maximize the perfomrance,
but only when isochronous/interrupt transa
From: "Alvin (Weike) Chen"
Hi,
Intel Quark X1000 consists of one USB host controller which can be PCI
enumerated. And the exsiting EHCI-PCI framework supports it with the
default packet buffer in/out threshold. We reconfigure the in/out threshold
as maximal as possible to maximize the performanc
Peter,
On Tue, Jul 01, 2014 at 08:21:14AM +0800, Peter Chen wrote:
> On Mon, Jun 30, 2014 at 03:33:13PM +0200, Antoine Ténart wrote:
> > On Fri, Jun 27, 2014 at 11:25:07AM +0800, Peter Chen wrote:
> > > On Tue, Jun 24, 2014 at 12:35:16PM +0200, Antoine Ténart wrote:
> > > >
> > > > ifneq ($(CON
On Mon, 30 Jun 2014 07:45:43 -0700
Greg Kroah-Hartman wrote:
> > > > > From: Of Richard Leitner
> > > > > > Replaces all hardcoded ttyGS strings with the PREFIX macro.
> > > > > > Due to the fact the strings are spread over different source files
> > > > > > the
> > > > > > PREFIX definition is
On 06/30/2014 09:40 PM, Daniel Mack wrote:
> #3 fixes a reproducible kernel crash when unplugging streaming audio
> devices, and #5 causes data stream starvation which makes using many
s/causes/fixes/, of course.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body
On Mon, Jun 30, 2014 at 04:17:10PM -0700, Bryan Wu wrote:
> On Mon, Jun 30, 2014 at 4:33 AM, Jiri Kosina wrote:
> > On Mon, 30 Jun 2014, Johan Hovold wrote:
> >
> >> > I think the better place is HID/input tree, since this patch depends
> >> > on the initial one which is not in my tree.
> >> > I'm
On 07/01/2014 02:21 AM, Peter Chen wrote:
On Mon, Jun 30, 2014 at 03:33:13PM +0200, Antoine Ténart wrote:
On Fri, Jun 27, 2014 at 11:25:07AM +0800, Peter Chen wrote:
On Tue, Jun 24, 2014 at 12:35:16PM +0200, Antoine Ténart wrote:
+
+static const struct of_device_id ci_hdrc_generic_of_match[] =
Hi Roger,
On Monday 30 June 2014 04:30 PM, Roger Quadros wrote:
> On some SoCs e.g. J6 the 3.3V supply to the USB2 PHY can be
> powered down when the PHY is not in use. Add regulator
> management code to control this power line.
>
> Signed-off-by: Roger Quadros
> ---
> drivers/phy/phy-omap-usb2
Hi Kamil,
On Tuesday 24 June 2014 06:24 PM, Kamil Debski wrote:
> The Exynos4412 USB 2.0 PHY hardware differs from the description provided
> in the documentation. Some register bits have different function. This
> patch fixes the defines of register bits and changes the way how phys are
> powered
On Tue, Jul 01, 2014 at 10:55:37AM +0200, Sebastian Hesselbarth wrote:
> On 07/01/2014 02:21 AM, Peter Chen wrote:
> >On Mon, Jun 30, 2014 at 03:33:13PM +0200, Antoine Ténart wrote:
> >>On Fri, Jun 27, 2014 at 11:25:07AM +0800, Peter Chen wrote:
> >>>On Tue, Jun 24, 2014 at 12:35:16PM +0200, Antoin
On 07/01/2014 12:56 PM, Kishon Vijay Abraham I wrote:
> Hi Roger,
>
> On Monday 30 June 2014 04:30 PM, Roger Quadros wrote:
>> On some SoCs e.g. J6 the 3.3V supply to the USB2 PHY can be
>> powered down when the PHY is not in use. Add regulator
>> management code to control this power line.
>>
>>
Hi,
On Tuesday 01 July 2014 03:43 PM, Roger Quadros wrote:
> On 07/01/2014 12:56 PM, Kishon Vijay Abraham I wrote:
>> Hi Roger,
>>
>> On Monday 30 June 2014 04:30 PM, Roger Quadros wrote:
>>> On some SoCs e.g. J6 the 3.3V supply to the USB2 PHY can be
>>> powered down when the PHY is not in use. A
On 07/01/2014 01:20 PM, Kishon Vijay Abraham I wrote:
> Hi,
>
> On Tuesday 01 July 2014 03:43 PM, Roger Quadros wrote:
>> On 07/01/2014 12:56 PM, Kishon Vijay Abraham I wrote:
>>> Hi Roger,
>>>
>>> On Monday 30 June 2014 04:30 PM, Roger Quadros wrote:
On some SoCs e.g. J6 the 3.3V supply to t
On Tuesday 01 July 2014 03:55 PM, Roger Quadros wrote:
> On 07/01/2014 01:20 PM, Kishon Vijay Abraham I wrote:
>> Hi,
>>
>> On Tuesday 01 July 2014 03:43 PM, Roger Quadros wrote:
>>> On 07/01/2014 12:56 PM, Kishon Vijay Abraham I wrote:
Hi Roger,
On Monday 30 June 2014 04:30 PM, Ro
On 01/07/2014 at 16:30:08 +0800, Peter Chen wrote :
> > >>Well, there is nothing specific about the Berlin CI. Some subsystems
> > >>use the 'generic' keyword in these cases. Do you see a particular reason
> > >>I should use some Berlin related compatible here?
> > >
> > >Not must, one suggestion i
The drivers/usb/gadget directory contains many files.
Files which are related can be distributed into separate directories.
This patch moves the legacy gadgets (i.e. those not using configfs)
into a separate directory.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/Kconfig
This is a follow-up to this thread:
http://www.spinics.net/lists/linux-usb/msg107611.html
The cleanup rearranges the way source code files are located in the
drivers/usb/gadget directory. New subdirectories are introduced:
- "udc" for UDC chip drivers
- "function" for actual usb functions' imple
The drivers/usb/gadget directory contains many files.
Files which are related can be distributed into separate directories.
This patch moves the UDC drivers into a separate directory.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/Kconfig| 371 +--
The drivers/usb/gadget directory contains many files.
Files which are related can be distributed into separate directories.
This patch moves the USB functions implementations into a separate directory.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/Makefile|
W dniu 30.06.2014 20:21, Felipe Balbi pisze:
Hi,
On Tue, Jun 17, 2014 at 02:19:14PM +0200, Andrzej Pietrasiewicz wrote:
This is a follow-up to this thread:
http://www.spinics.net/lists/linux-usb/msg107611.html
Rebased onto Greg's usb-next.
please rebase on my testing/next, doesn't appl
On 06/30/2014 05:43 PM, Alan Stern wrote:
> On Mon, 30 Jun 2014, Mathias Nyman wrote:
>
>> xhci specs says it needs the interval rounded to nearest 2^(X) value,
>> which would be 256, not 128. I'll take a look at that.
>
> Doesn't the spec says it needs the interval rounded _down_ to a
> power of
I have following system:
USB0: host mode (USB hub is soldered internally)
USB1: OTG mode with OTG connector
My DTS: http://pastebin.com/KB3iTehQ
If I enable DMA in the kernel, I get USB0 working, i.e. USB hub is
detected and USB devices, that are connected to this hub are also
detected and worki
f->os_desc_table[0].if_id is zero by default. If the actual id happens
to be different then no Feature Descriptors will be returned to the host
for this interface, so assign if_id as soon as it is known.
Signed-off-by: Andrzej Pietrasiewicz
---
@Felipe:
Can you please consider it for 3.16? It is
On Tue, Jul 01 2014, Andrzej Pietrasiewicz wrote:
> f->os_desc_table[0].if_id is zero by default. If the actual id happens
> to be different then no Feature Descriptors will be returned to the host
> for this interface, so assign if_id as soon as it is known.
>
> Signed-off-by: Andrzej Pietrasiewi
On Tue, 1 Jul 2014, Chen, Alvin wrote:
> From: Bryan O'Donoghue
>
> The EHCI packet buffer in/out threshold is programmable for Intel Quark X1000
> USB host controller, and the default value is 0x20 dwords. The in/out
> threshold
> can be programmed to 0x80 dwords (512 Bytes) to maximize the pe
On Tue, Jul 1, 2014 at 3:03 PM, Yegor Yefremov
wrote:
> I have following system:
>
> USB0: host mode (USB hub is soldered internally)
> USB1: OTG mode with OTG connector
>
> My DTS: http://pastebin.com/KB3iTehQ
>
> If I enable DMA in the kernel, I get USB0 working, i.e. USB hub is
> detected and U
The Exynos4412 USB 2.0 PHY hardware differs from the description provided
in the documentation. Some register bits have different function. This
patch fixes the defines of register bits and changes the way how phys are
powered on and off.
Signed-off-by: Kamil Debski
---
drivers/phy/phy-exynos4x1
Hello.
On 07/01/2014 02:42 PM, Alexandre Belloni wrote:
Well, there is nothing specific about the Berlin CI. Some subsystems
use the 'generic' keyword in these cases. Do you see a particular reason
I should use some Berlin related compatible here?
Not must, one suggestion is: can you change
On Tue, Jul 01, 2014 at 08:50:19AM +0530, Sachin Kamat wrote:
> On Mon, Jun 30, 2014 at 10:19 PM, Felipe Balbi wrote:
> > On Mon, Jun 30, 2014 at 02:33:14PM +0530, Sachin Kamat wrote:
> >> Make the config depend on ARCH_EXYNOS5 instead of ARCH_EXYNOS
> >> as this IP is available only on Exynos5 pl
On 1 July 2014 12:07, Yegor Yefremov wrote:
[..]
>
> What can be done with these error messages:
>
> of_get_named_gpiod_flags: can't parse gpios property of node
> '/ocp/usb@4740/usb-phy@47401300[0]'
> 47401300.usb-phy supply vcc not found, using dummy regulator
> musb-hdrc musb-hdrc.0.auto: F
On Tue, 1 Jul 2014 09:31:49 +0200
Richard Leitner wrote:
> On Mon, 30 Jun 2014 07:45:43 -0700
> Greg Kroah-Hartman wrote:
>
> > > > > > From: Of Richard Leitner
> > > > > > > Replaces all hardcoded ttyGS strings with the PREFIX macro.
> > > > > > > Due to the fact the strings are spread over di
On Tue, Jul 1, 2014 at 10:37 AM, Ezequiel García
wrote:
> On 1 July 2014 12:07, Yegor Yefremov wrote:
> [..]
>>
>> What can be done with these error messages:
>>
>> of_get_named_gpiod_flags: can't parse gpios property of node
>> '/ocp/usb@4740/usb-phy@47401300[0]'
>> 47401300.usb-phy supply v
On Tue, Jul 1, 2014 at 1:48 AM, Johan Hovold wrote:
> On Mon, Jun 30, 2014 at 04:17:10PM -0700, Bryan Wu wrote:
>> On Mon, Jun 30, 2014 at 4:33 AM, Jiri Kosina wrote:
>> > On Mon, 30 Jun 2014, Johan Hovold wrote:
>> >
>> >> > I think the better place is HID/input tree, since this patch depends
>>
Move led_mode attribute from HID device to led-class devices and rename it
msi_mode. This will also fix race condition by using attribute-groups.
Signed-off-by: Janne Kanniainen
---
Changes in v3:
- Style fixes
- Rename sysfs-class-hid-driver-gt683r to sysfs-class-leds-driver-gt6
> Great, I just cherry-picked and applied to my tree
> http://git.kernel.org/cgit/linux/kernel/git/cooloney/linux-leds.git/commit/?h=for-next&id=f471d9480275796dea2ac7ec249b050e70a2888d
>
> Thanks,
> -Bryan
Ok, thank you!
Janne
--
To unsubscribe from this list: send the line "unsubscribe linux-us
On Tue, Jul 01, 2014 at 12:04:35AM -0500, Rob Herring wrote:
> > +- clock-names: Should contain the following:
> > + "core" Master/Core clock, have to be >= 125 MHz for SS
> > + operation and >= 60MHz for HS operation
> > +
> > +Optional clocks:
> > +
Hi, I am writing about commit 1f81b6d22a5980955b01e08cf27fb745dc9b686f
"usb: xhci: Prefer endpoint context dequeue pointer over stopped_trb".
This commit has been introduced in kernel 3.15-rc3, and subsequently
backported to older kernels. In kernel 3.2.59 (used by Ubuntu 12.04 LTS),
and newer kern
There's a new version of the Telewell 4G modem working with, but not
recognized by this driver.
Signed-off-by: Bernd Wachter
---
--- linux-3.15.3/drivers/net/usb/qmi_wwan.c.orig2014-07-01
21:31:07.0 +0300
+++ linux-3.15.3/drivers/net/usb/qmi_wwan.c 2014-07-01 20:39:30.0
On Tue, Jul 1, 2014 at 1:01 PM, Andy Gross wrote:
> On Tue, Jul 01, 2014 at 12:04:35AM -0500, Rob Herring wrote:
>
>
>
>> > +- clock-names: Should contain the following:
>> > + "core" Master/Core clock, have to be >= 125 MHz for SS
>> > + operation and
On Tue, Jul 01, 2014 at 08:50:54PM +0300, Janne Kanniainen wrote:
> -static DEVICE_ATTR_RW(leds_mode);
> +static DEVICE_ATTR_RW(mode);
> +
> +static struct attribute *gt683r_led_attrs[] = {
> + &dev_attr_mode.attr,
> + NULL
> +};
> +
> +ATTRIBUTE_GROUPS(gt683r_led);
I was referring to t
This patch intoduces the use of devm_ioremap_resource instead of
request_mem_region and ioremap_nocache and removes the calls to free the
allocated memory. Some labels are removes and a new label failed
introduced to make it less specific to the context. The call to a
platform get resource with IOR
Hi all,
This series fixes a probe order issue with the Tegra EHCI driver.
Basically, the register area of the 1st USB controller contains some
registers that are global to all of the controllers, but that are also
cleared when reset is asserted to the 1st controller. So if (say) the
3rd controller
tegra_usb_phy_close() is supposed to undo the effects of
tegra_usb_phy_init(). It is also currently added as the USB PHY shutdown
callback, which is wrong, since tegra_usb_phy_init() is only called
during probing wheras the shutdown callback can get called multiple
times. This then leads to warning
The Tegra USB complex has a particularly annoying misdesign: some of the
UTMI pad configuration registers are global for all the 3 USB controllers
on the chip, but those registers are located in the first controller's
register space and will be cleared when the reset to the first
controller is asse
Commit b424080a9e086e683ad5fdc624a7cf3c024e0c0f (reset: Add optional
resets and stubs) accidentally dropped the declaration of
of_reset_control_get from include/linux/reset.h. Add it back to the
header.
Signed-off-by: Tuomas Tynkkynen
---
include/linux/reset.h | 8
1 file changed, 8 ins
Thanks for the report, this sounds very troubling. The piece of code
you pointed out only affects single-segment transfer rings. I think
the kernel generally switched to using multi-segment transfer rings
for everything in commit 2fdcd47b69 "xHCI: Allocate 2 segments for
transfer ring", which expla
On 07/01/2014 03:08 PM, Tuomas Tynkkynen wrote:
> tegra_usb_phy_close() is supposed to undo the effects of
> tegra_usb_phy_init(). It is also currently added as the USB PHY shutdown
> callback, which is wrong, since tegra_usb_phy_init() is only called
> during probing wheras the shutdown callback c
On Tuesday, July 01, 2014 11:12 PM, Alan Stern wrote:
> On Tue, 1 Jul 2014, Chen, Alvin wrote:
>
> > From: Bryan O'Donoghue
> >
> > The EHCI packet buffer in/out threshold is programmable for Intel Quark
> > X1000
> > USB host controller, and the default value is 0x20 dwords. The in/out
> > th
From: Bryan O'Donoghue
The EHCI packet buffer in/out threshold is programmable for Intel Quark X1000
USB host controller, and the default value is 0x20 dwords. The in/out threshold
can be programmed to 0x80 dwords (512 Bytes) to maximize the perfomrance,
but only when isochronous/interrupt transa
>
> Hello.
>
> On 07/01/2014 02:42 PM, Alexandre Belloni wrote:
>
> > Well, there is nothing specific about the Berlin CI. Some
> > subsystems use the 'generic' keyword in these cases. Do you see a
> > particular reason I should use some Berlin related compatible here?
>
> No
> On Tue, Jul 01, 2014 at 08:50:19AM +0530, Sachin Kamat wrote:
>> On Mon, Jun 30, 2014 at 10:19 PM, Felipe Balbi
>> wrote:
>>> On Mon, Jun 30, 2014 at 02:33:14PM +0530, Sachin Kamat wrote:
Make the config depend on ARCH_EXYNOS5 instead of ARCH_EXYNOS
as this IP is available only on Exyn
On 2014-07-02 02:01, Bernd Wachter wrote:
There's a new version of the Telewell 4G modem working with, but not
recognized by this driver.
Signed-off-by: Bernd Wachter
---
--- linux-3.15.3/drivers/net/usb/qmi_wwan.c.orig2014-07-01
21:31:07.0 +0300
+++ linux-3.15.3/drivers/net/us
Hello,
I have a query regarding DMA(Direct Memory Access) for the usb devices.
The understanding of DMA actions over PCI is straight forward. PCI
devices support bus mastering capability, such that the PCI devices
could take the ownership of the bus and perform access to the memory
directly, a
Hi Greg,
This bug was found during the USB Certification test, and the
fix is needed for stable tree, I added Andrzej Pietrasiewicz's
comments, and re-test it with USB Certificaiton test, thanks.
Peter Chen (1):
usb: chipidea: udc: delete td from req's td list at ep_dequeue
drivers/usb/chipid
We need to delete un-finished td from current request's td list
at ep_dequeue API, otherwise, this non-user td will be remained
at td list before this request is freed. So if we do ep_queue->
ep_dequeue->ep_queue sequence, when the complete interrupt for
the second ep_queue comes, we search td list
55 matches
Mail list logo