Re: [RFT 0/3] usb: usb3503: Fix probing on Arndale board (missing phy)

2015-10-09 Thread Krzysztof Kozlowski
module). >> >> *The patchset was not tested on Arndale board.* >> I don't have that board. Please test it and say if the usb3503 deferred probe >> works fine and the issue is solved. > > FYI... I built this series on top of next-20151009 and using > exynos_defconfi

Re: Mass Storage Gadget Kthread

2015-10-09 Thread Felipe Balbi
Hi, Alan Stern writes: > On Fri, 9 Oct 2015, Felipe Balbi wrote: > >> that's all clear :-) The point is that I _do_ get a ton of PINGs because >> the gadget doesn't queue requests fast enough and I'm, currently, >> blaming the latency of the kthread() itself, though I haven't been >> successful

Re: Mass Storage Gadget Kthread

2015-10-09 Thread Alan Stern
On Fri, 9 Oct 2015, Felipe Balbi wrote: > that's all clear :-) The point is that I _do_ get a ton of PINGs because > the gadget doesn't queue requests fast enough and I'm, currently, > blaming the latency of the kthread() itself, though I haven't been > successful at proving that statement thus fa

Re: [PATCH 2/3] xhci: handle no ping response error properly

2015-10-09 Thread Paul Zimmerman
Sorry, resending as plain text. On Fri, Oct 9, 2015, Mathias Nyman wrote: > + handling_skipped_tds = ep->skip && > + (trb_comp_code != COMP_MISSED_INT || ^^ I think this should be &&, shouldn't it? > + trb_comp_code != COMP_PING_ERR); -- Paul -- To unsubscribe from this list: send the line

Re: simplify configfs attributes V2

2015-10-09 Thread Felipe Balbi
Christoph Hellwig writes: > This series consolidates the code to implement configfs attributes > by providing the ->show and ->store method in common code and using > container_of in the methods to access the containing structure. > > This reduces source and binary size of configfs consumers a lo

Re: [PATCH v2 2/2] usb: gadget: composite: remove redundant bcdUSB setting in legacy

2015-10-09 Thread Felipe Balbi
Hi, Igor Kotrasinski writes: > Since composite now overwrites bcdUSB for any gadget, remove > setting it in legacy gadgets. All legacy gadgets set 0x0200, the > same as the value additionally set by composite, so there is no > behaviour change. > > Signed-off-by: Igor Kotrasinski this doesn't

Re: [PATCH 0/7][v4] Add OTG support for FSL socs

2015-10-09 Thread Felipe Balbi
Felipe Balbi writes: > Hi, > > Ramneek Mehresh writes: >> Add support for otg for all freescale socs having internal >> usb phy. >> >> Ramneek Mehresh (7): >> usb:fsl:otg: Make fsl otg driver as tristate >> usb:fsl:otg: Add controller version based ULPI and UTMI phy >> usb:fsl:otg: Add sup

Re: [PATCH 0/7][v4] Add OTG support for FSL socs

2015-10-09 Thread Felipe Balbi
Hi, Ramneek Mehresh writes: > Add support for otg for all freescale socs having internal > usb phy. > > Ramneek Mehresh (7): > usb:fsl:otg: Make fsl otg driver as tristate > usb:fsl:otg: Add controller version based ULPI and UTMI phy > usb:fsl:otg: Add support to add/remove usb host driver

Re: [PATCH] usb: musb: dsps: implement vbus_status method

2015-10-09 Thread Felipe Balbi
Hi, Roman Alyautdin writes: > On 08/10/15 17:07, Sergei Shtylyov wrote: >> On 10/8/2015 4:50 PM, Sergei Shtylyov wrote: >> Implement vbus_status method of musb_platform_ops that allows musb_core to properly represent the VBUS status of musb_dsps devices in corresponding sysfs ent

Re: [PATCH 02/23] usb-gadget: use per-attribute show and store methods

2015-10-09 Thread Felipe Balbi
Hi, Christoph Hellwig writes: > To simplify the configfs interface and remove boilerplate code that also > causes binary bloat. > > Signed-off-by: Christoph Hellwig > Reviewed-by: Andrzej Pietrasiewicz I suppose this depends on other fs/configfs changes ? -- balbi signature.asc Descriptio

Re: [PATCH v2] usb: dwc2: reset dwc2 core before dwc2_get_hwparams()

2015-10-09 Thread John Youn
On 10/7/2015 5:50 PM, Doug Anderson wrote: > John, > > On Mon, Oct 5, 2015 at 3:02 PM, John Youn wrote: >> On 10/1/2015 1:50 PM, Doug Anderson wrote: >>> John, >>> >>> On Tue, Aug 18, 2015 at 5:19 PM, John Youn wrote: Hi Yunzhi, My concern is with the delays due to calling the dwc

Re: [PATCH v4 1/5] gadget: Introduce the notifier functions

2015-10-09 Thread Felipe Balbi
Hi, Pavel Machek writes: > HI! > >> > + int ret; >> > + >> > + mutex_lock(&gadget->lock); >> > + ret = raw_notifier_chain_unregister(&gadget->nh, nb); >> >> Greg, this is the kind of thing I wanted to avoid adding more of. >> >> I was wondering if you would accept subsystems using kdbus for

Re: [PATCH 1/1] usb: misc: usbtest: add bulk queue test

2015-10-09 Thread Felipe Balbi
Hi, Peter Chen writes: > The bulk queue tests are used to show 'best performance' for bulk > transfer, we are often asked this question by users. The implementation > is the same with iso test, that is queue request at interrupt completion, > so we reuse the iso structures, and rename them as co

Re: [PATCH 18/23] spear13xx_pcie_gadget: use per-attribute show and store methods

2015-10-09 Thread Felipe Balbi
Pratyush Anand writes: > On Sat, Oct 3, 2015 at 7:02 PM, Christoph Hellwig wrote: >> Signed-off-by: Christoph Hellwig > > Acked-by: Pratyush Anand I don't seem to have the actual patch, care to resend? -- balbi signature.asc Description: PGP signature

Re: Mass Storage Gadget Kthread

2015-10-09 Thread Felipe Balbi
Hi, Peter Chen writes: > On Fri, Oct 02, 2015 at 11:05:28AM -0500, Felipe Balbi wrote: >> Hi Alan, >> >> here's a question which I hope you can help me understand :-) >> >> Why do we have that kthread for the mass storage gadgets ? I noticed a very >> interesting behavior. >> >> Basically, th

Re: [PATCH v3 1/4] usb: gadget: f_midi: free usb request when done

2015-10-09 Thread Felipe Balbi
Hi, Clemens Ladisch writes: > Felipe Tonello wrote: >> req->actual == req->length means that there is no data left to enqueue, > > This condition is not checked in the patch. > >> so free the request. >> >> Signed-off-by: Felipe F. Tonello >> --- >> drivers/usb/gadget/function/f_midi.c | 5 ++-

Re: [RFT 0/3] usb: usb3503: Fix probing on Arndale board (missing phy)

2015-10-09 Thread Kevin Hilman
ve that board. Please test it and say if the usb3503 deferred probe > works fine and the issue is solved. FYI... I built this series on top of next-20151009 and using exynos_defconfig. I booted it on my arndale, and I still don't see the networking come up. Full boot log attached. K

[PATCH 2/3] xhci: handle no ping response error properly

2015-10-09 Thread Mathias Nyman
If a host fails to wake up a isochronous SuperSpeed device from U1/U2 in time for a isoch transfer it will generate a "No ping response error" Host will then move to the next transfer descriptor. Handle this case in the same way as missed service errors, tag the current TD as skipped and handle it

[PATCH 1/3] xhci: don't finish a TD if we get a short transfer event mid TD

2015-10-09 Thread Mathias Nyman
If the difference is big enough between the bytes asked and received in a bulk transfer we can get a short transfer event pointing to a TRB in the middle of the TD. We don't want to handle the TD yet as we will anyway receive a new event for the last TRB in the TD. Hold off from finishing the TD a

[PATCH 3/3] Add spurious wakeup quirk for LynxPoint-LP controllers

2015-10-09 Thread Mathias Nyman
From: Laura Abbott We received several reports of systems rebooting and powering on after an attempted shutdown. Testing showed that setting XHCI_SPURIOUS_WAKEUP quirk in addition to the XHCI_SPURIOUS_REBOOT quirk allowed the system to shutdown as expected for LynxPoint-LP xHCI controllers. Set t

[PATCH 0/3] xhci fixes for usb-linus

2015-10-09 Thread Mathias Nyman
Hi Greg These xhci fixes for usb-linus makes sure xhci can handles a couple corner case transfer situations correctly, both triggered in real life. One was the host asking for a lot of data and device returning very little. Second one about host failing to wake up device in time for a isoc tranfe

[PATCH v2] HID: hiddev: change hiddev_connect() to return bool

2015-10-09 Thread Luis de Bethencourt
Since hid_connect() only cares about hiddev_connect() succeeding or failing, there is no need for this function to return an int and it can return a bool instead. Suggested-by: Jiri Kosina Signed-off-by: Luis de Bethencourt --- Hi, No idea why my local build did not complain about the obvious

Re: [PATCH] HID: hiddev: change hiddev_connect() to return bool

2015-10-09 Thread kbuild test robot
Hi Luis, [auto build test ERROR on v4.3-rc4 -- if it's inappropriate base, please ignore] config: x86_64-lkp (attached as .config) reproduce: # save the attached .config to linux build tree make ARCH=x86_64 All errors (new ones prefixed by >>): >> drivers/hid/usbhid/hiddev.c:87

[PATCH] HID: hiddev: change hiddev_connect() to return bool

2015-10-09 Thread Luis de Bethencourt
Since hid_connect() only cares about hiddev_connect() succeeding or failing, there is no need for this function to return an int and it can return a bool instead. Suggested-by: Jiri Kosina Signed-off-by: Luis de Bethencourt --- Hi, The suggestion to change the return type of the function was m

[PATCH 5/6] usb: Add support for ACPI identification to xhci-platform

2015-10-09 Thread Mathias Nyman
From: Duc Dang Provide the methods to let ACPI identify the need to use xhci-platform. Change the Kconfig files so the xhci-plat.o file is selectable during kernel config. This has been tested on an ARM64 machine with platform XHCI, an x86_64 machine with XHCI, and an x86_64 machine without XHCI

[PATCH 6/6] usb: xhci: configure 32-bit DMA if the controller does not support 64-bit DMA

2015-10-09 Thread Mathias Nyman
From: Duc Dang This change avoids DMA error in the cases where dma_mask and coherent_dma_mask of a 32-bit controller get configured as DMA_BIT_MASK(64) when running on a 64-bit system. Signed-off-by: Duc Dang Signed-off-by: Mathias Nyman --- drivers/usb/host/xhci.c | 10 ++ 1 file cha

[PATCH 4/6] usb: make xhci platform driver use 64 bit or 32 bit DMA

2015-10-09 Thread Mathias Nyman
From: Duc Dang The xhci platform driver needs to work on systems that either only support 64-bit DMA or only support 32-bit DMA. Attempt to set a coherent dma mask for 64-bit DMA, and attempt again with 32-bit DMA if that fails. [dhdang: regenerate the patch over v4.3-rc1 and address new comment

[PATCH 2/6] xhci: replace custom implementation of readq / writeq

2015-10-09 Thread Mathias Nyman
From: Andy Shevchenko The readq() and writeq() helpers are available in the asm-generic/io-64-nonatomic-hi-lo.h and asm-generic/io-64-nonatomic-lo-hi.h headers. Replace custom implementation by the generic helpers. Signed-off-by: Andy Shevchenko Signed-off-by: Mathias Nyman --- drivers/usb/ho

[PATCH 3/6] usb: xhci: Makefile: move xhci-pci and xhci-plat-hcd after xhci-hcd

2015-10-09 Thread Mathias Nyman
From: "Lu, Baolu" Module xhci-pci and xhci-plat-hcd depend on xhci-hcd. Module xhci-hcd should be put at a place before xhci-pci and xhci-plat-hcd. Otherwise, xhci_hcd_init() might be executed after other functions in xhci-hcd if they are all selected to be built in. Signed-off-by: Lu Baolu Sig

[PATCH 1/6] xhci: create one unified function to calculate TRB TD remainder.

2015-10-09 Thread Mathias Nyman
xhci versions 1.0 and later report the untransferred data remaining in a TD a bit differently than older hosts. We used to have separate functions for these, and needed to check host version before calling the right function. Now Mediatek host has an additional quirk on how it uses the TD Size fi

[PATCH 0/6] xhci features for usb-next

2015-10-09 Thread Mathias Nyman
Hi Greg A few more features for usb-next. Support for 64bit DMA only platforms, ACPI identification for xhci-platform and some other minor changes -Mathias Andy Shevchenko (1): xhci: replace custom implementation of readq / writeq Duc Dang (3): usb: make xhci platform driver use 64 bit or

Re: [PATCH v3 1/4] usb: gadget: f_midi: free usb request when done

2015-10-09 Thread Clemens Ladisch
Felipe Tonello wrote: > req->actual == req->length means that there is no data left to enqueue, This condition is not checked in the patch. > so free the request. > > Signed-off-by: Felipe F. Tonello > --- > drivers/usb/gadget/function/f_midi.c | 5 ++--- > 1 file changed, 2 insertions(+), 3 de

Re: 4758dcd19a7d9ba9610b38fecb93f65f56f86346 - usb: xhci: Add support for URB_ZERO_PACKET to bulk/sg transfers; into stable?

2015-10-09 Thread Mathias Nyman
On 08.10.2015 17:40, Oliver Neukum wrote: Hi, it looks to me like commit 4758dcd19a7d9ba9610b38fecb93f65f56f86346 Author: Reyad Attiyat Date: Thu Aug 6 19:23:58 2015 +0300 usb: xhci: Add support for URB_ZERO_PACKET to bulk/sg transfers should go into stable. Is there a special reason