Fix "pointer targets differ in signedness" and "variable set but not
used" warnings
Signed-off-by: Thomas Pugliese
---
drivers/usb/wusbcore/devconnect.c | 4 +---
drivers/usb/wusbcore/wa-xfer.c| 6 ++
2 files changed, 3 insertions(+), 7 deletions(-)
diff --git a/drivers/usb/wusbcore/dev
contact me for details of $21.4m transfer.
The information contained in this electronic communication is intended solely
for the individual(s) or entity to which it is addressed. It may contain
proprietary, confidential and/or legally privileged information. Any review,
retransmission, dissemi
On Fri, 2014-02-28 at 15:18 -0800, Dan Williams wrote:
> ACPI identifies peer ports by setting their 'group_token' and
> 'group_position' _PLD data to the same value. If a platform has tier
> mismatch [1] , ACPI can override the default (USB3 defined) peer port
> association for internal hubs. Ex
Add support of the device tree probing for the Renesas R-Car generation 2 SoCs
documenting the device tree binding as necessary.
Signed-off-by: Sergei Shtylyov
---
This patch is against the 'next' branch of Felipe Balbi's 'usb.git' repo.
Changes in version 2:
- restored devm_clk_get() call and
Attention: Please, Kindly contact KENYA COMMERCIAL BANK immediately for your
compensation payment of (3MILLION UNITED STATE DOLLARS) via email:
Email:(servic...@kenya.ncommercialbnk.com) quote your payment Ref
No:KCB/00Y/2014 For purposes of immediate payment.
--
To unsubscribe from this li
On Fri, Feb 28, 2014 at 3:18 PM, Dan Williams wrote:
> ACPI identifies peer ports by setting their 'group_token' and
> 'group_position' _PLD data to the same value. If a platform has tier
> mismatch [1] , ACPI can override the default (USB3 defined) peer port
> association for internal hubs. Ext
The current port name "portX" is ambiguous. Before adding more port
messages rename ports to "-portX"
This is an ABI change, but the suspicion is that it will go unnoticed as
the port power control implementation has been broken since its
introduction. If however, someone was relying on the old
ClearPortFeature(PORT_POWER) on a usb3 port places the port in either a
DSPORT.Powered-off-detect / DSPORT.Powered-off-reset loop, or the
DSPORT.Powered-off state. There is no way to ensure that RX
terminations will persist in this state, so it is possible a device will
degrade to its usb2 connect
Once usb-acpi has set the port's connect type the usb_device's
->removable attribute can be set in the standard location
set_usb_port_removable().
This also changes behavior in the case where the firmware says that the
port connect type is unknown. In that case just use the default setting
determ
Assume that the peer of a superspeed port is the port with the same id
on the shared_hcd root hub. This identification scheme is required of
external hubs by the USB3 spec [1]. However, for root hubs, tier mismatch
may be in effect [2]. Tier mismatch can only be enumerated via platform
firmware.
The usb topology after this change will have symlinks between usb3 ports
and their usb2 peers, for example:
usb2/2-1/2-1:1.0/2-1-port1/peer => ../../../../usb3/3-1/3-1:1.0/3-1-port1
usb2/2-1/2-1:1.0/2-1-port2/peer => ../../../../usb3/3-1/3-1:1.0/3-1-port2
usb2/2-1/2-1:1.0/2-1-port3/peer => ../../.
ACPI identifies peer ports by setting their 'group_token' and
'group_position' _PLD data to the same value. If a platform has tier
mismatch [1] , ACPI can override the default (USB3 defined) peer port
association for internal hubs. External hubs follow the default peer
association scheme.
Locati
Given that root hub port peers are already established, external hub peer
ports can be determined by traversing the device topology:
1/ ascend to the parent hub and find the upstream port_dev
2/ walk ->peer to find the peer port
3/ descend to the peer hub via ->child
4/ find the port with the m
A hub indicates whether it supports per-port power control via the
wHubCharacteristics field in its descriptor. If it is not supported
a hub will still emulate ClearPortPower(PORT_POWER) requests by
stopping the link state machine. However, since this does not save
power do not bother suspending.
Per Alan's request this is the first half of the series that addresses
the following disconnect scenarios when attempting to use port
power-off. These 8 patches address scenario 1. Scenarios 2 and 3 are
addressed in part2 of this series (to be re-posted once part1 is
accepted).
1/ Superspeed dev
* Roger Quadros [140227 06:21]:
> Hi,
>
> This patchset brings up USB Host ports and Ethernet port on
> the OMAP5 uEVM board.
>
> It also does some cleanup with respect to DT clock binding
> for the mfd/omap-usb-host driver.
>
> Please queue these for -next.
>
> Lee,
>
> I've folded some plat
On 02/28/2014 03:15 PM, Greg KH wrote:
On Thu, Feb 27, 2014 at 05:27:25PM -0700, Shuah Khan wrote:
usbip userspace has duplicated enum definition to report usbip device
status maintained by the kernel. Adding an usbip uapi header file will
define the kernel - userspace interface for this device
On Fri, 28 Feb 2014, Oliver Neukum wrote:
> On Thu, 2014-02-27 at 11:51 -0600, Thomas Pugliese wrote:
> >
> > On Thu, 27 Feb 2014, Oliver Neukum wrote:
> >
> > > On Thu, 2014-02-27 at 10:46 -0600, Thomas Pugliese wrote:
> > >
> > > > I could be wrong about the chipset. If I recall correctly,
On Thu, Feb 27, 2014 at 05:27:25PM -0700, Shuah Khan wrote:
> usbip userspace has duplicated enum definition to report usbip device
> status maintained by the kernel. Adding an usbip uapi header file will
> define the kernel - userspace interface for this device status.
>
> Signed-off-by: Shuah Kh
On Fri, Feb 28, 2014 at 1:57 PM, Greg KH wrote:
> On Fri, Feb 28, 2014 at 12:41:31PM -0800, Dan Williams wrote:
>> On Fri, Feb 28, 2014 at 12:32 PM, Sarah Sharp
>> wrote:
>> > On Mon, Feb 24, 2014 at 12:44:46PM -0500, Alan Stern wrote:
>> >> On Mon, 24 Feb 2014, Mathias Nyman wrote:
>> >>
>> >> >
On Fri, Feb 28, 2014 at 12:41:31PM -0800, Dan Williams wrote:
> On Fri, Feb 28, 2014 at 12:32 PM, Sarah Sharp
> wrote:
> > On Mon, Feb 24, 2014 at 12:44:46PM -0500, Alan Stern wrote:
> >> On Mon, 24 Feb 2014, Mathias Nyman wrote:
> >>
> >> > xHCI driver has its own pci probe function that will cal
If the endpoint companion descriptor is not the first descriptor in the
extra descriptor buffer of a usb_host_endpoint, the loop in
rpipe_epc_find will get its buffer pointer and remaining size values out
of sync. The buffer ptr 'itr' is advanced by the descriptor's bLength
field but the remaining
Use the iso_frame_desc.actual_length field instead of length when
reading isoc in data segments from the HWA. This fixes a case where the
isoc in read URB would never complete because it expected the HWA to
send more data than it actually did. When this happened the URB would
be stuck in the driv
Hello.
On 02/27/2014 06:56 PM, Mark Rutland wrote:
Add support of the device tree probing for the Renesas R-Car generation 2 SoCs
documenting the device tree binding as necessary.
Signed-off-by: Sergei Shtylyov
---
This patch is against the 'next' branch of Felipe Balbi's 'usb.git' repo.
This patch adds a debug print in the transfer dequeue case where a
transfer result arrives for a transfer that has already been cleaned up.
It also adds the transfer ID to some debug prints and prints error codes
as signed integers in a couple of others.
Signed-off-by: Thomas Pugliese
---
driver
On Mon, Feb 24, 2014 at 04:00:37PM +0100, Oliver Neukum wrote:
> On Fri, 2014-02-21 at 15:00 -0800, Sarah Sharp wrote:
> > On Tue, Feb 11, 2014 at 08:36:04PM +0100, oli...@neukum.org wrote:
> > > From: Oliver Neukum
> > >
> > > On some older XHCIs streams are not supported and the UAS driver
> >
On Fri, 28 Feb 2014, Sarah Sharp wrote:
> When testing 3.14-rc1 with a USB 3.0 Lexar flash drive, the drive fails
> to be mounted. I added a bit of debugging to the USB core:
>
> diff --git a/drivers/usb/core/urb.c b/drivers/usb/core/urb.c
> index 9ff665f1322f..eff59ac37865 100644
> --- a/driver
On Thu, Feb 20, 2014 at 09:12:15PM -0800, Julius Werner wrote:
> We have observed a rare cycle state desync bug after Set TR Dequeue
> Pointer commands on Intel LynxPoint xHCs (resulting in an endpoint that
> doesn't fetch new TRBs and thus an unresponsive USB device). It always
> triggers when a p
This set of patches fixes some issues with the URB dequeue process in
the HWA. In particular, problems that occur when unplugging the HWA
dongle while transferring data to a device. The last patch in the set
is just code cleanup to hopefully make this case a little less error
prone.
Thomas P
This patch takes a reference to the wa_xfer object in wa_urb_dequeue to
prevent the urb giveback code from completing the xfer and freeing it
while wa_urb_dequeue is executing. It also checks for done at the start
to avoid a double completion scenario. Adding the check for done in
urb_dequeue
This patch adds error checking to the abort request callback to forcibly
clean up the dequeued transfers if the abort request failed. The
wa_complete_remaining_xfer_segs was modified so that it could be used in
this situation as well. This fixes a stranded URB/PNP hang when the HWA
is unplugg
This patch adds ref counting to sections of code that operate on struct
wa_xfer objects that were missing it. Specifically, error handling
cases need to be protected from freeing the xfer while it is still in
use elsewhere. This fixes a kernel panic that can occur when pulling
the HWA dongle whil
This patch adds a convenience function for the commonly performed task
of marking a transfer segment as done. It combines the 3 steps of
setting the segment status, incrementing the segs_done field of the
transfer and checking if the completed segment results in the transfer
also being done.
Sign
On Fri, Feb 28, 2014 at 12:32 PM, Sarah Sharp
wrote:
> On Mon, Feb 24, 2014 at 12:44:46PM -0500, Alan Stern wrote:
>> On Mon, 24 Feb 2014, Mathias Nyman wrote:
>>
>> > xHCI driver has its own pci probe function that will call usb_hcd_pci_probe
>> > to register its usb-2 bus, and then continue to m
On Mon, Feb 24, 2014 at 12:44:46PM -0500, Alan Stern wrote:
> On Mon, 24 Feb 2014, Mathias Nyman wrote:
>
> > xHCI driver has its own pci probe function that will call usb_hcd_pci_probe
> > to register its usb-2 bus, and then continue to manually register the
> > usb-3 bus. usb_hcd_pci_probe does
On Thu, Feb 27, 2014 at 05:17:19PM +0100, Otto Meier wrote:
> I migrated my system from H77 Ivy-bridge to a haswell Platform
> B85 i3-4330.
>
> The system has three dvb-c usb receivers connected. On the Ivy
> Platform everything runs fine with xHCI. On the haswell Platform
> xHCI explodes with fo
When testing 3.14-rc1 with a USB 3.0 Lexar flash drive, the drive fails
to be mounted. I added a bit of debugging to the USB core:
diff --git a/drivers/usb/core/urb.c b/drivers/usb/core/urb.c
index 9ff665f1322f..eff59ac37865 100644
--- a/drivers/usb/core/urb.c
+++ b/drivers/usb/core/urb.c
@@ -430
Hi,
On Fri, Feb 28, 2014 at 10:35:16AM -0800, Greg KH wrote:
> > I would be more than glad if someone got PM fellows to accept removing
> > the ifdeffery around both macros and just *always* leave PM hooks
> > available and ready to go.
>
> Why are the macros even needed?
they are supposed to "h
On Fri, Feb 28, 2014 at 11:57:45AM -0600, Felipe Balbi wrote:
> On Fri, Feb 28, 2014 at 09:37:02AM -0800, Greg KH wrote:
> > On Fri, Feb 28, 2014 at 02:25:31PM +0900, Jingoo Han wrote:
> > > On Thursday, February 27, 2014 11:41 PM, Roger Quadros wrote:
> > > > On 02/27/2014 01:47 PM, Jingoo Han wro
On Fri, Feb 28, 2014 at 09:37:02AM -0800, Greg KH wrote:
> On Fri, Feb 28, 2014 at 02:25:31PM +0900, Jingoo Han wrote:
> > On Thursday, February 27, 2014 11:41 PM, Roger Quadros wrote:
> > > On 02/27/2014 01:47 PM, Jingoo Han wrote:
> > > > Use SIMPLE_DEV_PM_OPS macro in order to make the code simp
Add the USB device ID for the D-Link DUB-1312 USB 3.0 to Gigabit Ethernet
Adapter to the AX88179/178A driver.
Signed-off-by: Gerry Demaret
---
drivers/net/usb/ax88179_178a.c | 17 +
1 file changed, 17 insertions(+)
diff --git a/drivers/net/usb/ax88179_178a.c b/drivers/net/usb/ax
On Fri, Feb 28, 2014 at 02:25:31PM +0900, Jingoo Han wrote:
> On Thursday, February 27, 2014 11:41 PM, Roger Quadros wrote:
> > On 02/27/2014 01:47 PM, Jingoo Han wrote:
> > > Use SIMPLE_DEV_PM_OPS macro in order to make the code simpler.
> > >
> > > Signed-off-by: Jingoo Han
> > > ---
> > > driv
On Fri, Feb 28, 2014 at 09:48:08AM +0100, Ulf Hansson wrote:
> On 28 February 2014 00:44, Greg Kroah-Hartman
> wrote:
> > On Thu, Feb 27, 2014 at 03:41:31PM -0800, David Cohen wrote:
> >> On Thu, Feb 27, 2014 at 11:03:24AM -0800, Greg Kroah-Hartman wrote:
> >> > On Tue, Feb 25, 2014 at 12:33:36PM
On 28/02/2014 16:50, Alexandre Belloni wrote:
> Hi Gregory,
>
> On 28/02/2014 at 15:34:01 +0100, Gregory CLEMENT wrote :
>> The debug trace in the atmel_usba_stop function made the assumption
>> that the driver pointer passed in parameter was not NULL. Since the
>> commit "usb: gadget: udc-core: f
On Fri, Feb 28, 2014 at 02:50:07PM +0900, Chanho Park wrote:
> This patch moves initialization order of the phy driver ahead of
> the dwc3 driver. The dwc3 driver needs phy driver when probing.
> Of cource, the driver can be initialized later after the phy
> driver is initialized. For efficiency, h
Hi Gregory,
On 28/02/2014 at 15:34:01 +0100, Gregory CLEMENT wrote :
> The debug trace in the atmel_usba_stop function made the assumption
> that the driver pointer passed in parameter was not NULL. Since the
> commit "usb: gadget: udc-core: fix a regression during gadget driver
> unbinding", it w
On Thu, 27 Feb 2014, Dan Williams wrote:
> > BTW, after some more thought, I decided the right way to avoid races in
> > the peer assignments is to do some of the work under hub.c's
> > device_state_lock. Add a "usb_" prefix to the name and share it with
> > port.c. We already are guaranteed tha
On 27/02/2014 16:42, Alexandre Belloni :
> If no endpoints are present in the device tree, the kernel will cras hwith the
s/cras hwith/crash with/
> following error:
>
> Unable to handle kernel paging request at virtual address 00101008
> [...]
> [] (composite_dev_prepare) from []
> (composite_
The debug trace in the atmel_usba_stop function made the assumption
that the driver pointer passed in parameter was not NULL. Since the
commit "usb: gadget: udc-core: fix a regression during gadget driver
unbinding", it was no more always true. This lead to a kernel crash.
This commit now use the
On Thu, Feb 27, 2014 at 6:08 PM, clanlab.proj wrote:
> On Thu, Feb 27, 2014 at 5:25 PM, clanlab.proj wrote:
>
>> Hi all,
>> After I've replaced the WEIGHT/budget from 16 -> 32,
>> I've got better performance from previous NAPI version, but still
>> cannot beat the work queue version.
Dear all,
U
On Fri, Feb 28 2014, Manu Gautam wrote:
> Changes since v5:
> * There is no change in 1st patch.
> * 2nd patch from Michal updates ABI and adds new field - flags which lists
> the descriptors that are present. Driver selects between the schemes based
> on the magic number passed by client.
> With
From: Marek Szyprowski
This patch adds suspend/resume support to s3c-hsotg driver. It makes UDC
driver more power efficient.
Signed-off-by: Marek Szyprowski
Tested-by: Robert Baldyga
---
drivers/usb/gadget/s3c-hsotg.c | 53 +---
1 file changed, 49 inserti
Changes since v5:
* There is no change in 1st patch.
* 2nd patch from Michal updates ABI and adds new field - flags which lists
the descriptors that are present. Driver selects between the schemes based
on the magic number passed by client.
With the new scheme, usb_functionfs_descs header is remove
From: Michal Nazarewicz
This reworks the way SuperSpeed descriptors are added and instead of
having a magic after full and high speed descriptors, it reworks the
whole descriptors block to include a flags field which lists which
descriptors are present and makes future extensions possible.
Signe
Allow userspace to pass SuperSpeed descriptors and
handle them in the driver accordingly.
This change doesn't modify existing desc_header and thereby
keeps the ABI changes backward compatible i.e. existing
userspace drivers compiled with old header (functionfs.h)
would continue to work with the upd
On Fri, Feb 28, 2014 at 08:40:51AM +0800, Peter Chen wrote:
> On Thu, Feb 27, 2014 at 03:47:45PM +0100, Sascha Hauer wrote:
> > > portsc = PORTSC_PTS(PTS_UTMI) | PORTSC_PTW;
> > > lpm = DEVLC_PTS(PTS_UTMI) | DEVLC_PTW;
> > > break;
> > > case USBPHY_INTERFACE_MODE_UL
On 2/25/2014 10:32 PM, Michal Nazarewicz wrote:
> This reworks the way SuperSpeed descriptors are added and instead of
> having a magick after full and high speed descriptors, it reworks the
> whole descriptors block to include a flags field which lists which
> descriptors are present and makes fut
There are no users of the old interface left. Remove it.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/f_uvc.c | 167 -
drivers/usb/gadget/f_uvc.h | 11 ---
2 files changed, 178 deletions(-)
diff --git a/drivers/usb/gadget/f_uvc.c b/dri
Attach strings to gadget with usb_strings_attach.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/f_uvc.c | 29 -
1 file changed, 12 insertions(+), 17 deletions(-)
diff --git a/drivers/usb/gadget/f_uvc.c b/drivers/usb/gadget/f_uvc.c
index 51767c9..bbadc0a
Use the new function interface of f_uvc.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/Kconfig | 1 +
drivers/usb/gadget/Makefile | 4 ++--
drivers/usb/gadget/webcam.c | 53 -
3 files changed, 41 insertions(+), 17 deletions(-)
diff --
Compile uvc_queue, uvc_v4l2, uvc_video separately so that later they can
be all combined in a separately compiled f_uvc.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/Makefile| 2 +-
drivers/usb/gadget/f_uvc.c | 2 ++
drivers/usb/gadget/f_uvc.h | 8
drivers/
When configfs support is integrated the future uvc function
module must not take any parameters. Move parameters to
webcam.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/f_uvc.c | 30 --
drivers/usb/gadget/f_uvc.h | 6 +-
drivers/usb/gadget/webcam
Use the new function registration interface. It is required
in order to integrate configfs support.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/Kconfig | 3 +
drivers/usb/gadget/Makefile | 2 +
drivers/usb/gadget/f_uvc.c | 252 ++--
d
This series aims at integrating configfs into uvc, the way
it has been done for acm, ncm, ecm, eem, ecm subset, rndis, obex, phonet,
mass_storage, FunctionFS, loopback and sourcesink.
It contains everything that is required to provide the equivalent of
g_webcam.ko with configfs.
Some time ago I co
If uvc->control_buf is successfuly allocated but uvc->control_req
is not, uvc->control_buf is not freed in the error recovery path.
With this patch applied uvc->control_buf is freed unconditionally;
if it happens to be NULL kfree on it is safe anyway.
Signed-off-by: Andrzej Pietrasiewicz
---
dri
On 28 February 2014 00:44, Greg Kroah-Hartman
wrote:
> On Thu, Feb 27, 2014 at 03:41:31PM -0800, David Cohen wrote:
>> On Thu, Feb 27, 2014 at 11:03:24AM -0800, Greg Kroah-Hartman wrote:
>> > On Tue, Feb 25, 2014 at 12:33:36PM -0600, Felipe Balbi wrote:
>> > > Hi,
>> > >
>> > > On Mon, Feb 24, 201
On Thu, 2014-02-27 at 11:51 -0600, Thomas Pugliese wrote:
>
> On Thu, 27 Feb 2014, Oliver Neukum wrote:
>
> > On Thu, 2014-02-27 at 10:46 -0600, Thomas Pugliese wrote:
> >
> > > I could be wrong about the chipset. If I recall correctly, IOGear has
> > > used multiple chipset vendors across dif
This patch adds feature flags support to s3c-hsotg driver, according to
changes in Gadget Framework API.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/s3c-hsotg.c |5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/usb/gadget/s3c-hsotg.c b/drivers/usb/gadget/s3c-hsotg.c
in
68 matches
Mail list logo