Hi,
On Tue, Nov 13, 2012 at 11:20:49AM +0900, Jingoo Han wrote:
> The devm_ functions allocate memory that is released when a driver
> detaches. This makes the code smaller and a bit simpler.
>
> Signed-off-by: Jingoo Han
Next time you want to use the output of scripts/get_maintainer.pl so
you'
Thomas Abraham wrote:
>
> Convert clk_enable/clk_disable to clk_prepare_enable/clk_disable_unprepare
> calls as required by common clock framework.
>
> Signed-off-by: Thomas Abraham
(+ Alan Stern)
Acked-by: Kukjin Kim
Thanks.
Best regards,
Kgene.
--
Kukjin Kim , Senior Engineer,
SW Solution
Thomas Abraham wrote:
>
> Convert clk_enable/clk_disable to clk_prepare_enable/clk_disable_unprepare
> calls as required by common clock framework.
>
> Signed-off-by: Thomas Abraham
(+ Alan Stern)
Acked-by: Kukjin Kim
Thanks.
Best regards,
Kgene.
--
Kukjin Kim , Senior Engineer,
SW Solution
On 2012年11月12日 10:43, Alan Stern wrote:
> On Mon, 12 Nov 2012, Lan Tianyu wrote:
>
This will consume more power than suspend it
agian.
>>>
>>> No it won't, because the device will suspend itself after 3 ms.
>> But the premise is "they see a constant Idle state on their upstream
>> faci
The devm_ functions allocate memory that is released when a driver
detaches. This makes the code smaller and a bit simpler.
Signed-off-by: Jingoo Han
---
Changes since v1:
- Rebased on usb-next branch
drivers/usb/dwc3/dwc3-exynos.c | 51 ++--
1 files change
On Mon, Nov 12, 2012 at 03:44:35PM +0200, Meelis Roos wrote:
> MODPOST 490 modules
> ERROR: "ezusb_fx1_ihex_firmware_download" [drivers/usb/serial/whiteheat.ko]
> undefined!
> ERROR: "ezusb_fx1_ihex_firmware_download" [drivers/usb/serial/keyspan_pda.ko]
> undefined!
> ERROR: "ezusb_fx1_set_rese
Linus Walleij wrote:
> >> - some devices bug out on libusb_open()
> >
> > Please send me a debug log from when this happens. Exact steps are at
> > http://libusb.org/wiki/debug
>
> I'll see what I can dig up. Mostly this has come from upstream,
> Alessio do you have something at hand for these col
Bjørn Mork wrote:
> > The problem appear when you ask a device which is not MTP
> > for that descriptor, some of them just die, so I cannot do
> > that.
>
> Really? You ask for a string descriptor and the device dies? Won't
> those devices also die if they are connected to a Windows system?
Yes
The xHCI 1.0 specification made a change to the TD Size field in TRBs.
The value is now the number of packets that remain to be sent in the TD,
not including this TRB. The TD Size value for the last TRB in a TD must
always be zero.
The xHCI function xhci_v1_0_td_remainder() attempts to calculate
From: Felipe Balbi
that check will have to be done by all users
of xhci_suspend() so it sounds a lot better to
move the check to xhci_suspend() in order to
avoid code duplication.
Signed-off-by: Felipe Balbi
Signed-off-by: Sarah Sharp
---
drivers/usb/host/xhci-pci.c |9 +
drivers/
From: "Alexis R. Cortes"
This minor patch creates a more stricter conditional for the Z1 sytems for
applying
the Compliance Mode Patch, this to avoid the quirk to be applied to models that
contain a "Z1" in their dmi product string but are different from Z1 systems.
This patch should be backpor
Ali reports that plugging a device into the Fresco Logic xHCI host with
PCI device ID 1400 produces an IRQ error:
do_IRQ: 3.176 No irq handler for vector (irq -1)
Other early Fresco Logic host revisions don't support MSI, even though
their PCI config space claims they do. Extend the quirk to di
From: Julius Werner
xhci_alloc_segments_for_ring() builds a list of xhci_segments and links
the tail to head at the end (forming a ring). When it bails out for OOM
reasons half-way through, it tries to destroy its half-built list with
xhci_free_segments_for_ring(), even though it is not a ring ye
Non-static xHCI driver symbols should start with the "xhci_" prefix, in
order to avoid namespace pollution. Rename the "handshake" function to
"xhci_handshake".
Signed-off-by: Sarah Sharp
Reported-by: Ben Hutchings
---
drivers/usb/host/xhci-ring.c |2 +-
drivers/usb/host/xhci.c | 24
David reports that at drivers/usb/host/xhci.c:2257:
static bool xhci_is_sync_in_ep(unsigned int ep_type)
{
return (ep_type == ISOC_IN_EP || ep_type != INT_IN_EP);
}
The static analyser cppcheck says
[linux-3.7-rc2/drivers/usb/host/xhci.c:2257]: (style) Redundant condition: If
ep_type == 5,
The following changes since commit 2f02bc8af3abb846823811af65ec6cc46a4d525d:
USB: report submission of active URBs (2012-11-11 18:10:46 -0800)
are available in the git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/sarah/xhci.git
for-usb-next-2012-11-12
for you to fetch chang
On Thu, Nov 01, 2012 at 01:28:46PM -0700, Julius Werner wrote:
> >> Is it just
> >> for (prev = *first; prev; prev = prev->next)
> >>xhci_segment_free(xhci, prev);
> >>
> >> ?
> >
> > Yeah, that seems cleaner.
> >
> > Sarah Sharp
>
> I can submit it that way if you want, but I would advise
On Sat, Nov 10, 2012 at 02:30:36PM +0330, A Sh wrote:
> > Ah, then you probably have the xHCI driver built-in, not built as a
> > module.
>
> What does it mean?
Wow, I googled around, and even though I know what search terms to look
for, there's really no good documentation on this question. I'l
Like Lynx Point, Lynx Point LP is also switchable. See
1c12443ab8eba71a658fae4572147e56d1f84f66 for more details.
This patch should be backported to stable kernels as old as 3.0,
that contain commit 69e848c2090aebba5698a1620604c7dccb448684
"Intel xhci: Support EHCI/xHCI port switching."
Signed-o
On 11:54 Sat 10 Nov , Joachim Eastwood wrote:
> Hi Jean-Christophe,
>
> On 7 November 2012 12:22, Jean-Christophe PLAGNIOL-VILLARD
> wrote:
> > Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
> > Cc: Nicolas Ferre
> > Cc: linux-...@vger.kernel.org
> > Cc: linux-in...@vger.kernel.org
> > Cc:
This patch fixes the following:
WARNING: vmlinux.o(.devinit.text+0x24ac): Section mismatch in reference from
the function dma_controller_create() to the function
.init.text:cppi_controller_start()
The function __devinit dma_controller_create() references
a function __init cppi_controller_start()
Hello.
On 08/09/2012 06:38 PM, Shubhrajyoti D wrote:
> dma_controller_create is called only from musb_init_controller
> which is __devint so annotate dma_controller_create also with
> __devint.
> fixes the warn
> WARNING: vmlinux.o(.devinit.text+0x6fa8): Section mismatch in reference from
> th
On Mon, 12 Nov 2012, Paolo Bonzini wrote:
> Il 12/11/2012 16:10, James Bottomley ha scritto:
> >> Actually it only turns it on for large capacity drives, as said in the
> >> comment. sdp->force_read_16 only matters for >2TB drives:
> >
> > If you follow the discussion, we'll need to turn it on
Il 12/11/2012 16:10, James Bottomley ha scritto:
>> Actually it only turns it on for large capacity drives, as said in the
>> comment. sdp->force_read_16 only matters for >2TB drives:
>
> If you follow the discussion, we'll need to turn it on for some drives
> regardless of size.
Even if the tw
On Mon, 2012-11-12 at 10:01 -0500, Jason J. Herne wrote:
> > Any reason not to do this always on >2TB drives, which basically means
> > changing this:
> >
> > - } else if (block > 0x) {
> > + } else if (sdkp->capacity > 0x) {
> >
> > and nothing else?
>
> This was the i
On Mon, Nov 12, 2012 at 10:10 AM, James Bottomley
wrote:
> On Mon, 2012-11-12 at 15:31 +0100, Paolo Bonzini wrote:
>> Il 12/11/2012 12:33, James Bottomley ha scritto:
>> > On Fri, 2012-11-09 at 11:08 -0500, Jason J. Herne wrote:
>> >> diff --git a/drivers/usb/storage/scsiglue.c
>> >> b/drivers/usb
On Mon, 2012-11-12 at 15:31 +0100, Paolo Bonzini wrote:
> Il 12/11/2012 12:33, James Bottomley ha scritto:
> > On Fri, 2012-11-09 at 11:08 -0500, Jason J. Herne wrote:
> >> diff --git a/drivers/usb/storage/scsiglue.c
> >> b/drivers/usb/storage/scsiglue.c
> >> index 13b8bcd..6ff785e 100644
> >> ---
On Mon, Nov 12, 2012 at 9:31 AM, Paolo Bonzini wrote:
> Il 12/11/2012 12:33, James Bottomley ha scritto:
>> On Fri, 2012-11-09 at 11:08 -0500, Jason J. Herne wrote:
>>> diff --git a/drivers/usb/storage/scsiglue.c
>>> b/drivers/usb/storage/scsiglue.c
>>> index 13b8bcd..6ff785e 100644
>>> --- a/driv
Il 12/11/2012 12:33, James Bottomley ha scritto:
> On Fri, 2012-11-09 at 11:08 -0500, Jason J. Herne wrote:
>> diff --git a/drivers/usb/storage/scsiglue.c
>> b/drivers/usb/storage/scsiglue.c
>> index 13b8bcd..6ff785e 100644
>> --- a/drivers/usb/storage/scsiglue.c
>> +++ b/drivers/usb/storage/scsigl
On Wed, Nov 7, 2012 at 10:22 PM, Linus Walleij wrote:
> I'll see what I can dig up. Mostly this has come from upstream,
> Alessio do you have something at hand for these color calibration
> crashes you've been seeing?
Sorry but no, I don't. Actually, I've never had to deal with such
issues by mys
On Fri, 2012-11-09 at 11:08 -0500, Jason J. Herne wrote:
> diff --git a/drivers/usb/storage/scsiglue.c
> b/drivers/usb/storage/scsiglue.c
> index 13b8bcd..6ff785e 100644
> --- a/drivers/usb/storage/scsiglue.c
> +++ b/drivers/usb/storage/scsiglue.c
> @@ -251,6 +251,11 @@ static int slave_configure(s
On Fri, 2012-11-09 at 16:33 +, Elliott, Robert (Server Storage)
wrote:
> I recommend broadening this patch. T10 is discussing making READ
> (10), WRITE (10), etc. obsolete in SBC-4 in favor of their 16-byte CDB
> counterparts.
>
> The algorithm should be:
> 1. During discovery, determine if
From: Boyan Nedeltchev
since commit b4036cc (usb: gadget: add
isochronous support to gadget zero), g_zero
has learned about isochronous transfers, which
allows us to use usbtest.ko to exercise
isochronous pipes.
All we need to do to enable that functionality
on usbtest.ko, is set the "iso" to 1
On Nov 11 Stefan Richter wrote:
> On Nov 09 Elliott, Robert (Server Storage) wrote:
> > I recommend broadening this patch. T10 is discussing making READ (10),
> > WRITE (10), etc. obsolete in SBC-4 in favor of their 16-byte CDB
> > counterparts.
> >
> > The algorithm should be:
> > 1. During
34 matches
Mail list logo