Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Ming Lei
On Wed, Nov 20, 2013 at 7:53 AM, Loc Ho wrote: > + > + sprintf(name, "xgene-ahci-phy-%08X", (u32) ctx->csr_phys); > + ctx->phy = devm_phy_create(ctx->dev, (u32) ctx->csr_phys, > + &xgene_phy_ops, name); The devm_phy_create() API has changed, so suggest

Re: [PATCH 5/6] pm80xx : Removing redundant code snippets

2013-11-20 Thread Jack Wang
On 11/20/2013 08:21 AM, Viswas G wrote: > Removed redundant code snipptes in pm8001_hwi.c > and pm8001_ctl.c > > Signed-off-by: Viswas G Looks good, thanks Reviewed-by: Jack Wang > --- > drivers/scsi/pm8001/pm8001_ctl.c | 22 -- > drivers/scsi/pm8001/pm8001_hwi.c |7 +-

Re: [PATCH 6/6] pm80xx : Fixed return value issue

2013-11-20 Thread Jack Wang
On 11/20/2013 08:22 AM, Viswas G wrote: > pm8001_get_gsm_dump() was returning "1" in error case > instead of negative error code. > > Signed-off-by: Viswas G Looks good, thanks Reviewed-by: Jack Wang > --- > drivers/scsi/pm8001/pm8001_hwi.c |8 > 1 files changed, 4 insertions(+),

Re: [PATCH v2 2/4] Documentation: Add APM X-Gene SoC 6.0Gbps SATA PHY driver binding documentation

2013-11-20 Thread Mark Rutland
On Tue, Nov 19, 2013 at 11:53:15PM +, Loc Ho wrote: > Documentation: Add APM X-Gene SoC 6.0Gbps SATA PHY driver binding > documentation > > Document the DTS binding for the X-Gene SoC SATA PHY driver. > > Signed-off-by: Loc Ho > Signed-off-by: Tuan Phan > Signed-off-by: Suman Tripathi > -

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Mark Rutland
Hi, On Tue, Nov 19, 2013 at 11:53:16PM +, Loc Ho wrote: > This patch adds support for APM X-Gene SoC 6.0Gbps SATA PHY. This is the > physical layer interface for the corresponding SATA host controller. This > driver uses the new PHY generic framework posted by Kishon Vijay Abrahm. > > Signed-

Re: [PATCH v2 4/4] arm64: Add APM X-Gene SoC 6.0Gbps SATA PHY DTS entries

2013-11-20 Thread Mark Rutland
On Tue, Nov 19, 2013 at 11:53:17PM +, Loc Ho wrote: > arm64: Add APM X-Gene SoC 6.0Gbps SATA PHY DTS entries > > This patch adds the DTS entries for the APM X-Gene SoC 6.0Gbps SATA PHY > driver. The PHY for controller 0 and 1 are enabled by default. > > Signed-off-by: Loc Ho > Signed-off-by:

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Arnd Bergmann
On Wednesday 20 November 2013 11:37:05 Mark Rutland wrote: > > +static void phy_rd(void *addr, u32 *val) > > +{ > > + *val = readl(addr); > > +#if defined(XGENE_DBG1_CSR) > > + pr_debug("SATAPHY CSR RD: 0x%p value: 0x%08x\n", addr, *val); > > Can you not use dev_dbg here as you do else

[Bug 46891] [CHECK]scsi/bnx2fc/bnx2fc_io.c:1810: bad call to memset

2013-11-20 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=46891 Alan changed: What|Removed |Added Status|NEW |RESOLVED Resolution|---

[Bug 46891] [CHECK]scsi/bnx2fc/bnx2fc_io.c:1810: bad call to memset

2013-11-20 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=46891 Alan changed: What|Removed |Added Status|RESOLVED|CLOSED -- You are receiving this mail because: Yo

[Bug 49241] [PATCH]Unsafe dereference of pointer after allocing memory

2013-11-20 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=49241 Alan changed: What|Removed |Added Status|NEW |ASSIGNED -- You are receiving this mail because:

Re: [PATCH 1/3] sd: don't bother spinning up disks on resume

2013-11-20 Thread Mark Lord
On 13-11-18 10:54 AM, Phillip Susi wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA1 > > On 11/17/2013 8:06 PM, Phillip Susi wrote: >> I don't see anything particularly inefficient about issuing the >> command in the eh path ( in fact, libata always uses the eh path to >> handle power manag

Re: [PATCH 1/3] sd: don't bother spinning up disks on resume

2013-11-20 Thread Phillip Susi
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 11/20/2013 9:23 AM, Mark Lord wrote: > Yeah, solve that, and you're golden. I totally understand the > motivation for this patch, and would love to have it working on my > machines here too. > > But it may have to be some kind of sysfs optional set

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Tejun Heo
Hey, guys. On Tue, Nov 19, 2013 at 04:53:16PM -0700, Loc Ho wrote: > This patch adds support for APM X-Gene SoC 6.0Gbps SATA PHY. This is the > physical layer interface for the corresponding SATA host controller. This > driver uses the new PHY generic framework posted by Kishon Vijay Abrahm. Hmm.

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Arnd Bergmann
On Wednesday 20 November 2013, Tejun Heo wrote: > On Tue, Nov 19, 2013 at 04:53:16PM -0700, Loc Ho wrote: > > This patch adds support for APM X-Gene SoC 6.0Gbps SATA PHY. This is the > > physical layer interface for the corresponding SATA host controller. This > > driver uses the new PHY generic fr

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Tejun Heo
Hello, Arnd. On Wed, Nov 20, 2013 at 10:41 AM, Arnd Bergmann wrote: > It needs to be in drivers/phy, which is currently being prepared for > the next merge window and which contains the generic interface used > in this driver. Ah, cool, so I don't need to worry about this one, right? Thanks a l

Re: [PATCH 6/6] pm80xx : Fixed return value issue

2013-11-20 Thread Tomas Henzl
On 11/20/2013 08:22 AM, Viswas G wrote: > pm8001_get_gsm_dump() was returning "1" in error case > instead of negative error code. Hi, the pm8001_get_gsm_dum return value is used here I think: static ssize_t pm8001_ctl_gsm_log_show(struct device *cdev, struct device_attribu

Re: [PATCH v2 4/4] arm64: Add APM X-Gene SoC 6.0Gbps SATA PHY DTS entries

2013-11-20 Thread Sergei Shtylyov
Hello. On 20-11-2013 3:53, Loc Ho wrote: arm64: Add APM X-Gene SoC 6.0Gbps SATA PHY DTS entries This patch adds the DTS entries for the APM X-Gene SoC 6.0Gbps SATA PHY driver. The PHY for controller 0 and 1 are enabled by default. Signed-off-by: Loc Ho Signed-off-by: Tuan Phan Signed-of

Re: [PATCH v2 1/4] PHY: Add function set_speed to generic PHY framework

2013-11-20 Thread Sergei Shtylyov
Hello. On 20=11-2013 3:53, Loc Ho wrote: PHY: Add function set_speed to generic PHY framework There's no need to duplicate the subject in the changelog verbatim. This patch adds function set_speed to the generic PHY framework operation structure. This function can be called to instruct t

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Arnd Bergmann
On Wednesday 20 November 2013, Tejun Heo wrote: > On Wed, Nov 20, 2013 at 10:41 AM, Arnd Bergmann wrote: > > It needs to be in drivers/phy, which is currently being prepared for > > the next merge window and which contains the generic interface used > > in this driver. > > Ah, cool, so I don't n

Re: [PATCH v2 4/4] arm64: Add APM X-Gene SoC 6.0Gbps SATA PHY DTS entries

2013-11-20 Thread Arnd Bergmann
On Wednesday 20 November 2013, Sergei Shtylyov wrote: > > --- a/arch/arm64/boot/dts/apm-storm.dtsi > > +++ b/arch/arm64/boot/dts/apm-storm.dtsi > > @@ -193,5 +193,33 @@ > > reg = <0x0 0x1714 0x0 0x100>; > > mask = <0x1>; > > }; > > + > >

sysfs group not found for kobject on mpt2sas unload

2013-11-20 Thread Joe Lawrence
Starting in 3.12, when loading and unloading the mpt2sas driver, I see the following warning: [ cut here ] WARNING: CPU: 20 PID: 19096 at fs/sysfs/group.c:214 sysfs_remove_group+0xc6/0xd0() sysfs group 81ca2f40 not found for kobject 'end_device-30:0' Modules linked

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Loc Ho
Hi, I will move to the official GIT for 3.12.00 instead rc7. It is the same as Linux-next GIT. -Loc On Wed, Nov 20, 2013 at 12:57 AM, Ming Lei wrote: > On Wed, Nov 20, 2013 at 7:53 AM, Loc Ho wrote: >> + >> + sprintf(name, "xgene-ahci-phy-%08X", (u32) ctx->csr_phys); >> + ctx->phy

Re: [PATCHv2 00/18] ALUA update and Referrals support

2013-11-20 Thread Nicholas A. Bellinger
On Wed, 2013-11-20 at 08:44 +0100, Hannes Reinecke wrote: > On 11/20/2013 01:06 AM, Nicholas A. Bellinger wrote: > > On Tue, 2013-11-19 at 15:42 -0800, Nicholas A. Bellinger wrote: > >> Hey Hannes! > >> > >> On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > >>> Hi Nic, > >>> > >>> here's

Re: [PATCH 01/18] target core: rename (ex,im)plict -> (ex,im)plicit

2013-11-20 Thread Nicholas A. Bellinger
On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > Signed-off-by: Hannes Reinecke > --- > drivers/target/target_core_alua.c | 110 > - > drivers/target/target_core_alua.h | 20 +++--- > drivers/target/target_core_configfs.c | 26 > d

Re: [PATCH 02/18] target_core_alua: spellcheck

2013-11-20 Thread Nicholas A. Bellinger
On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > Signed-off-by: Hannes Reinecke > --- > drivers/target/target_core_alua.c | 18 +- > 1 file changed, 9 insertions(+), 9 deletions(-) Applied. --nab -- To unsubscribe from this list: send the line "unsubscribe linux-scsi

Re: [PATCH 03/18] target_core_alua: Rename ALUA_ACCESS_STATE_OPTIMIZED

2013-11-20 Thread Nicholas A. Bellinger
On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > Rename ALUA_ACCESS_STATE_OPTMIZED to > ALUA_ACCESS_STATE_OPTIMIZED. > Applied. --nab -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH 04/18] target_core_alua: Store supported ALUA states

2013-11-20 Thread Nicholas A. Bellinger
On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > The supported ALUA states might be different for individual > devices, so store it in a separate field. > > Signed-off-by: Hannes Reinecke Applied, with one minor change below.. > --- > drivers/target/target_core_alua.c | 14 -

Re: [PATCH 05/18] target_core_alua: Make supported states configurable

2013-11-20 Thread Nicholas A. Bellinger
On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > Signed-off-by: Hannes Reinecke > --- Applied, with two minor changes below.. > drivers/target/target_core_configfs.c | 50 > +++ > 1 file changed, 50 insertions(+) > > diff --git a/drivers/target/targe

Re: [PATCH 06/18] target_core_configfs: split up ALUA supported states

2013-11-20 Thread Nicholas A. Bellinger
On Tue, 2013-11-19 at 09:07 +0100, Hannes Reinecke wrote: > Split up the various ALUA states into individual attributes to > make parsing easier and adhere to the one value per attribute > sysfs principle. > > Signed-off-by: Hannes Reinecke > --- Applied with one minor change below.. > drivers

Re: [PATCH v2 2/4] Documentation: Add APM X-Gene SoC 6.0Gbps SATA PHY driver binding documentation

2013-11-20 Thread Loc Ho
Hi, >> +- compatible : Shall be "apm,xgene-ahci-phy" or >> + "apm,xgene-ahci-phy2". The "apm,xgene-ahci-phy" >> + describes an port shared with SGMII Ethernet port. >> + The "apm,xgene-ahci-phy2" describes an port not >> +

Re: [PATCH v2 3/4] ata: add APM X-Gene SoC 6.0Gbps SATA PHY driver

2013-11-20 Thread Loc Ho
Hi, > On Wednesday 20 November 2013, Tejun Heo wrote: >> On Tue, Nov 19, 2013 at 04:53:16PM -0700, Loc Ho wrote: >> > This patch adds support for APM X-Gene SoC 6.0Gbps SATA PHY. This is the >> > physical layer interface for the corresponding SATA host controller. This >> > driver uses the new PHY

Re: [patch] [SCSI] megaraid: missing bounds check in mimd_to_kioc()

2013-11-20 Thread Kees Cook
Hi, On Wed, Oct 30, 2013 at 10:13 AM, Dan Carpenter wrote: > pthru32->dataxferlen comes from the user so we need to check that it's > not too large so we don't overflow the buffer. > > Reported-by: Nico Golde > Reported-by: Fabian Yamaguchi > Signed-off-by: Dan Carpenter I don't see this in L

RE: [PATCH 6/6] pm80xx : Fixed return value issue

2013-11-20 Thread Viswas G
Hi Tomas, Patches 1-4 are submitted with subject "[PATCH V2 0/4]: pm8001 driver bug fixes". As this patch has to be applied after those four patches, we submitted this as 5/6 and 6/6. We will resend the modified patch. Regards, Viswas G -Original Message- From: Tomas Henzl [mailt

[PATCH v4 1/4] ata: Export required functions by APM X-Gene SATA driver

2013-11-20 Thread Loc Ho
ata: Export required functions by APM X-Gene SATA driver This patch exports functions required by APM X-Gene SoC SATA host controller driver to avoid duplication of code. Signed-off-by: Loc Ho Signed-off-by: Tuan Phan Signed-off-by: Suman Tripathi --- drivers/ata/ahci.h|6 ++ driv

[PATCH v4 0/4] ata: Add APM X-Gene SoC SATA host controller support

2013-11-20 Thread Loc Ho
ata: Add APM X-Gene SoC SATA host controller support This patch adds support for the APM X-Gene SoC SATA host controller. In order for the host controller to work, the corresponding SATA PHY driver musts also be available. v4: * Remove the ID property in DT * Remove the temporary PHY direct fun

[PATCH v4 2/4] Documentation:: Add documentation for APM X-Gene SoC SATA host controller DTS binding

2013-11-20 Thread Loc Ho
Documentation:: Add documentation for APM X-Gene SoC SATA host controller DTS binding Signed-off-by: Loc Ho Signed-off-by: Tuan Phan Signed-off-by: Suman Tripathi --- .../devicetree/bindings/ata/apm-xgene.txt | 56 1 files changed, 56 insertions(+), 0 deletions

[PATCH v4 3/4] ata: Add APM X-Gene SoC SATA host controller driver

2013-11-20 Thread Loc Ho
ata: Add APM X-Gene SoC SATA host controller driver This patch adds support for the APM X-Gene SoC SATA host controller driver. It requires the corresponding APM X-Gene SoC SATA PHY driver. Signed-off-by: Loc Ho Signed-off-by: Tuan Phan Signed-off-by: Suman Tripathi --- drivers/ata/Kconfig

[PATCH] arm64: Add APM X-Gene SoC SATA host controller DTS entries

2013-11-20 Thread Loc Ho
arm64: Add APM X-Gene SoC SATA host controller DTS entries Signed-off-by: Loc Ho Signed-off-by: Tuan Phan Signed-off-by: Suman Tripathi --- arch/arm64/boot/dts/apm-storm.dtsi | 33 + 1 files changed, 33 insertions(+), 0 deletions(-) diff --git a/arch/arm64/bo

RE: [PATCH] megaraid: Use resource_size_t for PCI resources, not long

2013-11-20 Thread Saxena, Sumit
>-Original Message- >From: Saxena, Sumit >Sent: Friday, September 13, 2013 10:40 PM >To: Ben Collins; linux-scsi >Cc: DL-MegaRAID Linux >Subject: RE: [PATCH] megaraid: Use resource_size_t for PCI resources, >not long > > > >>-Original Message- >>From: Ben Collins [mailto:be...@ser