> On 10/16/2014 05:59 PM, Anish Bhatt wrote:
> > libcxgbi was always returning an ipv4 address for
> > ISCSI_HOST_PARAM_IPADDRESS, return appropriate address based on
> > address family
> >
> > Signed-off-by: Anish Bhatt
> > Signed-off-by: Karen Xie
> > ---
> > drivers/scsi/cxgbi/libcxgbi.c | 42
> -Original Message-
> From: Hannes Reinecke [mailto:h...@suse.de]
> Sent: Friday, 24 October, 2014 7:27 AM
> To: James Bottomley
> Cc: Christoph Hellwig; Elliott, Robert (Server Storage); linux-
> s...@vger.kernel.org; Hannes Reinecke
> Subject: [PATCH 27/27] scsi: ratelimit I/O error mess
On Wed, Oct 22, 2014 at 08:57:07AM +0800, Ming Lei wrote:
> On Wed, Oct 22, 2014 at 4:05 AM, Jens Axboe wrote:
> > On 10/17/2014 07:27 AM, Christoph Hellwig wrote:
> >> On Thu, Oct 16, 2014 at 11:17:39AM -0400, Brian Foster wrote:
> >>> Hi all,
> >>>
> >>> Hopefully this is the right list for this
On 14-10-24 04:51 PM, Christoph Hellwig wrote:
On Tue, Oct 14, 2014 at 12:42:26PM -0400, Douglas Gilbert wrote:
I don't mind if you change it. However I plan to release
sg3_utils-1.40 in the next 2 or 3 weeks, so that would
be the earliest a revised sg_reset would be available for
distros. Impro
On 10/24/14 2:45 AM, Bart Van Assche wrote:
On 10/23/14 19:43, Webb Scales wrote:
On 10/23/14 3:16 AM, Bart Van Assche wrote:
All my tests with use_blk_mq=n were run with a WARN_ON_ONCE(req->tag <
0) statement present in srp_queuecommand(). I haven't seen any kernel
warning being triggered duri
On Fri, Oct 24, 2014 at 02:26:40PM +0200, Hannes Reinecke wrote:
> here is now the eigth iteration of my scsi logging update.
> With this I've updated the patch to ratelimit I/O error messages
> as suggested by Robert Elliott.
> Additionally I've updated it to core-for-3.19 and included the
> missi
On Tue, Oct 14, 2014 at 12:42:26PM -0400, Douglas Gilbert wrote:
> I don't mind if you change it. However I plan to release
> sg3_utils-1.40 in the next 2 or 3 weeks, so that would
> be the earliest a revised sg_reset would be available for
> distros. Improving error reports is something I always
>
print_opcode_name() was only ever called with a '0' argument
from LLDDs and ULDs which were _not_ supporting variable length
CDBs, so the 'if' clause was never triggered.
Instead we should be using the last argument to specify
the cdb length to avoid accidental overflow when reading
the cdb buffer.
Export functions for later use.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 58
include/scsi/scsi_dbg.h | 2 ++
2 files changed, 46 insertions(+), 14 deletions(-)
di
Implement a lookup array for SERVICE ACTION commands instead
of hardcoding it in a large switch statement.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 131 +++
1 file change
Last caller is gone, so we can remove it.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 35 ---
include/scsi/scsi_dbg.h | 1 -
2 files changed, 36 deletions(-)
diff --git a/drivers/scs
Calling scsi_print_command should not be necessary during abort;
if the information is required one should enable scsi logging.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c| 4 +---
drivers/scsi/NCR5380.c |
scsi_try_to_abort_cmd() might return SUCCESS, FAILED, or
FAST_IO_FAIL. So just checking for FAILED will treat
FAST_IO_FAIL as SUCCESS, which is wrong.
Cc: Robert Elliott
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --gi
scsi_try_to_abort_cmd() should only return
SUCCESS, FAILED, or FAST_IO_FAIL. So document
that in the function description and simplify the
logging message.
Suggested-by: Christoph Hellwig
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scs
The .eh_abort_handler needs to return SUCCESS, FAILED, or
FAST_IO_FAIL. So fixup all callers to adhere to this requirement.
Cc: Robert Elliott
Cc:
Signed-off-by: Hannes Reinecke
---
drivers/scsi/NCR5380.c| 2 +-
drivers/scsi/aha1740.c| 2 +-
drivers/scsi/esas2r/esas2r_m
Open-code scsi_print_result in sd.c, and cleanup logging to
not print duplicate informations.
Also remove the call to scsi_show_result() in ufshcd.c
to be consistent with other callers of scsi_execute().
With that we can remove scsi_show_result in constants.c
Reviewed-by: Robert Elliott
Reviewed
Currently we're only decoding sense extras for tape devices.
And even there only for fixed format sense formats.
As this is of rather limited use in the general case we should
be stop trying to decode sense extras; the tape driver does
its own decoding anyway.
Reviewed-by: Robert Elliott
Reviewed
Remove all uncommented debugging code and move all
printk() statements over to dev_printk().
And while we're at it we should be doing a whitespace
cleanup, too.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/aha152x.c | 994 ++
Instead of having two versions of print_opcode_name() we
should be consolidating them into one version.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 88 ++--
1 file changed,
There can be quite a lot of I/O error messages, even on smaller
machines. So we need to ratelimit them to not overwhelm logging.
Cc: Robert Elliott
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_lib.c | 32
1 file changed, 20 insertions(+), 12 deletions(-)
Consolidate the CDB opcode lookup in scsi_opcode_sa_name(),
so that we don't have to call several functions to figure
out the CDB opcode string.
Reviewed_by: Robert Elliott
Reviewed-by: Christoph Hellweg
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 37 ++---
Update logging messages to use dev_printk() variants for correct
device annotations.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/arm/fas216.c | 26 +++---
1 file changed, 11 insertions(+), 15 deletions(-)
diff
Convert scsi_normalize_sense() and friends to return 'bool'
instead of an integer.
Reviewed-by: Robert Elliott
Reviewed-by: Yoshihiro Yunomae
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 16
drivers/scsi/scsi_lib.c | 2 +-
i
Use the matching scope for logging messages to allow for
better command tracing.
Suggested-by: Robert Elliott
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/hosts.c | 4 +--
drivers/scsi/scsi_error.c | 77 ++
The EH statistics are per host, so we should be using
shost_printk() here.
Suggested-by: Robert Elliott
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/d
Simplify scsi_log_(send|completion) by externalizing
scsi_mlreturn_string() and always print the command address.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 41 ++---
drivers/scsi/
Unused.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 14 --
include/scsi/scsi_dbg.h | 2 --
2 files changed, 16 deletions(-)
diff --git a/drivers/scsi/constants.c b/drivers/scsi/constants.c
index d35a5d6
here is now the eigth iteration of my scsi logging update.
With this I've updated the patch to ratelimit I/O error messages
as suggested by Robert Elliott.
Additionally I've updated it to core-for-3.19 and included the
missing hunks for ufs as requested by Christoph Hellwig.
Hannes Reinecke (27):
fas216 returns DID_BAD_TARGET for an incomplete data
transfer. The midlayer uses DID_BAD_TARGET to signal
a non-existing or not reachable target. So we should
rather be using DID_ERROR here.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/s
Like scmd_printk(), but the device name is passed in as
a string. Can be used by eg ULDs which do not have access
to the scsi_cmnd structure.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/ch.c | 3 +--
drivers/scsi/sd.h
sd_done() was calling scsi_print_sense() for a sense code
of 'NO_SENSE'.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/sd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index cfba74c..52b40
We should be using the standard dev_printk() variants for
sense code printing.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c | 2 +-
drivers/scsi/ch.c | 2 +-
drivers/scsi/constants.c | 117 ++
Update acornscsi to use scsi_print_command() instead of the
underscore version and use scmd_printk() in acornscsi_done().
This will add correct device annotations in the resulting message.
And we should be using set_host_byte() for setting the
final result.
Reviewed-by: Robert Elliott
Reviewed-by
If scsi_normalize_sense() fails we couldn't decode the sense
buffer, and the scsi_sense_hdr fields are invalid.
For those cases we should rather dump the sense buffer
and not try to decode invalid fields.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
The 53c700 driver would be using scsi_print_sense() in a debug
statement, which was never compiled in. Plus the same information
can get retrieved with logging. So remove it.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c | 9
On Thu, Oct 23, 2014 at 03:10:21PM -0400, Tony Battersby wrote:
> Fix a memory leak with scsi-mq triggered by commands with large data
> transfer length.
Thanks, this was indeed caused by a last minute change due to someone
complaining about my earlier version being a little too convoluted.
Thank
On Fri, Oct 24, 2014 at 07:53:23AM -, Dolev Raviv wrote:
> The first patch is Akinobu Mita's patch.
> You can add my ack on it.
Given that you passed them on to me you should normally sign off on them
as well.
Btw, MAINTAINERS doesn't mention you for the ufs driver, should it?
--
To unsubscri
> On Thu, Oct 23, 2014 at 01:25:11PM +0300, Dolev Raviv wrote:
>> Contains a couple of bug fixes reported by Akinobu Mita, In adition to
>> "static checker" warnings reported by Dan Carpenter.
>
> Any reason you didn't add a signoff to the first patch?
The first patch is Akinobu Mita's patch.
You
38 matches
Mail list logo