On Tue, 25 Sep 2007 22:45:53 -0500
James Bottomley <[EMAIL PROTECTED]> wrote:
> On Tue, 2007-09-25 at 23:34 -0400, Jeff Garzik wrote:
> > Matthew Wilcox wrote:
> > > On Tue, Sep 25, 2007 at 10:37:33PM -0400, Jeff Garzik wrote:
> > >> Are there any const-ness worries for scsi_host_template, or plan
They are direct equivalents to {read,write}[bwl].
Signed-off-by: Jeff Garzik <[EMAIL PROTECTED]>
---
diff --git a/drivers/scsi/gdth.c b/drivers/scsi/gdth.c
index b9d1f69..d7ef159 100644
--- a/drivers/scsi/gdth.c
+++ b/drivers/scsi/gdth.c
@@ -294,13 +294,6 @@ static struct timer_list gdth_timer;
current scsi-misc on i386 says:
drivers/scsi/arcmsr/arcmsr_hba.c:129: error: ‘arcmsr_pci_error_detected’
undeclared here (not in a function)
drivers/scsi/arcmsr/arcmsr_hba.c:130: error: ‘arcmsr_pci_slot_reset’
undeclared here (not in a function)
make[2]: *** [drivers/scsi/arcmsr/arcmsr_hba.o]
Signed-off-by: Jeff Garzik <[EMAIL PROTECTED]>
---
diff --git a/drivers/scsi/gdth.c b/drivers/scsi/gdth.c
index f382664..3f3ef4b 100644
--- a/drivers/scsi/gdth.c
+++ b/drivers/scsi/gdth.c
@@ -3960,7 +3960,7 @@ static int __init gdth_register_virt(struct
scsi_host_template *shtp,
{
struc
* New function gdth_register_virt() replaces the three
basically-duplicate copies of virtual controller registration.
* shuffle scsi_host_template members such that they appear in the
order in which they are defined in the header. this makes is easier
to verify when initializers are missin
Use standard laddered-goto error handling approach in three probe-time
functions.
Signed-off-by: Jeff Garzik <[EMAIL PROTECTED]>
---
diff --git a/drivers/scsi/gdth.c b/drivers/scsi/gdth.c
index d7ef159..89ac155 100644
--- a/drivers/scsi/gdth.c
+++ b/drivers/scsi/gdth.c
@@ -3964,13 +3964,11 @@ st
Sanitizes access to some driver-global variables, in preparation for
making them dynamic rather than statically-sized.
This equivalent-transform style change blissfully ignores the fact that
gdth_ctr_vtab[] is never used (only assigned), and that the driver
itself seems to get a bit confused betw
* Remove in-source changelog. It's archived permanently in git and
various kernel archives, and changelogs should exist purely in git.
* Remove 2.4.x kernel support. It is an active obstacle to
modernizing this driver, at this point. This includes killing
gdth_kcompat.h which is 100% red
An equivalent-transformation change. No functional changes beyond those
necessary to call the new function.
Signed-off-by: Jeff Garzik <[EMAIL PROTECTED]>
---
diff --git a/drivers/scsi/gdth.c b/drivers/scsi/gdth.c
index f330d34..840bdf6 100644
--- a/drivers/scsi/gdth.c
+++ b/drivers/scsi/gd
An equivalent-transformation change. No functional changes beyond
those necessary to call the new, split-out functions.
Signed-off-by: Jeff Garzik <[EMAIL PROTECTED]>
---
diff --git a/drivers/scsi/gdth.c b/drivers/scsi/gdth.c
index b20c188..f330d34 100644
--- a/drivers/scsi/gdth.c
+++ b/drivers
On Tue, 25 Sep 2007 23:01:53 -0500
James Bottomley <[EMAIL PROTECTED]> wrote:
> On Wed, 2007-09-26 at 12:55 +0900, FUJITA Tomonori wrote:
> > On Tue, 25 Sep 2007 22:45:53 -0500
> > James Bottomley <[EMAIL PROTECTED]> wrote:
> >
> > > On Tue, 2007-09-25 at 23:34 -0400, Jeff Garzik wrote:
> > > > M
On Wed, 2007-09-26 at 12:55 +0900, FUJITA Tomonori wrote:
> On Tue, 25 Sep 2007 22:45:53 -0500
> James Bottomley <[EMAIL PROTECTED]> wrote:
>
> > On Tue, 2007-09-25 at 23:34 -0400, Jeff Garzik wrote:
> > > Matthew Wilcox wrote:
> > > > On Tue, Sep 25, 2007 at 10:37:33PM -0400, Jeff Garzik wrote:
>
On Tue, 25 Sep 2007 22:45:53 -0500
James Bottomley <[EMAIL PROTECTED]> wrote:
> On Tue, 2007-09-25 at 23:34 -0400, Jeff Garzik wrote:
> > Matthew Wilcox wrote:
> > > On Tue, Sep 25, 2007 at 10:37:33PM -0400, Jeff Garzik wrote:
> > >> Are there any const-ness worries for scsi_host_template, or plan
James Bottomley wrote:
This whole mess is generated basically because the zero default of the
template should be treated as initiator. How about this, which makes
that manifest?
James
diff --git a/drivers/scsi/hosts.c b/drivers/scsi/hosts.c
index adc9559..7e26440 100644
--- a/drivers/scsi/host
On Tue, 2007-09-25 at 23:34 -0400, Jeff Garzik wrote:
> Matthew Wilcox wrote:
> > On Tue, Sep 25, 2007 at 10:37:33PM -0400, Jeff Garzik wrote:
> >> Are there any const-ness worries for scsi_host_template, or plans for
> >> the future? I do not see any other examples of the host template
> >> mem
On Tue, 25 Sep 2007 22:37:33 -0400
Jeff Garzik <[EMAIL PROTECTED]> wrote:
> FUJITA Tomonori wrote:
> > diff --git a/drivers/scsi/hosts.c b/drivers/scsi/hosts.c
> > index adc9559..694015d 100644
> > --- a/drivers/scsi/hosts.c
> > +++ b/drivers/scsi/hosts.c
> > @@ -342,6 +342,10 @@ struct Scsi_Host
On Tue, Sep 25, 2007 at 11:34:00PM -0400, Jeff Garzik wrote:
> Well, sure, the driver is the owner of that memory.
>
> We're talking about common code.
>
> If everybody agrees SHT is R/W in the core, Fujita-san's patch is fine.
Oh ... harder to find, but scsi_module.c does that, as does
scsi_reg
Matthew Wilcox wrote:
On Tue, Sep 25, 2007 at 10:37:33PM -0400, Jeff Garzik wrote:
Are there any const-ness worries for scsi_host_template, or plans for
the future? I do not see any other examples of the host template
members getting modified.
Goodness, Jeff, you haven't looked too hard. Th
On Tue, Sep 25, 2007 at 10:37:33PM -0400, Jeff Garzik wrote:
> Are there any const-ness worries for scsi_host_template, or plans for
> the future? I do not see any other examples of the host template
> members getting modified.
Goodness, Jeff, you haven't looked too hard. There's dozens of exa
FUJITA Tomonori wrote:
diff --git a/drivers/scsi/hosts.c b/drivers/scsi/hosts.c
index adc9559..694015d 100644
--- a/drivers/scsi/hosts.c
+++ b/drivers/scsi/hosts.c
@@ -342,6 +342,10 @@ struct Scsi_Host *scsi_host_alloc(struct
scsi_host_template *sht, int privsize)
shost->unchecked_isa_dm
On Tue, 25 Sep 2007 20:42:35 -0500
James Bottomley <[EMAIL PROTECTED]> wrote:
> On Wed, 2007-09-26 at 10:28 +0900, FUJITA Tomonori wrote:
> > On Tue, 25 Sep 2007 20:00:02 -0500
> > James Bottomley <[EMAIL PROTECTED]> wrote:
> >
> > > Andrew asked that I provide a status report of pending updates.
On Tue, 2007-09-25 at 12:55 -0500, James Bottomley wrote:
> This is, unfortunately, not a recent regression but it's only been
> recently diagnosed. Apparently the SCSI Parallel transport class domain
> validation cable width detection wasn't working, leading to cases where
> controllers with dama
On Wed, 2007-09-26 at 10:28 +0900, FUJITA Tomonori wrote:
> On Tue, 25 Sep 2007 20:00:02 -0500
> James Bottomley <[EMAIL PROTECTED]> wrote:
>
> > Andrew asked that I provide a status report of pending updates. The
> > list is attached below. It's pretty much driver updates and minor bug
> > fixe
On Tue, 25 Sep 2007 20:00:02 -0500
James Bottomley <[EMAIL PROTECTED]> wrote:
> Andrew asked that I provide a status report of pending updates. The
> list is attached below. It's pretty much driver updates and minor bug
> fixes. The main functionality changes are Kay's sysfs updates and the
> s
On Wed, Sep 26 2007 at 3:00 +0200, James Bottomley <[EMAIL PROTECTED]> wrote:
> Andrew asked that I provide a status report of pending updates. The
> list is attached below. It's pretty much driver updates and minor bug
> fixes. The main functionality changes are Kay's sysfs updates and the
> sh
From: James Bottomley <[EMAIL PROTECTED]>
Date: Tue, 25 Sep 2007 20:00:02 -0500
> David Miller (1):
> esp: fix instance numbering.
I'd like to request that this one goes into 2.6.23 as
it is a bug fix and the bug confuses users.
Thanks.
-
To unsubscribe from this list: send the line "unsub
Andrew asked that I provide a status report of pending updates. The
list is attached below. It's pretty much driver updates and minor bug
fixes. The main functionality changes are Kay's sysfs updates and the
shift of the ULD attachement towards the block prep function.
James
---
Adrian Bunk
Michael Reed wrote:
Jeff Garzik wrote:
Moore, Eric wrote:
On Tuesday, September 25, 2007 11:32 AM, James Bottomley wrote:
Youve rejected the error recovery patchs, which is fair enough.
Just the separation ... the actual patch looks OK.
I'll will continue working to separate the "error
On Tue, 2007-09-25 at 17:38 -0500, Michael Reed wrote:
> Jeff Garzik wrote:
> > Moore, Eric wrote:
> >> On Tuesday, September 25, 2007 11:32 AM, James Bottomley wrote:
> >>
> Youve rejected the error recovery patchs, which is fair enough.
> >>> Just the separation ... the actual patch lo
Jeff Garzik wrote:
> Moore, Eric wrote:
>> On Tuesday, September 25, 2007 11:32 AM, James Bottomley wrote:
>>
Youve rejected the error recovery patchs, which is fair enough.
>>> Just the separation ... the actual patch looks OK.
>>>
>>
>> I'll will continue working to separate the "erro
Moore, Eric wrote:
On Tuesday, September 25, 2007 11:32 AM, James Bottomley wrote:
Youve rejected the error recovery patchs, which is fair enough.
Just the separation ... the actual patch looks OK.
I'll will continue working to separate the "error recovery
improvements:" into smaller fe
On Tuesday, September 25, 2007 11:32 AM, James Bottomley wrote:
> > Youve rejected the error recovery patchs, which is fair enough.
>
> Just the separation ... the actual patch looks OK.
>
I'll will continue working to separate the "error recovery
improvements:" into smaller feature add, b
This is, unfortunately, not a recent regression but it's only been
recently diagnosed. Apparently the SCSI Parallel transport class domain
validation cable width detection wasn't working, leading to cases where
controllers with damaged cables would end up hanging the system (the
reported one was a
On Mon, 2007-09-24 at 19:35 -0600, Moore, Eric wrote:
> On Saturday, September 22, 2007 10:02 AM, James Bottomley wrote:
>
> > What fixes?
> >
> > The object of a change log is to preserve the history of a particular
> > change (as per the Developer Certificate of Origin). This
> > means if y
On Mon, 2007-09-24 at 19:26 -0600, Moore, Eric wrote:
> On Saturday, September 22, 2007 9:39 AM, James Bottomley wrote:
> >
> > Well, I'll put this in this time. However, it contains a
> > whole slew of
> > pointless changes like this:
> >
> >
> > > - mdelay (10);
> > >
On Tue, Sep 25, 2007 at 07:30:29PM +0200, Boaz Harrosh wrote:
> OK This is on top of the first patch that I will take care of,
> right? (http://www.spinics.net/lists/linux-scsi/msg19470.html)
That's right.
> Here 2 it will not merge with my patchset. So I'll take it off your hands
> and rebase it
On Mon, 2007-09-24 at 19:26 -0600, Moore, Eric wrote:
> On Saturday, September 22, 2007 10:23 AM, James Bottomley wrote:
>
> >
> > OK, I thought I'd wait here for the breakout, but in the meantime I
> > tried to compile the first five patches, but they don't:
> >
> > CC [M] drivers/message/f
On Tue, Sep 25 2007 at 18:42 +0200, Matthew Wilcox <[EMAIL PROTECTED]> wrote:
> From: Matthew Wilcox <[EMAIL PROTECTED]>
>
> The ->done member was being used to mark commands as being internal.
> I decided to put a magic number in ->underflow instead. I believe this
> to be safe as no current use
On Tue, Sep 25, 2007 at 07:05:09PM +0200, Boaz Harrosh wrote:
> > @@ -694,7 +702,13 @@ void scsi_finish_command(struct scsi_cmnd *cmd)
> > "Notifying upper driver of completion "
> > "(result %x)\n", cmd->result));
> >
> > - cmd->done(cmd)
On Tue, Sep 25 2007 at 18:42 +0200, Matthew Wilcox <[EMAIL PROTECTED]> wrote:
> From: Matthew Wilcox <[EMAIL PROTECTED]>
>
> The ULD ->done callback moves into the scsi_driver. By moving the call
> to scsi_io_completion() from scsi_blk_pc_done() to scsi_finish_command(),
> we can eliminate the la
From: Matthew Wilcox <[EMAIL PROTECTED]>
The ->done member was being used to mark commands as being internal.
I decided to put a magic number in ->underflow instead. I believe this
to be safe as no current user of ->underflow has any of the bottom 9
bits set.
Signed-off-by: Matthew Wilcox <[EMAI
From: Matthew Wilcox <[EMAIL PROTECTED]>
The ULD ->done callback moves into the scsi_driver. By moving the call
to scsi_io_completion() from scsi_blk_pc_done() to scsi_finish_command(),
we can eliminate the latter entirely. By returning 'good_bytes' from
the ->done callback (rather than invoking
This series of four patches gets rid of ->done from scsi_cmnd. It applies
on top of the patch I sent earlier today to improve gdth's abuse of
scsi_done. Sorry, Boaz. I'd like to thank Christoph for talking me
through some of the bits of the block layer I didn't grok.
-
To unsubscribe from this
From: Matthew Wilcox <[EMAIL PROTECTED]>
All these drivers meant to call ->scsi_done() but got confused.
Signed-off-by: Matthew Wilcox <[EMAIL PROTECTED]>
---
drivers/scsi/NCR5380.c |8
drivers/scsi/NCR53C9x.c |2 +-
drivers/scsi/atari_NCR5380.c |4 ++--
drivers/s
From: Matthew Wilcox <[EMAIL PROTECTED]>
We can simply call the internal done function directly
Signed-off-by: Matthew Wilcox <[EMAIL PROTECTED]>
---
drivers/scsi/pluto.c |3 +--
1 files changed, 1 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/pluto.c b/drivers/scsi/pluto.c
index
On Tue, Sep 25, 2007 at 04:51:06PM +0200, Boaz Harrosh wrote:
> > As I said, it's ambitious. But it'll let us get rid of scsi_pointer
> > and host_scribble entirely.
> >
> This all is an excellent idea and you will find that in the patchset to
> gdth, I have made the work of one driver a bit easi
Am Dienstag 25 September 2007 schrieb Alan Stern:
> > Furthermore for many devices it will take real user intervention to
> > determine what is in the enclosure. This isn't very good. I think
> > we can do better.
>
> If by "we" you mean the Linux kernel in general, then I agree. If by
> "we" you
On Tue, 25 Sep 2007, Oliver Neukum wrote:
> Am Montag 24 September 2007 schrieb Alan Stern:
> > On Mon, 24 Sep 2007, Oliver Neukum wrote:
> >
> > > > subsystem implements its own form of runtime PM support, then you'll be
> > > > able to use it properly. But until then, there isn't anything much
On Tue, Sep 25 2007 at 15:37 +0200, Matthew Wilcox <[EMAIL PROTECTED]> wrote:
> Christoph grabbed me on IRC and we debated some of my plans for scsi_cmnd;
> with his permission I'm summarising the result of that debate for posterity.
> There's four main things discussed:
>
> 1. I'm going to be wri
On Mon, 24 Sep 2007, Oliver Neukum wrote:
> Am Montag 24 September 2007 schrieb Alan Stern:
> > On Mon, 24 Sep 2007, Oliver Neukum wrote:
> >
> > > > subsystem implements its own form of runtime PM support, then you'll be
> > > > able to use it properly. But until then, there isn't anything much
On Tue, Sep 25, 2007 at 02:47:50PM +0100, Christoph Hellwig wrote:
> On Tue, Sep 25, 2007 at 07:37:33AM -0600, Matthew Wilcox wrote:
> > 2. Thanks to a thinko, we also discussed the upper-layer ->done. We think
> > it should be feasible to move this from the scsi_cmnd to the scsi_device
> > since
ACK
Sincerely -- Mark Salyzyn
> -Original Message-
> From: James Bottomley [mailto:[EMAIL PROTECTED]
> Sent: Sunday, September 23, 2007 10:45 AM
> To: AACRAID; Bernhard Walle; James Bottomley
> Subject: Patch added to scsi-pending-2.6: [SCSI] ips: Update
> version information
>
> Your
On Tue, Sep 25, 2007 at 07:37:33AM -0600, Matthew Wilcox wrote:
> 2. Thanks to a thinko, we also discussed the upper-layer ->done. We think
> it should be feasible to move this from the scsi_cmnd to the scsi_device
> since sg doesn't use it.
I suspect putting it into the scsi_driver would be even
Christoph grabbed me on IRC and we debated some of my plans for scsi_cmnd;
with his permission I'm summarising the result of that debate for posterity.
There's four main things discussed:
1. I'm going to be writing and posting patches over the next week or so
to kill all the (ab)uses of ->scsi_do
On Tue, Sep 25, 2007 at 02:17:44PM +0200, Boaz Harrosh wrote:
> This patch looks grate, Thanks. It is very good for the direction
> I'm going to. However it does have a smallish conflict with One
> of Jeff's patches where he completely removes the 2.4.x support.
>
> If it is OK with you I will add
On Tue, Sep 25 2007 at 13:56 +0200, Matthew Wilcox <[EMAIL PROTECTED]> wrote:
> On Tue, Sep 25, 2007 at 11:51:13AM +0200, Boaz Harrosh wrote:
>> On top of that I have my own agenda of cleaning the !use_sg code paths and
>> getting
>> rid of scsi_cmnd abuse, so there is also that.
>
> This seems l
On Tue, Sep 25, 2007 at 11:51:13AM +0200, Boaz Harrosh wrote:
> On top of that I have my own agenda of cleaning the !use_sg code paths and
> getting
> rid of scsi_cmnd abuse, so there is also that.
This seems like a good time to post my own patch that removes the use of
->scsi_done from gdth. I
On Tue, Sep 25 2007 at 10:20 +0200, Christoph Hellwig <[EMAIL PROTECTED]> wrote:
> On Mon, Sep 24, 2007 at 08:25:28PM -0400, Jeff Garzik wrote:
>>> OK, we've had these competing patch sets floating around for two months
>>> now. Christoph and Jeff, can we get agreement on which is going in?
>> Wel
James Bottomley writes:
> On Mon, 2007-09-24 at 08:34 -0500, Brian King wrote:
> > Paul,
> >
> > It looks like there is a bunch of unrelated arch powerpc bits at the end
> > of this patch.
Oops... blush.
> It's actually a whole email at the bottom ... don't worry; I stripped
> it.
Several ema
On Mon, Sep 24, 2007 at 08:25:28PM -0400, Jeff Garzik wrote:
> >OK, we've had these competing patch sets floating around for two months
> >now. Christoph and Jeff, can we get agreement on which is going in?
>
> Well, my opinion is
>
> 1) When judging by total amount of positive improvement, Chri
Am Dienstag 25 September 2007 schrieb Hannes Reinecke:
> Oliver Neukum wrote:
> > Hi,
> >
> > what is the difference between these states? What function should
> > I call to block a device in order to securely flush the caches?
> >
> SDEV_BLOCK blocks _any_ commands from the midlayer; eg. if the
Am Montag 24 September 2007 schrieb Alan Stern:
> On Mon, 24 Sep 2007, Oliver Neukum wrote:
>
> > > subsystem implements its own form of runtime PM support, then you'll be
> > > able to use it properly. But until then, there isn't anything much you
> > > can do.
> >
> > Well, we can't simply cut
Oliver Neukum wrote:
> Hi,
>
> what is the difference between these states? What function should
> I call to block a device in order to securely flush the caches?
>
SDEV_BLOCK blocks _any_ commands from the midlayer; eg. if the LLDD
is doing some internal recovery.
SDEV_QUIESCE only blocks 'norma
Hi,
what is the difference between these states? What function should
I call to block a device in order to securely flush the caches?
Regards
Oliver
-
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to [EMAIL PROTECTED]
More m
64 matches
Mail list logo