t_monitor user space program.
After this fix both Freefall and Transient events are handled by the driver
without any conflicts.
thanks, p.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 309
1 file changed, 141 insertions(+
This patch fixes by detaching the event related information from
chip_info struct,
and based on channel type and event direction the corresponding
event configuration registers
are picked dynamically. Hence multiple events can be handled in
read/write callbacks.
which chip can have which even
Greg,
Sure, I will fix it and resend a fresh patch.
Thanks,
Hari
xcept mma8653 chip all other chips like mma845x and
> > fxls8471 have single tap detection feature.
> > Tested thoroughly using iio_event_monitor application on
> > imx6ul-evk board which has fxls8471.
> >
> > Signed-off-by: Harinath Nampally
> > ---
> What t
Hi Martin,
> But given your concerns, I would strip down this patch to only offer the
> already documented "low_noise" and "low_power" modes. It wouldn't be
> worth it to extend the ABI just because of this!
OK then we can map 'low_noise' to high resolution mode. But I am afraid
I can't test the f
Rename structs holding event configuration registers
to more appropriate names. This naming is consistent
with the event config register names given in the
mma845x and fxls8471 datasheets.
Signed-off-by: Harinath Nampally
---
v4:
Shorter subject line and better description in commit message
Rename some struct names improve code readability.
Harinath Nampally (2):
iio: accel: mma8452: Rename a struct for code readibility
iio: accel: mma8452: Rename config structs for readability
drivers/iio/accel/mma8452.c | 16
1 file changed, 8 insertions(+), 8 deletions
Rename time step look up struct to generic name
as the values in the look table are same for all
the other events like pulse, transient etc.
Signed-off-by: Harinath Nampally
---
v4:
Shorter subject line and better description in commit message
drivers/iio/accel/mma8452.c | 6 +++---
1 file
to publish it for you to
> make any necessary corrections and submit it after testing.
>
> Do we have a deal?
Sure, sounds great!
Thanks,
Harinath
On Sun, Nov 5, 2017 at 3:36 PM, Martin Kepplinger wrote:
> On 2017-11-05 19:00, Harinath Nampally wrote:
>> Rename structs holding event
by not returning IRQ_NONE if DRDY is set.
>
> Fixes: 605f72de137a ("iio: accel: mma8452: improvements to handle
> multiple events")
>
> Signed-off-by: Leonard Crestez
Thanks for catching it. Looks good to me.
Acked-by: Harinath Nampally
Thanks,
Harinath
On Wed, Jun 20,
This patch fixes below kind of warnings:
WARNING: Symbolic permissions 'S_IXXX | S_IXXX' are not preferred.
Issue found and fixed by checkpatch.pl
Signed-off-by: Harinath Nampally
---
drivers/staging/iio/meter/ade7758_core.c | 50
1 file changed, 25
Jonathan,
Thank you for letting me know. In future I will work on 'togreg' branch
of iio.git tree to send my patches.
Thanks,
Harinath
On Sun, May 14, 2017 at 11:29 AM, Jonathan Cameron wrote:
> On 10/05/17 00:41, Harinath Nampally wrote:
>>
>> This patch fix
it is for different file
ade7758_core.c
Please refer to below link for Quentin Swain's patch.
https://www.spinics.net/lists/linux-iio/msg33010.html
Please let me know if I am wrong.
Thanks,
Harinath
On Mon, May 15, 2017 at 12:22 AM, harinath Nampally
wrote:
> Jonathan,
>
> Thank
it is for different file
ade7758_core.c
Please correct me if I am wrong.
Thanks,
Harinath
On Mon, May 15, 2017 at 12:27 AM, harinath Nampally
wrote:
> Jonathan,
>
> Thank you for letting me know about correct iio git tree.
>
> I checked out 'togreg' branch, and noticed
Jonathan,
Yes I see it in the testing branch, thank you for letting me know.
Thanks,
Harinath
On Tue, May 16, 2017 at 2:24 PM, Jonathan Cameron wrote:
> On 15/05/17 05:38, harinath Nampally wrote:
>>
>> Jonathan,
>>
>> Thank you for letting me know about correct ii
This patch fixes the miscoded use of return value of snprintf
by using the scnprintf function which returns the length of actual
string created in the buffer.
Signed-off-by: Harinath Nampally
---
drivers/staging/iio/light/tsl2x7x.c | 20 ++--
1 file changed, 10 insertions(+), 10
On Mon, 31 Jul 2017 07:17:38 -0400
Harinath Nampally wrote:
This driver supports multiple devices like mma8653, mma8652, mma8452, mma8453
and
fxls8471. Almost all these devices have more than one event. Current driver
design
hardcodes the event specific information, so only one event can be
On Mon, 31 Jul 2017 07:17:38 -0400
Harinath Nampally wrote:
This driver supports multiple devices like mma8653, mma8652, mma8452, mma8453
and
fxls8471. Almost all these devices have more than one event. Current driver
design
hardcodes the event specific information, so only one event can be
On 08/01/2017 11:50 AM, Martin Kepplinger wrote:
On 2017-08-01 05:08, Harinath Nampally wrote:
Thanks for doing that work. I have had it on my list for a long time
and you seem to fix it. Although I'd happily review and possibly test
it, unfortunately I can't do so before the week of
k when disabling
it'. Please elaborate. I would
appreciate if you could suggest your logic in the form of pseudo-code.
Thanks for your time
On Tue, Aug 29, 2017 at 10:55 PM, harinath Nampally
wrote:
>> We should never say "transient is for rising
>> direction" or "
If rising: use transient OR ff_mt device-dependent like before. But
now save it in a simple flag,
whether transient registers are available.
Ok, is it good idea to add the flag to struct mma_chip_info like below?
* @mma_scales:scale factors for converting
register v
> Am 23.08.2017 02:29 schrieb Harinath Nampally:
> If rising: use transient OR ff_mt device-dependent like before. But now save
> it in a simple flag,
> whether transient registers are available.
> Ok, is it good idea to add the flag to struct mma_chip_info like below?
&g
-Remove unrelated change of IIO_ACCEL channel type
check in read/write event callbacks
Changes since v1 -> v2
-Fix indentations
-Remove unused fields in mma8452_event_regs struct
-Remove redundant return statement
-Remove unrelated changes like checkpatch.pl warning f
nt threshold mask
-Remove unrelated change of IIO_ACCEL channel type
check in read/write event callbacks
Changes since v1 -> v2
-Fix indentations
-Remove unused fields in mma8452_event_regs struct
-Remove redundant return statement
-Remove unrelated changes like checkpatch
i
On Sun, Sep 10, 2017 at 11:51 AM, Jonathan Cameron wrote:
> On Sun, 10 Sep 2017 08:36:43 +0200
> Martin Kepplinger wrote:
>
>> On 2017-09-09 21:56, Harinath Nampally wrote:
>> > This driver supports multiple devices like mma8653,
>> > mma8652, mma8452,
gs_accel_rising' to 'ev_trans_regs'
and 'ev_regs_accel_falling' to 'ev_ff_mt_regs'.
As Jon just applied this patch, I will cover this in my next patch set
which fix the checkpatch.pl warnings in this file.
Thanks,
Hari
On Sun, Sep 10, 2017 at 2:36 AM, Martin Kep
M, Jonathan Cameron wrote:
> On Tue, 29 Aug 2017 23:01:16 -0400
> harinath Nampally wrote:
>
>> > We should never say "transient is for rising
>> > direction" or "ff_mt is for falling direction". any combination is fine.
>>
>> Ok I a
This patch fixes by detaching the event related information from
chip_info struct,
and based on channel type and event direction the corresponding
event configuration registers
are picked dynamically. Hence multiple events can be handled in
read/write callbacks.
which chip can have which even
ations
-Remove unused fields in mma8452_event_regs struct
-Remove redundant return statement
-Remove unrelated changes like checkpatch.pl warning fixes
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 272 +++-
1 file changed, 118 insertions(+
river without any conflicts.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 277
1 file changed, 123 insertions(+), 154 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index eb6e3dc..7bfc257 100644
[PATCH V3]...
(I think, I've lost track - but this needs to be in the patch title
so we know which is latest.
ok I will resend it with patch version and change history.
This just missed my pull request for today anyway. There may be time for
another pull towards the end of this week, depending
hange of IIO_ACCEL channel type
check in read/write event callbacks
Changes since v1 -> v2
-Fix indentations
-Remove unused fields in mma8452_event_regs struct
-Remove redundant return statement
-Remove unrelated changes like checkpatch.pl warning fixes
Signed-off-by
igit octal (0777) not decimal permissions
ade7753.c:386: ERROR: Use 4 digit octal (0777) not decimal permissions
Signed-off-by: Harinath Nampally
---
drivers/staging/iio/meter/ade7753.c | 104 ++--
1 file changed, 52 insertions(+), 52 deletions(-)
diff --git a/drive
Signed-off-by: Harinath Nampally
---
drivers/staging/iio/meter/ade7753.c | 46 ++---
1 file changed, 23 insertions(+), 23 deletions(-)
diff --git a/drivers/staging/iio/meter/ade7753.c
b/drivers/staging/iio/meter/ade7753.c
index 5d45a68..2534bd0 100644
--- a/drive
This patch fixes below checkpatch.pl kind of warnings:
CHECK: Alignment should match open parenthesis
Signed-off-by: Harinath Nampally
---
drivers/staging/iio/meter/ade7753.c | 55 ++---
1 file changed, 27 insertions(+), 28 deletions(-)
diff --git a/drivers
This patch fixes below checkpatch.pl warning:
CHECK: struct mutex definition without comment
Signed-off-by: Harinath Nampally
---
drivers/staging/iio/meter/ade7753.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/iio/meter/ade7753.c
b/drivers/staging/iio
permissions
-
Harinath Nampally (3):
staging: iio: meter: Add the comment for mutex definition in ade7753.c
staging: iio: meter: Fix the identations for proper alignments in
ade7753.c
staging: iio: meter: Replace
Signed-off-by: Harinath Nampally
---
Changes in v2:
- None because only [PATCH v2 1/3] has improvement
drivers/staging/iio/meter/ade7753.c | 46 ++---
1 file changed, 23 insertions(+), 23 deletions(-)
diff --git a/drivers/staging/iio/meter/ade7753.c
b/drivers/s
] staging: iio: meter: Add the comment for mutex definition
[PATCH v2 2/3] staging: iio: meter: Fix the identations for proper alignments
[PATCH v2 3/3] staging: iio: meter: Replace symbolic permissions with octal
permissions
Harinath Nampally (3):
staging: iio: meter: Add the comment for mutex
This patch fixes below checkpatch.pl kind of warnings:
CHECK: Alignment should match open parenthesis
Signed-off-by: Harinath Nampally
---
Changes in v2:
- None because only [PATCH v2 1/3] has improvement
drivers/staging/iio/meter/ade7753.c | 55 ++---
1 file
This patch fixes below checkpatch.pl warning:
CHECK: struct mutex definition without comment
Signed-off-by: Harinath Nampally
---
Changes in v2:
- Removed the extra comment for mutex in the struct.
drivers/staging/iio/meter/ade7753.c | 3 ++-
1 file changed, 1 insertions(+), 1
Replace 'unsigned' with 'unsigned int'
to improve code readability.
Issue found by checkpatch.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers
Replace symbolic permissions with octal permissions
to improve code readability.
Issue found by checkpatch.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel
Please find the following patches:
iio: accel: mma8452: Fix code style warning for symbolic permissions
iio: accel: mma8452: Fix code style warning for unsigned int
declarations
drivers/iio/accel/mma8452.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
--
2.7.4
Improves code readability, no impact on functionality.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 6194169..3472e7e 100644
--- a
Harinath Nampally (3):
Following 2 patches are for refactor:
iio: accel: mma8452: Rename time step look up struct to generic
name as the values are same for all the events.
iio: accel: mma8452: Rename read/write event value callbacks to
generic function name.
Following patch
re.
Tested thoroughly using iio_event_monitor application on
imx6ul-evk board.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 156 ++--
1 file changed, 151 insertions(+), 5 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers
lity.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 74b6221..43c3a6b 100644
--- a/drivers/iio/accel/mma8452.c
+++ b/drivers/iio/accel/mma845
Improves code readability, no impact on functionality.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 3472e7e..74b6221 100644
--- a/drivers
Improves code readability, no impact on functionality.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 6194169..3472e7e 100644
--- a
Rename some struct names and function names to
improve code readability.
Harinath Nampally (3):
iio: accel: mma8452: Rename structs holding event configuration
registers to more appropriate names.
iio: accel: mma8452: Rename time step look up struct to generic
name as the
lity.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 74b6221..43c3a6b 100644
--- a/drivers/iio/accel/mma8452.c
+++ b/drivers/iio/accel/mma845
Improves code readability, no impact on functionality.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 3472e7e..74b6221 100644
--- a/drivers
re.
Tested thoroughly using iio_event_monitor application on
imx6ul-evk board.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 156 ++--
1 file changed, 151 insertions(+), 5 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers
Please disregard this patch set as this includes an unrelated patch
'[PATCH 4/4] iio: accel: mma8452: Add single pulse/tap event detection
feature for fxls8471.'
On Mon, Sep 25, 2017 at 6:07 AM, Harinath Nampally
wrote:
> This patch adds following changes to support tap feature
et email right. Why not test sending it
> privately
> to yourself first?
Sure will do, sorry for the convenience.
Thanks,
Harinath
On Mon, Sep 25, 2017 at 6:11 AM, Martin Kepplinger wrote:
> Am 25.09.2017 12:07 schrieb Harinath Nampally:
>>
>> Rename some struct names an
lity.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 74b6221..43c3a6b 100644
--- a/drivers/iio/accel/mma8452.c
+++ b/drivers/iio/accel/mma845
Improves code readability, no impact on functionality.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 3472e7e..74b6221 100644
--- a/drivers
Improves code readability, no impact on functionality.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 6194169..3472e7e 100644
--- a
Rename some struct names and function names to
improve code readability.
Harinath Nampally (3):
iio: accel: mma8452: Rename structs holding event configuration
registers to more appropriate names.
iio: accel: mma8452: Rename time step look up struct to generic
name as the
ote:
>
>> Am 25.09.2017 12:40 schrieb Harinath Nampally:
>> > Improves code readability, no impact on functionality.
>> >
>> > Signed-off-by: Harinath Nampally
>>
>> Please make the headline shorter and put some of it in the git commit
>> messag
> > On 2017-09-30 19:59, Jonathan Cameron wrote:
> > > On Wed, 27 Sep 2017 08:52:54 +0200
> > > Martin Kepplinger wrote:
> > >
> > >> Am 25.09.2017 12:40 schrieb Harinath Nampally:
> > >>> Improves code readability, no impact on fun
backs.
Changes are thoroughly tested on fxls8471 device on imx6UL Eval board using
iio_event_monitor user space program.
After this fix both Freefall and Transient events are handled by the driver
without any conflicts.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c
backs.
Changes are thoroughly tested on fxls8471 device on imx6UL Eval board using
iio_event_monitor user space program.
After this fix both Freefall and Transient events are handled by the driver
without any conflicts.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c
left/right.
Any suggestions are welcome. Thank you.
On 07/31/2017 10:17 PM, harinath Nampally wrote:
This driver supports multiple devices like mma8653, mma8652, mma8452,
mma8453 and
fxls8471. Almost all these devices have more than one event. Current
driver design
hardcodes the event specific infor
backs.
Changes are thoroughly tested on fxls8471 device on imx6UL Eval board using
iio_event_monitor user space program.
After this fix both Freefall and Transient events are handled by the driver
without any conflicts.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c
ghly using iio_event_monitor application on
imx6ul-evk board which has fxls8471.
Signed-off-by: Harinath Nampally
---
drivers/iio/accel/mma8452.c | 156 ++--
1 file changed, 151 insertions(+), 5 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers
Hi Martin,
Thanks for publishing the patch.
I will work on it, but unfortunately I can't promise anything before 11/27.
Thanks,
Harinath
On Mon, Nov 6, 2017 at 2:19 AM, Martin Kepplinger wrote:
> This adds the power_mode sysfs interface to the device as documented in
> sysfs-bus-iio.
>
> ---
>
> This replaces the custom license information text with the appropriate
> SPDX identifier. While the information here stays the same, it is easier
> to read.
> Signed-off-by: Martin Kepplinger
> Acked-by: Peter Meerwald-Stadler
Acked-by: Harinath Nampally
On Sat, Nov 18, 2
xcept mma8653 chip all other chips like mma845x and
> > fxls8471 have single tap detection feature.
> > Tested thoroughly using iio_event_monitor application on
> > imx6ul-evk board which has fxls8471.
> >
> > Signed-off-by: Harinath Nampally
>
> The use of
To fix the below warning added static qualifier
"warning: symbol 'verify_sha256_digest' was not
declared"
Signed-off-by: Harinath Nampally
---
arch/x86/purgatory/purgatory.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/purgatory/pu
To fix the below warning added static qualifier
"warning: symbol 'verify_sha256_digest' was not
declared"
Signed-off-by: Harinath Nampally
---
arch/x86/purgatory/purgatory.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/purgatory/pu
72 matches
Mail list logo