> On Tue, Feb 19, 2013 at 03:07:57PM +0000, Pallala, Ramakrishna wrote:
> > I am trying to populate battery related information through ACPI
> > tables and do battery management through non acpi drivers. Can you
> > tell or point me on how to populate the ACPI tables in FW/
> > > On Tue, Feb 19, 2013 at 03:07:57PM +, Pallala, Ramakrishna wrote:
> > > > I am trying to populate battery related information through ACPI
> > > > tables and do battery management through non acpi drivers. Can
> > > > you tell or point me
> > > > > > I am trying to populate battery related information through
> > > > > > ACPI tables and do battery management through non acpi
> > > > > > drivers. Can you tell or point me on how to populate the ACPI
> > > > > > tables in FW/BIOS and get them in OS? I am new to ACPI world.
> > > > >
>
> > Mika, I want to populate this characterization data as device
> > specific/custom data which could be anything And may not be entirely
> > related to battery. Is this is possible?
>
> Yes, for example you could have a custom ACPI method with your device which
> then returns this information.
>
> > Mika, _BIF method returns battery data/struct which is defined Table.
> > 10-233.
>
> Yes, it was just an example. You can have your own custom method for that,
> lets
> say:
>
> BLAH()
>
> that then returns whatever you need.
>
> > If I want to pass some device specific data seems
Hi,
How can I schedule driver's worker and threaded IRQ on the same core?
For work queue we have schedule_delayed_work_on () API available.
But how to schedule the threaded IRQ on the same core where my worker thread is
going to run?
Thanks in Advance.
Thanks,
Ram
--
To unsubscribe from this l
> > How can I schedule driver's worker and threaded IRQ on the same core?
> >
> > For work queue we have schedule_delayed_work_on () API available.
> > But how to schedule the threaded IRQ on the same core where my worker
> thread is going to run?
> Why do you need to worry about where your worker
> On Tue, 2012-10-02 at 12:54 +0000, Pallala, Ramakrishna wrote:
> > > > How can I schedule driver's worker and threaded IRQ on the same core?
> > > >
> > > > For work queue we have schedule_delayed_work_on () API available.
> > > > But ho
Thanks Alan.
> The second error check is unreachable because the lock function isn't assigned
> to ret
>
> Signed-off-by: Alan Cox
Acked-by: Ramakrishna Pallala
> ---
>
> drivers/power/max17042_battery.c |2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/po
> -bool irq_work_queue(struct irq_work *work)
> +void irq_work_queue(struct irq_work *work)
> {
> - if (!irq_work_claim(work)) {
> - /*
> - * Already enqueued, can't do!
> - */
> - return false;
> - }
> -
> + /*
> + * This functio
Hi Anton,
> On Thu, Jul 26, 2012 at 08:47:24PM +0530, Ramakrishna Pallala wrote:
> > On some platforms one driver(or HW chip) may not be able to provide
> > all the necessary attributes of the power supply connected to the
> > platform or may provide very limited info which can be used by core/pri
> if (power_supply_register(pchg->dev, &psy->usb))
> - goto err_psy;
> + goto err_psy_ac;
"err_psy_ac" label name is confusing. Why can't you use err_psy_usb
> if (power_supply_register(pchg->dev, &psy->batt))
> - goto err_psy;
> + goto
> On Wed, Sep 19, 2012 at 10:37:34AM +0300, Mika Westerberg wrote:
> > On Tue, Sep 18, 2012 at 09:58:07PM +0530, Ramakrishna Pallala wrote:
> > > This patch checks for charger status register for determining the
> > > battery charging status and reports Discharing/Charging/Not
> > > Charging/Full a
> > +static int ps_get_cur_chrage_cntl_limit(struct thermal_cooling_device
> > +*tcd,
>
> Typo, "charge".
>
> > + unsigned long *state)
> > +{
> > + struct power_supply *psy;
> > + union power_supply_propval val;
> > + int ret;
> > +
> > + WARN_ON
Hi Anton,
> > On Thu, Jul 26, 2012 at 08:47:24PM +0530, Ramakrishna Pallala wrote:
> > > On some platforms one driver(or HW chip) may not be able to provide
> > > all the necessary attributes of the power supply connected to the
> > > platform or may provide very limited info which can be used by
> On Sun, Jul 29, 2012 at 09:01:54AM +0530, Ramakrishna Pallala wrote:
> > It is possible that users can use non-standard chargers or use invalid
> > batteries especially with mobile devices.
>
> Maybe 'original' or 'authentic' would be a better term for this?
> For me, 'valid' is kind of too broa
Hi Anton,
> On Thu, Aug 23, 2012 at 07:19:18AM +0530, Ramakrishna Pallala wrote:
> > This patch checks for charger status register for determining the
> > battery charging status and reports Discharing/Charging/Not
> > Charging/Full accordingly.
> >
> > This patch also adds the interrupt support f
> > > > This patch checks for charger status register for determining the
> > > > battery charging status and reports Discharing/Charging/Not
> > > > Charging/Full accordingly.
> > > >
> > > > This patch also adds the interrupt support for Safety Timer Expiration.
> > > > This interrupt is helpful
> On Fri, Jul 20, 2012 at 07:22:48PM +0530, Ramakrishna Pallala wrote:
> > This patch checks for charger status register for determining the
> > battery charging status and reports Discharing/Charging/Not
> > Charging/Full accordingly.
> >
> > This patch also adds the interrupt support for Safety
> On Fri, Jul 27, 2012 at 10:26:21PM +0530, Ramakrishna Pallala wrote:
> > This patch adds the support to report the battery power supply
> > attributes STATUS and CHARGE_TYPE. This patch makes use of
> > power_supply_get_external_attr() API to get these attributes through power
> supply core.
> >
Hi Anton,
Please ignore the following patch.
> This patch adds a helper function in the power supply core to get the power
> supply object from supplied_to list based on power supply attribute.
>
> Signed-off-by: Ramakrishna Pallala
> ---
> drivers/power/power_supply_core.c | 19 +++
> > +struct power_supply_charger_control {
> > + const char *name;
> > + /* get charging status */
> > + int (*is_charging_enabled)(void);
> > + int (*is_charger_enabled)(void);
> > +
> > + /* set charging parameters */
> > + int (*set_in_current_limit)(int uA);
> > + int (*set_charge
> > > > +struct power_supply_charger_control {
> > > > + const char *name;
> > > > + /* get charging status */
> > > > + int (*is_charging_enabled)(void);
> > > > + int (*is_charger_enabled)(void);
> > > > +
> > > > + /* set charging parameters */
> > > > + int (
> > > > > +struct power_supply_charger_control {
> > > > > + const char *name;
> > > > > + /* get charging status */
> > > > > + int (*is_charging_enabled)(void);
> > > > > + int (*is_charger_enabled)(void);
> > > > > +
> > > > > + /* set charging parameters */
> > > > > + i
Hi Choi,
> Subject: [PATCH 1/2] extcon: Modify the id and name of external connector
>
> This patch modifies the id and name of external connector with the additional
> prefix to clarify both attribute and meaning of external connector as
> following:
> - EXTCON_CHG_* mean the charger connector
> >> diff --git a/include/linux/extcon.h b/include/linux/extcon.h index
> >> c0f8c4fc5d45..c8dd881e2b8d 100644
> >> --- a/include/linux/extcon.h
> >> +++ b/include/linux/extcon.h
> >> @@ -31,32 +31,42 @@
> >> /*
> >> * Define the unique id of supported external connectors
> >> */
> >> -#define
Hi Andreas,
> On Wed, Aug 26, 2015 at 11:03:00AM +0000, Pallala, Ramakrishna wrote:
> > Hi Andreas,
> >
> > I went on a unplanned leave and I came back to office recently. I will go
> through your comments and get back to you.
>
> Hi Ram,
> hope all is we
Hi,
> From: k.kozlowsk...@gmail.com [mailto:k.kozlowsk...@gmail.com] On Behalf
> Of Krzysztof Kozlowski
> Sent: Monday, September 7, 2015 9:28 AM
> To: Pallala, Ramakrishna
> Cc: linux-kernel@vger.kernel.org; linux...@vger.kernel.org;
> devicet...@vger.kernel.org; Sebastian
Hi Andreas,
> Hi Ram, thanks for submitting this, please see some feedback inlined...
>
> On Sun, Sep 06, 2015 at 10:53:07PM +0530, Ramakrishna Pallala wrote:
> > Add new charger driver support for BQ24261 charger IC.
> >
> > BQ24261 charger driver relies on extcon notifications to get the
> > c
Hi,
> > diff --git a/include/linux/mfd/axp20x.h b/include/linux/mfd/axp20x.h
> > index dfabd6d..4ed8071 100644
> > --- a/include/linux/mfd/axp20x.h
> > +++ b/include/linux/mfd/axp20x.h
> > @@ -275,4 +275,9 @@ struct axp20x_fg_pdata {
> > int thermistor_curve[MAX_THERM_CURVE_SIZE][2];
> > };
>
> > > > diff --git a/include/linux/mfd/axp20x.h
> > > > b/include/linux/mfd/axp20x.h index dfabd6d..4ed8071 100644
> > > > --- a/include/linux/mfd/axp20x.h
> > > > +++ b/include/linux/mfd/axp20x.h
> > > > @@ -275,4 +275,9 @@ struct axp20x_fg_pdata {
> > > > int thermistor_curve[MAX_THERM_CU
Hi Choi,
> Hi Ramakrishna,
>
> When I apply this patch for build test on extcon-next branch, conflict happen.
> you have to implement this patchset on latest extcon-next branch.
Ok I will create the patches on
git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git
> Also, This patch m
> > This patch series adds the support for axp288 extcon driver and also
> > adds the cell info for extcon device in axp20x mfd driver.
> >
> > Ramakrishna Pallala (2):
> > mfd/axp20x: add support for extcon cell
> > extcon-axp288: Add axp288 extcon driver support
> >
> > drivers/extcon/Kconfi
> On Thu, 02 Apr 2015, Ramakrishna Pallala wrote:
>
> > This patch adds the mfd cell info for axp288 extcon device.
> >
> > Signed-off-by: Ramakrishna Pallala
> > ---
> > drivers/mfd/axp20x.c | 28
> > include/linux/mfd/axp20x.h |5 +
> > 2 files chan
Hi Choi,
Please find my response below.
> On 04/09/2015 02:12 AM, Ramakrishna Pallala wrote:
> > This patch adds the extcon support for AXP288 PMIC which has the BC1.2
> > charger detection capability. Additionally it also adds the USB mux
> > switching support b/w SOC and PMIC based on GPIO con
Hi Choi,
Please see my response below.
> >>
> >>> + ret = PTR_ERR(info->otg);
> >>> + return ret;
> >>> + }
> >>> +
> >>> + for (i = 0; i < EXTCON_IRQ_END; i++) {
> >>> + pirq = platform_get_irq(pdev, i);
> >>> + info->irq[i] = regmap_irq_get_virq(info->regmap_irqc
>
> Only a license nit.
>
> On Tue, 2015-04-28 at 04:02 +0530, Ramakrishna Pallala wrote:
> > --- /dev/null
> > +++ b/drivers/extcon/extcon-axp288.c
>
> > + * This program is free software; you can redistribute it and/or
> > + modify
> > + * it under the terms of the GNU General Public License a
> > This patch adds the extcon support for AXP288 PMIC which has the BC1.2
> > charger detection capability. Additionally it also adds the USB mux
> > switching support b/w SOC and PMIC based on GPIO control.
> >
> > Signed-off-by: Ramakrishna Pallala
> > ---
> > drivers/extcon/Kconfig |
> On Tue, 28 Apr 2015, Pallala, Ramakrishna wrote:
>
> > > > This patch adds the extcon support for AXP288 PMIC which has the
> > > > BC1.2 charger detection capability. Additionally it also adds the
> > > > USB mux switching support b/w SOC and PMIC bas
Hi Choi,
> On Tue, Apr 28, 2015 at 8:20 PM, Pallala, Ramakrishna
> >> > > > diff --git a/include/linux/mfd/axp20x.h
> >> > > > b/include/linux/mfd/axp20x.h index dfabd6d..81152e2 100644
> >> > > > --- a/include/linux/mfd/axp20x.h
> &g
> On Tue, Apr 28, 2015 at 9:17 PM, Pallala, Ramakrishna
> wrote:
> > Hi Choi,
> >
> >> On Tue, Apr 28, 2015 at 8:20 PM, Pallala, Ramakrishna
> >> >> > > > diff --git a/include/linux/mfd/axp20x.h
> >> >> > > > b/include/l
Hi Lee Jones,
I have agreed to move the AXP288_EXTCON_* macros to driver source file as
Choi is going to submit another extcon class driver patch to fix the consumer
driver
access issue.
I will submit the v7 patch now with this change. Thank you for your time.
> > This patch adds the extcon sup
> When submitting patches, please observe the $SUBJECT line formatting of the
> subsystem you're sending to.
>
> You can do so by: `git log --oneline -- drivers/`
>
> In the case of MFD it's:
>
> mfd: :
>
> Note the ':' separators and the capitalisation of the first letter of the
> descriptio
Hi Sebastian,
> -Original Message-
> From: Todd E Brandt [mailto:todd.e.bra...@linux.intel.com]
> Sent: Saturday, March 14, 2015 9:29 AM
> To: Pallala, Ramakrishna
> Cc: linux-kernel@vger.kernel.org; Sebastian Reichel; Brandt, Todd E;
> Woodhouse, David
>
Hi Sebastian,
It's been almost 45 days since I submitted this patch and I did not receive any
feedback from you.
Can you take a look at this patch now?
> On Fri, Mar 13, 2015 at 09:49:09PM +0530, Ramakrishna Pallala wrote:
> > Add the original author details of the axp288_fuel_gauge driver.
> >
Hi Choi,
Thank you for the comments. I will be fixing them and submit the v8 patch.
> On Wed, Apr 29, 2015 at 11:22 AM, Ramakrishna Pallala
> wrote:
> > This patch adds the extcon support for AXP288 PMIC which has the BC1.2
> > charger detection capability. Additionally it also adds the USB mux
> > This patch adds the extcon support for AXP288 PMIC which has the BC1.2
> > charger detection capability. Additionally it also adds the USB mux
> > switching support b/w SOC and PMIC based on GPIO control.
> >
> > Signed-off-by: Ramakrishna Pallala
>
> When you send next versions, the conventi
Hi Choi,
I think I missed some. I will fix them and submit the v9 patch.
> Hi Ram,
>
> I added some comment.
> If you fix minor issue according to comment, I'll apply it.
>
> On 04/30/2015 10:43 AM, Ramakrishna Pallala wrote:
> > This patch adds the extcon support for AXP288 PMIC which has the
> Hi Ram,
>
> This patch has still one minor issue on below comment.
> But I fix it and will apply it on extcon-next branch after discussing how to
> apply
> this patch with Lee Jones (MFD maintainer).
Ok. Thanks.
> Dear Lee,
> Do you want to send pull request after I make the immutable branch f
Thanks you. I will add linux-pm also in CC list going forward.
> On Wed, Apr 29, 2015 at 06:09:29AM +0000, Pallala, Ramakrishna wrote:
> > It's been almost 45 days since I submitted this patch and I did not
> > receive any feedback from you.
> > Can you take a look at
Hi Anton,
Following patch needs your attention.
Thanks,
Ram
> From: Pallala, Ramakrishna
> Sent: Monday, June 25, 2012 6:07 PM
> To: linux-kernel@vger.kernel.org
> Cc: Anton Vorontsov; Anton Vorontsov; Pallala, Ramakrishna
> Subject: [PATCH] power_supply: Added support f
Hi Anton,
Sorry for replying late. But please find my response below.
> > This patch adds the generic support to register the drivers as power
> > supply attribute(properties) sources and adds an interface to read
> > these attributes from power supply class drivers.
>
> So, you would add power
Hi All,
I am trying to enable a i2c client driver under ACPI. The device is being
enumerated behind adapter device and I am getting IRQ resource as well.
The problem I have now is, how do I pass the platform data to driver?
struct i2c_board_info {
chartype[I2C_NAME_SIZE];
>> In non ACPI environment I used to initialize the platform_data under
>> board or platforms files. Under ACPI how do I do that?
>
>If you can't extract that information from ACPI namespace, then one option is
>to pass platform data along with the device ACPI ID:
>
>static const struct acpi_devi
>> > > And initialize the platform data in either driver or in separate
>> > > module which gets compiled along with driver?
>> >
>> > Typically it has been done in the same driver but I don't see any
>> > problems having a separate module as well.
>> >
>> > > static const struct acpi_device_id
HI All,
I have received few kernel library .o (object files) from third party and I am
planning to include in our kernel tree. As the library contains some
proprietary algorithms the sources are not shared.
How can I include this library .o files to my kernel and if this kernel is
release to
guess the late Friday push was
too hard).
I promise to be more careful next time.
Thanks & Regards,
Ram
-Original Message-
From: Hohndel, Dirk
Sent: Saturday, April 26, 2014 3:31 AM
To: linux-kernel@vger.kernel.org
Cc: Pallala, Ramakrishna
Subject: Re: how to include already comp
Hi Jacob,
> +#if defined(CONFIG_PM_SLEEP) || defined(CONFIG_PM_RUNTIME) static int
> +axp288_gpadc_suspend(struct device *dev) {
> + int ret;
> + struct iio_dev *indio_dev = dev_get_drvdata(dev);
> + struct gpadc_info *info = iio_priv(indio_dev);
> +
> + mutex_lock(&indio_dev->mlo
Hi Andreas,
I went on a unplanned leave and I came back to office recently. I will go
through your comments and get back to you.
> Subject: Re: [RFC PATCH] power: bq24261_charger: Add support for TI BQ24261
> charger
>
> Hi,
>
> On Tue, Aug 18, 2015 at 11:19:35PM +0530, Ramakrishna Pallala wr
Hi Krzysztof Kozlowski,
>On Tue, Jun 23, 2015 at 09:58:41AM +0900, Krzysztof Kozlowski wrote:
>> 2015-06-08 10:22 GMT+09:00 Krzysztof Kozlowski :
>> > 2015-05-24 12:41 GMT+09:00 Ramakrishna Pallala
>> > :
>> >> This patch adds the support for following battery properties to
> >> max17042 fuel ga
Hi Sebastian,
> On Thu, Oct 29, 2015 at 10:07:03PM +0530, Ramakrishna Pallala wrote:
> > This patch series adds the support for TI BQ24261 charger driver.
> >
> > TI BQ24261 charger driver relies on extcon notifications to get the
> > charger cable type and based on that it will set the charging p
Hi Sebastian,
Any feedback on this patch?
> This patch adds new power supply charger driver support for X-Power AXP288
> PMIC integrated charger.
>
> This driver interfaces with the axp20x mfd driver as a cell and listens to
> extcon
> cable events for setting up charging.
>
> Signed-off-by: R
Hi Sebastian,
Any feedback on this patch?
> This patch adds the support for following battery properties to max17042 fuel
> gauge driver.
>
> POWER_SUPPLY_PROP_TEMP_ALERT_MIN
> POWER_SUPPLY_PROP_TEMP_ALERT_MAX
> POWER_SUPPLY_PROP_TEMP_MIN
> POWER_SUPPLY_PROP_TEMP_MAX
> POWER_SUPPLY_PROP_HEALTH
>
> Hi,
>
> On Tue, May 05, 2015 at 05:10:32AM +0530, Ramakrishna Pallala wrote:
> > This patch adds the support for following battery properties to
> > max17042 fuel gauge driver.
> >
> > POWER_SUPPLY_PROP_TEMP_ALERT_MIN
> > POWER_SUPPLY_PROP_TEMP_ALERT_MAX
> > POWER_SUPPLY_PROP_TEMP_MIN
> > POWER_
> This patch uses the unique id to identify the type of external connector
> instead
> of string name. The string name have the many potential issues. So, this patch
> defines the 'extcon' enumeration which includes all supported external
> connector
> on EXTCON subsystem. If new external connecto
Hi,
> W dniu 05.05.2015 o 07:18, Ramakrishna Pallala pisze:
> > This patch adds the support for following battery properties to
> > max17042 fuel gauge driver.
>
> The patchset itself looks good. Only minor nits and a question at the end.
>
> >
> > POWER_SUPPLY_PROP_TEMP_ALERT_MIN
> > POWER_SUPP
> Hi,
>
> On Fri, Sep 11, 2015 at 09:58:40AM +0900, Krzysztof Kozlowski wrote:
> > On 11.09.2015 01:42, Andrew F. Davis wrote:
> > > On 09/09/2015 06:47 PM, Krzysztof Kozlowski wrote:
> > > +- ti,enable-user-write: boolean, if present driver will allow
> > > +the
> > > user space
> > >
Hi Krzysztof,
> 2015-10-30 1:37 GMT+09:00 Ramakrishna Pallala
> :
> > This patch adds the device tree documentation for TI BQ24261 charger.
> >
> > Signed-off-by: Ramakrishna Pallala
> > Signed-off-by: Jenny TC
> > ---
> > .../devicetree/bindings/power/bq24261.txt | 34
>
68 matches
Mail list logo