label = "devkit8000::led2";
> + gpios = <&gpio6 3 0>; /* 163 -> LED2 */
> + default-state = "on";
> + linux,default-trigger = "none";
> + };
+ status = "disabled";
> +};
> +
> +&wdt2 {
> + status = "disabled";
> +};
> +
> +&mcbsp1 {
> + status = "disabled";
> +};
> +
> +&mcbsp2 {
> + status = "disabled";
> +};
> +
> +&mcb
engine_terminate_all(tspi->rx_dma_chan);
> + dev_err(tspi->dev, "RxDma Xfer failed\n");
> + err += 2;
> + }
> + }
> + }
> +
> + spin_lock_irqsave(&tspi->
Hi Mark,
Thank you for your reply.
On Tue, Oct 1, 2013 at 2:52 PM, Mark Brown wrote:
> On Tue, Oct 01, 2013 at 09:41:04AM +0530, Manish Badarkhe wrote:
>> This patch changes the driver to avoid the usage of IS_ERR_OR_NULL()
>> macro.
>
> Why?
Code use "IS_ERR_OR_NULL(
Hi Stephan,
Thank you for your reply.
On Tue, Oct 1, 2013 at 9:19 PM, Stephen Warren wrote:
> On 10/01/2013 08:59 AM, Manish Badarkhe wrote:
>> Hi Mark,
>>
>> Thank you for your reply.
>>
>> On Tue, Oct 1, 2013 at 2:52 PM, Mark Brown wrote:
>>> On Tue
Update the code to use devm_* API so that driver core will manage
resources.
Signed-off-by: Manish Badarkhe
---
This is just clean up of code to manage resources using "devm_"
funtions. Not tested on hardware.
:100644 100644 bddabc5... 4ddf97c... M drivers/input/touchscreen/atme
Update the code to use devm_* API so that driver core will manage
resources.
Signed-off-by: Manish Badarkhe
---
This is just clean up of code to manage resources using "devm_"
funtions. Not tested on hardware.
:100644 100644 59aa240... 73c5ad0... M drivers/input/touchscreen/atme
Update the code to use devm_* API so that driver core will manage
resources.
Signed-off-by: Manish Badarkhe
---
Changes since V1:
As per Dmitry's comment, avoid "devm_" operation on irq as it may cause
kernel crash while device is getting unbound and CCing Nick dryer.
:100644
gt;charger.name != charger_device->pdata->name)
> + kfree(charger_device->charger.name);
> +
> + return 0;
Ditto, If go with free_gpio.
Regards
Manish Badarkhe
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Currently, code checks false return value from "regulator_set_voltage"
to show failure message. Modify the code to check proper return
value from "regulator_set_voltage".
Signed-off-by: Manish Badarkhe
---
Based on master branch of linux-mainline.
:100644 100644 0fac344... 1
Currently, code include opp.h twice. Remove one inclusion
of opp.h
Signed-off-by: Manish Badarkhe
---
:100644 100644 574b16b... 93c29f4... M drivers/devfreq/exynos/exynos5_bus.c
drivers/devfreq/exynos/exynos5_bus.c |1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/devfreq/exynos
Remove unwanted define "WSI_TIMEOUT" present in code.
Signed-off-by: Manish Badarkhe
---
:100644 100644 e030e17... fa61323... M drivers/video/da8xx-fb.c
drivers/video/da8xx-fb.c |1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/video/da8xx-fb.c b/drivers/video/da8xx-
Instead of "#if defined(CONFIG_OF)" use "IS_ENABLED(CONFIG_OF)" option
for DT code to avoid if-deffery in code.
Also, arranged header files in alphabetically.
Signed-off-by: Manish Badarkhe
---
:100644 100644 bdd7b9b... 8b9c406... M drivers/power/tps65090-charger.c
dr
This patch changes the driver to avoid the usage of IS_ERR_OR_NULL()
macro.
The case present in this patch simply translates to normal check for pointer,
wheather it is NULL or has an error code.
Signed-off-by: Manish Badarkhe
---
:100644 100644 bd611cdf.. ad3d4d4... M drivers/regulator
ame);
> + if (ret)
> + dev_err(&client->dev, "Failed GPIO request: %d\n",
> ret);
This should include GPIO number also to show error with more verbosity.
Regards
Manish Badarkhe
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" i
&tps6507x_dev->ts->vref);
>> + if (err < 0)
>> + goto error_ret;
>> +
>> + err = of_property_read_u16(node, "ti,vendor",
>> + &am
Hi Dmitry
On Mon, Jul 1, 2013 at 4:40 PM, Manish Badarkhe
wrote:
>
> Hi Dmitry
>
>
> On Wed, Jun 12, 2013 at 12:23 PM, Vishwanathrao Badarkhe, Manish
> wrote:
> > Hi Dmitry,
> >
> > On Mon, Jun 10, 2013 at 23:33:11, Dmitry Torokhov wrote:
> >> Ma
Hi Mark,
On Fri, Feb 22, 2013 at 11:32 PM, Mark Brown
wrote:
> On Fri, Feb 22, 2013 at 07:59:11PM +0530, Manish Badarkhe wrote:
>> On Fri, Feb 22, 2013 at 6:07 PM, Laxman Dewangan
>> wrote:
>> > Add SPI driver for NVIDIA's Tegra114 SPI controller. This controll
Hi Dmitry,
On Tue, Jan 28, 2014 at 10:24 PM, Manish Badarkhe
wrote:
> Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
> option for DT code to avoid if-deffery in code.
>
> Signed-off-by: Manish Badarkhe
> ---
> Changes since V1:
> 1.Updated
Use "devm_regulator_register" instead of "regulator_register"
which simplifies the code.
Signed-off-by: Manish Badarkhe
---
:100644 100644 5ea64b9... 6d32341... M drivers/regulator/fixed.c
drivers/regulator/fixed.c |4 ++--
1 file changed, 2 insertions(+), 2 deleti
Instead of "#if define CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Signed-off-by: Manish Badarkhe
---
:100644 100644 b4513f2... d353fbc... M drivers/power/max8925_power.c
drivers/power/max8925_power.c | 14 +
Hi Tomasz,
Thank you for your review comments.
On Sun, Jan 26, 2014 at 6:52 PM, Tomasz Figa wrote:
>
> Hi Manish,
>
>
> On 26.01.2014 08:15, Manish Badarkhe wrote:
>>
>> Instead of "#if define CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
>> option
Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Signed-off-by: Manish Badarkhe
---
Changes since V1:
1. update code to retrieve platform/dt data in same function
:100644 100644 b4513f2... 20a7100... M drivers/p
Hi
On Mon, Jan 27, 2014 at 5:33 AM, Mark Brown wrote:
> On Sun, Jan 26, 2014 at 01:36:53PM -0800, Dmitry Torokhov wrote:
>> On Sat, Jan 25, 2014 at 11:35:54PM +0530, Manish Badarkhe wrote:
>
>> > Use "devm_regulator_register" instead of "regulator_regi
Figa wrote:
>>> > On 26.01.2014 22:45, Dmitry Torokhov wrote:
>>> >>
>>> >> On Sun, Jan 26, 2014 at 07:31:50PM +0530, Manish Badarkhe wrote:
>>> >>>
>>> >>> Hi Tomasz,
>>> >>>
&g
Hi Nishanth
On Wed, Oct 16, 2013 at 6:54 PM, Nishanth Menon wrote:
> On 10/16/2013 06:40 AM, Vishwanathrao Badarkhe, Manish wrote:
>> From: "Vishwanathrao Badarkhe, Manish"
>>
>> Currently, probe returns success(0) on "debugfs_create_dir"
>> function call failed. Return proper error on "debugfs_
Currently, driver includes 'pm_runtime.h' which is not
used anywhere in code hence remove this unnecessory
inclusion.
Signed-off-by: Manish Badarkhe
---
:100644 100644 a9caf04... 7af0020... M drivers/rtc/rtc-tps65910.c
drivers/rtc/rtc-tps65910.c |1 -
1 file changed, 1 deletio
Use the SIMPLE_DEV_PM_OPS macro to declare the driver's
pm_ops.
Signed-off-by: Manish Badarkhe
---
:100644 100644 d664ef5... bd72b0f... M drivers/power/max17042_battery.c
drivers/power/max17042_battery.c | 16 +---
1 file changed, 5 insertions(+), 11 deletions(-)
diff --
Hi Mark,
Apologize for my late reply.
On Thu, Oct 24, 2013 at 10:57 PM, Mark Rutland wrote:
>
> On Thu, Oct 24, 2013 at 06:05:53PM +0100, Manish Badarkhe wrote:
> > Hi Mark,
> >
> > Thank you for your reply.
> >
> > On Wed, Oct 23, 2013 at 10:15 PM, Mark Rut
pdev->name);
> + return PTR_ERR(rdev);
> + }
> +
> + /* Save regulator */
> + tps->rdev[id] = rdev;
> +
> + return 0;
> +}
Best Regards
Manish Badarkhe
--
To unsubscribe from this list: send the line "unsubscribe linux-ke
Update driver to use SIMPLE_DEV_PM_OPS macro for power
management suspend and resume operations.
Signed-off-by: Manish Badarkhe
---
:100644 100644 a1d74dd... 0c0ba92... M drivers/video/da8xx-fb.c
drivers/video/da8xx-fb.c | 22 ++
1 file changed, 10 insertions(+), 12
Hi Dmitry,
On Tue, Feb 11, 2014 at 10:15 PM, Manish Badarkhe
wrote:
> Hi Dmitry,
>
> On Tue, Jan 28, 2014 at 10:24 PM, Manish Badarkhe
> wrote:
>> Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
>> option for DT code to avoid if-deffery i
Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Signed-off-by: Manish Badarkhe
---
:100644 100644 b4513f2... 3e54476... M drivers/power/max8925_power.c
drivers/power/max8925_power.c | 17 +
1 file c
Update the code to use devm_* API so that driver core will manage
resources.
Signed-off-by: Manish Badarkhe
---
Changes since V1:
1. Updated driver to use "devm_kzalloc" to "kstrdup".
2. Updated commit message.
Not tested on any board.
:100644 100644 5ea64b9... e9763a4...
Hi Dmitry,
Thank you for your review.
On Tue, Jan 28, 2014 at 12:03 PM, Dmitry Torokhov
wrote:
> Hi Manish,
>
> On Tue, Jan 28, 2014 at 08:42:00AM +0530, Manish Badarkhe wrote:
>> Update the code to use devm_* API so that driver core will manage
>> resources.
>&g
Hi Heiko
Thank you for your reply.
On Tue, Jan 28, 2014 at 1:08 PM, Heiko Stübner wrote:
> On Tuesday, 28. January 2014 12:46:01 Manish Badarkhe wrote:
>> Hi Dmitry,
>>
>> Thank you for your review.
>>
>> On Tue, Jan 28, 2014 at 12:03 PM, Dmitry Toro
On Tue, Jan 28, 2014 at 2:25 PM, Heiko Stübner wrote:
> On Tuesday, 28. January 2014 14:16:39 Manish Badarkhe wrote:
>> Hi Heiko
>>
>> Thank you for your reply.
>>
>> On Tue, Jan 28, 2014 at 1:08 PM, Heiko Stübner wrote:
>> > On Tuesday, 28. January 201
Hi Tomasz,
On Tue, Jan 28, 2014 at 5:21 PM, Tomasz Figa wrote:
> Hi,
>
>
> On 27.01.2014 19:37, Manish Badarkhe wrote:
>>
>> Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
>> option for DT code to avoid if-deffery in code.
>>
>
Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Signed-off-by: Manish Badarkhe
---
Changes since V1:
1.Updated code to use "IS_ENABLED" during retrieval
of platform/DT data.
Changes since V2:
1.Updated c
Hi Stephan,
On Tue, Jan 28, 2014 at 10:11 PM, Stephen Warren wrote:
> On 01/27/2014 08:12 PM, Manish Badarkhe wrote:
>> Update the code to use devm_* API so that driver core will manage
>> resources.
>
> I'm not sure why this patch is sent to linux-te...@vger.kernel.org
Hi Mark,
On Tue, Jan 28, 2014 at 4:15 PM, Mark Brown wrote:
> On Tue, Jan 28, 2014 at 02:31:32PM +0530, Manish Badarkhe wrote:
>> On Tue, Jan 28, 2014 at 2:25 PM, Heiko Stübner wrote:
>
>> > I don't have a strong opinion on this and others are most likely more
>
Update the code to use devm_* API so that driver core will manage
resources.
Signed-off-by: Manish Badarkhe
---
:100644 100644 5ea64b9... 1d42613... M drivers/regulator/fixed.c
drivers/regulator/fixed.c | 44 ++--
1 file changed, 14 insertions(+), 30
This patch introduces "devm_kstrdup" API so that the
device's driver can allocate memory and copy string.
Signed-off-by: Manish Badarkhe
---
:100644 100644 545c4de... 6e88a3d... M drivers/base/devres.c
:100644 100644 952b010... 8fee649... M include/linux/device.h
drivers/base/d
of
"kstrdup".
2. Added a seperate patch to introduce new API "devm_kstrdup"
Changes since V1:
1. Updated driver to use "devm_kzalloc" instead of "kstrdup".
2. Updated commit message.
Manish Badarkhe (2):
devres: introduce API "devm_kstrdup&
Hi Joe,
Thank you for your review.
On Wed, Jan 29, 2014 at 9:48 AM, Joe Perches wrote:
> On Wed, 2014-01-29 at 09:33 +0530, Manish Badarkhe wrote:
>> This patch introduces "devm_kstrdup" API so that the
>> device's driver can allocate memory and copy string.
>
Hi Mark,
On Wed, Jan 29, 2014 at 5:10 PM, Mark Brown wrote:
> On Wed, Jan 29, 2014 at 04:38:20PM +0530, Manish Badarkhe wrote:
>> On Wed, Jan 29, 2014 at 9:48 AM, Joe Perches wrote:
>
>> >> + buf = devm_kzalloc(dev, size, gfp);
>
>> > If this is reall
This patch introduces "devm_kstrdup" API so that the
device's driver can allocate memory and copy string.
Signed-off-by: Manish Badarkhe
---
:100644 100644 545c4de... db4e264... M drivers/base/devres.c
:100644 100644 952b010... ec1b6e2... M include/linux/device.h
drivers/base/d
ed driver to use "devm_kzalloc" instead of "kstrdup".
2. Updated commit message.
Manish Badarkhe (2):
devres: introduce API "devm_kstrdup"
regulator: fixed: update to devm_* API
drivers/base/devres.c | 26 ++
drivers/regulator/fixe
Update the code to use devm_* API so that driver core will manage
resources.
Signed-off-by: Manish Badarkhe
---
:100644 100644 5ea64b9... 3c307d6... M drivers/regulator/fixed.c
drivers/regulator/fixed.c | 42 --
1 file changed, 12 insertions(+), 30
Hi Mark,
On Wed, Jan 29, 2014 at 8:27 PM, Manish Badarkhe
wrote:
> Use devm_* API operations for fixed regulator driver so that
> driver core will manage resources.
>
> Also, introduce a new API "devm_kstrdup" and used it in fixed
> regulator driver to manage resour
Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Also, modify code as per coding style.
Signed-off-by: Manish Badarkhe
---
:100644 100644 162a0fa... 97868b7... M drivers/regulator/tps6507x-regulator.c
driver
Instead of "#ifdef CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Also, modify code as per coding style.
Signed-off-by: Manish Badarkhe
---
Changes since V1:
1. fix build break when CONFIG_OF is not set.
:100644 100644 162a0fa... 8
Add tps6507x touchscreen DT node to da850-evm.
Touchscreen DT data is added as per da850 board file.
Signed-off-by: Manish Badarkhe
---
Changes since V3:
- Removed vref property.
Changes since V2:
- Updated tps6507x documentation.
- Removed unnecessary code.
Changes since V1:
- Updated
ommit message.
- return proper error value in absence platform and DT data
for touchscreen.
Manish Badarkhe (2):
tps6507x-ts: Add DT support
ARM: davinci: da850: add tps6507x touchscreen DT data
Documentation/devicetree/bindings/mfd/tps6507x.txt | 24 +-
arch/arm/boot/dts/da850-ev
Add device tree based support for TI's tps6507x touchscreen.
Signed-off-by: Manish Badarkhe
---
Changes since V3:
- Rebased on top of Dmitry's changes
- Removed error handling for optional DT properties
Changes since V2:
- Removed unnecessary code.
- Updated Documentation to prov
Hi Samuel,
On Sun, Dec 22, 2013 at 11:18 PM, Manish Badarkhe
wrote:
>
> Instead of "#if define CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
> option for DT code to avoid if-deffery in code.
>
> Signed-off-by: Manish Badarkhe
> ---
> :100644 100644 791ae
Instead of "#if define CONFIG_OF" use "IS_ENABLED(CONFIG_OF)"
option for DT code to avoid if-deffery in code.
Signed-off-by: Manish Badarkhe
---
:100644 100644 791aea3... be9a8b0... M drivers/mfd/max8997.c
drivers/mfd/max8997.c | 14 ++
1 file changed,
Remove '.owner' field of driver structure as it is
going to be filled via "module_platform_driver" call.
Signed-off-by: Manish Badarkhe
---
:100644 100644 f0a4028... e2b97ac... M drivers/regulator/tps65218-regulator.c
drivers/regulator/tps65218-regulator.c |1 -
1 file
Hi Mark,
On Sun, Nov 9, 2014 at 2:49 PM, Mark Brown wrote:
> On Sat, Nov 08, 2014 at 05:42:52PM +0530, Manish Badarkhe wrote:
>> Remove '.owner' field of driver structure as it is
>> going to be filled via "module_platform_driver" call.
>
> Same question
_SUPPLY_PROP_VOLTAGE_NOW,
> };
>
> +/* In milliamps */
> +static const unsigned int wm831x_usb_limits[] = {
> + 0,
> + 2,
> + 100,
> + 500,
> + 900,
> + 1500,
> + 1800,
> + 550,
> +};
Just for curiosity, How these current limits are getting decided?
Can we have some proper defines over here so that it can be grasped easily?
Thanks
Manish Badarkhe
; without any error capture?
> +#ifdef CONFIG_PM_SLEEP
> +static int bam_dma_suspend(struct device *dev)
> +{
> + struct bam_device *bdev = dev_get_drvdata(dev);
> +
> + pm_runtime_force_suspend(dev);
> +
> + clk_unprepare(bdev->bamclk);
>
> return 0;
> }
Why this function simply return 'success' without any error capture?
Regards
Manish Badarkhe
The defines would just be TABLE_ENTRY_1 or
> whatever.
Thanks for the clarification, In that case, comments/documentation
will work instead of making any defines.
Regards
Manish Badarkhe
disable wont return anything.
got it.
>>> +#ifdef CONFIG_PM_SLEEP
>>> +static int bam_dma_suspend(struct device *dev)
>>> +{
>>> + struct bam_device *bdev = dev_get_drvdata(dev);
>>> +
>>> + pm_runtime_force_suspend(dev);
>>> +
>>> + clk_unprepare(bdev->bamclk);
>>>
>>> return 0;
>>> }
>>
>> Why this function simply return 'success' without any error capture?
> Same logic applies here as well, as pm_runtime_force_suspend and
> clk_unprepare may not return error in our case once probe is through.
got it.
Regards
Manish Badarkhe
gt; + struct mutex lp873_lock;/* lock guarding the data structure */
> + struct regmap *regmap;
> +};
> +#endif /* __LINUX_MFD_LP873X_H */
> --
Regards
Manish Badarkhe
; +
> +static int omap_i2c_unreg_slave(struct i2c_client *slave)
> +{
> + struct omap_i2c_dev *omap = i2c_get_adapdata(slave->adapter);
> + u16 reg;
> +
> + pm_runtime_put(omap->dev);
> + return 0;
> +}
> +#endif
This function always return 0
Regards
Manish Badarkhe
l_zone_device *zone, int *temp)
> +{
> + struct rcar_thermal_priv *priv = rcar_zone_to_priv(zone);
> +
> + *temp = rcar_thermal_get_current_temp(priv);
> +
> return 0;
> }
>
Above two function, always returns 0. Can it possible to handle error
and log some mes
On Tue, Nov 17, 2015 at 11:35 AM, Pankaj Dubey wrote:
> This patch moves exynos_sys_powerdown_conf function above all
> static functions, to avoid confusion causing due to mixing of
> static-nonstatic-static functions and to improve readability of this
> driver.
>
> Signed-off-by: Pankaj Dubey
>
other properties present in charging status register
like POWER_FAIL, VOLTAGE_OR,
CURRENT_OR etc.
Don't know weather it is feasible to add or not and Also, let me know,
if it is already been covered in
some part of the code.
Thanks
Manish Badarkhe
Hi Nicolas
On Wed, Dec 21, 2016 at 3:00 PM, Nicolas Saenz Julienne
wrote:
> Hi Manish, thanks for the interest.
>
> On 20/12/16 17:54, Manish Badarkhe wrote:
>> Hi Nicola
>>
> [...]
>>
>> Just some general comment, Can you add some more properties here t
Hi
> +static int pmic_thermal_remove(struct platform_device *pdev)
> +{
> + return 0;
> +}
> +
Why this remove function still requires?
Regards
Manish Badarkhe
s(gpio->lp873->regmap,
> + LP873X_REG_GPO_CTRL,
> + BIT(offset * 4 + 2), 0);
> + default:
> + return -ENOTSUPP;
> + }
> +}
Error needs to be return, this function always return 0. Only default
returns error here which is unlikely condition.
Regards
Manish Badarkhe
Hi Keerthy,
sorry ignore my last two comments in previous mail.
On Wed, Jun 29, 2016 at 4:13 PM, Manish Badarkhe
wrote:
> Hi Keerthy
>
> Some minor comment
>
>> +static int lp873x_gpio_direction_output(struct gpio_chip *chip,
>> +
72 matches
Mail list logo