Re: [PATCH vhost v2] vdpa/mlx5: Fix oversized null mkey longer than 32bit

2025-03-02 Thread Lei Yang
I tested this patch with virtio-net and mlx5 vdpa regression tests, everything works fine. Tested-by: Lei Yang On Fri, Feb 21, 2025 at 9:13 AM Jason Wang wrote: > > On Fri, Feb 21, 2025 at 3:40 AM Dragos Tatulea wrote: > > > > From: Si-Wei Liu > > > > create_user_mr() has correct code to coun

Re: [PATCH v7 0/8] vhost: Add support of kthread API

2025-03-02 Thread Lei Yang
QE tested this series of patches with virtio-net regression tests, everything works fine. Tested-by: Lei Yang On Sun, Mar 2, 2025 at 10:33 PM Cindy Lu wrote: > > In commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads"), > the vhost now uses vhost_task and operates as a child of the

Re: [PATCH v7 8/8] vhost: Add a KConfig knob to enable IOCTL VHOST_FORK_FROM_OWNER

2025-03-02 Thread Jason Wang
On Sun, Mar 2, 2025 at 10:34 PM Cindy Lu wrote: > > Introduce a new config knob `CONFIG_VHOST_ENABLE_FORK_OWNER_IOCTL`, > to control the availability of the `VHOST_FORK_FROM_OWNER` ioctl. > When CONFIG_VHOST_ENABLE_FORK_OWNER_IOCTL is set to n, the ioctl > is disabled, and any attempt to use it wi

[PATCH v2] x86/paravirt: Remove unused paravirt_disable_iospace

2025-03-02 Thread linux
From: "Dr. David Alan Gilbert" The last use of paravirt_disable_iospace() was removed in 2015 by commit d1c29465b8a5 ("lguest: don't disable iospace.") Remove it. Note the comment above it about 'entry.S' is unrelated to this but stayed when intervening code got deleted. Signed-off-by: Dr. Dav

Re: [PATCH v4 3/3] rcu: Use _full() API to debug synchronize_rcu()

2025-03-02 Thread Paul E. McKenney
On Sun, Mar 02, 2025 at 11:19:44AM +0100, Uladzislau Rezki wrote: > On Fri, Feb 28, 2025 at 05:08:49PM -0800, Paul E. McKenney wrote: > > On Fri, Feb 28, 2025 at 11:59:55AM -0800, Paul E. McKenney wrote: > > > On Fri, Feb 28, 2025 at 08:12:51PM +0100, Uladzislau Rezki wrote: > > > > Hello, Paul! >

Re: [PATCH net-next v20 12/25] ovpn: implement TCP transport

2025-03-02 Thread Antonio Quartulli
On 02/03/2025 19:59, Sabrina Dubroca wrote: 2025-02-27, 02:21:37 +0100, Antonio Quartulli wrote: Moreover export tcp_release_cb by means of EXPORT_SYMBOL instead of EXPORT_IPV6_MOD, so that other modules can use it, even if IPV6 is not compiled in. Is that really needed? You're saving tcp.sk_c

[PATCH 2/2] selftests/pidfd: Fix missing header

2025-03-02 Thread Siddharth Menon
Fix compilation errors caused by the missing sys/ioctl.h header --- tools/testing/selftests/pidfd/pidfd_setns_test.c | 1 + 1 file changed, 1 insertion(+) diff --git a/tools/testing/selftests/pidfd/pidfd_setns_test.c b/tools/testing/selftests/pidfd/pidfd_setns_test.c index 222f8131283b..4c8a0253

[PATCH 0/2] selftests/pidfd: Fix missing headers

2025-03-02 Thread Siddharth Menon
Fix compilation errors caused by missing headers in the pidfd selftest. The errors include: pidfd_fdinfo_test.c:230:13: error: implicit declaration of function ‘mount’ pidfd_setns_test.c:172:54: error: implicit declaration of function ‘ioctl’ Siddharth Menon (2): selftests/pidfd: Fix missing he

[PATCH v3 03/10] selftests/mm: Skip uffd-wp-mremap if userfaultfd not available

2025-03-02 Thread Brendan Jackman
It's obvious that this should fail in that case, but still, save the reader the effort of figuring out that they've run into this by just SKIPping Signed-off-by: Brendan Jackman --- tools/testing/selftests/mm/uffd-wp-mremap.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git

Re: [PATCH net-next v20 20/25] ovpn: implement peer add/get/dump/delete via netlink

2025-03-02 Thread Sabrina Dubroca
2025-02-27, 02:21:45 +0100, Antonio Quartulli wrote: > @@ -1310,9 +1329,12 @@ void ovpn_peer_keepalive_work(struct work_struct *work) > if (next_run > 0 && ovpn->registered) { > netdev_dbg(ovpn->dev, > "scheduling keepalive work: now=%llu next_run=%llu

Re: [PATCH v4 3/3] rcu: Use _full() API to debug synchronize_rcu()

2025-03-02 Thread Boqun Feng
On Sun, Mar 02, 2025 at 09:39:44AM -0800, Paul E. McKenney wrote: > On Sun, Mar 02, 2025 at 11:19:44AM +0100, Uladzislau Rezki wrote: > > On Fri, Feb 28, 2025 at 05:08:49PM -0800, Paul E. McKenney wrote: > > > On Fri, Feb 28, 2025 at 11:59:55AM -0800, Paul E. McKenney wrote: > > > > On Fri, Feb 28,

Re: [PATCH net-next v20 20/25] ovpn: implement peer add/get/dump/delete via netlink

2025-03-02 Thread Antonio Quartulli
On 02/03/2025 19:24, Sabrina Dubroca wrote: 2025-02-27, 02:21:45 +0100, Antonio Quartulli wrote: @@ -1310,9 +1329,12 @@ void ovpn_peer_keepalive_work(struct work_struct *work) if (next_run > 0 && ovpn->registered) { netdev_dbg(ovpn->dev, "sch

Re: [PATCH] selftests/nolibc: only run constructor tests on nolibc

2025-03-02 Thread Thomas Weißschuh
Hi Willy! On 2025-03-01 12:07:35+0100, Willy Tarreau wrote: > [..] > OK so I've tested the patch below which does what we want, except that > it reveals that the order is still not granted. Actually I haven't found > what dictates it. On one machine (gcc-9.5, ld-2.26) I'm getting: > > $ ./noli

[PATCH] tools/nolibc: add support for openat(2)

2025-03-02 Thread Louis Taylor
openat is useful to avoid needing to construct relative paths, so expose a wrapper for using it directly. Signed-off-by: Louis Taylor --- tools/include/nolibc/sys.h | 29 tools/testing/selftests/nolibc/nolibc-test.c | 22 +++ 2 files changed, 51

Re: [PATCH v4 3/3] rcu: Use _full() API to debug synchronize_rcu()

2025-03-02 Thread Joel Fernandes
On Fri, Feb 28, 2025 at 05:08:49PM -0800, Paul E. McKenney wrote: > On Fri, Feb 28, 2025 at 11:59:55AM -0800, Paul E. McKenney wrote: > > On Fri, Feb 28, 2025 at 08:12:51PM +0100, Uladzislau Rezki wrote: > > > Hello, Paul! > > > > > > > > > > > > > > > > > > > Except that I got this from overnigh

Re: [PATCH] x86/paravirt: Remove unused paravirt_disable_iospace

2025-03-02 Thread Dr. David Alan Gilbert
* li...@treblig.org (li...@treblig.org) wrote: > From: "Dr. David Alan Gilbert" > > The last use of paravirt_disable_iospace() was removed in 2015 by > commit d1c29465b8a5 ("lguest: don't disable iospace.") > > Remove it. > > Note the comment above it about 'entry.S' is unrelated to this > but

Re: [PATCH v4 3/3] rcu: Use _full() API to debug synchronize_rcu()

2025-03-02 Thread Joel Fernandes
On Sun, Mar 02, 2025 at 07:15:07PM -0500, Joel Fernandes wrote: > On Fri, Feb 28, 2025 at 05:08:49PM -0800, Paul E. McKenney wrote: > > On Fri, Feb 28, 2025 at 11:59:55AM -0800, Paul E. McKenney wrote: > > > On Fri, Feb 28, 2025 at 08:12:51PM +0100, Uladzislau Rezki wrote: > > > > Hello, Paul! > >

[PATCH] x86/paravirt: Remove unused paravirt_disable_iospace

2025-03-02 Thread linux
From: "Dr. David Alan Gilbert" The last use of paravirt_disable_iospace() was removed in 2015 by commit d1c29465b8a5 ("lguest: don't disable iospace.") Remove it. Note the comment above it about 'entry.S' is unrelated to this but stayed when intervening code got deleted. Signed-off-by: Dr. Dav

Re: KASAN: global-out-of-bounds Read in srcu_gp_start_if_needed

2025-03-02 Thread Paul E. McKenney
On Mon, Mar 03, 2025 at 08:44:48AM +0800, Strforexc yn wrote: > Dear Maintainers, When using our customized Syzkaller to fuzz the > latest Linux kernel, the following crash was triggered. > > Kernel commit: v6.14-rc4 (Commits on Feb 24, 2025) > Kernel Config : https://github.com/Strforexc/LinuxKer

Re: [PATCH] kunit: constify return of string literals

2025-03-02 Thread Christian Göttsche
On Tue, 26 Nov 2024 at 12:36, Christian Göttsche wrote: > > From: Christian Göttsche > > The function kunit_status_to_ok_not_ok() returns string literals, thus > declare the return value as such. > > Reported by clang: > > ./include/kunit/test.h:143:10: warning: returning 'const char[3]' from

[PATCH 1/2] selftests/pidfd: Fix missing header

2025-03-02 Thread Siddharth Menon
Fix compilation errors caused by the missing sys/mount.h header --- tools/testing/selftests/pidfd/pidfd_fdinfo_test.c | 1 + 1 file changed, 1 insertion(+) diff --git a/tools/testing/selftests/pidfd/pidfd_fdinfo_test.c b/tools/testing/selftests/pidfd/pidfd_fdinfo_test.c index f062a986e382..f718a

Re: [PATCH net-next v20 12/25] ovpn: implement TCP transport

2025-03-02 Thread Sabrina Dubroca
2025-02-27, 02:21:37 +0100, Antonio Quartulli wrote: > Moreover export tcp_release_cb by means of EXPORT_SYMBOL instead of > EXPORT_IPV6_MOD, so that other modules can use it, even if IPV6 is > not compiled in. Is that really needed? You're saving tcp.sk_cb.prot, so you could just call peer->tcp.s

Re: [PATCH 0/3] Fixes for IPA v4.7

2025-03-02 Thread Alex Elder
On 2/28/25 4:52 PM, Jakub Kicinski wrote: On Thu, 27 Feb 2025 11:33:39 +0100 Luca Weiss wrote: couldn't be tested much back then due to missing features in tqftpserv which caused the modem to not enable correctly. Especially the last commit is important since it makes mobile data actually funct

Re: [PATCH v4 3/3] rcu: Use _full() API to debug synchronize_rcu()

2025-03-02 Thread Uladzislau Rezki
On Fri, Feb 28, 2025 at 05:08:49PM -0800, Paul E. McKenney wrote: > On Fri, Feb 28, 2025 at 11:59:55AM -0800, Paul E. McKenney wrote: > > On Fri, Feb 28, 2025 at 08:12:51PM +0100, Uladzislau Rezki wrote: > > > Hello, Paul! > > > > > > > > > > > > > > > > > > > Except that I got this from overnigh

Re: [PATCH v3 02/10] selftests/mm: Skip uffd-stress if userfaultfd not available

2025-03-02 Thread Dev Jain
On 28/02/25 10:24 pm, Brendan Jackman wrote: It's pretty obvious that the test wouldn't work if you don't have the feature enabled. But, it's still useful to SKIP instead of failing so the reader can immediately tell that this is the reason why. Signed-off-by: Brendan Jackman --- tools/tes

Re: [PATCH 2/4] selftests/mm: rename guard-pages to guard-regions

2025-03-02 Thread Lorenzo Stoakes
On Thu, Feb 13, 2025 at 06:17:01PM +, Lorenzo Stoakes wrote: > The feature formerly referred to as guard pages is more correctly referred > to as 'guard regions', as in fact no pages are ever allocated in the > process of installing the regions. > > To avoid confusion, rename the tests accordin

Re: [PATCH] selftests/dma: Fix bad array reference.

2025-03-02 Thread liuye
By code observation only. Thanks, Liu Ye 在 2025/2/27 05:41, Shuah Khan 写道: > On 2/25/25 18:31, liuye wrote: >> Friendly ping. >> >> 在 2025/2/6 10:12, Liu Ye 写道: >>> dir[directions] should be directions[dir] to correctly index the >>> directions array. >>> >>> Signed-off-by: Liu Ye >>> --- >>>  

Re: [PATCH] tools/nolibc: add support for openat(2)

2025-03-02 Thread Thomas Weißschuh
Hi Louis, On 2025-03-02 20:25:23+, Louis Taylor wrote: > openat is useful to avoid needing to construct relative paths, so expose > a wrapper for using it directly. Can you say what you are using nolibc for? I'm curious :-) > Signed-off-by: Louis Taylor > --- > tools/include/nolibc/sys.h

[PATCH v7 4/8] vhost: Introduce vhost_worker_ops in vhost_worker

2025-03-02 Thread Cindy Lu
Abstract vhost worker operations (create/stop/wakeup) into an ops structure to prepare for kthread mode support. Signed-off-by: Cindy Lu --- drivers/vhost/vhost.c | 63 ++- drivers/vhost/vhost.h | 11 2 files changed, 56 insertions(+), 18 deletion

[PATCH v7 6/8] vhost: uapi to control task mode (owner vs kthread)

2025-03-02 Thread Cindy Lu
Add a new UAPI to configure the vhost device to use the kthread mode The userspace application can use IOCTL VHOST_FORK_FROM_OWNER to choose between owner and kthread mode if necessary This setting must be applied before VHOST_SET_OWNER, as the worker will be created in the VHOST_SET_OWNER function

[PATCH v7 8/8] vhost: Add a KConfig knob to enable IOCTL VHOST_FORK_FROM_OWNER

2025-03-02 Thread Cindy Lu
Introduce a new config knob `CONFIG_VHOST_ENABLE_FORK_OWNER_IOCTL`, to control the availability of the `VHOST_FORK_FROM_OWNER` ioctl. When CONFIG_VHOST_ENABLE_FORK_OWNER_IOCTL is set to n, the ioctl is disabled, and any attempt to use it will result in failure. Signed-off-by: Cindy Lu --- driver

[PATCH v7 7/8] vhost: Add check for inherit_owner status

2025-03-02 Thread Cindy Lu
The VHOST_NEW_WORKER requires the inherit_owner setting to be true. So we need to add a check for this. Signed-off-by: Cindy Lu --- drivers/vhost/vhost.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/drivers/vhost/vhost.c b/drivers/vhost/vhost.c index ff930c2e5b78..fb0c7fb43f78 1006

[PATCH v7 1/8] vhost: Add a new parameter in vhost_dev to allow user select kthread

2025-03-02 Thread Cindy Lu
The vhost now uses vhost_task and workers as a child of the owner thread. While this aligns with containerization principles,it confuses some legacy userspace app, Therefore, we are reintroducing kthread API support. Introduce a new parameter to enable users to choose between kthread and task mode

[PATCH v7 0/8] vhost: Add support of kthread API

2025-03-02 Thread Cindy Lu
In commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads"), the vhost now uses vhost_task and operates as a child of the owner thread. This aligns with containerization principles. However, this change has caused confusion for some legacy userspace applications. Therefore, we

[PATCH v7 5/8] vhost: Reintroduce kthread mode support in vhost

2025-03-02 Thread Cindy Lu
This commit restores the previously removed functions kthread wake/stop/create, and use ops structure vhost_worker_ops to manage worker wakeup, stop and creation. The function vhost_worker_create initializes these ops pointers based on the value of inherit_owner The old function was remove in comm

[PATCH v7 2/8] vhost: Reintroduce vhost_worker to support kthread

2025-03-02 Thread Cindy Lu
Add the previously removed function vhost_worker() back to support the kthread and rename it to vhost_run_work_kthread_list. The old function vhost_worker was change to support task in commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads") change to xarray in commit 1cdaafa1b8b4 ("vhost

[PATCH v7 3/8] vhost: Add the cgroup related function

2025-03-02 Thread Cindy Lu
Add back the previously removed cgroup function to support the kthread The biggest change for this part is in vhost_attach_cgroups() and vhost_attach_task_to_cgroups(). The old function was remove in commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads") Signed-off-by: Cindy Lu --- d

Re: [PATCH v4 3/3] rcu: Use _full() API to debug synchronize_rcu()

2025-03-02 Thread Paul E. McKenney
On Sun, Mar 02, 2025 at 10:46:29AM -0800, Boqun Feng wrote: > On Sun, Mar 02, 2025 at 09:39:44AM -0800, Paul E. McKenney wrote: > > On Sun, Mar 02, 2025 at 11:19:44AM +0100, Uladzislau Rezki wrote: > > > On Fri, Feb 28, 2025 at 05:08:49PM -0800, Paul E. McKenney wrote: > > > > On Fri, Feb 28, 2025