Hi Henry,
On Tue, Apr 30, 2019 at 2:45 AM Henry Chen wrote:
>
> Add dvfsrc driver for MT8183
>
> Signed-off-by: Henry Chen
> ---
> drivers/soc/mediatek/Kconfig | 15 ++
> drivers/soc/mediatek/Makefile | 1 +
> drivers/soc/mediatek/mtk-dvfsrc.c | 347
> ++
Use u32 rather than unsigned long for register variables for clarity and
consistency.
Signed-off-by: Ryan Case
Reviewed-by: Stephen Boyd
Reviewed-by: Evan Green
---
Changes in v2:
- Updated commit message
- Updated missed rxstale variable
drivers/tty/serial/qcom_geni_serial.c | 24
The variables of tx_wm and rx_wm were set to the same define value in
all cases, never updated, and the define was sometimes used
interchangably. Remove the variables/function and use the fixed value.
Signed-off-by: Ryan Case
Reviewed-by: Evan Green
---
Changes in v2:
- Removed CONSOLE from
A frequent side comment has been to remove the use of writel_relaxed,
readl_relaxed, and mb. This reduces driver complexity and the _relaxed
variants were not known to provide any noticeable performance benefit.
Signed-off-by: Ryan Case
Reviewed-by: Evan Green
---
Changes in v2:
- Expanded
The driver only supports FIFO mode so setting and checking this variable
is unnecessary. If DMA support is ever added then such checks can be
introduced.
Signed-off-by: Ryan Case
Reviewed-by: Evan Green
---
Changes in v2:
- Fixed commit message typo
- Coalesced lines where possible
drivers
This is a series of cleanups for issues raised in prior reviews that
were unrelated to the patches at hand.
Changes in v2:
- Updated commit messages
- Removed CONSOLE from UART_CONSOLE_RX_WM
- Coalesced lines where possible
- Updated missed rxstale variable
Ryan Case (4):
tty: serial
Signed-off-by: Ryan Case
---
drivers/tty/serial/qcom_geni_serial.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/drivers/tty/serial/qcom_geni_serial.c
b/drivers/tty/serial/qcom_geni_serial.c
index 3103aa0adc86..fa67a2ced420 100644
--- a/drivers
The driver only supports FIFO mode so setting and checking this variable
is unnecessary. If DMA support is ever addedd then such checks can be
introduced.
Signed-off-by: Ryan Case
---
drivers/tty/serial/qcom_geni_serial.c | 66 ++-
1 file changed, 24 insertions(+), 42
The variables of tx_wm and rx_wm were set to the same define value in
all cases, never updated, and the define was sometimes used
interchangably. Remove the variables/function and use the fixed value.
Signed-off-by: Ryan Case
---
drivers/tty/serial/qcom_geni_serial.c | 23
This is a series of cleanups for issues raised in prior reviews that
were unrelated to the patches at hand.
Ryan Case (4):
tty: serial: qcom_geni_serial: Remove use of *_relaxed() and mb()
tty: serial: qcom_geni_serial: Remove set_rfr_wm() and related
variables
tty: serial
A frequent side comment has been to remove the use of writel_relaxed,
readl_relaxed, and mb.
Signed-off-by: Ryan Case
---
drivers/tty/serial/qcom_geni_serial.c | 187 +++---
1 file changed, 80 insertions(+), 107 deletions(-)
diff --git a/drivers/tty/serial
interrupts.
Signed-off-by: Ryan Case
---
drivers/tty/serial/qcom_geni_serial.c | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/tty/serial/qcom_geni_serial.c
b/drivers/tty/serial/qcom_geni_serial.c
index 0c93beb69e73..a694a47747c7 100644
--- a/drivers/tty/serial
lcke
>
> Oh nice, so this did end up being your problem with corrupt
> characters? Strange though, I still would have expected this bug to
> result in inserted serial characters, rather than edited ones.
> Either way, this looks good to me.
>
> Reviewed-by: Evan Green
UART bluetooth firmware downloads consistently working for me again.
Tested-by: Ryan Case
interrupt after filling the FIFO so we do not
receive notification again prior to actually having free space.
Signed-off-by: Ryan Case
---
Changes in v2:
Addressed Doug's comments
- Avoid M_TX_WATERMARK_EN writes when values already match
- Added note about M_TX_WATERMARK_EN triggering and lat
interrupt after filling the FIFO so we do not
receive notification again prior to actually having free space.
Signed-off-by: Ryan Case
---
drivers/tty/serial/qcom_geni_serial.c | 16 ++--
1 file changed, 14 insertions(+), 2 deletions(-)
diff --git a/drivers/tty/serial/qcom_geni_s
softlocks on large transmissions.
This patch allows larger transfers with continuous FIFO additions as
space becomes available and removes polling from the interrupt handler.
Signed-off-by: Ryan Case
---
Changes in v3:
- Reworded comment for clarity
- Fixed mips compiler warning
Changes in v2
On Thu, Nov 29, 2018 at 2:12 PM Doug Anderson wrote:
>
> Hi,
>
> On Wed, Nov 28, 2018 at 3:55 PM Ryan Case wrote:
> > @@ -465,9 +470,19 @@ static void qcom_geni_serial_console_write(struct
> > console *co, const char *s,
> > }
> >
softlocks on large transmissions.
This patch allows larger transfers with continuous FIFO additions as
space becomes available and removes polling from the interrupt handler.
Signed-off-by: Ryan Case
---
Changes in v2:
- Addressed nits raised by Stephen
drivers/tty/serial/qcom_geni_serial.c | 56
On Tue, Nov 27, 2018 at 6:04 PM Stephen Boyd wrote:
>
> Quoting Ryan Case (2018-11-27 17:24:44)
> > On Tue, Nov 27, 2018 at 4:20 PM Stephen Boyd wrote:
> > >
> > > Quoting Ryan Case (2018-11-26 18:25:36)
> > > > Transfers were being divided into device F
On Tue, Nov 27, 2018 at 4:20 PM Stephen Boyd wrote:
>
> Quoting Ryan Case (2018-11-26 18:25:36)
> > Transfers were being divided into device FIFO sized (64 byte max)
> > operations which would poll for completion within a spin_lock_irqsave /
> > spin_unlock_irqrestore bloc
softlocks on large transmissions.
This patch allows larger transfers with continuous FIFO additions as
space becomes available and removes polling from the interrupt handler.
Signed-off-by: Ryan Case
Version: 1
---
drivers/tty/serial/qcom_geni_serial.c | 58 ++-
1 file changed
Address remaining comments from original driver patch series
* Move RD_FIFO_CFG to be ordered corretly
* Expand spinlock comment
Signed-off-by: Ryan Case
---
drivers/spi/spi-qcom-qspi.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/spi/spi-qcom-qspi.c b
.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v6:
- Fixed IRQ error logging accessibility
- Minor cleanup suggested by Doug
Changes in v5:
- Fixed tabbing/spacing errors in defines
Changes in v4:
- Set bus_num to -1
- Alphabetized Makefile entry
- Grouped register and
From: Girish Mahadevan
Bindings for Qualcomm Quad SPI used on SoCs such as sdm845.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
Reviewed-by: Douglas Anderson
Reviewed-by: Rob Herring
Reviewed-by: Stephen Boyd
---
Changes in v6:
- None
Changes in v5:
- None
Changes in v4
.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
Fixed tabbing/spacing in defines
---
Changes in v5:
- Fixed tabbing/spacing errors in defines
Changes in v4:
- Set bus_num to -1
- Alphabetized Makefile entry
- Grouped register and associated flag defines
- Read and write transfers now use
From: Girish Mahadevan
Bindings for Qualcomm Quad SPI used on SoCs such as sdm845.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v5:
- None
Changes in v4:
- Changed qspi@ to spi@ and device@ to flash@ to match Rob's review
Changes in v3:
- Added generic compa
From: Girish Mahadevan
Bindings for Qualcomm Quad SPI used on SoCs such as sdm845.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v4:
- Changed qspi@ to spi@ and device@ to flash@ to match Rob's review
Changes in v3:
- Added generic compatible string in additi
.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v4:
- Set bus_num to -1
- Alphabetized Makefile entry
- Grouped registers with associated flag defines
- Read and write transfers now use ioread32_rep and iowrite32_rep
- Added IRQ error logging
- Updated types, formatting, and
On Wed, Sep 26, 2018 at 11:43 PM Stephen Boyd wrote:
> Quoting Ryan Case (2018-09-26 13:52:04)
> > From: Girish Mahadevan
> > +#include
> > +
> > +#define AHB_MIN_HZ 960UL
>
> Is this used?
Nope. Do you want all currently unused defines remove
-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v3:
- Corrected QPSPI typo
- Removed setup function and moved configurations to prepare_message
- Added __maybe_unused to suspend and resume functions
Changes in v2:
- Addressed formatting feedback
- Squashed bug fixes and features
From: Girish Mahadevan
Bindings for Qualcomm Quad SPI used on SoCs such as sdm845.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v3:
- Added generic compatible string in addition to specific SoC
Changes in v2:
- Added commit text
- Removed invalid property
On Thu, Sep 20, 2018 at 3:46 PM Randy Dunlap wrote:
> On 9/20/18 3:40 PM, Ryan Case wrote:
> > diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
> > index de03d67bcd2b..36922e12c3b0 100644
> > --- a/drivers/spi/Kconfig
> > +++ b/drivers/spi/Kconfig
> > @@
modes.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v2:
- Addressed formatting feedback
- Squashed bug fixes and features from Doug
- Now uses transfer_one_message instead of mem_ops
- Fixed suspend/resume
- Added spinlocks
drivers/spi/Kconfig | 6
From: Girish Mahadevan
Bindings for Qualcomm Quad SPI used on SoCs such as sdm845.
Signed-off-by: Girish Mahadevan
Signed-off-by: Ryan Case
---
Changes in v2:
- Added commit text
- Removed invalid property
- Updated example to match sdm845 with attached spi-nor
.../bindings/spi/qcom,spi
34 matches
Mail list logo