Re: [PATCH v4 2/5] sched: Take cpufreq feedback into account

2024-01-30 Thread Qais Yousef
On 01/30/24 10:35, Vincent Guittot wrote: > On Tue, 30 Jan 2024 at 01:50, Qais Yousef wrote: > > > > On 01/30/24 00:26, Qais Yousef wrote: > > > On 01/09/24 17:46, Vincent Guittot wrote: > > > > Aggregate the different pressures applied on the capacity of CP

Re: [PATCH v4 2/5] sched: Take cpufreq feedback into account

2024-01-29 Thread Qais Yousef
On 01/30/24 00:26, Qais Yousef wrote: > On 01/09/24 17:46, Vincent Guittot wrote: > > Aggregate the different pressures applied on the capacity of CPUs and > > create a new function that returns the actual capacity of the CPU: > > get_actual_cpu_capacity() > > > &g

Re: [PATCH v4 4/5] sched: Rename arch_update_thermal_pressure into arch_update_hw_pressure

2024-01-29 Thread Qais Yousef
l mitigation but also generated by max current > limitation as an example. Such high frequency signal needs filtering to be > smoothed and provide a value that reflects the average available capacity > into the scheduler time scale. > > Signed-off-by: Vincent Guittot > --- Revi

Re: [PATCH v4 5/5] sched/pelt: Remove shift of thermal clock

2024-01-29 Thread Qais Yousef
is exception and always keep this PELT signal > aligned with other signals. > Mark sysctl_sched_migration_cost boot parameter as deprecated > > Signed-off-by: Vincent Guittot > --- Better without it, yes. Reviewed-by: Qais Yousef > .../admin-guide/kernel-parameters.txt

Re: [PATCH v4 4/5] sched: Rename arch_update_thermal_pressure into arch_update_hw_pressure

2024-01-29 Thread Qais Yousef
On 01/09/24 17:46, Vincent Guittot wrote: > Now that cpufreq provides a pressure value to the scheduler, rename > arch_update_thermal_pressure into HW pressure to reflect that it returns > a pressure applied by HW (i.e. with a high frequency change) and not > always related to thermal mitigation bu

Re: [PATCH v4 2/5] sched: Take cpufreq feedback into account

2024-01-29 Thread Qais Yousef
On 01/09/24 17:46, Vincent Guittot wrote: > Aggregate the different pressures applied on the capacity of CPUs and > create a new function that returns the actual capacity of the CPU: > get_actual_cpu_capacity() > > Signed-off-by: Vincent Guittot > Reviewed-by: Lukasz Luba > --- > kernel/sched

Re: [PATCH v4 1/5] cpufreq: Add a cpufreq pressure feedback for the scheduler

2024-01-29 Thread Qais Yousef
pressure = max_capacity - > +mult_frac(max_capacity, capped_freq, max_freq); > + } > + > + for_each_cpu(cpu, policy->related_cpus) > + WRITE_ONCE(per_cpu(cpufreq_pressure, cpu), pressure); Is this WRITE_

Re: [PATCH v4 1/2] Provide in-kernel headers for making it easy to extend the kernel

2019-03-04 Thread Qais Yousef
s that would extract the headers from a kernel or module > image. > > Signed-off-by: Joel Fernandes (Google) I could get the headers using this patch in both built-in and modules options. You can add my tested-and-reviewed-by: Qais Yousef I am not familiar with running kselftests so did

Re: [PATCH v3 1/2] Provide in-kernel headers for making it easy to extend the kernel

2019-03-01 Thread Qais Yousef
ling a new syscall e.g: bpf) it's very easy to forget that the headers has changed as well and you need to push an updated copy. FWIW most of the time I run on non-android systems for development/debugging purposes. I use the built-in version although I can see a module version helpful

Re: [PATCH v3 1/2] Provide in-kernel headers for making it easy to extend the kernel

2019-02-28 Thread Qais Yousef
On 02/28/19 17:04, Dietmar Eggemann wrote: > Hi Joel, > > On 2/28/19 3:47 PM, Joel Fernandes wrote: > > On Thu, Feb 28, 2019 at 01:53:43PM +0000, Qais Yousef wrote: > > > Hi Joel > > > > > > On 02/27/19 14:37, Joel Fernandes (Google) wrote: > > [.

Re: [PATCH v3 1/2] Provide in-kernel headers for making it easy to extend the kernel

2019-02-28 Thread Qais Yousef
On 02/28/19 17:04, Dietmar Eggemann wrote: > Hi Joel, > > On 2/28/19 3:47 PM, Joel Fernandes wrote: > > On Thu, Feb 28, 2019 at 01:53:43PM +0000, Qais Yousef wrote: > > > Hi Joel > > > > > > On 02/27/19 14:37, Joel Fernandes (Google) wrote: > > [.

Re: [PATCH v3 1/2] Provide in-kernel headers for making it easy to extend the kernel

2019-02-28 Thread Qais Yousef
gt; +cpio_dir=$outdir/$tarfile.tmp > + > +src_file_list="" > +for f in $file_list; do $file_list is not assigned here. I applied the patches and I got an empty tar generated. Setting `file_list=$*` fixed it for me - though not sure if this is the right fix to use. Last minute change/cl