Re: [PATCH net-next v5 8/8] netconsole: docs: Add documentation for CPU number auto-population

2025-02-10 Thread Breno Leitao
Hello Bagas, On Fri, Feb 07, 2025 at 08:50:22AM +0700, Bagas Sanjaya wrote: > On Thu, Feb 06, 2025 at 03:05:59AM -0800, Breno Leitao wrote: > > +.. note:: > > + > > + If the user has set a conflicting `cpu` key in the userdata dictionary, > > + both keys will b

[PATCH net-next v5 2/8] netconsole: Rename userdata to extradata

2025-02-06 Thread Breno Leitao
>userdata_length; The upcoming patches will, which will add support for sysdata, will change it to: extradata_len = nt->userdata_length + sysdata_len; Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 87 -

[PATCH net-next v5 8/8] netconsole: docs: Add documentation for CPU number auto-population

2025-02-06 Thread Breno Leitao
ing to the "populate_cpu_nr" file in the netconsole configfs hierarchy. This documentation update ensures users are aware of the new CPU number auto-population functionality and how to leverage it for better demultiplexing and visibility of parallel netconsole output. Signed-off-by: Breno

[PATCH net-next v5 7/8] netconsole: selftest: test for sysdata CPU

2025-02-06 Thread Breno Leitao
: Breno Leitao Reviewed-by: Simon Horman --- tools/testing/selftests/drivers/net/Makefile | 1 + .../selftests/drivers/net/lib/sh/lib_netcons.sh| 17 +++ .../selftests/drivers/net/netcons_sysdata.sh | 167 + 3 files changed, 185 insertions(+) diff --git a/tools

[PATCH net-next v5 6/8] netconsole: add support for sysdata and CPU population

2025-02-06 Thread Breno Leitao
he sysdata is dynamically updated at message time and appended after any existing userdata. The CPU number is formatted as "cpu=XX" and is added to the extradata buffer, respecting the existing size limits. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/n

[PATCH net-next v5 5/8] netconsole: Include sysdata in extradata entry count

2025-02-06 Thread Breno Leitao
the CPU_NR flag in the sysdata_fields, incrementing the entry count accordingly. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 10 +- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c

[PATCH net-next v5 4/8] netconsole: Introduce configfs helpers for sysdata features

2025-02-06 Thread Breno Leitao
does not modify the message itself. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 81 1 file changed, 81 insertions(+) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH net-next v5 3/8] netconsole: Helper to count number of used entries

2025-02-06 Thread Breno Leitao
number of children in the userdata group configfs hierarchy. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 14 +++--- 1 file changed, 11 insertions(+), 3 deletions(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH net-next v5 1/8] netconsole: consolidate send buffers into netconsole_target struct

2025-02-06 Thread Breno Leitao
of two) The buffer in netconsole_target is protected by target_list_lock, maintaining the same synchronization semantics as the original code. Suggested-by: Jakub Kicinski Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 30 -- 1

[PATCH net-next v5 0/8] netconsole: Add support for CPU population

2025-02-06 Thread Breno Leitao
riginates in kernel. - Improved the test to send from a very specific CPU, which can be checked to be correct on the other side, as suggested by Jakub. - Fixed a bug where CPU # was populated at the wrong place - Link to v1: https://lore.kernel.org/r/20241113-netcon_cpu-v1-0-d187bf7c0...@deb

Re: [PATCH net-next v4 1/8] netconsole: consolidate send buffers into netconsole_target struct

2025-02-06 Thread Breno Leitao
Hello Simon, On Wed, Feb 05, 2025 at 01:34:55PM +, Simon Horman wrote: > On Tue, Feb 04, 2025 at 03:35:09AM -0800, Breno Leitao wrote: > > Move the static buffers from send_msg_no_fragmentation() and > > send_msg_fragmented() into the netconsole_target structure. This > >

[PATCH net-next v4 7/8] netconsole: selftest: test for sysdata CPU

2025-02-04 Thread Breno Leitao
: Breno Leitao Reviewed-by: Simon Horman --- tools/testing/selftests/drivers/net/Makefile | 1 + .../selftests/drivers/net/lib/sh/lib_netcons.sh| 17 +++ .../selftests/drivers/net/netcons_sysdata.sh | 167 + 3 files changed, 185 insertions(+) diff --git a/tools

[PATCH net-next v4 8/8] netconsole: docs: Add documentation for CPU number auto-population

2025-02-04 Thread Breno Leitao
ing to the "populate_cpu_nr" file in the netconsole configfs hierarchy. This documentation update ensures users are aware of the new CPU number auto-population functionality and how to leverage it for better demultiplexing and visibility of parallel netconsole output. Signed-

[PATCH net-next v4 6/8] netconsole: add support for sysdata and CPU population

2025-02-04 Thread Breno Leitao
he sysdata is dynamically updated at message time and appended after any existing userdata. The CPU number is formatted as "cpu=XX" and is added to the extradata buffer, respecting the existing size limits. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/n

[PATCH net-next v4 5/8] netconsole: Include sysdata in extradata entry count

2025-02-04 Thread Breno Leitao
the CPU_NR flag in the sysdata_fields, incrementing the entry count accordingly. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 10 +- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c

[PATCH net-next v4 4/8] netconsole: Introduce configfs helpers for sysdata features

2025-02-04 Thread Breno Leitao
does not modify the message itself. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 81 1 file changed, 81 insertions(+) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH net-next v4 3/8] netconsole: Helper to count number of used entries

2025-02-04 Thread Breno Leitao
number of children in the userdata group configfs hierarchy. Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 14 +++--- 1 file changed, 11 insertions(+), 3 deletions(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH net-next v4 2/8] netconsole: Rename userdata to extradata

2025-02-04 Thread Breno Leitao
>userdata_length; The upcoming patches will, which will add support for sysdata, will change it to: extradata_len = nt->userdata_length + sysdata_len; Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 87 -

[PATCH net-next v4 1/8] netconsole: consolidate send buffers into netconsole_target struct

2025-02-04 Thread Breno Leitao
of two) The buffer in netconsole_target is protected by target_list_lock, maintaining the same synchronization semantics as the original code. Suggested-by: Jakub Kicinski Signed-off-by: Breno Leitao Reviewed-by: Simon Horman --- drivers/net/netconsole.c | 30 -- 1

[PATCH net-next v4 0/8] netconsole: Add support for CPU population

2025-02-04 Thread Breno Leitao
ub. - Fixed a bug where CPU # was populated at the wrong place - Link to v1: https://lore.kernel.org/r/20241113-netcon_cpu-v1-0-d187bf7c0...@debian.org --- Breno Leitao (8): netconsole: consolidate send buffers into netconsole_target struct netconsole: Rename userdata to extradata

Re: [PATCH RFC net-next v3 1/8] netconsole: consolidate send buffers into netconsole_target struct

2025-01-31 Thread Breno Leitao
Hello Simon, On Thu, Jan 30, 2025 at 10:35:44AM +, Simon Horman wrote: > On Tue, Jan 28, 2025 at 04:11:28PM +, Simon Horman wrote: > > On Fri, Jan 24, 2025 at 07:16:40AM -0800, Breno Leitao wrote: > > > Move the static buffers from send_msg_no_fragmentation() and > &g

Re: [PATCH RFC net-next v3 8/8] netconsole: docs: Add documentation for CPU number auto-population

2025-01-27 Thread Breno Leitao
On Fri, Jan 24, 2025 at 05:15:10PM +0100, Andrew Lunn wrote: > > +CPU number auto population in userdata > > +-- > > + > > +Inside the netconsole configfs hierarchy, there is a file called > > +`cpu_nr` under the `userdata` directory. This file is used to enable

Re: [PATCH RFC net-next v3 0/8] netconsole: Add support for CPU population

2025-01-27 Thread Breno Leitao
Hello Andrew, On Fri, Jan 24, 2025 at 05:02:26PM +0100, Andrew Lunn wrote: > On Fri, Jan 24, 2025 at 07:16:39AM -0800, Breno Leitao wrote: > > The current implementation of netconsole sends all log messages in > > parallel, which can lead to an intermixed and interleave

[PATCH RFC net-next v3 2/8] netconsole: Rename userdata to extradata

2025-01-24 Thread Breno Leitao
>userdata_length; The upcoming patches will, which will add support for sysdata, will change it to: extradata_len = nt->userdata_length + sysdata_len; Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 87 1 file changed, 44 ins

Re: [PATCH net-next v2 3/5] netconsole: add support for sysdata and CPU population

2025-01-24 Thread Breno Leitao
Hello Jakub, On Mon, Jan 20, 2025 at 11:06:53AM -0800, Jakub Kicinski wrote: > > > > The only way to do it properly is having a extra buffer where we > > have `cpu=42` and copy 5 bytes from there, and then copy the last one in > > the next iteration. I am not sure we can do it in one shot. > > FW

[PATCH RFC net-next v3 8/8] netconsole: docs: Add documentation for CPU number auto-population

2025-01-24 Thread Breno Leitao
ing to the "populate_cpu_nr" file in the netconsole configfs hierarchy. This documentation update ensures users are aware of the new CPU number auto-population functionality and how to leverage it for better demultiplexing and visibility of parallel netconsole output. Signed-

[PATCH RFC net-next v3 7/8] netconsole: selftest: test for sysdata CPU

2025-01-24 Thread Breno Leitao
: Breno Leitao --- tools/testing/selftests/drivers/net/Makefile | 1 + .../selftests/drivers/net/lib/sh/lib_netcons.sh| 17 +++ .../selftests/drivers/net/netcons_sysdata.sh | 167 + 3 files changed, 185 insertions(+) diff --git a/tools/testing/selftests/drivers

[PATCH RFC net-next v3 6/8] netconsole: add support for sysdata and CPU population

2025-01-24 Thread Breno Leitao
he sysdata is dynamically updated at message time and appended after any existing userdata. The CPU number is formatted as "cpu=XX" and is added to the extradata buffer, respecting the existing size limits. Signed-off-by: Breno Leitao --- drivers/n

[PATCH RFC net-next v3 5/8] netconsole: Include sysdata in extradata entry count

2025-01-24 Thread Breno Leitao
the CPU_NR flag in the sysdata_fields, incrementing the entry count accordingly. Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 10 +- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH RFC net-next v3 4/8] netconsole: Introduce configfs helpers for sysdata features

2025-01-24 Thread Breno Leitao
does not modify the message itself. Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 81 1 file changed, 81 insertions(+) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index 1c197da806962a751a3da8794def6a97cff5f701

[PATCH RFC net-next v3 3/8] netconsole: Helper to count number of used entries

2025-01-24 Thread Breno Leitao
number of children in the userdata group configfs hierarchy. Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 14 +++--- 1 file changed, 11 insertions(+), 3 deletions(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH RFC net-next v3 1/8] netconsole: consolidate send buffers into netconsole_target struct

2025-01-24 Thread Breno Leitao
of two) The buffer in netconsole_target is protected by target_list_lock, maintaining the same synchronization semantics as the original code. Suggested-by: Jakub Kicinski Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 29 +++-- 1 file changed, 15 insertions

[PATCH RFC net-next v3 0/8] netconsole: Add support for CPU population

2025-01-24 Thread Breno Leitao
n feature Provides instructions on how to enable and use the feature I believe these changes will be a valuable addition to the netconsole subsystem, enhancing its usefulness for kernel developers and users. Signed-off-by: Breno Leitao --- Changes in v3: - Moved the buffer into netconsole_

Re: [PATCH net-next v2 3/5] netconsole: add support for sysdata and CPU population

2025-01-20 Thread Breno Leitao
On Fri, Jan 17, 2025 at 06:35:20PM -0800, Jakub Kicinski wrote: > On Fri, 17 Jan 2025 03:02:40 -0800 Breno Leitao wrote: > > > Looks like previously all the data was on the stack, now we have a mix. > > > > Not sure I followed. The data ({userdata,extradata}_complete)

Re: [PATCH net-next v2 3/5] netconsole: add support for sysdata and CPU population

2025-01-17 Thread Breno Leitao
Hello Jakub, On Thu, Jan 16, 2025 at 05:44:05PM -0800, Jakub Kicinski wrote: > On Wed, 15 Jan 2025 05:35:20 -0800 Breno Leitao wrote: > > + WARN_ON_ONCE(userdata_len + sysdata_len > > > +MAX_EXTRADATA_ENTRY_LEN * MAX_EXTRADATA_ITEMS); > > + > > +

Re: [PATCH net-next v2 5/5] netconsole: docs: Add documentation for CPU number auto-population

2025-01-16 Thread Breno Leitao
Hello Randy, On Wed, Jan 15, 2025 at 02:56:06PM -0800, Randy Dunlap wrote: > On 1/15/25 5:35 AM, Breno Leitao wrote: > > Update the netconsole documentation to explain the new feature that > > allows automatic population of the CPU number. > > > > The key change

[PATCH net-next v2 4/5] netconsole: selftest: test for sysdata CPU

2025-01-15 Thread Breno Leitao
: Breno Leitao --- tools/testing/selftests/drivers/net/Makefile | 1 + .../selftests/drivers/net/lib/sh/lib_netcons.sh| 17 +++ .../selftests/drivers/net/netcons_sysdata.sh | 166 + 3 files changed, 184 insertions(+) diff --git a/tools/testing/selftests/drivers

[PATCH net-next v2 3/5] netconsole: add support for sysdata and CPU population

2025-01-15 Thread Breno Leitao
he sysdata is dynamically updated at message time and appended after any existing userdata. The CPU number is formatted as "cpu=XX" and is added to the extradata buffer, respecting the existing size limits. Signed-off-by: Breno Leitao --- drivers/ne

[PATCH net-next v2 5/5] netconsole: docs: Add documentation for CPU number auto-population

2025-01-15 Thread Breno Leitao
ing to the "populate_cpu_nr" file in the netconsole configfs hierarchy. This documentation update ensures users are aware of the new CPU number auto-population functionality and how to leverage it for better demultiplexing and visibility of parallel netconsole output. Signed-

[PATCH net-next v2 2/5] netconsole: Helper to count number of used entries

2025-01-15 Thread Breno Leitao
number of children in the userdata group configfs hierarchy. Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 14 +++--- 1 file changed, 11 insertions(+), 3 deletions(-) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH net-next v2 0/5] netconsole: Add support for CPU population

2025-01-15 Thread Breno Leitao
= Updates the netconsole documentation to explain the new CPU number auto-population feature Provides instructions on how to enable and use the feature I believe these changes will be a valuable addition to the netconsole subsystem, enhancing its usefulness for kernel developers and users.

[PATCH net-next v2 1/5] netconsole: Rename userdata to extradata

2025-01-15 Thread Breno Leitao
>userdata_length; The upcoming patches will, which will add support for sysdata, will change it to: extradata_len = nt->userdata_length + sysdata_len; Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 84 1 file changed, 42 ins

Re: [PATCH net-next 2/4] netconsole: Add option to auto-populate CPU number in userdata

2024-12-04 Thread Breno Leitao
On Tue, Nov 19, 2024 at 09:07:45AM -0800, Breno Leitao wrote: > > > #endif > > > boolenabled; > > > boolextended; > > > > > + /* Check if CPU NR should be populated, and append it to the user > > > +

Re: [PATCH net-next 2/4] netconsole: Add option to auto-populate CPU number in userdata

2024-11-19 Thread Breno Leitao
Hello Jakub, On Mon, Nov 18, 2024 at 06:33:36PM -0800, Jakub Kicinski wrote: > Sorry for the late review, I think this will miss v6.13 :( That is fine, there is no rush for this change. > On Wed, 13 Nov 2024 07:10:53 -0800 Breno Leitao wrote: > > /** > > * struct

[PATCH net-next 1/4] netconsole: Ensure dynamic_netconsole_mutex is held during userdata update

2024-11-13 Thread Breno Leitao
the user changes the configuration, so this addition does not impact performance as it is not in the hot path. Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index

[PATCH net-next 3/4] netconsole: docs: Add documentation for CPU number auto-population

2024-11-13 Thread Breno Leitao
tput. Signed-off-by: Breno Leitao --- Documentation/networking/netconsole.rst | 44 + 1 file changed, 44 insertions(+) diff --git a/Documentation/networking/netconsole.rst b/Documentation/networking/netconsole.rst index d55c2a22ec7af0e687b7

[PATCH net-next 2/4] netconsole: Add option to auto-populate CPU number in userdata

2024-11-13 Thread Breno Leitao
id doesn't need to be precise, do not disable preemption when getting the CPU id. Signed-off-by: Breno Leitao --- drivers/net/netconsole.c | 61 1 file changed, 61 insertions(+) diff --git a/drivers/net/netconsole.c b/drivers/ne

[PATCH net-next 4/4] netconsole: selftest: Validate CPU number auto-population in userdata

2024-11-13 Thread Breno Leitao
regressions in this functionality. Signed-off-by: Breno Leitao --- tools/testing/selftests/drivers/net/netcons_basic.sh | 18 ++ 1 file changed, 18 insertions(+) diff --git a/tools/testing/selftests/drivers/net/netcons_basic.sh b/tools/testing/selftests/drivers/net/ne

[PATCH net-next 0/4] netconsole: Add support for CPU population

2024-11-13 Thread Breno Leitao
n" Updates the netconsole documentation to explain the new CPU number auto-population feature Provides instructions on how to enable and use the feature I believe these changes will be a valuable addition to the netconsole subsystem, enhancing its usefulness for kernel developers

[PATCH v6 05/13] x86/bugs: Rename RETPOLINE to MITIGATION_RETPOLINE

2023-11-21 Thread Breno Leitao
. Rename the Kconfig entry from RETPOLINE to MITIGATION_RETPOLINE. Suggested-by: Josh Poimboeuf Signed-off-by: Breno Leitao --- Documentation/admin-guide/hw-vuln/spectre.rst | 8 Documentation/admin-guide/kernel-parameters.txt | 4 ++-- arch/x86/Kconfig| 6

[PATCH v5 05/12] x86/bugs: Rename RETPOLINE to MITIGATION_RETPOLINE

2023-10-19 Thread Breno Leitao
. Rename the Kconfig entry from RETPOLINE to MITIGATION_RETPOLINE. Suggested-by: Josh Poimboeuf Signed-off-by: Breno Leitao --- Documentation/admin-guide/hw-vuln/spectre.rst | 8 Documentation/admin-guide/kernel-parameters.txt | 4 ++-- arch/x86/Kconfig| 6

Re: [PATCH v9 44/51] selftest/vm: powerpc implementation for generic abstraction

2017-11-10 Thread Breno Leitao
Hi Ram, On Thu, Nov 09, 2017 at 03:37:46PM -0800, Ram Pai wrote: > On Thu, Nov 09, 2017 at 04:47:15PM -0200, Breno Leitao wrote: > > On Mon, Nov 06, 2017 at 12:57:36AM -0800, Ram Pai wrote: > > > @@ -206,12 +209,14 @@ void signal_handler(int signum, siginfo_t *si, void

Re: [PATCH v9 44/51] selftest/vm: powerpc implementation for generic abstraction

2017-11-09 Thread Breno Leitao
Hi Ram, On Mon, Nov 06, 2017 at 12:57:36AM -0800, Ram Pai wrote: > @@ -206,12 +209,14 @@ void signal_handler(int signum, siginfo_t *si, void > *vucontext) > > trapno = uctxt->uc_mcontext.gregs[REG_TRAPNO]; > ip = uctxt->uc_mcontext.gregs[REG_IP_IDX]; > - fpregset = uctxt->uc_mco