/3 and 2/3 patches:
Acked-by: Anton Vorontsov
(Do you need EXPORT_SYMBOL()? You don't use this from modules?)
Thanks.
> drivers/power/ab8500_bmdata.c | 8 ++--
> 1 file changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/power/ab8500_bmdata.c b/drivers/po
On Wed, Jan 23, 2013 at 09:56:45AM +0530, Rajanikanth H.V wrote:
> From: "Rajanikanth H.V"
>
> Power supply subsystem creates thermal zone device for
> the property 'POWER_SUPPLY_PROP_TEMP' which requires
> thermal subsystem to be ready before 'ab8500 battery temperature monitor'
> driver is init
On Mon, Dec 03, 2012 at 11:42:55PM +0530, Rajanikanth H.V wrote:
> From: "Rajanikanth H.V"
>
> ab8500_fg driver prepares instance list of fuelgauge which is
> required by btemp driver for battery identification. So make sure
> that ab8500 fuelgauge list is ready before btemp driver starts.
>
> f
On Fri, Nov 30, 2012 at 05:30:03PM +0400, Andrey Konovalov wrote:
[...]
> >>>How do you suggest to solve these issues?
> >>
> >>That you, Andrey and
> >>the 'the guy maintaining the Android topic'
>
> Deepak, is that ^^^ John, Anton, or someone else? :)
Same question. :)
I can easily pull branch
On Fri, Nov 23, 2012 at 12:13:44AM +0530, Rajanikanth H.V wrote:
[...]
> +/*
> + * Note that the batres_vs_temp table must be strictly sorted by falling
> + * temperature values to work.
> + */
> +struct batres_vs_temp temp_to_batres_tbl_thermistor[] = {
It must be static.
[..]
> +struct batres_v
On Mon, Nov 19, 2012 at 09:28:59AM +0530, Rajanikanth HV wrote:
> > FWIW, I fixed these warnings.
> >
> > CHECK drivers/power/ab8500_bmdata.c
> > drivers/power/ab8500_bmdata.c:146:23: warning: symbol
> > 'temp_to_batres_tbl_thermistor' was not declared. Should it be static?
> > drivers/power/a
On Wed, Oct 31, 2012 at 03:40:29PM +, Rajanikanth H.V wrote:
> From: "Rajanikanth H.V"
>
> This patch-set adds device tree binding for ab8500 battery-managed
> devices. Removes the redundant platform structure maintained
> across bm devices and implements common DT probe routine across all th
(Thanks for Cc'ing me.)
On Thu, Sep 13, 2012 at 02:37:38PM +, Arnd Bergmann wrote:
[...]
> > > If this is true, I don't understand what makes the 'supplied-to'
> > > properties you list in the device tree binding board specific. Are
> > > they not always done the same way? If so, you could jus
places.
I fixed this and applied the patch.
Thanks!
--
Anton Vorontsov
Email: cbouatmai...@gmail.com
___
linaro-dev mailing list
linaro-dev@lists.linaro.org
http://lists.linaro.org/mailman/listinfo/linaro-dev
; + vbat_vs_capacity_look_up[access_index][index][1];
> + level_lower =
> + vbat_vs_capacity_look_up[access_index][index + 1][1];
> + flag = 1;
> + break;
I can't parse it.
You don't have to use 24-character variable name to document your
code. For example, you can rename vbat_vs_capacity_look_up to "vc_tbl"
and just add a comment that the table is used to lookup voltage via
capacity.
s/vbat_vs_capacity_look_up/vc_tbl/g
s/access_index/i/g
s/index/j/g
[...]
> +static irqreturn_t da9052_bat_irq(int irq, void *data)
> +{
> + struct da9052_battery *battery = (struct da9052_battery *)data;
Needless cast.
Thanks!
--
Anton Vorontsov
Email: cbouatmai...@gmail.com
___
linaro-dev mailing list
linaro-dev@lists.linaro.org
http://lists.linaro.org/mailman/listinfo/linaro-dev
e some cosmetic issues, the patch looks OK to me.
So, I'm fine if it goes via MFD tree.
Although, if you ever need to respin this patch, try to make the
code fully conform to the Linux coding style.
Thanks,
--
Anton Vorontsov
Email: cbouatmai...@gmail.com
_
11 matches
Mail list logo