On 19 January 2015 at 12:29, Kevin Hao wrote:
> These are needed when we want to boot from qeumu.
>
> Signed-off-by: Kevin Hao
> ---
> meta-aarch64/conf/machine/genericarmv8.conf | 4
> 1 file changed, 4 insertions(+)
>
> diff --git a/meta-aarch64/conf/machine/genericarmv8.conf
> b/meta-aa
On Tue, Jan 20, 2015 at 6:06 AM, Lisa Nguyen wrote:
> Update the Android makefiles in cputopology and cpuhotplug
> since a few subtests have been added or renamed. Remove
> unnecessary whitespace detected by checkpatch as well.
Have you ensured that the test spec[1] corresponds to the current
scr
On Tue, Jan 20, 2015 at 6:06 AM, Lisa Nguyen wrote:
> Rename z_sanity_check.sh script to cpuhotplug_09.sh to give it a
> more meaningful name and to check if all cpus are back online after
> running previous cpuhotplug tests.
>
> Signed-off-by: Lisa Nguyen
> ---
> cpuhotplug/cpuhotplug_09.sh |
On Tue, Jan 20, 2015 at 6:06 AM, Lisa Nguyen wrote:
> [ It's been long overdue and PM-QA gets a makeover... ]
Indeed.
> This patchset primarily fixes Linaro Bug# 772
> (https://bugs.linaro.org/show_bug.cgi?id=772) to remove
> bashisms in all PM-QA scripts. These scripts will run on
> Android, Op
On Mon, Jan 19, 2015 at 04:03:52PM -0500, Christopher Covington wrote:
> Hi Kevin,
>
> On 01/19/2015 06:29 AM, Kevin Hao wrote:
> > These are needed when we want to boot from qeumu.
> >
> > Signed-off-by: Kevin Hao
> > ---
> > meta-aarch64/conf/machine/genericarmv8.conf | 4
> > 1 file cha
Rename z_sanity_check.sh script to cpuhotplug_09.sh to give it a
more meaningful name and to check if all cpus are back online after
running previous cpuhotplug tests.
Signed-off-by: Lisa Nguyen
---
cpuhotplug/cpuhotplug_09.sh | 39 +++
cpuhotplug/z_sanity_
1_sanity_check does not provide a meaningful name of what this
script does. Rename 1_sanity_check.sh to cpuhotplug_00.sh to be
the first subtest to check if all cpus are online before
starting the remaining cpuhotplug tests.
Also, rename sanity_check() function to check_cpus_online() to
make it cl
Remove thermal_try_max variable since it is not used anywhere in
PM-QA nor does its value change at any point.
Signed-off-by: Lisa Nguyen
---
Switches.sh |3 ---
1 file changed, 3 deletions(-)
diff --git a/Switches.sh b/Switches.sh
index e01d4c5..111d5cb 100644
--- a/Switches.sh
+++ b/Switc
Update the Android makefiles in cputopology and cpuhotplug
since a few subtests have been added or renamed. Remove
unnecessary whitespace detected by checkpatch as well.
Signed-off-by: Lisa Nguyen
---
cpufreq/Android.mk |2 +-
cpuhotplug/Android.mk | 18 ++
cpuidle/And
Currently, the suspend test module is disabled by default, but
make the suspend scripts more POSIX-compliant to be consistent
with other scripts.
Signed-off-by: Lisa Nguyen
---
include/suspend_functions.sh | 20 +---
suspend/suspend_01.sh|9 -
suspend/suspen
Rewrite the logic to check for userspace and powersave governors, so
that the test_status_show() function gets called before these cpufreq
scripts exit to display the final results.
Without this change, these cpufreq scripts will run on Android but
will not print "cpufreq_xx: pass/fail/skip" at th
After renaming 1_sanity_script.sh and z_sanity_script.sh to
cpuhotplug_00.sh and cpuhotplug_09.sh respectively, provide the
text files for these scripts that contain the description of
these tests.
Signed-off-by: Lisa Nguyen
---
cpuhotplug/1_sanity_check.txt |1 -
cpuhotplug/cpuhotplug_00.tx
Remove bashism in cpuhotplug scripts. $RANDOM is an internal BASH
function, so remove it to follow POSIX standards.
Signed-off-by: Lisa Nguyen
---
cpuhotplug/1_sanity_check.sh|7 +++
cpuhotplug/cpuhotplug_01.sh |5 ++---
cpuhotplug/cpuhotplug_02.sh | 21 ++--
Remove bashisms in the cpufreq test module in addition to
renaming variables to more meaningful names and minor cleanups.
Signed-off-by: Lisa Nguyen
---
cpufreq/cpufreq_01.sh |4 ++--
cpufreq/cpufreq_02.sh |5 ++---
cpufreq/cpufreq_03.sh | 13 ++--
cpufreq/cpufreq_0
Use the sort built-in function to ensure that scripts
will be executed in order depending on make version.
See the following link for details on return value of
the built-in wildcard function:
https://lists.gnu.org/archive/html/info-gnu/2010-07/msg00023.html
Signed-off-by: Lisa Nguyen
---
Test
Remove bashisms in utils_sanity.sh script.
Signed-off-by: Lisa Nguyen
---
utils/utils_sanity.sh |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/utils/utils_sanity.sh b/utils/utils_sanity.sh
index 84f4905..c5bdcd7 100755
--- a/utils/utils_sanity.sh
+++ b/utils/utils_san
Add cputopology_sanity script to check for topology entries for
all cpus. Also, all test modules have a sanity script, so add one
for cputopology test module.
Signed-off-by: Lisa Nguyen
---
cputopology/cputopology_sanity.sh | 49 +
1 file changed, 49 inserti
Remove bashisms in the cputopology scripts.
Signed-off-by: Lisa Nguyen
---
cputopology/cputopology_01.sh |9 -
cputopology/cputopology_02.sh |5 ++---
2 files changed, 6 insertions(+), 8 deletions(-)
diff --git a/cputopology/cputopology_01.sh b/cputopology/cputopology_01.sh
inde
Remove bashism in thermal scripts and remove thermal_try_max
variable as it is not used anywhere else nor does its value
changes. Rename variables to something more meaningful and
improve format for readability.
Signed-off-by: Lisa Nguyen
---
thermal/thermal_00.sh | 22 ++-
thermal
Export hotplug_allow_cpu0 to resolve invalid comparison errors from
cpuhotplug scripts in Android.
Signed-off-by: Lisa Nguyen
---
Switches.sh |3 +++
1 file changed, 3 insertions(+)
diff --git a/Switches.sh b/Switches.sh
index cc59992..e01d4c5 100644
--- a/Switches.sh
+++ b/Switches.sh
@@ -
Remove bashisms in cpuidle test module to make them POSIX-compliant.
Also do some minor cleanups to make the scripts readable.
Signed-off-by: Lisa Nguyen
---
cpuidle/cpuidle_01.sh | 21 +
cpuidle/cpuidle_02.sh |7 +++
cpuidle/cpuidle_03.sh | 17 +++
Remove bashisms such as bash arrays and local keywords in all function
scripts. Replace bash arrays with POSIX-compliant ones to store a series
of values. Some variables are renamed to be clear of what values are
assigned to them. Formatting has been changed to make the scripts
more readable.
Howe
[ It's been long overdue and PM-QA gets a makeover... ]
This patchset primarily fixes Linaro Bug# 772
(https://bugs.linaro.org/show_bug.cgi?id=772) to remove
bashisms in all PM-QA scripts. These scripts will run on
Android, Openembedded, and Ubuntu.
Cleanups have been done to remove redundant c
Hi Kevin,
On 01/19/2015 06:29 AM, Kevin Hao wrote:
> These are needed when we want to boot from qeumu.
>
> Signed-off-by: Kevin Hao
> ---
> meta-aarch64/conf/machine/genericarmv8.conf | 4
> 1 file changed, 4 insertions(+)
>
> diff --git a/meta-aarch64/conf/machine/genericarmv8.conf
> b/
The qemu in oe-core has updated to the latest version and also has the
system mode support for aarch64.
Signed-off-by: Kevin Hao
---
.../3f08ffb4a4741d147634761dc053ed386243a0de.patch | 42 ---
.../qemu/files/enable-i386-linux-user.patch| 55 --
.../recipes-devtools
These are needed when we want to boot from qeumu.
Signed-off-by: Kevin Hao
---
meta-aarch64/conf/machine/genericarmv8.conf | 4
1 file changed, 4 insertions(+)
diff --git a/meta-aarch64/conf/machine/genericarmv8.conf
b/meta-aarch64/conf/machine/genericarmv8.conf
index 1d05238d8c04..76b380
Hi,
With these two patches, I can boot the genericarmv8 kernel from qemu with the
following command:
./tmp-glibc/sysroots/x86_64-linux/usr/bin/qemu-system-aarch64 -kernel
./tmp-glibc/deploy/images/genericarmv8/Image-genericarmv8.bin -machine virt
-cpu cortex-a57 -drive
id=disk0,file=./tmp-glibc
27 matches
Mail list logo